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Using this Manual

Using this Manual
Welcome to the Deltek® Open Plan™ User Guide. Open Plan is an enterprise project management
system that substantially improves your organization’s ability to complete multiple projects on time
and on budget. With multi-project analysis, critical path planning and resource management, Open
Plan offers the power and flexibility to serve the differing needs of business, resource, and project
managers.
This document uses Adobe™ Reader™ to display the Deltek Open Plan User Guide. To learn the
various features of Acrobat Reader, consult the Rader online help system.
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If You Need Assistance

If You Need Assistance
If you need assistance installing, implementing, or using Open Plan, Deltek makes a wealth of
information and expertise readily available to you.

Customer Services
For over 30 years, Deltek has maintained close relationships with client firms, helping with their
problems, listening to their needs, and getting to know their individual business environments. A full
range of customer services has grown out of this close contact, including the following:


Extensive self-support options through the Customer Care Connect Web portal.



Phone and email support from Customer Care analysts



Technical services



Consulting services



Custom programming



Classroom, on-site, and Web-based training
Find out more about these and other services from the Customer Care Connect site.

Customer Care Connect Site
The Deltek Customer Care Connect site is a support Web site for Deltek customers who purchase an
Ongoing Support Plan (OSP).
The following are some of the many options that the Customer Care Connect site provides:


Search for product documentation, such as release notes, install guides, technical information,
online help topics, and white papers



Ask questions, exchange ideas, and share knowledge with other Deltek customers through the
Deltek Connect Customer Forums



Access Cloud specific documents and forums



Download the latest versions of your Deltek products



Search Deltek’s knowledge base



Submit a support case and check on its progress



Transfer requested files to a Customer Care analyst



Subscribe to Deltek communications about your products and services



Receive alerts of new Deltek releases and hot fixes



Use Quick Chat to submit a question to a Customer Care analyst online
For more information regarding Deltek Customer Care Connect, refer to the online help available
from the Web site.
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Access Customer Care Connect
To access the Customer Care Connect site, complete the following steps:
1. Go to http://support.deltek.com.
2. Enter your Customer Care Connect Username and Password.
3. Click Log In.
If you do not have a username and password for the Customer Care Connect site, contact your
firm’s Open Plan Administrator.
If you forget your username or password, you can click the Account Assistance button on the
login screen for help.

Additional Documentation
Release notes and other guides are available for this release. You can download these documents in
two ways.

Deltek Software Manager
The Documents tab in Deltek Software Manager lists all of the documents associated with a release
and lets you download the ones that you want.
To download documents, complete the following steps:
1. On the Deltek Customer Care site, click the Product Downloads tab, then select Launch
Deltek Software Manager.
2. When the Deltek Software Manager opens, highlight a release in the left pane.
Do not enter a check next to the release name or click Add to Download Queue. If
you do so, you will download the software as well as any documentation that you want.

3. Click the Documents tab to display a list of available documents for the release.
4. Select the documents that you want.
5. Click View Download Queue to see a list of documents that you selected.
6. Click Download.

Customer Care Site Enterprise Search
Use the search feature to find specific documents or to see a list of all documents associated with a
release. Then open or download the ones that you want.
To download documents, complete the following steps:
1. On the Deltek Customer Care site, click Enterprise Search.
2. Select Release Documentation as the Source.
3. Perform one of the following actions:


To see a list of all available documentation for a release, enter the product and release
number (for example, Vision 7.4) in the search field.
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To find a specific document, enter a description of the document (for example, Vision 7.4
release notes) in the search field.

4. Click on the document, then choose to open or save it.
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Chapter Summaries
Chapter 1 discusses Open Plan Professional and covers the basics of getting started with the
program. It concludes with a discussion on the types of documentation supplied with Open Plan.
Chapter 2 discusses the basic skills common to many Windows applications (such as selecting
commands, working with dialog boxes, and using the mouse) as well as how to cut, copy, and paste.
Chapter 3 describes the Open Plan Explorer interface and discusses how to manage your project
data using the commands available in the Open Plan Explorer.
Chapter 4 discusses how to create new files using Open Plan default settings and using custom
settings. The chapter concludes with a detailed description of each page of the New File Wizard.
Chapter 5 begins with a discussion of the Properties dialog box for ancillary (resource, code, and
calendar) files and view files and concludes with a discussion of the Project Properties dialog box.
Chapter 6 outlines guidelines for planning activities and describes the types of information you can
enter in Open Plan for activities and relationships. The chapter also includes procedures for entering
activity and relationship information and concludes with discussions of a number of utilities related to
activity information.
Chapter 7 contains discussions on defining resources in Open Plan, including such topics as creating
a resource file, reserving resources for projects, and displaying resource information.
Chapter 8 begins with a description of the different methods you can use to enter resource
assignments. This is followed by a section on resource allocation and concludes with sections on
effort-driven activities and defining assignment profiles manually.
Chapter 9 starts with a discussion on calendars in Open Plan and ends with discussions on creating
and maintaining calendars.
Chapter 10 begins with a brief discussion of basic cost control and earned value concepts. It
concludes with discussions on planning costs, capturing actual costs, and reporting on costs.
Chapter 11 discusses working with project code files, entering codes, displaying code information,
and entering code assignments
Chapter 12 discusses a number of issues related to project hierarchies in Open Plan, including
setting up a project hierarchy and working with hierarchical projects in different views. It concludes
with a discussion of reporting hammocks, a traditional feature for rolling up project information.
Chapter 13 begins with a brief introduction to time analysis features followed by a description of how
to perform time analysis in Open Plan.
Chapter 14 begins with a brief introduction to resource scheduling in Open Plan, followed by a
description of the different scheduling attributes available for activities. The chapter continues with a
description of how to perform resource scheduling in Open Plan, including information about
advanced resource scheduling options. It concludes with discussions on using resource scheduling
information and reporting resource scheduling results.
Chapter 15 provides discussions on risk analysis in Open Plan and how to perform it. The chapter
ends with discussions on interpreting the results of risk analysis and displaying the results in a risk
histogram.
Chapter 16 starts with discussions on creating and managing project baselines. It provides
discussions on entering activity and resource progress information and how Open Plan uses progress
information when calculating schedules. The chapter concludes with a discussion of the automatic
progressing features in Open Plan.
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Chapter 17 discusses a number of topics related to the reporting of project data in Open Plan,
including working with views, using custom symbols, printing reports, and assigning reporting
calendars. It concludes with a discussion of the notes feature in Open Plan.
Chapter 18 discusses customizing the bar display portion of a barchart view.
Chapter 19 discusses how to customize a network view.
Chapter 20 discusses each of the ways you can customize a stand-alone spreadsheet view and the
spreadsheet portion of barchart views.
Chapter 21 starts with a general discussion of resource histogram views in Open Plan, followed by a
description of the types of resource and earned value information that can appear in a histogram
view. Next is a description of how to customize a resource histogram. The chapter concludes with a
discussion of the features related to risk histograms.
Chapter 22 discusses the import and export utilities for Microsoft Project and Primavera Project
Planner as well as customized importing and exporting using user-defined scripts.
Chapter 23 discusses a number of project-level utilities that facilitate the manipulation of project data.
These include filters, sorts, calculated fields, global edits, user defined fields, and spread curves.
Chapter 24 discusses each of the system utilities provided by Open Plan and concludes with a
discussion of working with project data in a multi-user environment.
Chapter 25 discusses how to modify the system options defaults using the different tabs of the
Options dialog box.
Appendix A is a glossary of terms used throughout the Deltek Open Plan User Guide.
Appendix B contains a list of keyboard shortcuts.

Introduction
Deltek Open Plan 8.0 User Guide

7

Symbols Used Throughout the Manual

Symbols Used Throughout the Manual
The following are descriptions of the various icons you will encounter throughout this manual:
This icon identifies a Note. This is additional information about the subject being discussed.

This icon refers you to other sections of the user guide for additional information about the
subject being discussed.

This icon gives a precaution or warning.
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Overview

Overview
Welcome to Open Plan, your comprehensive solution to project planning and management tasks.
Designed to cope with the most demanding requirements of project planners, Open Plan has the
capability, the flexibility, and the processing muscle to handle your largest projects. At the same time,
Open Plan takes advantage of the latest advances in OLE automation and graphical interface design
to make its power accessible to the most inexperienced user.
This chapter begins with a discussion of the basics of getting started in Open Plan — the Deltek
Applications program group, starting the application, and getting help information. The chapter
concludes with a discussion of the various types of documentation supplied with Open Plan.
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Open Plan Professional
Deltek Open Plan is an enterprise-class project management solution that provides planning and
scheduling, resource management, and risk analysis across all projects within your organization.
Open Plan is both powerful and flexible. It provides multi-project analysis, critical path planning,
resource management across the organization, and much more. Open Plan is easy to use, and
caters to the different needs of the different levels within your organization, from the project team to
the project managers, to the finance team, to the executive team.

Open Plan supports the Program Management Office (PMO)
Open Plan has many tools that support the PMO, including the ability to define standard templates for
all or part of a project, the ability to validate schedule quality as schedules are built, and to provide
guidance along the way to improve scheduling practices.
Open Plan provides a robust security model to control who has access to project data and who can
make certain types of changes like baseline management, activity deletion, and more.
Open Plan provides shared concurrent access to data when needed and allows projects to be
checked out for unfettered access even when the project file is not open. You can ensure you have
access to the project when you have time to work on it.
Open Plan has the processing speed and capacity to look at resources, progress, and other project
information across the business unit or portfolio of projects. Open Plan is tested with hundreds of
thousands of activities at a time to provide the scalability to handle the largest programs.

Open Plan supports the Project Manager and Project Team
Open Plan is designed to provide comprehensive solutions to real-world problems facing corporate
project managers. Even in organizations with a strong commitment to modern project management
techniques, there are often only a relative handful of skilled planners and schedulers who are charged
with tracking the vast amounts of data that can be generated in the course of a typical large-scale
project.
With Open Plan, planners can take advantage of the full range of high-end project management
features, including:


Creation of projects in support of proposals, execution and internal company projects



All projects can share corporate resources definitions and calendars or create their own unique
resources and calendars



All projects can share standard corporate coding as well as project specific codes



The creation of custom view layouts and reports



The specification of custom calculations and nonlinear reporting calendars



The ability to develop multi-project schedules, resource loadings, and reports

Planners using Open Plan can develop custom views and reports, and calculations. In many cases,
standard resource lists, coding systems, work calendars, and even model networks would be
developed and disseminated across the entire organization. A more comprehensive planning and
control strategy might include the use of multi-project scheduling and resource loading in which
master projects created by Open Plan users would reflect the dates and requirements of subprojects
being planned and maintained at a lower level.
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With Open Plan, creative organizations have the strategic and tactical tools to make corporate project
management a reality.
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The Deltek Applications Program Group
Open Plan comes with an automated setup utility. With this utility, you can perform a complete
installation of all the files that come with your Open Plan CD, or you can perform a custom installation
that copies only the features you plan to use.
For information about using the setup utility, refer to the Deltek Open Plan Installation Guide.

As a part of its installation procedures, Open Plan automatically adds the Deltek Open Plan 8.0
Applications folder containing a set of application shortcuts to the Windows Start/Programs menu.
The applications represented in this folder are as follows:


Deltek Open Plan Professional 8.0 — The main Open Plan application



Deltek Open Plan User Guide — The Open Plan user documentation



Deltek Open Plan Developer Guide — Reference and technical documentation



Deltek Open Plan Help —The Open Plan context-sensitive Help system



Deltek EPM Security Administrator — The Deltek security management application



Deltek Open Plan Data Tool— This tool initializes Open Plan databases



Deltek Open Plan Release Notes — A document that discusses the new features of this release,
changes to the documentation, and software defect resolutions.
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Starting Open Plan
Once you have used the setup utility to install Open Plan, you can start the application from the
Windows Desktop.
To start Open Plan each time you enter Windows, add the Open Plan application to the Startup
menu. For more information about the Startup menu, refer to your Windows documentation.

To start Open Plan, complete the following steps:
1. On the Windows Desktop, click Start, and point to All Programs.
2. On the Programs menu, click the Deltek Open Plan 8.0 folder, and click Deltek Open Plan
Professional 8.0 on the submenu.

Logging into Open Plan
When Open Plan starts it displays the Open Plan Login dialog box:

The active data source is set up by the system administrator.

You can use the following controls to log into the active data source for your session of Open Plan:


User ID — The ID that your system administrator has set up for your use.
Open Plan remembers the user ID from the last time Open Plan was used and automatically
enters that user ID in this field. If this user ID is not the one you wish to use, simply delete it, and
enter the proper one.



Password — The password associated with your user ID.



Using Briefcasing Data Source — If you select this option, Open Plan opens your briefcasing
data source instead of your main data source.
If, after you click Login, Open Plan issues a message that your login information is invalid,
reenter your user ID and password, and click Login again. If Open Plan still does not start, check
with your system administrator. There are several possible causes for this situation, including:


There may be an interruption of network services.



You may not be properly registered as a valid user of the active data source.



You may have entered an incorrect password.
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Your system administrator will be able to determine the cause of the problem and take steps to
correct it.
You can change the active data source before logging in. To do so, hold down the Ctrl
key while clicking Login. This will display the Data Sources dialog box that you can
use to select a different data source for this session.

First time users can login using the following:


User ID: SYADMIN; Password: PASSWORD



User ID: GUEST; Password: <blank>
You can change your password using the Change Password dialog box. For more information,
see Chapter 25 System Utilities.
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Using the Help System
Online, context-sensitive help is available throughout Open Plan. Each time you display a dialog box,
you can display help about that dialog box by clicking Help or by pressing F1.

You can also display help for any view or window by pressing F1.
To examine a list of topics covered in the help system, click Help Contents
from the Quick
Access Toolbar (QAT). You can also launch the help by clicking the File menu » Help » Deltek
Open Plan Help. From the Contents tab of the Help window, you can select a topic by clicking the
topic heading.
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To display Help for a window, complete the following step:
Press F1.
To display help for a dialog box, complete the following step:
Click Help or press F1.
To display help for a specific topic, complete the following steps:
1. From within a help window, click the Search tab.
2. Enter a keyword for the topic by typing the keyword or by selecting it from the list.
3. Click List Topics, or press Enter.
Open Plan displays a list of all topics matching your search criteria.
4. Select the topic from the list.
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Displaying System Information
The About Deltek Open Plan Professional message boxes display information about your Open
Plan installation, including the version number, serial number, user information, and data source.

When contacting Deltek technical support, you may need this information for diagnostic purposes.
To display the About Deltek Open Plan dialog box, complete any of the following steps:
About Open Plan
button



Click File menu » Help » About Deltek Open Plan.
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Exiting Open Plan
You can exit Open Plan at any time by clicking Exit on the File menu.
If you have any unsaved changes for project or data files that are open when you click the Exit
command, Open Plan allows you to save your changes before closing the application.
To exit Open Plan, complete the following step:


On the File menu, click

.

You can also exit Open Plan in certain situations by clicking the Close button in the upper right
corner of the screen.
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Where to Go from Here
Open Plan includes a number of tools to help you learn about the features and operations of the
product.
For more comprehensive information about Open Plan, examine the Deltek Open Plan User Guide.
This PDF file contains complete descriptions of the various features found in Open Plan, and includes
procedures for carrying out many common tasks. Chapter 2, “Basic Skills,” and Chapter 3, “Getting
Started,” will help you master the basics of project planning in Open Plan. The remaining chapters are
organized on the basis of topics such as entering activity information and project analysis, and do not
have to be read in any particular order.
The Deltek Open Plan Help system contains a wealth of information about using Open Plan and is
available whenever you need it. For more complicated features, look for an Examples button in the
help window for an extended explanation of the feature. To print a help topic, click the Print button
within the help system.
For in-depth information about advanced topics, check the Deltek Open Plan Developer Guide. This
PDF file includes information on topics such as customizing project views, data file structures,
compatibility issues, and OLE automation techniques.
For information on training courses offered on Open Plan, visit our Web site at www.deltek.com. Click
Education » Browse Courses. On the My Deltek University page, browse for Open Plan courses in
the Browse for Training pane.

Chapter 01 Welcome to Deltek Open Plan
Deltek Open Plan 8.0 User Guide

20

2
Basic Skills
Overview ........................................................................................................................................ 24
Choosing Commands .................................................................................................................... 25
Working with Dialog Boxes ............................................................................................................ 40
Using Edit Boxes ........................................................................................................................... 44
Cutting, Copying, and Pasting Data .............................................................................................. 45

Overview

Overview
Deltek Open Plan is an enterprise-class project management solution that offers the power and
flexibility to complete medium-to-large and/or multiple projects on time and on budget. With multiproject analysis, critical path planning, resource management and Risk analysis, Open Plan caters to
the differing needs of business, resource and project managers.
This chapter starts with descriptions of basic skills common to many Windows applications such as
selecting commands and working with windows and dialog boxes. Next, skills related to selecting,
cutting, copying, and pasting data in the different views are discussed.
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Choosing Commands
The File Menu and the Open Plan Tabs
The File menu and the Open Plan tabs at the top of the application windows display the names of the
menus and tabs containing available commands.
The following image displays the items in the Open Plan application window:
Quick Access Toolbar

File Menu
Command Button

Group

Hierarchical Pane

Command Tabs

Status Bar

View Tabs
Open a View Drop Down

Contents Pane

Item

Description

File Menu

The file menu contains commands related to the management of
files, such as open, save, print, share, change password, and so
on.

Command Button

A command button allows you to trigger an event, such as
performing time analysis, resource scheduling, risk analysis,
launch dialog boxes, and so on. Command buttons may be
arranged together into a Group.

Hierarchical Pane

The hierarchical pane displays a hierarchy of folders available to
you. Each folder contains other folders or Open Plan objects
such as projects and views.

Status Bar

The status bar shows information about the Open Plan Explorer
or a view being displayed. The information shown include filters
or sorts that were applied, user that is currently logged in,
baseline in use, data source, current project status date, and so
on.

Quick Access Toolbar

The Quick Access Toolbar contains commonly used commands
that are independent of the tab on the ribbon that is currently
displayed.
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Item

Description

Group

The Group contains commands for related features and
functionality and are placed together in the ribbon.

Command Tabs

The command tabs contain command groups, most often
displayed as icons, which allows you to trigger an event.

View Tabs

The view tabs allow you to switch between views that are
currently open.

Open a View Drop Down

The drop down contains available views for a selected project or
file. This item is also an alternative way to open a project.

Contents Pane

The contents pane displays the contents of the currently
selected folder in the hierarchical pane.

You can minimize the ribbon by clicking the following:

The same set of menu and tabs appear throughout Open Plan. The contents however, may change
depending on the current window or view.
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When you click the name of the menu or tab (or press the Alt key in combination with the first letter of
the menu or tab name), Open Plan displays the commands available from that menu or tab:

or

Notice that the names of some of the commands are dimmed. These commands are not available in
a given situation.
Some menu items have a right-pointing triangle next to their name on the menu. When you point to
one of these commands, Open Plan displays a submenu of choices related to that command.
To select a command, simply click the name of the command.

Using the Open Plan Tabs
Many of the most commonly used commands are available as buttons on the tabs.
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To select a command from the Quick Access Toolbar, File menu or tabs, click the button for the
command. Commands available are as follows:
Button

Command

Button

Command

Quick Access Toolbar
Create a New
File

Open

Save

Print

Print Preview

Help

Exit Open Plan

Customize
Quick Access
Toolbar

New

Open

Project

Calendar File

Code File

Resource File

Save

Save As

Save as New
File

Save as Project
Template

Close

Save View

Save View

Copy View

Print

Print

File Menu
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Button

Command

Button

Command

Print Preview

Print Setup

Print Options

Manage Files

Backup Data

Restore Data

Delete

Owner and
Access Rights

Mode

Check Out

Check In

Share

Send Project

Send Message

Change
Password

Help

Deltek Open
Plan Help

About Deltek
Open Plan

Deltek
Customer Care

Preferences

Application

Data Sources

Exit
Processes
(Schedule group)
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Analysis

Time
Now/Calendar

Auto-analyze

Lock Project

Perform
Resource
Scheduling

Perform Risk
Analysis
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Button

Command

Button

Command

Time Analysis,
Resource
Scheduling,
and Risk
Analysis
Options
(Calculate group)
Cost
Calculations

Progress
Calculations

Project
Properties

Manage
Baselines

(Dialogs)

Change Mode
(Ancillary Data)
Display
Calendar View

Display
Resource View

Display Code
View
(Tools)
Trace Logic

Schedule Driver
Analysis

(Log Viewer)
Open Log File

Integration
(Import)
Microsoft
Project Import
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Button

Command

Button

Command

Oracle
Primavera P3
Import

General Import

Microsoft
Project Export

General Export

(Export)

Export
Crosstable
Data
(Kona)
Deltek Kona

(Scripts)
Edit
Transfer.dat

Tools
(Custom Fields)
User Defined
Fields

Note Categories

Calculated
Fields
(Manage)
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Global Edits

Batch Global
Edits

Email Advisor

Rollups

Spread Curves

31

Choosing Commands

Button

Command

Button

Command

Reporting
Calendars

Group Delete

Browser Views

Organize
Favorites

(Log Viewer)
Open Log File

(Publish)
Web Publisher
Edit
(View)
Select View

(Clipboard)
Paste

Cut

Copy

Select All

Add Activity,
Add Resource,
and Add Code

Expand

Expand All

Collapse

Collapse All

Outdent

Indent

Add
Relationship,
Add Child
Resource, and
Add Child Code

(Data)

,

,
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Button

Command

Button

Command

Delete Activity,
Delete
Resource, and
Delete Code

Group Delete

Link/Unlink
Activities

Fill Column
Down

Find And
Replace

Replace

Insert
Subproject

Insert Project
Template

Skills

Clear Summary
Usage

Favorite Filters

Filters

Clear Filter

Toggle Filter

Reapply Filter
And Sort

Add To Filter

Remove From
Filter

Edit Filter

Favorite Sorts

Reapply Filter
And Sort

Sorts

Clear Sort

Activity Details

Activity
Progress

Activity

Activity

(Insert)

(Manage)

(Filters)

(Sorts)

(Dialogs)
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Button

Command

Button

Command

Information

Properties

Assign
Resources

Resource
Allocation

Display
Calendar View

Display Code
View

(Resources)

(Ancillary Data)

Display
Resource View
View
(Network)
Network
Preferences

Placements

Split View

Conditional
Formatting

(Hierarchy)
Hierarchy View
Preferences
(Barchart)
Barchart
Preferences

Bar Sets

Date Scale

Numeric Axis

Spreadsheet
Preferences

Table Layout

Split View

Conditional
Formatting

(Table)

(Columns)
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Button

Command

Button

Command

Add

Insert

Remove

Edit

Best Fit

Click to Sort

Relationships

Bar Data

(Show)

Go to Date
(Histogram)
Preferences

Select
Resource

Display
Histogram
(Favorites)
Add to
Favorites

Organize

(Printing)
Title Blocks
(Save)
Save View

Copy View

(Snapshot)
Capture

(Font)
Font

(View)
Zoom In
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Button

Command

Button

Command

Show Page
Breaks

Go To Parent

Go To Top

Go To
Subproject

Add Annotation

Suppress
Activity Dialog

To display a description for a command button, position the cursor on the button. Open Plan displays
a description of the button on the status line at the bottom of the window and, after a short delay, next
to the cursor as well. To continue without invoking the command, move the cursor off of the button.
As is the case with commands on the menu file and tabs, dimmed buttons indicate that a specific
command is not available in a given situation.
Open Plan displays the file menu and tabs in the application window by default.
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The Status Bar
Record Count

Filter

Baseline

Sort

Auto TA
User
Data Source

Access Mode
Time Now

The status bar, located at the bottom of the Open Plan window, displays the following information
(note that some panes are visible only in a certain context):
Information

Description

Record Count

This displays the record count for the data displayed (activities,
resources, codes, and calendars) associated with the active
view

Baseline

This displays the baseline that is currently selected, if a projectrelated view is the active view. If multiple baselines are
selected, “< Multiple > “ will be shown instead of a baseline
name. If you hover the cursor over the pane when multiple
baselines are selected, the names of the selected baselines will
be displayed in the tooltip.

Auto TA

This indicates whether or not the automatic calculation of time
analysis has been activated, if a project-related view is the active
view.
This can be easily toggled by selecting or deselecting
the Auto-analyze option from the Schedule group of the
Processes tab.

Time Now

This displays the current project status date if a project-related
view is the active view

Access Mode

This displays the mode in which the project, resource, code, or
calendar associated with the active view was opened

Filter

This displays the current filter that was applied. Double click to
display the Filters dialog box. This pane will always be visible.

Sort

This displays the current sort that was applied. Double click to
display the Sorts dialog box. This pane will always be visible.
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Information

Description

User

This displays the user that is currently logged in. This pane will
always be visible.

Data Source

This displays the data source. This pane will always be visible.

The status bar may be hidden by unchecking the Status Bar option on the General tab of the Options
dialog.

Using the Right Mouse Menus
Throughout Open Plan, you can display a context menu of commonly used commands by rightclicking an object or area of the screen. The contents of the context menu varies, depending on the
location that you click.
In a network view, for example, right-clicking an activity displays the following menu of commands:

Right-clicking a relationship line displays the following menu:
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Right-clicking an empty area of the workspace displays the following menu:

Clicking a command on a context menu is identical to clicking a command on the Open Plan menu
bar.

Using Keyboard Shortcuts
You can select any command in Open Plan by a combination of keystrokes corresponding to the
menu and the name of the command. For example, to add an activity, press Alt+F to display the File
menu, and then press Ctrl+A.
In addition, a number of commands in Open Plan have keyboard shortcuts that allow you to select
them without having to display a menu.
Commands with keyboard shortcuts are listed in Appendix B, “Keyboard Shortcuts.”

Working with Windows
Open Plan displays all data in windows that function identically to the document windows used in
many standard Windows applications:
Title Bar

Minimize Button
Close Button
Maximize Button

For information about the standard features of a document window, refer to your Windows
documentation.

Open Plan allows you to display as many windows as you want at one time. You can also arrange,
resize, and close windows as necessary.
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Working with Dialog Boxes
In many places in Open Plan, you enter and update information using a dialog box. The contents of a
dialog box can range in complexity from a single text box to multiple lists, items, commands, and
options:

Although dialog boxes vary considerably in their functions, the following elements are common to
many dialog boxes:


Text boxes — Enter text by typing



List boxes — Select an item from a list of available choices



Check boxes — Select one or more options



Radio buttons — Click one option from a group of options



Command buttons — Perform an operation from within the dialog box

Most dialog boxes have at least three command buttons: OK, Cancel, and Help. Clicking these
buttons has the following results:


OK — Saves any changes you have made and closes the dialog box



Cancel — Closes the dialog box without saving any changes



Help — Displays help information for this dialog box

Dialog boxes usually have a default command, which you can execute by pressing Enter. (Open Plan
displays a special outline border around the default button of a dialog box.)
You can always select Cancel in a dialog box by pressing Esc.
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Using Tabbed Dialog Boxes
Tabbed dialog boxes are dialog boxes that group similar options, commands, and settings together
using tabs that are similar to file tabs in a filing cabinet:

Tabs

To display the different tabs in a tabbed dialog box, simply click the tabs.
Going from one tab to another does not automatically save any changes you may have made on the
first tab. In tabbed dialog boxes, there is only one set of command buttons. These commands affect
all of the settings in the dialog box, not just those on the tab currently displayed. If you click Cancel or
Undo, Open Plan does not save any changes you have made to settings on other tabs in the dialog
box.

Using Modeless Dialog Boxes
A number of dialog boxes in Open Plan are modeless; in other words, you can leave these dialog
boxes open when performing other operations. This allows you, for example, to open the Activity
Details dialog box from a spreadsheet view and then view the detailed information for specific
activities simply by clicking them in the view without having to close and re-open the dialog box each
time.
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You can also use modeless dialog boxes to scroll through the records in a file. Four navigation
buttons in the lower left corner of the dialog box provide this functionality:

Navigation
buttons

Use these controls to go to the first record in the file, the previous record, the next record, or the last
record in the file.
You can also use the following keyboard shortcuts to scroll through the records in the file: Page
Up/Page Down (go to previous/next record) and Ctrl+Home/Ctrl+End (go to first/last record).

If you select a group of items in the view with a modeless dialog box open, you can use the
navigation buttons on the dialog box to scroll through the selected items. You can also configure
Open Plan to synchronize multiple modeless dialog boxes so that using the navigation buttons on one
dialog box will result in Open Plan scrolling to the appropriate item on another dialog box.
For information about enabling this feature, refer to Chapter 25, “System Defaults.”

Because you can update multiple items without having to close a modeless dialog box each time,
Open Plan automatically saves any changes you make to an item before displaying the next record.
As a result, the OK and Cancel buttons on a non-modal dialog box have been replaced with a Close
button. When you click this button, Open Plan closes the dialog box and returns to the view. If you
have not saved the information currently displayed, Open Plan saves the changes before returning to
the view.
Some modeless dialog boxes also include an Undo button that returns the dialog box to its previous
state and an Apply button that saves the changes you made to the current record.
You must update information for an item before the Undo and Apply buttons become active.

Using Resizable Dialog Boxes
Resizable dialog boxes are dialog boxes that can be resized according to the user’s needs. Among
the dialog boxes that can be resized are the following:
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Activity Details



Activity Information



Activity Progress



Organize Spreadsheet Columns



Calculated Field Expression



Project Properties



Batch Global Edits



Batch Global Edits Definition

These dialog boxes have a resizing grip at the lower right corner, indicating that the dialog box is
resizable.

To resize a dialog box, complete the following steps:
1. Position your cursor at any corner or side of the dialog box, until it becomes a double-headed
arrow

,

, or

.

2. Drag the corner or side of the dialog box to the desired size.
The size of the dialog box, as well as the relative width of any column grid will be saved
after you close and re-launch the dialog box.
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Using Edit Boxes
For entering some types of information, Open Plan provides an edit box in which you can type the
information directly.

Click to cancel entry.

Click to display list.
Click to save entry.

Each edit box includes two buttons: one for canceling the entry and the other for saving the entry.
Many edit boxes also include a button for displaying a list of valid choices for the item. For some
types of information (for example, colors), using the list is the only way you can enter a selection.
Edit boxes appear in all spreadsheet views as well as in many dialog boxes.
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Cutting, Copying, and Pasting Data
Open Plan supports the standard cut, copy, and paste operations found in many Windows products
that allow you to transfer information using a clipboard function stored in memory. The definitions for
these operations are as follows:


Cut — Removes the selected information from its present location and stores it on the Clipboard.
(Notice that cutting an item is not the same as deleting an item. Deleting an item does not change
the contents of the Clipboard.)



Copy — Makes a copy of the selected information and stores it on the Clipboard.



Paste — Inserts the current contents of the Clipboard.



Paste Special — Displays the Confirm Paste dialog box which is used to control ID renumbering
options.

In Open Plan, you can cut, copy, and paste text displayed in a text box on a dialog box, in an edit box
(which may appear in either a dialog box or in a spreadsheet view), and in a spreadsheet cell. You
can also cut, copy, or paste activities displayed in a barchart, codes, network, resource, and
spreadsheet view. You can use these commands to transfer data within a single project or between
different projects. This makes it possible, for example, to define a group of activities in one project
and then copy that group to other projects as well.
You can also cut or copy data from a spreadsheet view, a network view, or a display of
resources or codes and then paste it into another application such as Microsoft Excel or
Microsoft Word. Open Plan stores any data as tab-delimited text with a line feed at the end of
each record. The first record always consists of the column headings for the data you have cut
or copied.

Paste and Paste Special
The Confirm Paste dialog is displayed by the Paste and Paste Special commands when the current
view displays the Activity Details, Code Details, or Resource Details tables. These are the only tables
in Open Plan that support the IDs, thus the ID renumbering options.

The following options are available:
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Paste row(s) as children of the currently selected row — This option has three states:
checked, unchecked, and indeterminate. The default state is indeterminate.


Checked — When the current insertion context is a parent row, Paste row(s) as children of
the currently selected row is treated as checked. The user may uncheck this option, which
will cause the pasted rows to be pasted at the same level as the selected row.



Unchecked — When the current insertion point is not a parent row, Paste row(s) as children
of the currently selected row is treated as unchecked. The user may check this option, which
will cause the pasted rows to be pasted as children of the selected row and cause the
selected row to become a parent row.



Indeterminate — When the check box is in the indeterminate state, Open Plan will apply the
default behavior based on the current insertion context. This allows the user to let Open Plan
choose the appropriate default behavior based on the insertion context when he saves the
dialog box preferences and/or choose Only show the dialog on Paste Special.



Specify a Prefix and/or Suffix for the IDs being pasted — When this option is selected, the
prefix and suffix windows are enabled to allow the user to enter both a prefix and suffix value to
be added to the ID values being pasted. Specify a Prefix and/or a Suffix for the IDs being pasted
is unchecked by default. The maximum allowable text length for the prefix and suffix fields is the
length of the appropriate ID field of the table being pasted into (59 characters by default).



How should Open Plan renumber duplicate row(s)?
Users may select one of the following options:


Generate new IDs based on the row(s) being pasted — If the IDs in the data being pasted
already exist, the IDs being pasted will be used as the seed value for generating new IDs.
This is the default renumbering option.



Generate new IDs based on where the row(s) are being pasted — If the IDs in the data
being pasted already exist, new IDs will be generated based on the IDs of the paste insertion
point.



Generate a suffix for the row(s) being pasted — If this option is chosen, rows that are
being pasted that have the same ID value as an existing row are renumbered by adding a
suffix to the ID.



Do not paste duplicate row(s) — If this option is chosen, rows that are being pasted that
have the same ID value as an existing row will not be pasted.



Save the choices as the default — When this option is selected, all of the options chosen in the
dialog box will be retained as a user preference and will be used to initialize the dialog box during
subsequent paste operations. When the Do not show this dialog again option is chosen, the
saved preferences will be applied automatically during a paste operation without showing the
dialog box.



Only show the dialog when Paste Special is chosen — When this option is selected, the
dialog box will not be displayed when the user performs a normal paste operation.

When the user performs a normal paste and the Paste Special option is enabled, the paste operation
will use the preferences specified with the Save the choices as the default option or the standard
defaults if the user has not chosen the Save the choices as the default option.
This dialog box is only displayed when pasting data copied from Open Plan. It does not apply to
pasting data that has been copied from Excel or other applications.
To cut, complete the following steps:
1. Select what you want to cut.
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2. Take one of the following actions:
Cut button



Press Ctrl+X.



In a spreadsheet view, click Cut button from the Clipboard group on the Edit tab.



In a spreadsheet view, right-click the cell, and click Cut Text on the context menu.

To copy, complete the following steps:
1. Select what you want to copy.
2. Take one of the following actions:

Copy button



Press Ctrl+C.



In a spreadsheet view, click Copy button from the Clipboard group on the Edit tab.



In a spreadsheet view, right-click the cell, and click Copy Text on the context menu.

To paste, complete the following steps:
1. Cut or copy what you want to paste.
2. Position the insertion cursor in the text box, edit box, or spreadsheet cell.
3. Take one of the following actions:

Paste button



Press Ctrl+V.



From the Clipboard group on the Edit tab, click Paste.



In a spreadsheet view, right-click the cell, and click Paste Text on the context menu.

To paste special, complete the following steps:
1. Cut or copy what you want to paste.
2. Take one of the following actions:


Press Ctrl+Alt+V (paste special).



Right-click the row button, and Paste Special.
If necessary, Open Plan renumbers any pasted activities that duplicate the IDs of
existing activities.

Pasting activities in a network view has an extra step to allow you to position where you want the
activities to be placed in the view.
To paste in the network view complete the following steps:
1. Cut or copy the activities you want to paste.
2. Take one of the following actions:

Paste button



Press Ctrl+V or Ctrl+Alt+V (paste special).



On the Edit tab, click Paste.

3. Move the paste cursor to the desired location in the view, and click.
If necessary, Open Plan renumbers any pasted activities that duplicate the IDs of
existing activities.
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Overview

Overview
The Open Plan Explorer provides a familiar graphical user interface (GUI) similar to Windows
Explorer in order to simplify the task of managing your project data.
This chapter begins with detailed descriptions of the two panes of the Open Plan Explorer. It
concludes with discussions on how to manage your project data using the various commands
available to the Open Plan Explorer.
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Describing the Open Plan Explorer
The Open Plan Explorer interface contains two panes with a moveable splitter bar between them. The
left pane displays a hierarchy of nested folders through which you navigate. The right pane displays
the contents of the currently selected folder.

The right pane displays the contents
of the currently selected folder.

Splitter bar

The left pane displays a hierarchy of
nested folders.

Chapter 03 Getting Started
Deltek Open Plan 8.0 User Guide

47

The Hierarchical Pane

The Hierarchical Pane
The left pane of the Open Plan Explorer displays a hierarchy of folders available to you. When you
start Open Plan, you are presented with six default folders:


My Folder



Projects



Open Plan Library



Briefcase



Users



Startup

Each folder can contain other folders or Open Plan objects such as projects and views.
Within your My Folder or within any individual project, resource, or code folder, you can create
custom folders to help organize your data. You also can create a custom folder within a custom
folder.
The custom folders you create are not available to other users in the data source.

To create a custom folder, complete the following steps:
1. Select the folder in which you want to create the custom folder.
2. Take one of the following actions:


In the hierarchical pane, right-click the folder.



In the contents pane, right-click an empty space.

3. On the context menu, click New Folder.
4. Enter a name for the folder, and press Enter.
You can also perform standard Windows operations in the hierarchy such as dragging and dropping
objects into Open Plan folders or using a context menu to manipulate a selected object.
The following sections detail each of the six default folders.

My Folder
This is your personal folder. It provides a convenient way of organizing all the links to your projects,
views, ancillary files, and application shortcuts. These objects can be referenced in this folder in
either of the following ways:


By creating a project



By dragging a project, view, ancillary file, or application shortcut from another folder to My Folder
Deleting an object from My Folder deletes the link rather than the actual data.
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Projects
All projects in the data source — either created by you or created by someone else and to which you
have been given rights to view or manipulate — are listed in the Projects folder together with their
views and ancillary files.
When you create a project, it is placed in the Projects folder and a link to it is automatically placed in
your My Folder. You can also drag existing projects from this folder to your My Folder to establish a
link.
Deleting a project from the Projects folder deletes both the actual project data from the database
and the link to it in My Folder. No ancillary files are deleted with the project in the Project folder.

Open Plan Library
This folder contains ancillary files (calendars, codes, resources, and views) that can be linked to
projects. Each type of ancillary file has its own subfolder. To create a link to an ancillary file, simply
drag the file from the Open Plan Library to the target project folder.
As ancillary files are created in Open Plan, they are automatically added to the appropriate folders of
the Open Plan Library. You cannot drag a file directly into the Open Plan Library.
Provided that you have sufficient rights and the file is not referenced by another file, you can
delete it from the Open Plan Library. Deleting a file from here deletes both the actual data from
the database and any links to that file that may exist.

Briefcase
Briefcasing is the ability to take a copy of a project stored in the central database and work on that
copy remotely. The database restricts access to the master copy to prevent changes being made,
which would be lost when the remote copy is returned. While briefcased, other users are only able to
open the project in Read Only mode.
The Briefcase folder displays the following information for projects that have been checked out:


Who has a project checked out



The date and time the project was checked out
For more information on checking out projects, refer to the “Briefcasing” section in Chapter 24,
“System Utilities.”

Users
This folder displays a list of users who are currently logged into Open Plan. The following information
is available for each user in the contents pane:


User ID



Login Time



Machine ID
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You can control what information is displayed in this folder by customizing the folder headings. By
default, only the User ID column is displayed.
For more information, refer to the “Customizing the Display” section later in this chapter.

You can also view what files a user has open by displaying the Logged-in User dialog box:

The User Id field lists all the users currently logged into your Open Plan data source. Selecting a user
from the list displays the files that the user has open.
When you display the Logged-in User dialog box, the default user selected in the User Id field
depends on the following:


If you display the Logged-in User dialog box from the hierarchical pane, the default user shown in
the User Id field is the first user in the list of users.



If you display the dialog box for a specific user in the contents pane, that user is automatically
selected in the User Id field.

Regardless of how you display the Logged-in User dialog box, you still can access all the other users
from the list.
The following information is displayed for each file the user has open:


Opened File — The name of the file opened



File Type — The type of file opened (Project, Calendar, Resource, or Code)



Machine ID — The computer from which the file was opened



Opened On — The date and time the file was opened



Open Mode — The mode (Exclusive, Shared, or Read Only) in which the file is open

To display the Logged-in User dialog box, complete the following steps:
1. In the contents pane, right-click a User ID, and click Properties on the context menu.

Startup
Each Open Plan user has its own Startup folder. You can use this folder to store shortcuts to data or
applications that you want to run each time you start Open Plan. For example, if you want a particular
project to open or Windows Notepad to start automatically when Open Plan starts, place a shortcut to
it in this folder.
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Dragging an object into this folder establishes the Startup link, and deleting the icon in the Startup
folder removes the link.
For more information on creating an application shortcut, refer to the “Creating an Application
Shortcut” section later in this chapter.
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The Contents Pane
The right pane of the Open Plan Explorer displays the contents of the currently selected folder in the
hierarchical pane. In addition to identifying the object by its name, the right pane also displays
additional information about each object such as description, open mode, user ID, etc. The type of
information displayed can be controlled by customizing the folder headings.
For more information on customizing folder headings, refer to the “Customizing the Display”
section.

Double-clicking an object can invoke the following operations:


If the object is a folder, double-clicking expands it.



If the object is a view or calendar, double-clicking opens the object.



If the object is an application shortcut, double-clicking launches the application.

Customizing the Display
Except for My Folder, you can customize the display of information on the right pane.
Right-clicking a heading on the header bar displays a context menu where you can perform the
following actions:


Customize Columns — Displays the Customize Columns dialog box where you can customize
the columns that are displayed.
You can also display the Customize Columns dialog box by double-clicking anywhere
on the header bar.



Remove Column — Removes the target column from the display.



Rename Column — Renames the target column in the display.



Sort Ascending — Performs an ascending sort on the target column. An arrow placed next to
the column heading indicates which column is being sorted on and the direction of the sort.



Sort Descending — Performs a descending sort on the target column. An arrow placed next to
the column heading indicates which heading is being sorted on and the direction of the sort.



Group/Group by Type /Ungroup — Groups/ungroups the contents according to its type. For
example, when the Project Views folder is selected on the left pane, selecting Group in the
context menu organizes the contents according to the view type: Barchart View, Histogram View,
Spreadsheet View, etc.



Best Fit — Resizes the width of the target column to properly display the entries in the column.
In order to customize the columns in the contents pane, the folder that is displayed
must contain only like objects. For example, the objects must be all views, all projects,
etc.
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Customize Columns
You can customize the columns displayed by displaying the Customize Columns dialog box:

From this dialog box, you can perform the following actions:


Add fields for display



Remove fields from display



Rearrange the display order



Rename columns using the Heading button

To add a column using the Customize Columns dialog box, complete the following steps:
1. Display the Customize Columns dialog box by taking one of the following actions:


Double-click the header bar.



Right-click the header bar, and click Customize Columns on the context menu.

2. For each column you want to display, select the field from the Available fields list, and click
>.
This action moves the selected field to the Display these fields list.
3. When finished, click OK.
To remove a heading using the Customize Columns dialog box, complete the following steps:
1. Display the Customize Columns dialog box by taking one of the following actions:


Double-click the header bar.



Right-click the header bar, and click Customize Columns on the context menu.

2. For each column you want to remove from display, select the field from the Display these
fields list, and click <.
3. When finished, click OK.
An alternative way to add or remove a heading is to double-click the field name on the
Customize Columns dialog box. Double-clicking has the same result as selecting the
field and clicking > or <.
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To rearrange the column display order using the Customize Columns dialog box, complete the
following steps:
1. Display the Customize Columns dialog box by taking one of the following actions:


Double-click the header bar.



Right-click the header bar, and click Customize Columns on the context menu.

2. In the Display these fields list, select the field to move.
3. Use the up or down arrow buttons to reposition the selected field.
4. When finished, click OK.

Remove Column
When you right-click on the header bar to display the context menu, notice that each heading
displayed is listed on the context menu with a check mark next to it:

There are three ways to remove a heading from the Details format:


By using the Customize Columns dialog box (discussed in the previous section)



By using the Remove Column command



By clearing the check mark from the heading on the context menu.

To remove a column from display, complete any of the following steps:


Right-click the column to remove, and click Remove Column on the context menu.



Right-click the header bar, and clear the check mark from the heading you want to remove
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Rename Column
You can use the following dialog box to rename a column heading to reflect your own organizational
methods:

To rename a column heading, complete the following steps:
1. Display the Change Column Heading dialog box by taking one of the following actions:


Display the Customize Columns dialog box, select the field from the right pane to be
renamed, and click Heading.



Right-click the column heading to be renamed, and click Rename Column on the context
menu.

2. In the Change Column Heading dialog box, enter the new name.
3. Click OK.

Sort Ascending
You can perform an ascending sort based on any column of the contents pane when in the Details
format. An up arrow next to the column heading indicates which column is being sorted on and the
direction of the sort.
To perform an ascending sort of the Details format, complete the following steps:
1. Right-click the column heading on which to sort.
2. On the context menu, click Sort Ascending.

Sort Descending
You can perform a descending sort based on any column of the contents pane when in the Details
format. A down arrow next to the column heading indicates which column is being sorted on and the
direction of the sort.
To perform a descending sort of the Details format, complete the following steps:
1. Right-click the column heading on which to sort.
2. On the context menu, click Sort Descending.

Group
Clicking this item places the contents into expandable groups by object type. For example, selecting a
project from the hierarchical pane of the Open Plan Explorer, right-clicking the Name column in the
Details pane, and selecting Group by Type places the project contents into three groups: Calendars,
Resources, and System Folder. Clicking a group heading expands the folder to reveal the contents.
Right-clicking a group heading displays the following additional options:


Collapse — Collapses the selected expanded group heading
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Collapse All — Collapses all expanded group headings



Expand — Expand the selected group heading



Expand All — Expands all group headings



Group Ascending — Sorts the groups in ascending order. (This is the default.)



Group Descending — Sorts the groups in descending order



Ungroup — Removes the applied grouping
You can sort the contents within the groups (but not the groups themselves) in ascending or
descending order by right-clicking a column heading (not a group heading) and selecting Sort
Ascending or Sort Descending.

Ungroup
Clicking this item allows you to remove the applied grouping. You can access this item by either rightclicking a column heading or a group heading.

Best Fit
When applied, the Best Fit option instructs Open Plan to resize the width of a selected column. Open
Plan will either shrink the column width by eliminating unneeded space or widen the column to
properly display all entries.
To resize the column width, complete the following steps:
1. Right-click the heading of the column to be resized.
2. On the context menu, click Best Fit.
You can also resize a column’s width manually by placing the cursor at either edge of
column’s header. When the cursor changes to this shape
edge to the desired width.
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Using the Open Plan Explorer
The Open Plan Explorer provides a graphical and intuitive means of working with your Open Plan
projects.
The Open Plan Explorer features two panes separated by a moveable splitter bar:


The pane on the left contains a hierarchical list of folders and subfolders. In Open Plan, data is
stored in a database. The items displayed in these folders are references to this data.



The pane on the right displays a multi-column list that provides information about the contents of
the currently selected folder.

At the top of the left pane is the Open a view drop-down list. You can use this drop-down list as an
alternative way to open a project.

Select an open project.

Opening a Project or Ancillary File
When you open a project, all ancillary files associated with the project are also opened. It is also
possible to open an ancillary file or view without first having to open the project.
There are two ways to open a project or ancillary file:


Using the File Open dialog box



Right-clicking a project or ancillary file and clicking Open on the context menu. (A view can also
be opened in this manner.)
Another way to open a view is by double-clicking its icon or by selecting a project and choosing
a view from the view drop list at the top of the explorer.
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Open Plan displays the following dialog box when you click Open on the File menu or click Open on
the Quick Access Toolbar:
Select the file to open.

Select the type of file to open.

Select the mode.

You can use the List Files of Type list to display the project, calendar, resource, or code files from
which to select.
Before you can open a file, you must specify the mode in which to open it:


Default — If you are opening a project, Open Plan opens the project and its ancillary files in the
mode specified on the Preferences tab of the Project Properties dialog box. This setting overrides
the default access mode for the ancillary file as set on its own Properties dialog box.



Exclusive — Opening the file in this mode allows you to update the information for the file and
save any changes. Other users must use the Read Only mode if they wish to open the file while
you are using it.



Shared — Opening the file in this mode allows other users to open the file in the same mode,
giving them the ability to make changes while you have it open.



Read Only — Opening the file in this mode means you cannot edit the information in any way.

If the file you want to open is already open by another user, Open Plan enables or disables the four
access modes as appropriate depending on the mode in which the file is already open. For example,
if the file you want to open is already opened by another user in Exclusive mode, Open Plan will
disable the first three modes and only allow you to choose Read Only.
You can open multiple files at once by Shift-clicking or Ctrl+clicking the desired files.
For more information on the exclusive, shared, and read-only modes, refer to Chapter 24,
“System Utilities.”

To open a file using the File Open dialog box, complete the following steps:
1. Take one of the following actions:

Open button



On the File menu, click Open.



Press Ctrl+O.



On the Quick Access Toolbar, click Open.

2. Select the file to open.
3. Use the List Files of Type list to display the type of file you want to open.
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4. Click the mode in which to open the file.
5. When finished, click OK.
To open a file using the context menu, complete the following steps:
1. Right-click the file you want to open.
2. On the context menu, point to Open.
3. On the Open submenu, click the mode in which to open the project.
When you open a project (regardless of the access mode you select), the ancillary files
associated with the project are opened in the default access mode established on the
Preferences tab of the Project Properties dialog box. If you open an ancillary file
outside the context of a project, clicking Default on the Open submenu opens the
ancillary file in the default access mode established on the Properties dialog box for
that file.

To open a file using the view list, complete the following steps:
1. Click the file you want to open.
2. Select the view from the Open a view drop down list.
You can apply a temporary exclusive lock on a project while on shared mode. For more
information on shared mode locks, see Chapter 25 System Utilities.

Creating a New Project or Ancillary File
When you create a new project or ancillary file, you have the option of creating it using default
settings or using the New File Wizard to specify some or all of the settings. When the project or
ancillary file is created, it is placed in the appropriate system folder. If you created a project, a link to it
is also established in My Folder.
If you created a project or ancillary file using default settings, you can always change the settings
later.
For information on changing file settings, refer to the “Assigning Ancillary Files to a Project”
section later in this chapter.
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When you create a new file, the following dialog box is displayed:

You can use this dialog box to define the following settings:


File Type — The type of file to create: Project, Calendar, Resource, or Code



Name — The name for the file



Description — The description for the file



Use previous settings as defaults — Selecting this option instructs Open Plan to create the
new file using the settings from the last time you created a new file. This setting is disabled for
Calendars and Codes.

Clicking Next will take you to the first page of the New File Wizard. Clicking Finish creates the file
using default settings. If you do not select the Use previous settings as defaults option and then
click Finish, the file is created using Open Plan defaults.
For more information on using the New File Wizard, refer to Chapter 4, “Creating a New File.”

To create a new project or ancillary file, complete the following steps:
1. Display the New File dialog box by taking one of the following actions:

New button



On the quick access toolbar, click New » <Project> or <Ancillary Data>.



Press Ctrl+N.



On the File menu, click New » <Project> or <Ancillary Data>.



Double-click an empty area of the Open Plan Explorer.

2. In the New File dialog box, select the type of file to create.
3. Provide a name and description for the file
4. Take one of the following actions:


To define your own settings for the file, click Next to start the New File Wizard.



To create the file using default settings, select the Use previous settings as defaults
option, and click Finish.



To create the file using Open Plan default settings, click Finish.
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Saving Files
Open Plan allows you to save a file with its current name using the Save command or under a
different name using the Save As command. These commands are available as follows:


If you opened the file in Exclusive mode, you can use the Save or Save As command at any
time.



If you opened a file in Shared mode, the Save command is not available. To save the project
under a different name, use the Save As command. (Normally, Open Plan saves your changes to
project, code, resource, and calendar files opened in Shared mode as you make them.)
For more information about working with files opened in Shared mode, refer to Chapter 24,
“System Utilities.”



If you opened the file in Read Only mode, the Save command is not available. You must use the
Save As command to save the file under a different name before you can make any changes to
it.

When you click Save As on the File menu, Open Plan displays the following dialog box:

With this dialog box, you can save project and data files to your database.
Depending on the circumstances under which you perform the Save As, the following rules apply:


When you create a copy of a project, the new project maintains the same ancillary file
attachments as in the original project.



When you create a copy of an ancillary file, if you want a project to use the new file, you must
attach it to the project by either dragging it from the Open Plan Library and dropping it on the
project, or by using the Files tab of the Project Properties dialog box.
You cannot perform Save As on a file if there is another file open which refers to it. For
example, if you open project CLEAN and then try to perform a Save As on the calendar file
CLEANCAL, you are given the following warning: "Cannot perform Save As on Calendar File
CLEANCAL because there are open objects referring to it." Since CLEAN refers to CLEANCAL,
you need to close the project before you can perform Save As on CLEANCAL.

To use the Save command, complete any of the following steps:
Save button



On the File menu, click Save.



Press Ctrl+S.



On the quick access toolbar, click Save.

To use the Save As command, complete the following steps:
1. On the File menu, click Save As.
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2. Enter a name for the file.
3. Click OK.

Closing Files
The operation performed when you issue a Close command depends on what method you use and
the context in which you issue the command. There are four methods for performing the Close
command:


Clicking Close on the File menu



Clicking Close on a context menu



Clicking Close located in the upper-right corner of a window



Clicking Close on a view
You cannot close a file if another file is dependent on it. For example, assume you have the
resource view displayed for an open project. If you close the project without first closing the
resource view, the project and its ancillary files will close except for the resource file. The
resource file remains open because the resource view is dependent on it.

The following sections describe each of the above methods.

Clicking Close on the File Menu


In an activity data view, such as a barchart or spreadsheet view, clicking Close on the File menu
closes the project.



Selecting an open ancillary file and clicking Close on the File menu closes the file. (This is
assuming that there is not another open file, such as a project or view, dependent on the ancillary
file.)



For a project selected in the hierarchy pane of the Open Plan Explorer, clicking Close on the File
menu closes the project.

Clicking Close on a Context Menu
Right-clicking an open file in the Open Plan Explorer and clicking Close on the context menu that is
displayed performs the same operation as clicking Close on the File menu.

Clicking the Close Button
The close button is located in the upper-right corner of a window:
Open Plan program window

Close buttons

Maximize view



Clicking the Close button for Open Plan closes the program. You are prompted for confirmation
before the program closes.
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Clicking Close on a View


Clicking Close on a view closes that view. The close button is located on the tab for each
individual view.

Assigning Ancillary Files to a Project
As stated in the previous section, when you create a file, you have the option of using the New File
Wizard to define you own settings for the file. In the case of a project, this also includes assigning
ancillary files. On the other hand, if you create the project using Open Plan defaults, only the default
calendar is assigned to the project.
There are two ways to assign ancillary files to an existing project (or change previously assigned
files):


Edit the Project Properties dialog box



Use drag and drop

You can use the Files tab of the Project Properties dialog box to assign calendar, resource definition,
and code files:
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Clicking the ellipsis button next to a field displays a list of available files from which to choose. For
example, clicking the calendar ellipsis displays a list of all available calendar files:

You also have the option of creating a new file. Clicking New displays the New File dialog box.
For more information on creating a new file, refer to the “Creating a New Project or Ancillary
File” section in this chapter.

Dragging an ancillary file from the appropriate folder of the Open Plan Library and dropping it into a
project folder automatically assigns the file to the project. Only one calendar file and one resource
definition file can be assigned to a project at a time. If you drag a calendar or resource definition file
from the Open Plan Library to a project that already contains one of these files, Open Plan asks if you
would like to replace the existing file.
A project cannot be dragged onto itself.

When a resource definition file is assigned to a project, a link to the file is displayed in a project
subfolder that has the same name as the resource file.
When a one or more code files are assigned to a project, links to these files are displayed in a project
subfolder named codes.
When a calendar file is assigned to a project, a link to that file is displayed in the project’s root folder.
To assign an ancillary file using the Project Properties dialog box, complete the following
steps:
1. Open the project in Exclusive mode to which you want to assign an ancillary file.
2. Take one of the following actions:


On the Processes tab, click Properties.



Right-click the project folder, and click Properties on the context menu.

3. On the Project Properties dialog box, click the Files tab.
4. Use the ellipsis buttons to select the ancillary files.
5. When finished, click OK.
To assign an ancillary file using drag and drop, complete the following steps:
1. In the Open Plan Library, locate the ancillary file you want to assign to a project.
2. Drag and drop the file into the target project folder.

Chapter 03 Getting Started
Deltek Open Plan 8.0 User Guide

64

Using the Open Plan Explorer

3. If the project already contains a calendar or resource definition file, click Yes when Open
Plan asks if you want to replace the existing file.
When using drag and drop, it is not necessary to first open the target project. The
project is automatically opened when the ancillary file is dropped into it.

Assigning Views to a Project
View files are stored in the Views folder of the Open Plan Library. To assign a view to a project, you
can either drag it from the Library to the project folder or double-click it in the Library to display the
Choose a Project dialog box. You can also use the Select dialog box to do this.
For more information on views and the Choose a Project dialog box, refer to Chapter 17, “Views
and Reports.”

To assign a view using drag and drop, complete the following steps:
1. In the Views folder of the Open Plan Library, locate the view file you want to assign to a
project.
2. Drag and drop the file into the target project folder.
When using drag and drop, it is not necessary to first open the target project.

To assign a view using the Choose a Project dialog box, complete the following step:
The project to which you want to add the view must be open for this method to work.

1. In the Views folder of the Open Plan Library, double-click the view file you want to assign to
the project.
2. From the Choose a Project dialog box, select the open project for which to display the view.
3. Take one of the following actions:


To display the view without creating a link, clear the Make a Permanent Link to Project
setting.



To create a link to the project, select the Make a Permanent Link to Project setting.

4. Click OK.
To assign a view using the Select dialog box, complete the following steps:
1. While in a view on the project, click the Select button from the View group of the Edit tab,
then click Other Views.
Select button
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The Select dialog box opens.

2. Select a view and click OK.

Creating a Shortcut
You can easily create a shortcut to a Windows application, file, or URL in any of the following Open
Plan folders:


The first level of My Folder



The Startup folder



Any user-created folder

Placing a shortcut in the Startup folder automatically launches it when you start Open Plan. For
example, if you want Windows Notepad to automatically start when Open Plan starts, you would
place a shortcut to Windows Notepad in the Startup folder. Open Plan also allows you to edit the
properties of a shortcut using a Properties dialog box.
You can suppress the automatic loading of items in the Startup folder by holding down the Ctrl key
after launching Open Plan.
For information on displaying and using the Properties dialog box for a shortcut, refer to Chapter
24, “System Utilities.”

To create a shortcut using Copy and Paste, complete the following steps:
1. In the Windows Explorer, locate and select the appropriate file.
2. Take one of the following actions:


On the Windows Explorer Edit menu, click Copy.



Press Ctrl+C.

3. In the Open Plan Explorer, select the folder in which to create the shortcut.


Press Ctrl+V.

Open Plan creates the shortcut in the designated folder.
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To create an application shortcut using Drag and Drop
In order for this operation to work, you must be able to view both the Open Plan
Explorer and the Windows Explorer at the same time. You can easily do this by starting
both programs and then right-clicking the Windows Taskbar and clicking Tile Windows
Horizontally (or Vertically).

1. In the Windows Explorer, locate and select the application.
2. Drag the application and drop it in the target Open Plan folder.
Open Plan creates the application shortcut in the designated folder.
You can copy Windows Desktop Shortcuts to Open Plan by selecting the shortcut and
either using the Cut/Paste or Drag/Drop method described above. You can also drag
the icon preceding the URL name in the Address Bar of Internet Explore to the desired
user created folder.

Deleting Files
There are two ways to delete a file:


By selecting the file and pressing the Delete key. However, in the My Folder view, pressing
Delete only deletes the link to the file, and not the file itself.



By using the Select File to Delete dialog box

There is a third way to perform a deletion that pertains only to views — right-click a view and click
Delete on the context menu.
You cannot delete a file that is open, referenced by another file, or to which you do not have the
appropriate rights.

When you use the Delete key to delete a file, Open Plan interprets the deletion depending on where
the file is located in the hierarchical view.
Codes that are assigned to projects cannot be deleted from the projects using this method. Codes are
removed from projects using the Files tab of the Project Properties dialog box.
For more information on removing codes from projects, refer to the “Using Code Files” section of
Chapter 11, “Project Codes.”

My Folder — If you delete a file from within this folder, Open Plan only deletes the link you created to
the file. In the case of a project, the project link as well as the ancillary files links are deleted. No
actual data is deleted from the data source.
To quickly delete a project link from this folder, right-click the project, and click Delete Link on
the context menu.

Projects — If you delete a project from within this folder, the project data and all the links to ancillary
files and views are deleted. Deleting just an ancillary file or view deletes the link to the file. No actual
ancillary file or view data is deleted from the data source.
Open Plan Library — If you delete an ancillary file or view from within this folder, the actual data is
deleted from the data source.
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To delete a file, complete the following steps:
1. Select the file, and press the Delete key.
2. When Open Plan asks you to confirm the deletion, click Yes.
Pointing to Manage Files on the File menu and clicking Delete File displays the Select File to Delete
dialog box that you can use to delete a file from the data source.

This dialog box displays a list of files based on the type of file you select in the File Type field.
It is possible to select multiple files to delete at once by using either Shift+click or Ctrl+click to
make your selection.

Also, depending on the file type, Open Plan performs one of the following actions when you delete a
file:


If the file is a project, all the project data is deleted from the data source. The links created in the
Project folder to any ancillary files are removed, but the ancillary file data itself is not deleted. Any
links to the project in your My Folder are also removed.



If the file is a calendar, resource, or code file, the file’s data is deleted from the data source and
any links to in other folders.

To delete a file using the Delete key, complete the following steps:
1. From the appropriate folder, select the file to delete.
2. Press the Delete key.
3. When Open Plan asks you to confirm the deletion, click Yes.
To delete a data file using the Select File to Delete dialog box, complete the following steps:
1. On the File menu, point to Manage Files.
2. On the Manage Files submenu, click Delete File.
3. Select the file you want to delete, and click OK.
4. When Open Plan asks you to confirm the deletion, click Yes.
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Filtering the Contents of the Open Plan Explorer
The Open Plan Explorer provides a command for filtering its contents. You can use this option, for
example, to filter out all completed projects or all views that are not barcharts from contents pane.
The Filter option is available for the following folders:


Projects



Calendars



Codes



Resources



Views



Briefcase
For folders that cannot be filtered, this option is disabled or not listed.

Right-clicking the folder and clicking Filter on the context menu invokes the Filter Settings dialog box:

Use this dialog box to define the following settings:


Enable Filtering — Selecting this option applies the filter folder.



Field Name — This setting lists all the fields on which you can filter. These fields are the
headings displayed in the Details format.



Operator — This setting lists the logical operators used in the filter definition. These operators
are:


Contains



Equals



Gr. Or Equals



Greater than



Is Empty



Less or Equals



Less than



Not Contains



Not Empty



Not equals
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The Contains operator is case-sensitive. Criteria entered using this expression must
be typed in the same case as the original value. If the same case is not used, no
results will be displayed.



Criteria — This setting allows you to enter a value for comparison to the Field Name as defined
by the Operator. This setting is text sensitive.



Clear — Removes all values that have been entered in the dialog box.

To filter the contents of the display format
1. In the hierarchical pane, select the folder to filter.
2. Right-click the folder to filter, and click Filter on the context menu.
3. In the Filter Settings dialog box, define the filter, and select Enable Filtering.
4. Click OK
The filter you define is only applied to the selected folder. This means that you can
have a different filter for each folder if you so desire.

Using Find in the Explorer
The Find dialog box allows you to find an object in any subfolder of the folder that is currently
selected. You can search for an object based on its name or on any field that is available. Since this
dialog box is modeless, you can keep it open while you initiate any number of searches.
You can display the Find dialog box by right-clicking the left or right pane of the Open Plan Explorer,
and selecting Find from the context menu:

Use this dialog box to define the following search parameters:


Search For — The type of object to find. Selecting <All Objects> instructs Open Plan to perform
a complete search of all object types (that is, calendars, resources, projects, etc.).



Named — Use of this field is optional. If you enter the name of the object to find, Open Plan will
find all objects that match the name entered or that begin with the name entered. For example, if
you are searching for the project named CLEAN, Open Plan will respond with all projects that
begin with the name CLEAN.
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If you do not know the entire name of the object for which you are searching, you can
enter the first few letters of the name. Be aware, though, that you must provide the
beginning letters of the name. Open Plan does not search for text embedded within the
name. For example, if you enter LEAN, Open Plan will not find CLEAN.



Where — Use of these fields is optional. The three Where fields allow you to apply a filter to your
search criteria:


The first field contains a list of data fields based on the type of object selected in the
Search For field.



The second field contains a list of the following logical operators that you can use to
further define the filter:



Equal to



Greater than



Less than



Not equal to



The third field allows you to enter a value to compare against.
The Where fields are not available when <All Objects> is selected in the Search For
field.



Look In — This field allows you to specify the folder in which Open Plan should start the search.
By default, the selected folder in the hierarchical pane is displayed in this field. However, you can
also select <All Folders>, My Folder, Projects, and Open Plan Library from the list. Open Plan
also facilitates your search by displaying any subfolders that have been opened during the
current session.
Since the Find dialog box is modeless, an alternative to using the Look In field is to
simply select the folder to search from the hierarchical pane while the dialog box is
displayed.



Include subfolders — Selecting this option instructs Open Plan to include all subfolders of the
currently selected folder in the search.

Once the search criteria is defined, clicking Find Now performs the search. Open Plan displays the
name, location, and file type for each object it finds matching the search criteria.
If you would like to perform another search, click New Search to clear the Named and Where fields.
The Find utility is different in views. For more information, see Chapter 06 Activity Information.

To search for an object using the Find dialog box, complete the following steps:
1. Right-click the left or right pane of the Open Plan Explorer » select Find from the context
menu.
2. In the Find dialog box, define the search criteria for the object to want to find.
3. Click Find Now.
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4. To close the dialog box, click Cancel.
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Favorites
Open Plan allows users to identify their favorite views, sorts, and filters to make it easy to access and
use them. Favorites are stored for each user. While views, sorts, and filters can be backed up by
Open Plan, your list of favorites cannot be backed up, as it is simply a convenient way of accessing
the objects.
You can identify your favorites in two ways: through the Organize Favorites dialog box available on
the Tools tab, or by using a view, sort, or filter and then adding them to your list of favorites. To add
filters and sorts to the favorites list, use the Add To Favorites buttons accessible from the Edit tab »
Filters group and Edit tab » Sorts groups. For views, use the Add To Favorites button on the Edit tab
» Views group under the Select view button.
For each category of favorites, you can reuse your favorites by clicking the appropriate Favorite list in
the Edit tab. For views, the favorites are shown under the Select button in the View category of the
edit tab. For filters and sorts there is a Favorites button in the filters and sorts groups.
Open Plan displays a maximum of 10 favorites. If you have more than 10 favorites in your lists, you
can click More Favorites to display the rest of the favorites in a dialog.

To view and select additional favorite filters, complete the following steps:
1. Click the Favorite Filters button and select More Favorites.
The following dialog box displays:

2. Select a filter and click OK.
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You can also manage views, sorts, and filters on your favorites lists by displaying the Organize
Favorites dialog box:

From this dialog box, you can perform the following actions:


Add items to the favorites lists



Remove items from the favorites lists



Rearrange the position of favorite items in the list
The Organize Favorites dialog box is resizable. You can resize this by dragging any corner or
side of the dialog box. You can also resize the relative widths of the Available Items and
Selected Favorites panes by clicking between the two panes (near the bottom of the panes) and
dragging the mouse to either the left or right.

To add an item to a favorites list, complete the following steps:
1. Display the Organize Favorites dialog box by clicking the Organize button from the Favorites
group of the Spreadsheet or Barchart View tab or from the Favorites button of the Manage
group of the Spreadsheet or Barchart Tools tab.
2. For each item that you want to add to its corresponding favorites list, take one of the following
actions:


Select the item from the Available Items list and the click



Double-click the item from Available Items.

button.

This action moves the selected item to the Selected Favorites list.
You can expand or collapse the list categories by clicking

or

.

3. When finished, click OK.
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To remove an item to a favorites list, complete the following steps:
1. Display the Organize Favorites dialog box by clicking the Organize button from the Favorites
group of the Spreadsheet or Barchart View tab or from the Favorites button of the Manage
group of the Spreadsheet or Barchart Tools tab.
2. For each item that you want to remove from the Selected Favorites list, take one of the
following actions:


Select the item from the Selected Favorites list and the click the



Double-click the item from Selected Favorites.

button.

This action moves the selected item to the Available Items list.
3. When finished, click OK.
To rearrange the display of the items, complete the following steps:
1. Display the Organize Favorites dialog box by clicking the Organize button from the Favorites
group of the Spreadsheet or Barchart View tab or from the Favorites button of the Manage
group of the Spreadsheet or Barchart Tools tab.
2. Select an item in the Selected Favorites list and click either
down the list.

or

to move the item or

3. When finished, click OK.
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Overview

Overview
Open Plan allows you to create new project, calendar, resource definition, and code files with one of
following methods:


Using default settings



Using the New File Wizard where you can define custom settings for the file
Regardless of the method you use to create the file, you can always change the settings later
using the Properties dialog box for the file.

This chapter begins with a description of how to create a new file with default settings, continues with
a discussion of how to create a file with custom settings, and ends with a detailed description of the
New File Wizard.
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Creating a File with Default Settings
The starting point for creating any type of Open Plan file is the New File dialog box.

You can create a file using Open Plan default settings or you can create the file using the settings
from the last file you created. If you are creating a project or resource file, the Use previous settings
as defaults option allows you to use the settings from the last project or resource file you created.
If you want to create a file with Open Plan default settings, you have only to select a File Type
(project, calendar, resource, or code), enter a Name for the file, and click Finish. To use the settings
from the last file created, be sure to select the Use previous settings as defaults option before
clicking Finish.
While most project managers will enter a Description for the file, this field is not required.

To display the New File dialog box, complete the following steps:
1. Take one of the following actions:

New button



On the File menu, click New » Project, Calendar File, Code File, or Resource File.



Press Ctrl+N.



On the Quick Access Toolbar, click New.



Double-click an empty area of the Open Plan Explorer.

Chapter 04 Creating a New File
Deltek Open Plan 8.0 User Guide

77

Creating a File with Custom Settings

Creating a File with Custom Settings
The New File Wizard in Open Plan helps you to specify custom settings for a new file as it is being
created. Once you have entered the information in the New File dialog box (as described in the
previous section), you can start the New File Wizard by clicking Next.
The New File Wizard contains a total of nine pages. The type of file (project, calendar, resource, or
code) you create determines which pages are displayed during the process. A brief overview of each
page follows:


Create — This page of the wizard is displayed for all files you create. You can use the Create
page to specify whether you want to create a new blank file or create a file as a copy of another.



Summary — This page of the wizard is displayed only when you are creating a project or
multiproject. You can use the Summary page to enter summary information about the project.



Status Information — This page of the wizard is displayed only when you are creating a project
or multiproject. You can use the Status Information page to enter status information about the
project.



Files — This page of the wizard is displayed when you are creating a project, multiproject, or a
resource file. You can use the Files page to select the ancillary files that the project or resource
file will use. If the ancillary file you want to use does not yet exist, you can also create it “on the
fly” by displaying the New File dialog box from this page.



External Subprojects — This page of the wizard is displayed only when you are creating a
multiproject. You can use the External Subprojects page to select the external subprojects to be
included in the new multiproject project.



Preferences — This page of the wizard is displayed only when you are creating a project or
multiproject. You can use the Preferences page to define the default preferences for the project.



Code Structure — This page of the wizard is displayed only when you are creating a code file.
You can use the Code Structure page to define the structure of a code file.



Notes — This page of the wizard is displayed when you create a project, multiproject, resource,
or code file. You can use the Notes page to attach a note to the file.



Access Control — This page of the wizard is displayed for all files you create. You can use the
Access Control page to define the access rights that groups or individual users with a specified
role will have to the file you are creating.

After you have created your new file, Open Plan saves the setting choices you made on the pages in
the New File Wizard. The next time you create a file, you have the option of using these saved
settings as the default settings for the new file.
The following chart summarizes the circumstances under which each page of the New File Wizard is
displayed:
Wizard Page

Project

Multiproject

Create





Summary





Status Information





Files
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Wizard Page

Project

Multiproject

Calendar

Resource

Code



External Subproject



Preferences




Code Structure
Notes





Access Control















For detailed information about each page of the wizard, refer to the corresponding sections later
in this chapter.

To create a file with custom settings, complete the following steps:
1. Display the New File dialog box.
2. From the File Type field, select the appropriate file type (project, calendar, resource, or
code).
3. In the Name field, enter a name for the new file.
4. In the Description field, enter a description for the file. (This step is optional.)
5. Click Next.
6. Open Plan starts the New File Wizard and displays the Create page.
7. If the Default Access Mode field is displayed on this page, select a default access mode for
the file.
If you are creating a new project, the Default Access Mode field is displayed on the
Preferences page of the wizard.

8. Decide whether you want to create an original new file or create the file as a copy of an
existing one, and click the appropriate option.
9. If you are creating the new file as a copy of an existing one, Open Plan allows you to select
the file that you want to use as a template.
10. If the Startup View field is displayed on this page, you may select the view that you would
like Open Plan to display when the file is opened.
If you are creating a new project, the Startup View field is displayed on the
Preferences page of the wizard.

11. Complete the remaining pages of the wizard, clicking Next to advance from page to page.
12. On the last page of the wizard, click Finish.
13. Open Plan creates the file with the information you entered. If you have created a project,
Open Plan places it in the Projects folder and creates a link to the project in your My Folder. If
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you have created a calendar, resource, or code file, Open Plan places it within the
appropriate folder in the Open Plan Library.
When you have finished creating the file, you can display the relevant Properties dialog
box to review your settings and make any necessary changes.
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Using the New File Wizard
The following fields are located at the top of each page of the New File Wizard:


Name — The name of the file as it was entered on the New File dialog box is displayed at the top
of each page. You can change this name only on the Create page of the wizard.



Owner — Your user ID is displayed in this field. As the owner of the file, only you or the security
administrator can assign access rights to the file to other users.



Description — The description of the file is displayed in this field. While this description may
have been entered on the New File dialog box, it may also be entered or changed on any page of
the wizard.

Buttons located along the bottom of each page allow you to navigate through the series of pages
available for the type of file you are creating.
You can also click Finish at any time during the wizard process to create the new file using the
settings you have defined to that point. It is not necessary to complete all pages of the wizard as
you can always define the remaining settings on the Properties dialog box for the file.

New File Wizard — Create Page
The Create page of the wizard is used for all types of files. When you click Next on the New File
dialog box, this page is displayed automatically:

You can use the Create page to specify the following parameters for the new file:
Default Access Mode — This field is displayed only when you are creating an ancillary (resource,
calendar, or code) file.
If you are creating a project, the Default Access Mode field is displayed on the Preferences
page of the wizard.
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The setting you choose determines the default access mode when the file is opened. The three
access modes are:


Exclusive — A file opened in Exclusive mode can only be opened in Read Only mode by other
users. When you have a file open in Exclusive mode, you can save any changes you make. You
can also close the file without saving your changes.



Shared — This mode allows two or more users to access a file and work with the data at the
same time. When you have a file open in Shared mode, any change that you make to the file are
automatically saved as soon as they are made. This provides all users who have the file open
with the latest information



Read Only — This mode allows you to view a file. You cannot, however, make any changes to
the file while you have it open in this mode.
For more information on the three access modes, refer to Chapter 24, “System
Utilities.”



Ancillary Files — This field is displayed only when you are creating a resource file. It controls the
default access mode of the ancillary files attached to the resource file.

The following options control how Open Plan should create the new file:


Create a new file — Selecting this option instructs Open Plan to create a new blank file.
A user with system administrator rights can disable this option by selecting the Create
New Projects Using Default Project on the Project tab of the Options dialog box.



Create a new file as a copy of an existing file — If you select this option, the wizard enables a
list of files of the appropriate type that are currently stored in the database. You must use this list
to select the file to be used as a template.
When creating a project, if you choose to use a master project as the template, Open
Plan prompts you to open the external subprojects. If you open these external
subprojects, they will become internal subprojects in the new project. If you prefer to
keep them as external subprojects, do not open them.



Startup View — This field is displayed only when you are creating an ancillary (resource,
calendar, or code) file. The setting you choose determines the view that Open Plan automatically
displays when the file is opened.
If you are creating a project, the Startup View field is displayed on the Preferences
page of the wizard.
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New File Wizard — Summary Page
The Summary page of the New File Wizard is displayed only when you are creating a project or
multiproject:

This page allows you to enter the following summary information about the new project:


Project Manager — The name of the project manager. While use of this field is optional, the
information it contains is used in many reports.



Project Manager Email Address — The project manager's email address. While use of this field
is optional, Open Plan can use the information it contains as the "To" address in the Email
Advisor.



Company — Your company name.



Client — The project's client.



Project Priority — Specifies the priority of the project. Open Plan uses this setting when
performing resource scheduling on a number of projects at one time. You can give the project a
high priority by entering a low numeric value.



Create Summary Usage Upon Saving Project — Selecting this option instructs Open Plan to
populate the Project Summary Usage (PSU) table when the project is saved. Open Plan uses this
data when performing resource scheduling on a number of projects at one time.



Create Summary Usage Based On – This field is enabled when you select the Create
Summary Usage Upon Saving Project option. It allows you to specify the type of dates (early,
late, or scheduled) that Open Plan should use when creating the summary usage data.
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New File Wizard — Status Information
The Status Information page of the New File Wizard is used only when you are creating a project or
multiproject:

You can use this page to enter the following status information for the project:


Project Start — The date on which the project starts. You can specify the Project Start either by
entering the date directly or by clicking the ellipsis at the right edge of the field and selecting a
date from the calendar that is displayed.



Time Now — The original status date for the project. You can specify Time Now either by
entering the date directly or by clicking the ellipsis at the right edge of the field and selecting a
date from the calendar that is displayed.



Auto Time Analysis — If you select this option, Open Plan will perform time analysis each time
the data in the project changes.
You can also specify the Time Now date and select the Auto Time Analysis option on the
Processes tab from the Schedule group.





Finish Type — You can use this field to specify the type of target Open Plan should use when a
Target Finish is set. You can select from the following Finish Types:


None



Not Earlier Than



Not Later Than



On Target

Target Finish — This field is enabled only if you have selected one of the target types in the
Finish Type field. If enabled, you can impose a finish date on the project either by entering the
date directly or by clicking the ellipsis at the right edge of the field and selecting a date from the
calendar that is displayed.
The target finish date affects the dates that the program calculates when performing time analysis
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or resource scheduling. Entering this date is optional. Ordinarily, you will want to give Open Plan
as much flexibility as possible in its calculations by not setting a project target finish date.


Target Cost — The target cost for the project.

New File Wizard — Files Page
The Files page of the New File Wizard is displayed only when you are creating a project,
multiproject, or resource file. This page allows you to assign ancillary files to the file you are creating:

The fields that are displayed on this page depend on the type of file you are creating.


Calendar File — This field is displayed when you are creating a project, multiproject, or resource
file. You can assign a single calendar file to the file you are creating. The way in which this
calendar is used depends on the type of file you are creating:


If you are creating a project or multiproject, the calendar you select is used as the default
calendar for project calculations.



If you are creating a resource file, the calendar you select is used as the default calendar
when defining resource availabilities.



Resource Definition File — This field is displayed only when you are creating a project or
multiproject. You can use this field to assign a single resource definition file to the project.



Code Files — This field is displayed when you are creating a project, multiproject, or resource
file. You can assign up to 90 code files to the file you are creating.
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Assigning Calendar and Resource Definition Files
Clicking the ellipsis button next to the Calendar File or Resource Definition File field displays a
Select dialog box from which you can select the ancillary file. For example, if you click the ellipsis
button next to the Calendar File field, the Select dialog box that is displayed contains a list of all
available calendar files in the database:

You can also create a new calendar or resource file by clicking New on the Select dialog box. Doing
so displays the New File dialog box with the type of file you are creating automatically selected in the
File Type field. You can then choose to create the file using Open Plan default settings, or you can
start a new instance of the New File Wizard.
Once it is created, the new ancillary file is automatically added to the Select dialog box.
To assign an existing calendar or resource file, complete the following steps:
1. On the New File Wizard — Files page, click the ellipses button next to the appropriate field.
2. From the Select dialog box, select the ancillary file.
3. Click OK.
To create a new calendar or resource file, complete the following steps:
1. On the New File Wizard — Files page, click the ellipses button next to the Calendar or
Resource field.
2. On the Select dialog box, click New.
Open Plan displays the New File dialog box. After creating the new file, it is added
automatically to the Select dialog box.
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Assigning Code Files
Clicking the ellipsis button next to the Code Files field displays the Assign Code dialog box:

This dialog box allows you to assign code files for up to 90 code fields in the Project Directory, or
Activity or Resource tables. Select a code file from the left pane and then select a field to assign it to
in the right pane.
Each time you click OK to assign the selected code to the selected field, Open Plan displays the
Code File Prompt dialog box:

This dialog box allows you to change the prompt text for the code file before assigning it to the code
field.
If the code has default prompt text defined (on the Properties dialog box for the code file), it is
automatically entered when the Code File Prompt dialog box is displayed. If no prompt text has
been defined for the code, the code file name is automatically entered on the dialog box. The
code prompt is used instead of the generic field name (C1…C90) in any field list that is brought
up in a specific context. For example, if “OBS” is the code prompt for C1 in Project Clean, that is
what you will see when you select fields in an activity spreadsheet view opened under CLEAN.
C1…C90 will appear in dialogs that are not opened under a specific context (such as the
Calculated Fields Dialog).

Once you have entered the prompt text and clicked OK, Open Plan assigns it to the code file. You
can change the prompt text by selecting the code in the right pane of the Assign Code dialog box and
clicking Prompt to display the Code File Prompt dialog box again.
Code files are stored as either a rotated column or as a permanent column in the code’s associated
table.
Rotated columns do not take up space in the database unless they are assigned values; assigned
values are stored as records. When the records are accessed, they are “rotated” logically into the
more familiar field structures. This method reduces the amount of database storage used when a
code column is used sparsely, but may increase the amount of time needed to load and save data,
especially if a column of data is densely populated.
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Non-rotated columns require database storage even when there is no value for a particular record,
but reduce loading and saving times.
If a code index (e.g., Code 1, Code 2, Code 3, etc. in the graphic above) does not currently have a
rotated column assigned to it, then a user has the option of either creating a new column as a rotated
or non-rotated column. The process of assigning codes can be performed when creating or changing
properties for an Open Plan project.
Only users who have system administrator rights may make changes to the structure of a database
table. That means that anyone attempting to make structural changes will be prompted to log in as
the System Administrator. The user will be prompted for this login even if he is currently logged in as
the System Administrator.
To assign code files to the Project Directory, or the Activity or Resource tables, complete the
following steps:
1. On the New File Wizard — Files tab, click the ellipses button next to the Code Files field.
2. In the Assign Code dialog box, assign a code file to a code field.
3. In the Code File Prompt dialog box, you may change the name for the code file prompt.
4. Repeat steps 2 and 3 as many times as necessary. You can assign code files for up to 90
code fields.
5. To return to the wizard, click OK.
6. If you have assigned a code to a code field (e.g., Index 90) that has not been previously
used, you will be prompted with the following dialog box when you click Finish:

7. If you select No (the default button), the code field is created as a rotated column. (Note: If
you select Yes, you will be prompted to log in as a system administrator.) If you select Yes,
the code field is created as a non-rotated column.
To change the code file prompt for an assigned code file, complete the following steps:
1. On the New File Wizard — Files page, click the ellipses button next to the Code Files field.
2. From the right pane of the Assign Code dialog box, select a code file.
3. Click Prompt.
4. Open Plan displays the Code File Prompt dialog box.
5. Enter a new prompt for the code file, and click OK.
6. To return to the New File Wizard — Files page, click OK.
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New File Wizard — External Subprojects
The External Subprojects page of the New File Wizard is displayed only when you are creating a
multiproject:

This page allows you to select the external subprojects to include in the multiproject. The text box on
this page displays a list of all the projects currently stored in the database.
By default, the project(s) that were selected when you displayed the context menu from the Open
Plan Explorer are preselected in this list. You can, however, add or remove selections in this list
simply by clicking them. The selected projects become external subprojects in the multiproject that is
created when you click Finish.
To create a new multiproject, complete the following steps:
1. Right-click a project in the Open Plan Explorer, and click Create Multiproject on the context
menu.
2. In the New File dialog box, enter a name and description for the multiproject.
3. Project is automatically selected for the File Type, and the field is disabled.
4. Click Next to start the New File Wizard.
5. Complete the pages of the wizard as needed.
The External Subproject page is the fourth page of the wizard.
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New File Wizard — Preferences
The Preferences page of the New File Wizard is used only when you are creating a project or
multiproject:

This page allows you to specify the following default project settings:


Default Date Format — You can use this field to specify the default format that Open Plan
should use for this project when displaying dates. For new projects, the default format is
31Dec07. However, you can choose from many other formats as well. If you later enter a date in
a different format, Open Plan attempts to convert it to the format you selected as the default.
For example, if your default date format is 31Dec07, Open Plan makes the following conversions:


31dec is interpreted as 31Dec07 if 2007 is the current year.



13/12/07 is always interpreted as December 13, 2007, since 13 cannot be interpreted as a
month.



If the date you enter is all numeric (for example, 10/01/07), Open Plan uses the order of
month and year from your Windows system.



Default Activity Type — You can use this field to select the activity type that Open Plan assigns
to new activities within the project. You can select from the following activity types: ASAP, ALAP,
Start Milestone, Finish Milestone, Discontinuous, Hammock, and Effort Driven. In addition, you
can also select External Subproject.



Def. Activity Calendar — You can use this field to select the default calendar to be used for all
new activities within the project. Using a default activity calendar makes it easier to share one
calendar file over all projects.



Default Res. Curve — You can use this field to choose from the following:


All valid Spread Curves defined within the Spread Curves dialog box for which the user has
at least read-only access; or



A blank curve type
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By default, Default Res. Curve is blank. The Default Res. Curve value is used for all new
resource assignments within the project. The Default Res. Curve option is available when using
Backup or Save As.


Startup View — You can select the view that Open Plan should display by default when opening
the project.



Def. Relationship Calendar — You can use this field to select the default calendar Open Plan
should use for all new relationships within the project.



Default Res. Level — The Default Res. Level field contains the following options:


0 — Sets the default resource level for new resource assignments to 0.



1 — Sets the default resource level for new resource assignments to 1.



First availability — The default resource level for new resource assignments is obtained
from the first resource availability that is defined for the assigned resource. If the Resource
does not have any defined availability, the default resource level will be set to 1.

By default, Default Res. Level is set to First Availability. The Default Res. Level value will be used
for all new resource assignments within the project.
The warning The resource level for this assignment is 0.0 Do you want to continue? is
displayed if:


The resource assignment is a new (unsaved) resource assignment;



The Default Resource Level option is set to ‘0’ (zero); and



The resource Level of the resource assignment is ‘0’ (zero).

The Default Res. Level option is included in Backup and Save As.


Conversions — You can use these fields to specify the way Open Plan should convert durations
into minutes from different time units:


per Day – Controls the number of hours and minutes per day that are used in the conversion.
The default setting is 8 hours and 0 minutes.



per Week – Controls the number of hours and minutes per week that are used in the
conversion. Typically, this would be the number of hours per day multiplied by the number of
work days in a week. The default setting is 40 hours and 0 minutes.



per Month – Controls the number of hours and minutes per month that are used in the
conversion. Typically, this would be the number of hours per day multiplied by the number of
work days in a month. The default setting is 160 hours and 0 minutes.



Default Duration Units — By specifying a default duration unit, you can enter durations in the
project without specifying a unit. You can specify any of the following units: Minutes, Hours, Days,
Weeks, or Months.



Min. Calculated Duration — You can use this field to specify the minimum duration unit that
Open Plan should use in calculations for the project.
Calculated durations include those generated while stretching a bar in the barchart
view.



Default Access Mode — You can use these fields to select which of three access modes Open
Plan should use by default for the project and its ancillary files. The three access modes are:
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Exclusive — A file opened in Exclusive mode can only be opened in Read Only mode by
other users. When you have a file open in Exclusive mode, you can save any changes you
make. You can also close the file without saving your changes.



Shared — This mode allows two or more users to access a file and work with the data at the
same time. When you have a file open in Shared mode, any changes that you make to the
file are automatically saved as soon as they are made. This provides all users who have the
file open with the latest information



Read Only — This mode allows you to view the project or ancillary file. You cannot, however,
make any changes to the file while you have it open in this mode.
For more information on the three access modes, refer to Chapter 24, “System
Utilities.”

New File Wizard — Code Structure
The Code Structure page of the New File Wizard is used only when you are creating a code file:

You can use this page to define the structure of the new code file:




Code Type — Open Plan supports two types of code file structures:


Punctuated Significant — With this type of code, Open Plan uses a period (.) to separate
the part of the code that corresponds to the different levels in the structure.



Fixed Format Significant — With this type of code, the length of the code represents the
structure level. Apart from the top-level code, each code is based on the name of its parent.

Fixed Level Length — If you select the Fixed Format Significant code type, Open Plan
enables the following controls:


Levels 1 through 10 — While Open Plan allows you to define up to 10 levels for the fixed
level length, most planners find that 3 or 4 levels are all they need.
At each level, you can define the number of characters that will be used. The number you
enter is cumulative.
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The following example assumes that three levels have been defined in the code file:
Level

Code Length

Example

Level 1

2

DV

Level 2

5

DV215

Level 3

7

DV21535

Note that the code at Level 2 includes the code of its parent, and that although the code
length is defined as 5, only 3 new characters (215) are added to the code.
Similarly, the code at Level 3 includes the code of its parent, and although the code length is
defined as 7, only 2 new characters (35) are added to the code.


Pad Character — The character specified as the pad character is used as a suffix to codes
that do not use the defined length at a given level.
The following example assumes that three levels have been defined in the code file and that
the pad character is "0":
Level

Code Length

Local Portion of Code

Code Example

Level 1

2

DV

Level 2

5

9

DV900

Level 3

6

A

DV900A

DV

Note that only a single character is entered in the local portion of the code at Level 2 but that
the cumulative code length is defined as 5. Open Plan pads the code out to the required
length by adding two 0s as a suffix to the local portion of the code.
You can use any character (including a space) as a pad character.
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New File Wizard — Notes
The Notes page of the New File Wizard is used when creating a project, multiproject, resource file,
or code file:

You can use the following fields to attach a note to the file:


Note — This text box can contain up to 29 KB of text. You can enter the text by typing directly in
this field or by using the Windows Cut (Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) commands to
insert text from another Windows application such as a word processor or spreadsheet.



Category — This field controls the category of the note. You can select a category from the list of
global categories.
Clicking abc checks the spelling of the text you enter.

You can enter links to files, Web pages, and e-mail addresses by entering the information in one of
the following formats:


File links must be entered in the format of: file://c:\document.doc
If the file link you enter contains spaces, you must enclose the link with angle brackets ( < > ) in
order for the link to work properly: <file://C:\Documents and Settings\All
Users\Desktop\test.txt>



Universal Resource Locators (URLs) must be entered in the format of: http://deltek.com



E-mail addresses must be entered in the format of: mailto:sales@deltek.com
While you can use drag and drop functionality to create links in the Note field, the Windows Cut
(Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) commands are not available for links.

To enter a note while creating a file, complete the following steps:
1. From the Category list, select a category for the note.
2. Use one of the following methods for entering a note in the Note pane:
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Type your message directly in the pane.



Use the Cut, Copy, and Paste commands to insert text in the pane from another Windows
application such as a word processor or spreadsheet.

3. If desired, click abc to check the spelling in your note.

New File Wizard — Access Control
The Access Control page of the New File Wizard is used when creating all types of files:

You can use this page to specify access rights that groups and individual users with a specified role
have to the file.
The following fields are available:


Group — By selecting a field in this column and selecting a group from the list, you can specify
the groups that can have access to the file.



Role — When you select a group or user ID, its default role is automatically entered in this field.
You can then change default role to any role that has been defined in the data source.



User ID — You can specify individual users who can access the file.
The Group and User ID settings are mutually exclusive. In other words, you cannot specify a
group and an individual user on the same row of the grid. You can, however, give access rights
to a group on one row and then give access rights to an individual on a separate row.



Read Only — Setting this option to Yes limits the rights of the group or user to viewing the file.
No changes can be made to the file. Setting this option to No gives the group or user all rights to
the file that are permitted by the assigned role.
The security options for groups and roles are assigned using the Security Administrator.
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To specify access rights for a group, complete the following steps:
1. In the Group column, select an empty cell/row, and select a group from the list.
2. In the Role column, select a role for the group from the list.
3. In the Read Only column, use the list to select Yes or No.
Notice that the User ID column is left blank.

To specify access rights for an individual user, complete the following steps:
1. In the User ID column, select an empty cell/row, and select a user ID from the list.
2. In the Role column, select a role for the user ID from the list.
3. In the Read Only column, use the list to select Yes or No.
Notice that the Group column is left blank.
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Overview

Overview
Each type of file in Open Plan has an associated tabbed Properties dialog box. For resource files,
code files, calendar files, and views, the dialog box is called the Properties – <Filename> dialog box,
where <Filename> is the name of the selected file. For a project, it is called the Project Properties
dialog box.
Many of the tabs on these dialog boxes are identical in function. Some are unique to that file. This
chapter begins with descriptions of the tabs located on the Properties dialog boxes for ancillary files
and views. Since the Project Properties dialog box contains many unique tabs and has only five tabs
in common with ancillary files and views, it will be discussed separately at the end of this chapter.
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Ancillary File and View Properties Tabs
The following table lists all the tabs found on the Properties dialog box for ancillary and view files. It
also indicates the type of file on which the tab can be found.
Properties Tab

Resource Files

Code Files

Calendar Files

View Files

General









Statistics



Files



Access Control









Open Status







References







Notes





User Fields





Structure





Preferences



Each tab, regardless of the file, displays the following information:


Name — This field displays the name given to the file at its creation.



Owner — This field displays the ID of the current owner of the file. Under normal circumstances,
the owner of the file or view is the person who created it. While other users may have the rights to
modify many of its properties, only the owner or the system administrator can transfer the
ownership of the object.



Description — This field displays the description of the file. Providing a description is optional
during file creation. You can edit the description on any tab of the Properties dialog box.

Editing Considerations


When editing the properties for a file, the following guidelines should be taken into consideration:



Provided you have the proper access control rights to the file, you do not have to first open a file
to edit its properties.



The Files tab for a resource file is only enabled when the file is opened in Exclusive mode.



A view does not have to be open to edit its properties.



Opening a resource, code, or calendar file in Read Only mode disables all the fields in the
Properties dialog box.

To display the Properties dialog box for a resource, code, or calendar file, complete the
following steps:
1. Take one of the following actions.
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In the Open Plan Explorer, right-click the appropriate file, and click Properties on the
context menu.



Open the appropriate file, and click Properties from the Dialogs group on the Edit tab.



Open the appropriate file, right-click an empty area of the workspace, and click
Properties on the context menu.

To display the Properties dialog box for a view file, complete the following steps:
1. In the Open Plan Explorer, locate the appropriate view file.
2. Right-click the view file, and click Properties from the Dialogs group on the context menu.

The General Tab
For the sake of consistency, the Properties dialog box for a resource file will be used to illustrate
the various tabs. Differences on the tabs among the various file types are clearly noted.

The General tab of the Properties dialog box is available for resource, code, calendar, and view files.
It displays the following information about the file:

This tab of the dialog box displays the following information:


File Type — Indicates whether the file is a code file, resource file, calendar file, or view template.



Last Updated On — Displays the date on which the file or view was last updated.



Updated By —Displays the user ID of the person who last updated the file or view.



Data Access Mode — Displays the current data access mode:


Not open



Exclusive



Shared



Read-only
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This field is not displayed for a view.



Default Access Mode — Controls the default access mode (Exclusive, Shared, or Read Only)
of the file
This field is not displayed for a view.



Ancillary Files — Controls the default access mode (Exclusive, Shared, or Read Only) of the
ancillary files attached to the resource file
This field is displayed only for resource files.



Startup View — Controls the view that Open Plan should display by default for the ancillary file
This field is not displayed for a view.



Default Prompt Text — Controls the default prompt text that is automatically entered on the
Code File Prompt dialog box that displays when you attach a code file to a project or resource
file. Although this text is entered by default, you can change it before clicking OK on the Code
File Prompt dialog box.
This field is displayed only for code files.
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The Statistics Tab
The Statistics tab of the Properties dialog box is displayed only for resource files:

This dialog box displays the following settings:


Pools — The total number of pools in the resource file



Skills — The total number of skills in the resource file



Resources —The total number of individual resources in the resource file
Resources with the type Pool are not included in this total.
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The Files Tab
The Files tab of the Properties dialog box is displayed only for resource files. It allows you to attach a
calendar and a code file to the resource file:

This dialog box has the following controls:


Calendar — Controls the calendar file attached to the resource file.
When you click the ellipsis button at the right edge of this field, Open Plan displays the Select
dialog box that you can use to assign a calendar file to the resource file.



Codes — Controls the code files attached to the resource file
When you click the ellipsis button at the right edge of this field, Open Plan displays the Assign
Code dialog box that you can use to assign codes to up to 90 code fields on the resource file.
For more information on using the Select dialog box and the Assign Code dialog box to assign
calendar file and code files, refer to the “New File Wizard — Files Page” section of Chapter 4,
Creating a New File.”
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The Access Control Tab
The Access Control tab of the Properties dialog box is available for resource, code, calendar, and
view files. It allows you to define the access rights that users or groups have and what role they have
to the file:

If you are the owner of the project or a member of the System Administrator group, you can use the
following fields to define access rights to the file:


Owner — You can change the owner of the file by selecting a new owner from the list.



Group — By selecting a field in this column and selecting a group from the list, you can specify
the group(s) that can have access to the file.



Role — When you select a group or user ID, its default role is automatically entered in this field.
You can then change default role to any role that has been defined in the data source.



User ID — By selecting a field in this column and selecting a user ID from the list, you can specify
the users that can have access to the file.



Read Only — By selecting Yes for this field, you limit the group or user to opening the file in
Read Only mode. By selecting No for this field, other users may open the file in any mode they
choose. Read Only mode has the following limitations:


In order to make changes to the file, you must first save it under a different name.



You cannot see changes made by other users.

Click

to accept a selection. Click

to cancel a selection.

In order to see changes made by other users who may have the file open in Exclusive or
Shared mode, you have to close and reopen the file.
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The Open Status Tab
The Open Status tab of the Properties dialog box is available for resource, code, and calendar files. It
displays the information about the open status of the project:

The following information is displayed on this tab:


User ID — Displays the user ID of each person who has the project open



Machine ID — Displays the ID of each computer where the file is open



Open Mode — Displays the mode in which the project is open. This mode can be any of the
following:


Exclusive — If a file is open in Exclusive mode, you have the exclusive right to make
changes to it. While you have the file open in exclusive mode, other users can open the file
only in Read Only mode.



Shared — If the file is open in Shared mode, other users can open the file and make
changes while you have it open.



Read Only — If the file is open in Read Only mode, you cannot use the Save command to
save any changes you may make. Instead, you must use the Save As command and save
the file with a different name.
For more information on the three access modes, refer to Chapter 24, “System
Utilities.”



Opened On — Displays the date and time that the file was opened by a user
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The References Tab
The References tab of the Properties dialog box is available for resource, code, and calendar files:

Every file that references the selected ancillary file is listed on this dialog box.

The Notes Tab
The Notes tab of the Properties dialog box is available for resource and code. You can use this tab to
attach text information to the file:

You can use the following fields to attach a note to the file:


Note — This text box can contain up to 29 KB of text. You can enter the text by typing directly in
this field or by using the Windows Cut (Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) commands to
insert text from another Windows application such as a word processor or spreadsheet.



Category — This field controls the category of the note. You can select a category from the list of
global categories.
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Clicking abc checks the spelling of the text you enter.
You can enter links to files, Web pages, and e-mail addresses by entering the information in one of
the following formats:


File links must be entered in the format of: file://c:\document.doc
If the file link you enter contains spaces, you must enclose the link with angle brackets ( < > ) in
order for the link to work properly: <file://C:\Documents and Settings\All
Users\Desktop\test.txt>



Universal Resource Locators (URLs) must be entered in the format of: http://deltek.com



E-mail addresses must be entered in the format of: mailto:sales@deltek.com
While you can use drag and drop functionality to create links in the Note field, the Windows Cut
(Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) commands are not available for links.

The User Fields Tab
The User Fields tab of the Properties dialog box is available for resource and code files. It allows you
to specify the values that Open Plan should include for user-defined fields.
User-defined fields are created on the appropriate table outside of an open file and may be used
by any file stored in the database. In order to use a user-defined field in your file, you must
specify a value for it on this tab.

The User Fields tab features a grid containing two columns:


Field — This column displays a list of all the user-defined fields that have been defined for the
appropriate table.



Value — For each user-defined field that you want to use in your file, you should enter an
appropriate value.
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For information on creating user-defined fields, refer to Chapter 23, “Project Utilities.”

The Structure Tab
The Structure tab of the Properties dialog box is available only for code files:

This dialog box displays the following information for the code file:




Code Type — Open Plan supports two types of code file structures:


Punctuated Significant – Open Plan uses a punctuation character to separate the part of
the code that corresponds to the different levels in the structure.



Fixed Format Significant – The length of the code represents the structure level. Apart from
the top-level code, each code is based on the name of its parent.

Fixed Level Length — These fields contain data only when the code type is Fixed Format
Significant. While Open Plan allows up to 10 levels for the fixed level length, in most cases, only
3 or 4 levels are used.
For each level that is used, Open Plan displays the number of characters that are specified. This
number is cumulative.



Pad Character — The character specified as the pad character is used as a suffix to codes that
do not use the defined length at a given level. Any character (including a space) can be used as a
pad character.
For more information on code structures, refer to Chapter 11, “Project Codes.”
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The Preferences Tab
The Preferences tab of the Properties dialog box is available only for views files:

You can use this tab to define the settings for the following fields.
Depending on the type of view selected, one or more of the fields may be enabled. When a field
is enabled, an ellipsis button is displayed at the right edge of the field.



Filter — This field allows you to apply a filter to the view. Clicking the ellipsis at the right edge of
the field displays the Filters dialog box that you can use to select a filter. You can also use that
dialog box to create, edit, or modify filters.



Sort — This field allows you to sort the data in the view. Clicking the ellipsis at the right edge of
the field displays the Sorts dialog box that you can use to select a sort. You can also use that
dialog box to create, edit, or modify sorts.



Title Block — This field allows you to apply a title block to the view. Clicking the ellipsis at the
right edge of the field displays the Title Blocks dialog box that you can use to select a title block.
You can also use that dialog box to create, edit, or modify title blocks.



Bar Set — This field allows you to select a bar set to be displayed on the view. Clicking the
ellipsis at the right edge of the field displays the Bar Sets dialog box that you can use to select
the bar set. You can also use that dialog box to create, edit, or modify bar sets.
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Project Properties Tabs
The Project Properties dialog box allows you to view and enter project-level information at any time.
Most of the settings found on the various tabs of the Project Properties dialog box can be entered
initially when you use the New File Wizard to create a new project. However, if you use Open Plan
default settings when you create a new project, you can later customize the settings using the Project
Properties dialog box.
The Project Properties dialog box has the following tabs:
The project Files, Access Control, Open Status, Notes, and User Fields tabs function similarly to
those described earlier.



Summary — This tab displays basic information about the project, for example, name,
description, and owner.



Preferences — This tab allows you to set a number of preferences that determine how Open
Plan should display and process project data.



Files — This tab allows you to display and assign the calendar, resource, and code file
assignments for a project.



Status — This tab displays information about project status.



Cost — This tab provides displays summary cost information for the project.



Notes — This tab allows you to attach text information to the project.



Scheduling — This tab allows you to specify both the project's priority and the type of dates that
should be used when calculating the resource usage summary.



User Fields — This tab allows you to specify the values that Open Plan should include for userdefined fields on the Project table.



Access Control — This tab allows you to define the access rights that users who are members
of a group with a specified role have to the project.



Open Status — This tab displays the information about the open status of the project.



References — This tab displays master projects that include this project as an external project.



Codes — This tab allows you to assign codes to the project.



Validation — This tab allows you to assign rules to a project or remove rules that have been
assigned to a project.

The following fields are located at the top of each tab:


Project Name — The name of the project is established during project creation. You cannot edit
the name of the project.
Provided that you have the project open in Exclusive or Shared mode, you can use the Save
As command to create a copy of the project by saving it under a different name.



Description — Providing a project description is optional during project creation. You can edit the
project description on any tab of the Project Properties dialog box.
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The Summary Tab
The Summary tab displays basic information about the project:

Along with the name and description of the project, the top of the tab displays the following
information:


Owner — This field displays the ID of the current owner of the project. In most cases, this is the
person who created the project.



Data Access Mode — This field identifies the mode in which the project is open:





Exclusive — A file opened in Exclusive mode can only be opened in Read Only mode by
other users. When you have a file open in Exclusive mode, you can save any changes you
make. You can also close the file without saving your changes.



Shared — This mode allows two or more users to access a file and work with the data at the
same time. When you have a file open in Shared mode, any changes that you make to the
file are automatically saved as soon as they are made. This provides all users who have the
file open with the latest information.



Read Only — This mode allows you to view a file. You cannot, however, make any changes
to the file while you have it open in this mode. You must first save the project under a
different name before you can make any changes.

Project Phase — This field indicates the phase at which the project currently stands. There are
three phase categories:


Proposed — The project proposal has been submitted and is awaiting approval.



Open — The project has been approved. Although the project phase is open, the actual
project may not necessarily have started as yet.
To check the current status of the project, display the Status tab of the Project
Properties dialog box.



Closed — The project has been completed.

The lower-left section of the tab controls the following general purpose information:
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Project Manager — Enter the name of the project manager in this field. While use of this field is
optional, the information it contains is used in many reports.



Project Manager Email Address — Enter the project manager's email address in this field.
While use of this field is optional, Open Plan can use the information it contains as the "To"
address in the Email Advisor.



Company — Enter the name of company managing the project in this field. While use of this field
is optional, the information it contains is used in many reports.



Client — Enter the name of the project's client in this field. While use of this field is optional, the
information it contains is used in many reports.

The Project Statistics section of the tab displays the following statistical information:


Total Activities —The total number of activities within the project.
Total Activities does not include the activities in any open external subprojects.



Total In Progress — The total number of activities in the project with a status of In Progress.
This value is updated only when time analysis is performed.



Total Complete — The total number of activities within the project that are complete. This value
is updated only when time analysis is performed.



Total Relationships — The total number of relationships within the project.



Total Assignments — The total number of resource assignments within the project.

If the project contains open external subprojects, the totals displayed include values from activities
within the external subprojects.
When the project contains unopened external subprojects, Open Plan includes in the totals the
external subproject activities acting as place holders but not the activities that are within the
unopened subprojects.
The lower-right section of the tab features the following baseline controls:


Baselines — Open Plan can display up to three project baselines in these fields. You can
change any of these baselines by clicking Select Baseline and selecting a different baseline from
the dialog box that is displayed.



Select Baseline — Clicking this button displays a dialog box that you can use to select up to
three baselines for the project. In addition, you can use this dialog box to create, update, and
delete project baselines.
For more information on managing baselines, refer to Chapter 16, “Status Information.”
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The Preferences Tab
The Preferences tab allows you to set a number of preferences that determine how Open Plan should
display and process project data:

Use this tab to enter any of the following project preferences:


Default Date Format — This option controls the default format Open Plan uses for dates. For
new projects, the default format is 31Dec07. However, you can select from many other formats as
well – most of which are predetermined, with two originating from the international settings of
Windows.
If you later enter a date in a different format, Open Plan attempts to convert it to the format you
selected as the default.
For example, if your default date format is 31Dec07, Open Plan makes the following conversions:


31dec is interpreted as 31Dec07 if 2007 is the current year.



13/12/07 is always interpreted as December 13, 2007 since 13 cannot be interpreted as a
month.

If the date you enter is all numeric (for example, 10/01/07), Open Plan uses the order of month
and year from your Windows Regional Options.


Default Activity Type — You can define the default type for new activities as one of the
following:


ASAP



ALAP



Start Milestone



Finish Milestone



Discontinuous



Subproject



Hammock



Effort Driven

Chapter 05 File Properties
Deltek Open Plan 8.0 User Guide

113

Project Properties Tabs



External Subproject
For a description of these activity types, refer to Chapter 6, “Activity Information.”



Def. Activity Calendar — The default calendar is used for all new activities within the project.
Using a default activity calendar makes it easier to share one calendar file over all projects.



Default Res. Curve —The Default Res. Curve field displays the following choices:


All valid Spread Curves defined within the Spread Curves dialog box for which the user has
at least read-only access



A blank curve type

By default, Default Res. Curve is blank. The Default Res. Curve value is used for all new
resource assignments within the project. The Default Res. Curve option is available when using
Backup or Save As.


Startup View — Open Plan automatically displays the selected startup view whenever you open
the project.



Def. Relationship Calendar — The default calendar for all new relationships within the project.



Default Res. Level — The Default Res. Level field contains the following options:


0 — Sets the default resource level for new resource assignments to 0.



1 — Sets the default resource level for new resource assignments to 1.



First availability — The default resource level for new resource assignments is obtained
from the first resource availability that is defined for the assigned resource. If the Resource
does not have any defined availability, the default resource level will be set to 1.

By default, Default Res. Level is set to First Availability. The Default Res. Level value will be used
for all new resource assignments within the project.
The warning The resource level for this assignment is 0.0 Do you want to continue? is
displayed if:


The resource assignment is a new (unsaved) resource assignment;



The Default Resource Level option is set to ‘0’ (zero); and



The resource Level of the resource assignment is ‘0’ (zero).

The Default Res. Level option is included in Backup and Save As.


Conversions — Three settings control the way in which Open Plan converts durations into
minutes from different time units:


Per Day — Controls the number of hours and minutes per day that are used in the
conversion. The default setting is 8 hours and 0 minutes.



Per Week — Controls the number of hours and minutes per week that are used in the
conversion. Typically, this would be the number of hours per day multiplied by the number of
work days in a week. The default setting is 40 hours and 0 minutes.



Per Month — Controls the number of hours and minutes per month that are used in the
conversion. Typically, this would be the number of hours per day multiplied by the number of
work days in a month. The default setting is 160 hours and 0 minutes.
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Open Plan calculates the number of hours available for work in any given duration by referring to
the applicable project calendar.
For information about the use of calendars to define working times, refer to Chapter 9, “Project
Calendars.”



Durations — You can define the following settings for durations:


Default Units — You can define a default duration unit for entering activity durations. For
example, if you set the default duration unit as days, an activity duration of 10 will be
interpreted by Open Plan as a duration of 10 days.



Min. Calculated — You can indicate a minimum time unit that Open Plan should use when
calculating durations in time analysis. For example, if you define the minimum calculated
duration as days, Open Plan will never calculate activity durations in units smaller than one
day during time analysis (except in cases where the user-defined duration for the activity is
less than a day). This setting is intended to allow you to improve processing times for very
large networks at the expense of decreased precision in the scheduling calculations. Whether
or not this approach yields acceptable results depends on a number of factors. For example,
if your project extends over a number of years, minor inaccuracies in the schedule of events
occurring several years in the future may not be significant.
It is important to remember that specifying a minimum calculated duration that is smaller than
your shortest activity duration does not improve scheduling accuracy. For example, if you
schedule all of your activities in days, specifying an hour as the minimum calculated duration will
not produce a more accurate schedule.



Default Access Mode — Open Plan supports two access modes:


Exclusive — If a file is open in Exclusive mode, you have the exclusive right to make
changes to it. While you have the file open in exclusive mode, other users can open the file
only in Read Only mode.



Read Only — If the file is open in Read Only mode, you must use the Save As command in
order to save any changes you may make.

Open Plan also features the Shared mode. If the file is open in Shared mode, multiple users can
have access to the file at the same time. Open Plan saves the data whenever a user clicks OK on
a dialog box that uses the shared file.
For more information on the three access modes, refer to Chapter 24, “System Utilities.”

You can override the Default Access Mode settings by opening the project using one of the following
procedures.


On the File menu, click Open, and select the appropriate access mode from the File Open dialog
box.



From Open Plan Explorer, right-click the file, point to Open on the context menu, and select the
appropriate access mode.
If you open an ancillary file outside the context of a project, right-clicking the file and clicking
Default on the Open submenu opens the ancillary file in the default access mode established on
the Properties dialog box for that file.
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Earned Value — You can specify the Earned Value Technique (EVT) that Open Plan
automatically assigns to a new activity. When the Base Physical Percent Complete on EVT option
is selected on the Progress Calculations dialog box, Open Plan uses the selected EVT to update
the earned value of the activities when progress calculations are run.
You can override this default EVT for an activity by assigning a new EVT to the activity using the
Advanced tab of the Activity Details dialog box.

You can choose from the following EVTs:


Level of Effort



Percent Complete



50-50



0-100



100-0



User-Defined Percentage



Planning Package



Resource % Complete.

The Files Tab
The Files tab allows you to display the calendar, resource, and code file assignments for a project:

You can also use this tab to assign resource, calendar, and code files to the project.
For more information on assigning ancillary files to a project, refer to the “Assigning Ancillary
Files to a Project” section of Chapter 3, “Getting Started.” You may also refer to the “New File
Wizard — Files Page” section of Chapter 4, Creating a New File.”
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The Status Tab
The Status tab displays information about project status:

You can use this tab to display the following information calculated by Open Plan:


Status — The project status: Planned, In-Progress, or Complete.



Min. Total Float — The total float for the critical path in the project.



Early Finish — The project early finish date as calculated by time analysis.



Late Finish — The project late finish date as calculated by time analysis.



Scheduled Finish — The project scheduled finish date as calculated by resource scheduling.

You can also use this tab to enter the following information about the project:


Project Start — The planned project start date. This date is used for reporting purposes such as
the default start date for barcharts.



Time Now — The current project status date. Open Plan will not calculate any activity dates in
either time analysis or resource scheduling prior to Time Now. If the project is not yet underway,
enter the planned project start date for Time Now. If the project has started and you have entered
progress information for one or more activities, Time Now should be the latest date for which all
progress information is correct.
You can also specify the Time Now date on the Processes tab from the Schedule
group.



Target Start — The target start date is an optional date used by Open Plan in cases where a
project appears as an external subproject within a master project.



Target Finish — The target finish date is an optional date used by the time analysis and
resource scheduling functions.



Finish Type — You can specify how Open Plan interprets this date with the following types:


None



Not Earlier Than



Not Later Than
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On Target
In general, you should not enter a target finish date for any project before you run time
analysis. However, many projects do have target finish dates imposed by outside
circumstances. If you must enter a target finish date for the project, the following points
describe how a target finish may affect calculations for the rest of the project.



If you assign a Not Later Than target finish date later than or equal to the latest early finish
date calculated by time analysis, the target date has no effect. If you enter a project target
finish date that is earlier than the early finish date calculated by time analysis, the result is a
number of activities with negative total float. This indicates that the target date is not
achievable for the project as planned and that replanning may be needed. (Note that the late
start date of the first activity in a project indicates the latest date the project can start and
remain achievable.)
To determine the latest date a project can start and still finish by a fixed deadline, set a
not-later-than finish date for the project and perform time analysis. The late start date
for the first activity in the project represents the latest date the project can start and still
meet the desired finish date.



If you assign a Not Earlier Than target finish date earlier than or equal to the latest early
finish date calculated by time analysis, the target date will have no effect. If you enter a
project target date that is later than the early finish date that time analysis would have
calculated, the result is additional float for the project.



If you assign an On Target finish date earlier than the calculated early finish date, you create
negative float in the project. If you enter a target finish date later than the calculated early
finish date, you add float. If you enter a target finish date exactly equal to the calculated date,
the target date has no effect.

The Cost Tab
The Cost tab displays summary cost information for the project:

You can use this dialog box to define the following:


Target Total Cost — The value you enter in this field is not used in any cost calculations.
However, by entering a target cost in this field, you have a value that you can use as a
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benchmark when comparing the budget and actual costs of a project with what was originally
planned.


Reporting Calendar — This field allows you to specify a reporting calendar file that will be used
as a default for date scales that use reporting calendars. When creating or updating a baseline or
any resource usage table, Open Plan uses the data in this file to break any usage records that
span more than one calendar period into additional records. This feature facilitates the accurate
export of time-phased resource assignment information.
The reporting calendar is also useful if your company uses a fiscal calendar that contains periods
that do not end on the last day of the month.
While the Reporting Calendar feature may be used with any Open Plan project, it is
particularly useful to Cobra users as it improves the ability of Cobra to accurately
spread time-phased assignment data.



Use Version 2 Cost Calculation Method — This option controls the cost calculations method
that Open Plan should use when calculating Budget at Complete (BAC) values at the activity
level:


When this option is cleared, Open Plan uses the Open Plan Version 3 method. With this
method, Open Plan calculates costs based on assignments in the Performance Measurement
Baseline (PMB) in the Baseline Usage (BSU) table. If there is no baseline named PMB, Open
Plan uses the first selected baseline. This is the default setting for new projects.



When this option is selected, Open Plan uses the Open Plan Version 2 method. With this
method, Open Plan calculates costs based on the current resource assignments. This is the
default setting for projects that were originally created in Open Plan 2.x.

The lower half of this tab is a grid that displays budgeted costs, scheduled value, earned value,
actual costs, and remaining costs rolled up to the project level for the following:


BAC — Budget at Completion



BCWS — Budgeted Cost of Work Scheduled



BCWP — Budgeted Cost of Work Performed. This is also referred to as earned value.



ACWP — Actual Cost of Work Performed



EAC — Estimate at Complete
For more information of the costs displayed in the grid, refer to the online Help system
for the Project Properties Cost tab.
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The Notes Tab
The Notes tab allows you to attach text information to the project:

You can use the following fields to attach a note to the file:


Note — This text box can contain up to 29 KB of text. You can enter the text by typing directly in
this field or by using the Windows Cut (Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) commands to
insert text from another Windows application such as a word processor or spreadsheet.



Category — This field controls the category of the note. You can select a category from the list of
global categories.

Clicking abc checks the spelling of the text you enter.
You can enter links to files, Web pages, and e-mail addresses by entering the information in one of
the following formats:


File links must be entered in the format of: file://c:\document.doc
If the file link you enter contains spaces, you must enclose the link with angle brackets ( < > ) in
order for the link to work properly: <file://C:\Documents and Settings\All
Users\Desktop\test.txt>



Universal Resource Locators (URLs) must be entered in the format of: http://deltek.com



E-mail addresses must be entered in the format of: mailto:sales@deltek.com
While you can use drag and drop functionality to create links in the Note field, the Windows Cut
(Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) commands are not available for links.

The Scheduling Tab
The summary resource usage file allows different projects to be scheduled successively using only a
single resource file. In order to realize the functionality of summary resource usage, it is necessary to
define a unique priority for each project.
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The Scheduling tab allows you to specify both the project's priority and the type of dates that should
be used when calculating the resource usage summary.

This tab features the following controls:


Project Priority — Open Plan allows you to specify a priority on the current project. When
assigning resources to another project, Open Plan considers only projects with a higher priority
than the current project. A higher priority is indicated by a lower numeric value.
When performing resource scheduling on a number of projects at one time (for example, when
scheduling external subprojects), Open Plan uses the priority of the master project when
determining the availability of resources that are shared with other projects. You can also use the
value in the Project Priority field as a tiebreaker between external subprojects.
When using the summary usage file from one project in a subsequent project, it is
presumed that the next project schedule has a lower priority than the one before
(indicated by having a higher project priority number). If the priority of the second
project is set higher than the original project, the first project should be scheduled again
or you will get unsatisfactory results.



Create Summary Usage Upon Saving Project — In order to take advantage of summary
resource usage, the resources used by a project must be saved in summary form with the
resource file. If you select this option, Open Plan allows you to select the type of dates (Early
Dates, Late Dates, or Scheduled Dates) that it should use when creating a record in the Project
Summary Usage (PSU) table. This option makes the data available to other projects using the
same resource file, and the summary resource usage is saved each time the project is saved.
In order for the summary usage to be saved, the following conditions must be met:


The project must be open in Exclusive mode.



The resource file must be open in Exclusive or Shared mode. (If the resource file is open in
Read Only mode, Open Plan offers to save the information in a new resource file.)
The summary resource usage file is not saved when you perform a Save As or do a
backup. Also, when you do perform a Save As or a backup, the option to Create
Summary Usage Upon Saving Project (as shown above) is automatically cleared on
the new project.
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Create Summary Usage Based On — This option is enabled when you select the Create
Summary Usage Upon Saving Project option. This field contains a list of dates that Open Plan
should use when creating the summary usage record:


Early Dates



Late Dates



Scheduled Dates

Delete Summary Usage For This Project — Summary resource usage data needs to be
deleted when it is no longer appropriate. The data is deleted automatically when a project is
associated with a new resource file but not when a project is deleted altogether. When you click
Delete Now, Open Plan deletes the project summary usage data from the PSU table for not only
the open project but also for any open external subprojects. This has the effect of freeing the
resources so that they can be made available to other projects.

You can also use the Summary Usage dialog box to delete summary usage from a project:

To display the Summary Usage dialog box, complete the following steps:
1. Display the resource view for the selected project.
2. On the Edit tab, click Summary Usage.
You can use either Delete Now on the Scheduling tab of the Project Properties dialog
box or the Summary Usage dialog box to delete summary resource usage on a single
project. The Summary Usage dialog box, however, can be used to delete summary
resource usage on multiple projects that share the same resource file.
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The User Fields Tab
The User Fields tab allows you to specify the values that Open Plan should include for user-defined
fields on the project table.
User-defined fields are created on the project table outside of an open project and may be used
by any project stored in the database. In order to use a user-defined field in your project, you
must specify a value for it on this tab.

This tab features a grid containing two columns:


Field — This column displays a list of all the user-defined fields that have been defined for the
project table.



Value — For each user-defined field that you want to use in your project, you should enter an
appropriate value.

For example, if the Field is Proj_Sec, you might enter the name of the project secretary as the Value
for the field.
For information on creating user-defined fields, refer to Chapter 24, “System Utilities.”
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The Access Control Tab
The Access Control tab allows you to define the access rights that users or groups have and what
role they plan on the project.

If you are the owner of the project or a member of the System Administrator group and you have the
project open in Exclusive mode, you can use the following fields to define access rights to the
project:


Owner — You can change the owner of the project by selecting a new owner from the list.
If you provide access rights to a group for a project, members of that group automatically inherit
read rights to all resource files, calendar files, code files, and external subprojects assigned to
that project. Note, however, that it is possible that after you change the ownership of a project to
another user, you may not have rights to save the project. If this occurs, simply close the project
without saving.



Group — By selecting a field in this column and selecting a group from the list, you can specify
the group(s) that can have access to the project.



Role — When you select a group or user ID, its default role is automatically entered in this field.
You can then change default role to any role that has been defined in the data source.



User ID — By selecting a field in this column and selecting a user ID from the list, you can specify
the users that can have access to the project.



Read Only — By selecting Yes for this field, you limit the group or user to opening the project in
Read Only mode. By selecting No for this field, Other users may open the file in any mode they
choose. Read Only mode has the following limitations:


In order to make changes to the project, you must first save the project under a different
name.



You cannot see changes made by other users.
In order to see changes made by other users who may have the project open in
Exclusive or Shared mode, you have to close and reopen the project.
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The Open Status Tab
The Open Status tab displays the information about the open status of the project:

The following information is displayed on this tab:


User ID — This column displays the user ID of each person who has the project open.



Machine ID — This column displays the ID of each computer where the file is open.



Open Mode — This column displays the mode in which the project is open. This mode can be
any of the following:


Exclusive — If a project is open in Exclusive mode, you have the exclusive right to make
changes to it. While you have the project open in exclusive mode, other users can open the
project only in Read Only mode.



Shared — If the project is open in Shared mode, other users can open the file and make
changes while you have it open.



Read Only — If the project is open in Read Only mode, you cannot use the Save command
to save any changes you may make. Instead, you must use the Save As command and save
the project with a different name.
For more information on the three access modes, refer to Chapter 24, “System Utilities.”



Opened On — This column displays the date and time that the project was opened by a user.
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The References Tab
The References tab displays master projects that include this project as an external subproject.

The References tab displays object references. This helps you identify dependencies that can be of
use when deciding whether to keep or delete data.
The References tab contains the following fields:


File Type — The file type is always a project.



Name — The name of the master project that references this project.



Description — The description of the project.



Owner — The owner of the project.
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The Codes Tab
The Codes tab allows you to assign codes to the project:

Being able to assign codes to a project allows you to sort your projects. For example, you might want
to sort your projects according to a region or division code.
The Codes tab contains the following fields:


Code — This column displays all the project-level code files that have been defined.



Value — For each available code file, you can assign a specific code to the project. Clicking the
ellipsis at the right edge of the input field displays the Select Code dialog box that you can use to
select a code from a hierarchical code structure.
For more information on project codes, refer to Chapter 11, “Project Codes.”
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The Validations Tab
The Validations tab on the Project Properties dialog box displays a list of available user defined
validation rules in Open Plan. It also allows you to assign or remove a rule to or from a project.

This tab displays the following fields:
Available User Defined Validations — Select a validation rule that you want to assign to a project
and then click

. The selected rule moves to the Assigned User Defined Validations list.

Assigned User Defined Validations — Select a validation rule that you want to assign to a project
and then click

. The selected rule moves to the Available User Defined Validations list.
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Overview

Overview
An activity is the smallest self-contained unit of work used to define the logic of a project. Think of
activities as the building blocks of a project. Their definition, therefore, constitutes one of the most
important aspects of project planning.
This chapter begins with a general discussion of some guidelines for planning activities followed by a
description of the types of information you can enter in Open Plan for activities and relationships.
Other topics include the procedures for entering activity and relationship information, both within
Open Plan as a whole and within each of the views that allow data entry:


Barchart views



Network views



Spreadsheet views

The chapter concludes with discussions of a number of utilities related to activity information.
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Guidelines for Planning Activities
Since projects can vary considerably, there are few hard-and-fast rules about the contents of
activities or how long they can last. Activities in a plant maintenance turnaround, for example, might
last less than an hour; activities in a long-range development project might have durations of many
months.
In general, most activities will share the following characteristics:


They have a finite duration.



It is possible to estimate the progress of activities that have started but are not yet finished.



There is a single point of accountability for accomplishing the activity.

It is a good idea to keep these characteristics in mind when defining activities. By breaking a project
down into a set of discrete tasks with relatively short durations, it is possible to establish more
objective, and thus more accurate, estimates of progress.
Many times an activity will have a defined cost associated with it and one or more resource
assignments. In the strictest sense, however, these assignments are not necessary. In fact, it is
possible to define your activities first and then return at a later date and enter resource information.
It is possible to define an activity as an internal subproject in Open Plan. You can also define an
activity as an external subproject. Both types of subprojects allow you to use a relatively low level of
detail when breaking down the work of a project but roll up schedules and costs to high-level
summaries for reporting purposes. In Open Plan, an activity representing a subproject is identical to a
standard activity except for the fact that the duration and the progress status of the subproject activity
is based on its child activities and is recalculated each time you perform time analysis.
For a complete description of internal and external subprojects in Open Plan, refer to Chapter
12, “Hierarchical Projects.”

When entering activities for a project, you may want to give some thought to how you want to number
your activities. Although you can use other forms of activity information (such as codes) to identify
activities, activity IDs are the only identifier that Open Plan validates as being unique for each activity.
As a result, the activity ID serves as the default sort order for most views and reports.
Although Open Plan supports almost any activity numbering system, most organizations use activity
IDs that have some significance built in. One of the most common approaches is to use the activity ID
to associate activities with logical flows of work or phases. This type of approach, however, is not
required.
If you are building an Integrated Master Plan (IMP) along with the Integrated Master Schedule (IMS)
then the summary activity IDs may include the IMP hierarchy.
Activity IDs in Open Plan do not imply a sequence, and can be entered in any order. Thus, the activity
0002 can be entered before its successor, activity 0001. However, IDs do imply hierarchical
relationships, so that activities 0001.1 and 0001.2 are interpreted as being the children of activity
0001. As a result, the use of the period in an activity ID is restricted to indicating project hierarchies.
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The Activity Details Dialog Box
The Activity Details dialog box displays the basic information about each activity. Open Plan
automatically displays this tabbed dialog box each time you add or edit an activity.
The Activity Details dialog box contains tabs for the various types of information associated with the
activity. This chapter includes discussions of four of the tabs: the General tab, the User Fields tab, the
Predecessors tab, and the Successors tab. The other tabs are discussed in the following chapters:


Resources tab — Chapter 8, “Resource Assignments”



Codes tab — Chapter 11, “Project Codes”



Advanced tab — Chapter 14, “Resource Scheduling”



Risk tab — Chapter 15, “Risk Analysis”



Notes tab — Chapter 17, “Views and Reports”

You can display the Activity Details dialog box for an existing activity in the following ways:


By selecting the activity in an activity view and clicking Details on the Edit tab



By right-clicking the selection button of an activity in an activity view and clicking Edit Activity on
the context menu



By double-clicking the activity bar in a barchart view



By double-clicking the activity box in a network view

Because you can update multiple activities without having to close the Activity Details dialog box each
time, Open Plan automatically applies any changes you make to an activity before displaying the next
record. Notice that the OK and Cancel buttons found on many dialog boxes have been replaced here
with the following buttons:


Close — Closes the dialog box and returns to the view. If you have not saved the information
currently displayed, Open Plan saves the changes before returning to the view.



Undo — Returns the dialog box to its previous state.



Apply — Saves the changes you have made to the current record.

The Activity Details dialog box is resizable. You can resize this by dragging any corner or side of the
dialog box.
You must update information for an activity before the Undo and Apply buttons become active.

You can also use the New command to create a new activity while the Activity Details dialog box is
open.
You can customize the action of the New command so that it copies the information for the current
activity rather than presenting the user with a blank entry screen. You do this by selecting the Do Not
Clear Contents of the Dialog Box When Creating a New Activity option on the Edit tab of the
Options dialog box.
For more information on using the Options dialog box, refer to Chapter 25, “System Defaults.”
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The General Tab
Open Plan displays the basic information for an activity on the General tab of the Activity Details
dialog box:

You can enter the following information about each activity:


ID — You can use up to 59 characters including spaces for an activity ID. When entering an
activity ID, keep in mind that Open Plan does not distinguish between upper and lower case
characters in an ID.



Description — You can enter a description of up to 60 characters for an activity.
By default, Open Plan defines the maximum field lengths of 59 characters for activity and
resource IDs, and 60 characters for activity descriptions, resource descriptions, code IDs, and
code descriptions. It is possible, however, to modify the standard data structure and data
dictionary so that any of these field lengths can be as long as 255 characters for new projects.
For information about customizing the Open Plan standard data structure and data
dictionary, contact the Deltek technical support staff.



Duration — You can enter an activity duration in minutes, hours, days, weeks, or months using
the following abbreviations:


T — minutes



H — hours



D — days



W — weeks



M — months

For example, to specify an activity duration of eight hours, enter 8H or 8h.
You can avoid having to specify a time unit when entering durations by assigning a default
duration unit for a project through the Preferences tab on the Project Properties dialog box.
Settings on this tab also affect how Open Plan determines the number of hours in a duration
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defined in days, weeks, or months as well as the minimum unit of duration considered by
calculations such as time analysis and resource scheduling.
For more information on these settings, refer to Chapter 5, “File Properties.”

You can use decimal values for durations (for example, 1.5d), but you cannot mix date formats by
entering durations such as 1w2d.
If you enter a duration that is not consistent with fixed target start and finish dates for
the activity, Open Plan will use the duration implied by the target dates when
performing time analysis and resource scheduling calculations.



Calendar — If you have assigned a calendar file to the project, you can assign a calendar to the
activity. If you do not assign a specific calendar to the activity, Open Plan uses the default
calendar to calculate dates for the activity. In projects for which no calendar file has been
assigned, all activity dates are calculated using a 5-day, 40-hour work week with no holidays.



Type — The activity type defines how the activity is treated during time analysis. The possible
activity types are as follows:


ASAP (As Soon As Possible) — Calculates the early dates of this activity to be as soon as
possible. This is the default activity type.



ALAP (As Late As Possible) — Calculates the early dates of this activity to be as late as
possible without delaying the early dates of any succeeding activities.



Start Milestone — Uses this activity to signify the start of a project phase. If the activity
duration is zero, Open Plan replaces the early and late finish dates with the early and late
start dates during time analysis.



Finish Milestone — Uses this activity to signify the finish of a project phase. If the activity
duration is zero, Open Plan replaces the early and late start dates with the early and late
finish dates during time analysis.
Define zero-duration activities as either start or finish milestones if you want to avoid
showing an activity that is scheduled to finish before it starts.



Discontinuous — Allows Open Plan to interpret the specified duration as a minimum rather
than fixed duration for the purpose of time analysis. Discontinuous activities are useful when
modeling situations where two activities (or two groups of activities) with dissimilar lengths
share start-to-start and finish-to-finish relationships.



Subproject — Interprets this activity as representing an internal subproject and allows Open
Plan to calculate its duration based on lower level activities.



Hammock — Interprets this activity as a reporting hammock for other activities.



Effort Driven — Allows Open Plan to calculate the activity duration based on resource
assignments.



External Subproject — Interprets this activity as representing an external subproject and
allows Open Plan to calculate its duration based on lower level activities.
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For more information about internal subprojects, hammocks, and external subprojects,
refer to Chapter 12, “Hierarchical Projects.” For more information about effort-driven
activities, refer to Chapter 8, “Resource Assignments.” For more information about
discontinuous activities, refer to Chapter 8, “Time Analysis Calculations,” in the Deltek
Open Plan Developer’s Guide.



Target Dates — Target dates act as user-defined constraints on the calculations performed by
time analysis and resource scheduling. You can enter start and finish targets and define how the
constraint should be interpreted as follows:


Not Earlier Than — Do not schedule the activity earlier than this target date. This is the
default setting for target start dates.



Not Later Than — Do not schedule the activity later than this target date. This is the default
setting for target finish dates.



On Target — Schedule the activity on the target date.



Fixed Target — Schedule this activity on the target date, regardless of the project logic. In
addition, set the total float of the activity to zero or possibly negative depending on
predecessor logic and Time Now. This negates the effect of any prior float in the project upon
subsequent activities.
Use target dates sparingly, particularly in the early stages of the planning process.
Extensive use of target dates often has the effect of artificially distorting the patterns of
float within a project, making analysis of the network more difficult. Instead, allow Open
Plan as much flexibility as possible to produce the most efficient set of project dates
during your initial calculations. Then you can assign the necessary target dates and
see how they affect the network schedule as whole.



Sub-Project — Displays the name of the project represented by the activity in this field when
the activity type is External Subproject.
You can click the ellipsis button at the right edge of the Subproject edit box and select
a project that will become the external subproject.

Using Automatic Numbering
When creating a new activity, you can have Open Plan generate the activity IDs automatically. If you
leave the ID field blank on the General tab of the Activity Details dialog box when creating a new
activity, Open Plan generates an ID for the new activity according to the following rules:


If the previous ID at a given level is all alphabetic, the program increments alphabetically.



If the previous ID at a given level is a mixture of alphabetic and numeric characters, the numeric
part is incremented numerically.



If there is no previous ID, the program uses a numeric ID. Therefore, the first ID in the file is
numbered "1."

Open Plan attempts to find a pattern in the activity ID numbering scheme for IDs that are incremented
numerically by looking at the last two IDs in the hierarchy. If a pattern can be established, Open Plan
uses the pattern when automatically creating a new activity ID.
For example, assume that your project has the following hierarchy:
A11
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A12
A13
A14
A15
A20
Open Plan looks at the last two IDs in the hierarchy and determines that there is a difference of 5
between the two. Therefore, if you use automatically numbering to create the next ID, Open Plan
creates activity ID A25.
On the other hand, if there is only one activity ID in the hierarchy and you have Open Plan create the
other IDs, it uses the ID’s value as the incremental pattern.
For example, if you enter 12 for the first ID in the hierarchy and then have Open Plan create the
remaining IDs, it increments the IDs by 12 resulting in the following hierarchy:
12
24
36
48
60
For information on using automatic numbering when creating new codes within a code view,
refer to Chapter 11, “Project Codes.”
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The User Fields Tab
When you click the User Fields tab on the Activity Details dialog box, the following is displayed:

This tab allows you to specify the values that Open Plan should include for user-defined fields on the
activity, using the following fields:


Field — This column displays a list of all the user-defined fields that have been defined.



Value — For each user-defined field that you want to use, you should enter an appropriate value.
User-defined fields are created on the activity table outside of an open project and may be used
by any activity stored in the database. In order to use a user-defined field for your activity, you
must specify a value for it on this tab.
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Entering Activity Relationships
Activity relationships define which activities are logical predecessors and successors of each other.
To enter information about the relationships of an activity, you can use any of the following:


Predecessors tab



Successors tab



Add Relationships dialog box



Add Relationship dialog box
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The Predecessors and Successors Tabs
To enter relationship information using the Activity Details dialog box, click either the Predecessors or
Successors tab:

Each relationship with a predecessor or successor activity is listed on the grids of one of these tabs.
Controlling relationships (that is, relationships that determine the early dates of an activity) display an
asterisk in the selection button at the left of the grid.
If you let the cursor hover over the Predecessor and Successor ID in the grid, it displays a
popup text message indicating the description of the ID followed in parentheses by the status of
the ID.
Hovering the cursor over the Type column in the grid displays the description of the abbreviated
relationship type.

You can use the Delete button to delete an existing relationship, click any cell on the row you want to
delete and press the Delete button.
You can use the New button to create new predecessor or successor relationships using the Add
Relationships dialog described below.
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You can use the Goto button to display the information for a selected predecessor or successor. To
use this feature, select the ID of a predecessor or successor activity and then click Goto. Open Plan
changes the focus to the specified activity.
This dialog box also shows the description, total float and free float for each predecessor and
successor relationship. To see these fields, you may need to use the horizontal scroll bar to display
the rightmost fields in the grid or reduce the width of displayed columns by dragging the column
boundaries. These columns are shaded in light blue and are not editable but are there for information
purposes.
For information about relationship float, refer to Chapter 8, “Time Analysis Calculations,” in the
Deltek Open Plan Developer’s Guide.

You can enter the following information about each relationship using the grid:


Predecessor/Successor — Enter the ID of the predecessor or successor.



Type — You can define any relationship as one of four types:





FS — Finish to Start, the successor activity cannot start until the predecessor activity is
complete. This is the default relationship type.



SS — Start to Start, the successor activity cannot start until the predecessor activity has
started.



SF — Start to Finish, the successor activity cannot finish until the predecessor activity has
started. This type of relationship is rarely used.



FF — Finish to Finish, the successor activity cannot finish until the predecessor activity is
complete.

Lag — Lag is the time delay associated with the relationship. Lags can be either positive (to
indicate a delay between two events) or negative (to indicate an overlap or lead time between two
events). For example, if an activity cannot start until two days after the completion of its
predecessor, define a finish-to-start relationship between the two activities and enter a lag of 2
days.
For start-to-start relationships, it is also possible to define a lag as a percentage of the
predecessor activity’s duration. To enter a duration-driven lag, enter a value followed by a percent
sign (%). For example, to define a lag equal to one half of the predecessor’s duration, enter 50%.
To shorten the overall duration of a project, identify activities that can be overlapped
and define their relationships with lag or lead times.



Calendar — By default, the calculation of lag times uses the calendar assigned to the successor
activity. You can, however, assign a different calendar to the lag.
A common use of relationship calendars is to schedule lags based on duration-driven
rather than activity-driven processes. For example, assume you want to schedule two
activities in sequence: pouring a foundation and removing the forms. This is a finish-tostart relationship, but the laborers removing the forms cannot start their work until the
concrete cures. The lag that occurs while the concrete cures should be scheduled
using a 7-day, 24-hour calendar instead of a calendar based on the laborers’ work
week.



Probability — In the absence of progress on any successor activities, this column is used to
indicate a relative probability that a particular path out of an activity will be taken. Probabilities for
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various options are mutually exclusive, such that the percent values for multiple options do not
have to equal 100%.
For more information on probability, see Chapter 15 Risk Analysis.

If successor activities have been started, it is assumed that the path has been taken already and
the probabilities are ignored.

The Add Relationships Dialog Box
You can use the Add Relationships dialog box to define logical predecessor and successor activities.
This dialog is modeless, meaning that it can stay on top of any view you are working with and add
relationships to any activity you point to in the view.
To add a relationship using the Add Relationships dialog box, complete the following steps:
1. Display the Add Relationships dialog box by taking one of the following actions:


In a view that displays activities:


Click Add Relationship from the Data group of the Edit tab.
This command will be enabled only when focus is on a cell or single row.



Click a row button and choose Add Relationships… from the context menu.

The row that has focus will be designated as the Anchor Activity (the activity to which
relationships will be added).


In the Activity Details dialog box » Predecessors or Successors tab, click the New button.
The current activity will be designated as the Anchor Activity.
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The Add Relationships dialog box displays:

2. Select the checkbox next to the activities you wish to add as predecessors or successors.
You can select as many as needed
3. Enter the following information for the relationship(s) that will be added:
Select the check box of the corresponding activities in the activity list


Type — Define the relationship type.



Lag — Define the lag or the time delay associated with the relationship.



Calendar — Define a calendar for the lag.
For more information on these fields, see The Predecessors and Successors Tabs in
the previous section.

4. Add the activities as predecessors or successors of the anchor activity by clicking Add
Predecessors or Add Successors.
The Add Predecessors and Add Successors buttons are only enabled when one or
more items have been selected from the activity list and there is a valid anchor activity.
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5. You can use the following buttons to help you navigate your way through the activity list:


Find and Find Next — Search for a specific activity by entering either the activity ID (or a
partial ID) or the activity description in the Find field.



Expand All and Collapse All — Expand or collapse the hierarchy of activities by clicking
these buttons.



Refresh — As activities are added, deleted, or renamed, the activity list will not be
automatically updated. You can click the Refresh button to reload the activities, as well
as the activity calendars. When refreshing the dialog box, current selections are cleared
and the hierarchy is collapsed.



Clear All — Click this button to clear the selections for all the activities in the hierarchy,
regardless of whether the hierarchy is expanded or collapsed.
6. Click Close.

The Add Relationship Dialog Box
When in the Relationship Spreadsheet view, you can enter relationships by double-clicking the
selection button of an empty row. This command displays the following dialog box, which you can use
to enter the same types of information that appear on the Relationships tab of the Activity Details
dialog box.

Use this dialog box to define relationships between any two activities in the project.
To add a relationship using the Add Relationship dialog box, complete the following steps:
1. Double-clicking the selection button of an empty row.
2. In the Add Relationship dialog box, enter the information for the relationship, and click OK.
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Loop Detection
Whenever you enter a relationship between activities, Open Plan automatically checks that a logical
loop has not been defined. To do this, Open Plan considers the relationships between the activities
and sorts them in an order to be processed. Open Plan ensures during this process that no activity is
processed before any of its logical predecessors.
In the course of the sort, Open Plan may find that entering the relationship would create a logical loop
in the project. In effect, this means that at least two activities are mutually dependent. (Neither activity
can start before the other.) If a loop is detected, Open Plan immediately deletes the relationship that
would otherwise cause the loop and alerts you of this action. If you are entering relationships in a
network view, Open Plan also selects all of the activities that comprise the loop.
Because of the speed at which Open Plan performs this function, you may not be aware that it is
taking place unless a logical loop is actually detected.

Using the Link/Unlink Activities Dialog Box
Use this dialog box to add and remove multiple relationships of the same type between activities
conveniently. Clicking the Link button automatically creates relationships between selected activities
using the selected type, lag, and calendar.
To display the Link/Unlink Activities dialog box, select two or more activities, and complete
any of the following steps:


From the Edit tab of Activity Spreadsheet, Resource or Activity Barchart, or Network views, select
Link/Unlink Activities.



Click Ctrl + F2



From the context menu of the Activity Spreadsheet, Resource or Activity Barchart, or Network
views, select Link/Unlink Activities.

This dialog box features the following fields and buttons:

Relationship Type
Select one of the following relationship types:


Finish to Start



Start to Start.



Start to Finish



Finish to Finish.

By default, this field displays Finish to Start.
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Lag
Enter a time delay associated with a relationship in a project. This field supports positive, negative,
and percentage lags. By default, this field displays zero (0). Some people call negative lags Leads.
Open Plan only allows a percentage lag on the Start-to-Start relationship type. When you enter the
percentage lag for a different relationship type, an error message displays.

Calendar
Select a calendar upon which Open Plan bases calculations for any lag in the relationship. The dropdown list contains all calendars defined in the calendar file including <Calendar of Successor> and
<Default>. By default, it displays <Calendar of Successor>.

Link
Click this button to create relationships among selected activities. Open Plan then creates
relationships between the selected activities using the relationship type, lag, and calendar that you
specified on the dialog box.
If relationships already exist between the selected activities, Open Plan would not allow you to modify
the existing relationships.

Unlink
Click this button to remove relationships among the selected activities.

Linking Activities
You can also use the Add Relationship dialog box to define relationship between activities. If
relationships already exist between the selected activities, Open Plan would not allow you to modify
the existing relationships.
To link activities, complete the following steps:
1. Open an activity spreadsheet, barchart, or network view.
2. Select activities or tasks to which you want to add relationships.
3. Open the Link/Unlink Activities dialog box.
4. Select or enter necessary information.
5. Click Link. Open Plan then creates the relationship between the selected activities using the
relationship type, lag, and calendar that you specified on the dialog box.
Open Plan displays all errors that occur when linking activities on the Link/Unlink Activities Errors
dialog box after the process completes.

Unlinking Activities
This procedure allows you to remove relationships between linked activities in Open Plan.
To unlink activities, complete the following steps:
1. Open an activity spreadsheet, barchart, or network view.
2. Select linked activities or tasks from which you want to remove relationships.
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3. Open the Link/Unlink Activities dialog box.
4. Select or enter necessary information.
5. Click Unlink.
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Using Barchart Views
Because it combines a traditional Gantt-style barchart with a spreadsheet, a barchart view provides a
convenient way to enter activities and their durations. This type of view is often used as the default
start-up view for a project. Barchart views consist of three panes:


The barchart pane



The spreadsheet pane



The histogram pane.

You can use either the barchart pane or the spreadsheet pane for entering activity information.

The Barchart Pane
The barchart pane displays activity information as date-driven bars arranged along a date scale:

Barchart
pane

To add an activity in the barchart pane, complete the following steps:
1. On the Edit tab, click Details.
The Activity Details dialog box opens.
2. Click the New button.
3. Enter the necessary fields in the Activity Details dialog box.
To display relationships in the barchart pane, complete the following steps:
1. Take one of the following actions:


On the Tools view, click Preferences from the Barchart group.



Right-click an empty area within the barchart pane, and click Preferences on the context
menu.

2. On the Barchart Preferences dialog box, click Show Relationships.
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For information about the other options for viewing relationships, refer to Chapter 18,
“Barchart Views.”

The Bar Data Mode and the Relationship Mode
The barchart pane provides two modes for entering activity-related information:

Bar Data mode
button



The Bar Data mode for entering activity durations and target dates



The Relationships mode for entering activity relationships.

The Bar Data mode offers a convenient way to enter and schedule groups of activities:

Drag the entire
bar to set a
target start date.

Drag the end of a
bar to change the
activity duration.

It is possible to change the target start date of an activity by repositioning the bar along the time line
or to change the activity duration by stretching or shrinking the bar. If you have automatic time
analysis turned on, the length or position of the bar changes immediately. If you do not have
automatic time analysis turned on, the bar does not reflect your changes until the next time you
perform time analysis.
The granularity of the date scale can also affect the manipulation of bars. For example, if the smallest
units displayed on the date scale are months, you may not be able to set the target start of an activity
to a specific day.
For information about customizing the date scale in a barchart view, refer to Chapter 18,
“Barchart Views.”

For bars to be eligible for manipulation in the bar chart view, the bar type must display early dates
and must have the Drag option set to Yes.
For information about defining custom activity bar types, refer to Chapter 6, “Customizing
Barchart Views,” in the Deltek Open Plan Developer’s Guide.
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Relationship mode
button

Barchart panes also allow you to display and enter relationships between activities. To use a barchart
pane for entering relationship information, click the Relationships mode button on the View tab:

Drag to create
relationships.

In the Relationships mode, you can use the mouse to draw relationships between activities by
linking the start or finish of one bar to the start or finish of another bar. All four types of relationships
can be created using this technique:


Finish to Start — The successor activity cannot start until the predecessor activity is complete.
This is the default relationship type.



Start to Start — The successor activity cannot start until the predecessor activity has started.



Start to Finish — The successor activity cannot finish until the predecessor activity has started.
This type of relationship is rarely used.



Finish to Finish — The successor activity cannot finish until the predecessor activity is complete.

To change the barchart pane to the Bar Data mode, complete the following step:
Bar Data mode
button

1. On the View tab, click Bar Data from the Show group.
To change an activity target start date in Bar Data mode, complete the following steps:

Target Start cursor

1. Using the mouse, position the cursor in the middle of the activity bar.
2. When the cursor changes to a double-headed arrow, drag the bar to the desired position.
To change an activity duration in Bar Data mode, complete the following steps:

Duration cursor

1. Using the mouse, position the cursor on the right edge of the activity bar.
2. When the cursor changes to a single-headed arrow, stretch or shrink the bar to the desired
length.
For information using a mouse to enter progress information about the activity in a
barchart view, refer to Chapter 16, “Status Information.”
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To change the barchart pane to the Relationships mode, complete the following step:
Relationship Mode
button

1. On the View tab, click Relationships mode from the Show group.
Clicking the Relationships mode button automatically turns on the display of
relationships in the view.

To enter a relationship in Relationships mode, complete the following step:
Add Relationships
cursor

1. Take one of the following actions:


Drag the cursor from the start or finish of an activity to the start or finish of its successor.



Right-click an activity and select Edit Activity. Enter necessary information in the
Predecessors or Successors tab.

To edit a relationship in Relationship Mode, complete the following step:
1. Take one of the following actions:


Position the cursor at the beginning or end of a relationship line, and when it changes
shape to a crosshair, right-click, and click Edit Relationship on the context menu.



Double-click the predecessor or successor activity, and click the Predecessors or
Successors tab on the Activity Details dialog box.

To create an activity by drawing a relationship in Relationship Mode, complete the following
step:
1. Draw a relationship from an existing activity to an empty row in the barchart.

The Spreadsheet Pane
The spreadsheet pane of a barchart view uses a tabular format to display activity information in rows
and columns:

Spreadsheet
pane
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You can enter, display, and edit any activity-related information in the spreadsheet pane of a barchart
view, including information stored in user-defined fields.
For fields with a limited number of valid entries (for example, an activity type), Open Plan displays a
list of valid choices in the edit box.
For information about changing the arrangement and display of columns in the spreadsheet
pane, refer to Chapter 20, “Spreadsheet Views.”

Because data entry in the spreadsheet pane tends to be keyboard-oriented, Open Plan provides a
number of keyboard shortcuts for navigating and updating information in this type of display. Three of
the most common navigation shortcuts are as follows:


To move down one cell, press Enter.



To move right one cell, press Tab.



To move left one cell, press Shift+Tab.

Other keyboard functions depend on the type of cell that has focus when you press a key. For
example, if you have selected a data entry cell (that is, a cell in which you can enter text, numeric, or
date information), the following keyboard shortcuts are available:
Key

Action

Down arrow

Move down one cell

Up arrow

Move up one cell

Left arrow

Move left one character

Right arrow

Move right one character

Shift+Left arrow

Select previous character

Shift+Right arrow

Select next character

Ctrl+Up arrow

Move to top row in view

Ctrl+Down arrow

Move to bottom row in view

Ctrl+Left arrow

Move to first cell in row

Ctrl+Right arrow

Move to last displayed cell in row

Page Up

Move up one screen

Page Down

Move down one screen

Home

Move to first character in cell

End

Move to last character in cell

Ctrl+Home

Move to top left cell
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Key

Action

Ctrl+End

Move to bottom right cell

If you have selected a cell displaying data generated by Open Plan (for example, an early start date),
the following keyboard shortcuts are available:
Key

Action

Down arrow

Move down one cell

Up arrow

Move up one cell

Left arrow

Move left one cell

Right arrow

Move right one cell

Ctrl+Up arrow

Move to top row in view

Ctrl+Down arrow

Move to bottom row in view

Ctrl+Left arrow

Move to first cell in row

Ctrl+Right arrow

Move to last displayed cell in row

Page Up

Move up one screen

Page Down

Move down one screen

Home

Move to first cell in row

End

Move to last cell in row

Ctrl+Home

Move to top left cell

Ctrl+End

Move to bottom right cell

Finally, if you have selected a cell with a fixed number of valid values (for example, activity type), the
following keyboard shortcuts are available:
Key

Action

Down or Right arrow

Choose next value

Up or Left arrow

Choose previous value

Home

Choose first value

End

Choose last value
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To add an activity, complete the following step:
1. Take one of the following actions:


On an empty row, select the Activity ID field, and enter an ID for the new activity.



On the Edit tab, click Add Activity from the Data group.



Double-click an empty row.

To display the Activity Details dialog box for an activity, complete the following step:
1. Take one of the following actions:


Double-click the selection button to the left of the row.



Right-click the selection button, and click Edit Activity on the context menu.
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Using Network Views
Network views are handy for defining the logic of a project since you can rapidly enter activities and
their relationships with a mouse.

In addition to entering activity information, you can modify the appearance and position of individual
activity boxes and relationship lines within a view. You can also click a relationship and then have
Open Plan go to and select the predecessor or successor of the relationship automatically.
For information about changing the display of activities or relationship lines in a network view,
refer to Chapter 19, “Network Views.”

To add an activity in a network view, complete the following step:
1. Take one of the following actions to open the Activity Details dialog box:


Double-click an empty area in the view.



Draw a relationship from an existing activity to an empty area in the view.



On the Edit tab, click Add Activity.

2. Enter necessary information in the dialog box.
To move an activity box, complete the following steps:
1. Position the cursor over the center of the activity box.
Move cursor

2. When the cursor changes shape to a hand, drag the box to the new location.
To add a relationship, complete the following step:
1. Take one of the following actions:

Add Relationship
cursor



Drag the cursor from the start or finish of an activity to the start or finish of its successor.



On the Edit tab, click Add Relationship from the Data group, and enter the predecessor
and successor activities.
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To edit a relationship, complete the following step:
1. Take one of the following actions:


Double-click the relationship line.



Right-click the relationship line, and click Edit Relationship on the context menu.



Select the predecessor or successor activity, click Edit Activity on the Edit tab, and
display the Predecessors or Successors tab.

To delete a relationship, complete the following step:
1. Take one of the following actions:


Right-click the relationship line, and click Delete Relationship on the context menu.



Position the cursor over the arrow head of the relationship line. When the cursor changes
shape, drag the line back to the predecessor activity.

To change the shape of a relationship line, complete the following steps:
Update Relationship
cursor

1. Position the cursor over the relationship line.
2. When the cursor changes to a crosshairs, drag the line to change its shape.
To straighten a relationship line, complete the following step:
1. Right-click the relationship line, and click Make Straight on the context menu.
To go to the predecessor of a relationship, complete the following step:
1. Right-click the relationship line, and click Go to Predecessor on the context menu.
To go to the successor of a relationship, complete the following step:
1. Right-click the relationship line, and click Go to Successor on the context menu.
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Using Spreadsheet Views
You can enter both activity and relationship information using standard Open Plan spreadsheet
views. Spreadsheet views are particularly useful in cases where you want to display information for
many activities at the same time.

Click to select activity or double-click to
display the Activity Details dialog box.

You can enter, display, and edit any activity-related information in an activity spreadsheet view,
including information stored in user-defined fields.
For a description on how to enter this type of information, refer to the discussion of the
spreadsheet pane in the “Using Barchart Views” section earlier in this chapter.

For displaying relationship information, Open Plan supplies two types of spreadsheet views:
relationship spreadsheets and predecessor/successor spreadsheets.
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Relationship spreadsheet views resemble activity spreadsheet views but display information about
each activity relationship on a single row:

Click to select a relationship.

Predecessor/successor spreadsheets display multiple relationships for each activity using an outlining
format.

Click to expand or collapse an activity.

In a predecessor/successor spreadsheet view, Open Plan displays a plus sign (+) or a minus sign
(-) on the outlining button to the left of the row to control the display of relationship information. If the
outlining button displays a plus sign, you can expand the activity to see its relationships. If the
outlining button displays a minus sign, the activity is already expanded — clicking the outlining button
will collapse the display of relationships. If the outlining button is blank, the activity does not have any
relationships.
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For information about expanding and collapsing items in a spreadsheet view, refer to Chapter
12, “Hierarchical Projects.”

Although you can use either a relationship spreadsheet or a predecessor/successor spreadsheet
view to display information about activity relationships, Open Plan does not allow you to change
relationship information in a predecessor/successor spreadsheet. You must use a relationship
spreadsheet to add or update relationship information. The same keyboard shortcuts available in
activity spreadsheets are available in relationship spreadsheets as well.
To add a relationship using a dialog box , complete the following steps:
1. On the Edit tab, click Add Relationship.
2. Enter the information for the relationship.
3. To return to the view, click OK.
To add a relationship in a relationship spreadsheet, complete the following steps:
1. On a blank row, select the Predecessor cell.
2. Click the ellipsis button to the right of the edit box at the top of the spreadsheet.
Open Plan displays the Select Activity dialog box listing the available activities.
3. Select the predecessor activity from the list, and click OK.
4. Select the Successor cell for the row, and repeat steps 2 and 3.
5. Enter the rest of the information for the relationship.
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Open Plan provides a number of utilities related to displaying activity information, including:


Finding activities



Displaying activity information



Displaying a particular project date



Deleting an activity



Setting conditional formatting for a view

The first two utilities are available in barchart, network, and activity spreadsheet views. The third utility
is available in either the barchart or the histogram view. The fourth applies to any activity.

Finding and Replacing an Activity
You can use the Find and Replace command to locate, display, and replace the information about
an activity in a view:
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To perform the search thoroughly, all hierarchical levels must be expanded. You can do this by
taking any of the following actions:



Click the Expand All



Press Ctrl+PgDn.

button located at the Data group of the Edit tab.

Activities that are hidden because of collapsed hierarchical levels will not be searched.

To find an activity, complete the following steps:
1. Take one of the following actions:


Press Ctrl+F.



On the Edit tab, click



Right-click an empty area of the view, and click Find on the context menu.

from the Data group.

2. In the Find tab, define the object of your search using the Search: drop-down list.
3. Enter the text you want to find in the Find what: field.
4. Click the Find Next or Find Previous button to go to the next/previous search matches.
To find data in a spreadsheet column, complete the following steps:
1. Take one of the following actions:


Select the column, and press Ctrl+F.



On the Edit tab, click



Right-click the column heading, and click Find on the context menu.

from the Data group.

2. In the Find tab, enter the text you want to find in the Find what: field.
3. Click the Find Next or Find Previous button to go to the next/previous search matches. You
can also press Shift+F4 or click Edit » Find Next to go to the next search match.
To replace information on an activity/activities, complete the following steps:
1. Take one of the following actions:


Select the column, and press Ctrl+H.



Select the column, and click



Right-click the column heading, and click Find on the context menu.

from the Data group on the Edit tab.

2. In the Replace tab, define the object of your search using the Search: drop-down list.
3. Enter the text you want to find in the Find what: field.
4. Enter the new text that will replace the searched information.
5. You can do any of the following:


Click Find Next to find the first occurrence of the search text, and then click the Replace
button to replace the searched text one by one. Each time you press the Replace button
Open Plan searches for the next occurrence and finds that automatically.



Click the Replace All button to replace all instances of the searched text.

You can further limit the search operation with the following options:
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Match Case — Limit the search to description text that matches the use of upper- and lower-case
letters in the find text.



Find Whole Word — Find only text that includes an exact match of the target text. For example,
use this option if you do not want Open Plan to find descriptions containing the word “information”
based on a search for the word “form.”
You can also launch the Find and Replace dialog box, using the Replace command by clicking

from the Data group on the Edit tab.

Displaying Activity Information
Use the Activity Information command to display a wide range of information for a single activity. To
display information related to the activity schedule, use the Schedule tab of the Activity Information
dialog box:

The Activity Information dialog box is resizable. You can resize this by dragging any corner or side of
the dialog box.
Schedule-related information displayed for each activity includes:


The early and late dates calculated by time analysis



The scheduled dates calculated by resource scheduling



Any baseline(s) selected in the project.



Any target dates assigned to the activity



Values for total float, free float, and an indication if the activity is one of the following:


Not Critical — an activity whose total float is greater than zero



Critical — an activity whose total float is zero or less



Most Critical — an activity possessing the least amount of total float in the project



Controlling Critical — an activity that is potentially critical but has float due to calendars
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To display information related to the activity costs, use the Cost tab of the Activity Information dialog
box:

This tab displays budgeted and actual costs calculated at the activity level for the following:


BAC — Budget at Completion



BCWS — Budgeted Cost of Work Scheduled



BCWP — Budgeted Cost of Work Performed. This is also referred to as Earned Value.



ACWP — Actual Cost of Work Performed



EAC — Estimate at Complete
For more information of the costs displayed in the grid, refer to the online Help system for the
Activity Information Cost tab. For more information about entering cost information, refer to
Chapter 10, “Cost Information.”

You can display this dialog box in any barchart, network, or spreadsheet view. Note that this dialog
box, like the Activity Details dialog box, is modeless; you can leave it open when performing other
operations. You can also use the navigation controls displayed in the lower left corner of the dialog
box to scroll through the activities in a network.
To display activity information, complete the following step:
1. Take one of the following actions:


Select the activity, and click Information from the Dialogs group on the Edit tab.



Right-click the selection button of an activity, and click Activity Information on the
context menu.



Select the activity, and press F5.
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Finding a Date
To display a date in a time-scaled view such as a barchart or histogram, use the Go To Date
command to display the Go to Date dialog box:

With this dialog box, you can have Open Plan automatically display the portion of the view that
contains one of the following dates:


The project start date



The project finish date



Time Now



A specific date

To find a date, complete the following steps:
1. Take one of the following actions:


On the View tab, click



Right-click an empty area of the barchart, and click Go To Date on the context menu.

from the Show group.

2. Select the date you want to display in the view, and click OK.

Deleting an Activity
There are many ways to delete activities. You can delete individual activities or multiple selected
activities. The prompts you receive to confirm your intent vary depending on the situation.

Primary Prompts


When you have a single activity selected that has at least one predecessor and one successor,
and you click Delete on the Edit tab with an activity view open, the Delete Activity dialog box
displays:

When you delete a single activity from a project, you can use this dialog box to instruct Open Plan
to take one of the following actions:
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Delete the activity and its relationships — Use this option to remove the activity and
relationships when the activity is not required and the chain of activities or the logic flow is
changing.



Delete the activity and reconnect its predecessors to its successor using Finish to
Start relationships — Use this option when one step in a process is not needed but the rest
of the work continues in its planned sequence. For example, this could be a work order with
steps or a process with steps.



In the Activity Spreadsheet view, when you delete a single activity with no children and no
relationships, the following confirmation dialog box displays:



In the Activity Spreadsheet view, when you delete a single activity with at least one child, the
following confirmation dialog box displays:



In the Activity Spreadsheet view, when you delete multiple activities with no children, the
following confirmation dialog box displays:



In the Activity Spreadsheet view, when you delete multiple activities with children, the following
confirmation dialog box displays:



In the Network view, when you delete a single activity without children, the following confirmation
dialog box displays:
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In the Network view, when you delete a single activity with children, the following confirmation
dialog box displays:

Secondary Prompts
The secondary confirmation dialog boxes are displayed when the activities to be deleted meet the
following conditions:


Is in progress



Is part of a baseline



Has resource assignments



Has children

The dialog displays all of the conditions that apply to the activities selected for deletion.
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Setting Conditional Formatting for a View
You may customize the display of the columns and rows for any spreadsheet, barchart, or network
view by using the Conditional Formatting dialog box:

Click to select
either <Row> or
a column.

The following attributes may be changed for any column or row:


Font — Select a font, font style, size, and/or script.



Text color — Select from the color palette.



Background — Select from the color palette.



Alignment — Select either Center, Left, or Right.

The following attributes may be changed only in columns:


Image — select the appropriate symbol from either the drop-down list or the Symbols dialog box



Image Context — select one of the following:


adjacent to data — both data and symbol are displayed in the same cell;



centered in cell — data is superimposed on the symbol which is centered; or
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replaces data — only symbol is displayed

If < Row > is selected in the drop-down list and the Criterion field is blank, all formatting selections
will be applied to every row. If the Criterion field contains a value, formatting selections will be
applied only to rows for which the criterion evaluates to True.
The Criterion field may contain one of the following:


A calculated field that evaluates to a Boolean (True/False) value or a filter



An on-the-fly expression that evaluates to a Boolean



A blank, indicating that the rule will be unconditionally applied

When previewing, you may see the cumulative effect of multiple rules being applied by selecting
multiple rows in the dialog box. You can press CTRL+click to select non-adjacent rows.
If a column name is selected in the drop-down list, all formatting selections will be applied to only that
column.
The order of rows in the may be changed by selecting the desired row and then using either

or

to move the row up or down. Rules are evaluated in sequential order. Individual attributes with a
value other than <Default> will replace the current attribute.
As each cell in the spreadsheet is drawn, only column rules that reference the current column or row
rules are evaluated (for example, if an "Activity Description" cell is being drawn, rules for the "Activity
ID" column are ignored).
Click

to accept a selection. Click

to cancel a selection.

To set a column or row attribute, complete the following steps:
1. Open the view you want to customize.
2. Click Conditional Formatting from the Table group on the View tab.
3. Select the column/row to be formatted from the drop-down list. (In the graphic above, < Row
> is displayed by default.)
4. Once you have selected a row or column to format, you may choose a criterion or other
attribute to modify on the same row.
5. To make a formatting selection, click the drop-down list and/or the ellipsis box (if present).
6. When finished making selections, click OK.

Chapter 06 Activity Information
Deltek Open Plan 8.0 User Guide

167

Utilities

Explanatory Text Captions
You can create explanatory text captions for spreadsheets, barcharts, and network views explaining
why formatting was applied to a particular row or cell. The text is displayed when you hover your
cursor over the row or cell.
You can enter the explanatory text captions in either the Bar Set Preferences or Conditional
Formatting dialog box, under the Show This Explanation column.
To create an explanatory text caption, complete the following steps:
1. Open the view you want to customize.
2. Perform any of the following to open the Conditional Formatting dialog box:




For spreadsheet and spreadsheets in barchart views:


Click View tab » Conditional Formatting from the Table group



Right-click the spreadsheet and select Conditional Formatting…



Press Ctrl+B

For barchart views:




Click View tab » Bar Sets from the Barchart group » Edit or New or Copy after
selecting a bar set.

For the network view:


Click View tab » Conditional Formatting from the Network group



Right click an empty space, and click Conditional Formatting…

3. For spreadsheet views (stand alone or as part of a barchart):
a. Select a row for which you want to create the text caption.
b. Enter the explanatory text in the Show This Explanation column corresponding to the
selected row.
c.

Click the Display Explanation When Hovering over Applied Rule(s) option to show
the explanatory text you created.

For the barchart pane of barchart views:
i. Select a row for which you want to create the text caption.
ii. Enter the explanatory text in the Show This Explanation column corresponding to
the selected row.
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iii. Click the Display Explanation When Hovering over Applied Rule(s) option to
show the explanatory text you created.

For the network view:
a. On the Conditional Formatting dialog box, enter the explanatory text in the Show This
Explanation column corresponding to the selected row.
b. Click the Display Explanation When Hovering over Applied Rule(s) option to show
the explanatory text you created.
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Overview

Overview
Resources are people, facilities, or anything else needed to perform the work of a project. Although
entering resources is not required in Open Plan, many project managers have found that the
successful planning, management, and control of project resources are crucial to the overall success
of a project.
In Open Plan, features related to resource management fall into three broad categories:


Defining resources



Assigning resources to activities



Performing resource scheduling

This chapter includes discussions on the first of these categories — defining resources.
For information about assigning resources, refer to Chapter 8, “Resource Assignments”. For
information about resource scheduling, refer to Chapter 14, “Resource Scheduling.”
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Resources in Open Plan
Resources in Open Plan use a self-defining coding structure in which periods within the resource
codes are used to distinguish between different hierarchical levels. This type of structure is
sometimes referred to as a “resource breakdown structure” (RBS).
BCI

BCI.RSH

BCI.RSH.GCB

BCI.RSH.GCB.PRG

BCI.RSH.GCB.PRG.DAVE

BCI.CST

BCI.RSH.PEB

BCI.RSH.GCB.DE

BCI.RSH.GCB.PRG.JOHN

A higher-level resource is referred to as a “resource pool” in Open Plan. With resource pools, you can
roll up resource availabilities, assignments, and usage for reporting purposes. However, information
entered at the pool level (for example, availability levels or unit costs) is not inherited by the members
of that pool.
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Resource Files
In Open Plan, information about a group of resources is stored in a resource file. (In reality, this
information is stored in three separate data tables. For the purposes of this discussion, however, we
will refer to these as comprising a single file.) Resource files can be project-specific, or they can be
shared among multiple projects. However, you can assign only one resource file to a project at any
given time.
If you make changes to the information in a resource file, the changes will affect all of the projects to
which that file is assigned. To make changes in a resource file that affect a single project only, make
sure that the resource file is not assigned to other projects.
In Open Plan, resource files are represented with a distinctive icon.

Resource file icon

You can open a resource file from within the resource’s Views folder. Assigning a resource file to a
project can be as simple as dragging the resource file from the Open Plan Library to the project
folder.
To create a resource file, complete the following steps:
1. Take one of the following actions to open the New File dialog box:


On the File menu, click New » Resource File.



Press Ctrl+N.



Double-click an empty area of the Open Plan Explorer.



Click

from the Quick Access Toolbar, and select Resource File.

2. From the File Type list on the New File dialog box, select Resource.
3. Enter a name and description for the new resource file.
4. Select Use previous settings as defaults if you wish to create the new resource file using the
same settings as the previous file.
5. Click Next to start the New File Wizard where you can define the settings for the resource
file, or click Finish to create the resource file with default settings or with previous settings.
Open Plan creates a new resource file and allows you to enter information for the first
resource.
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For more information on using the New File Wizard, refer to Chapter 4, “Creating a New File.”

To open a resource file, complete the following step:
1. Take one of the following actions to open the File Open dialog box:


Click



On the File menu, click Open.

from the Quick Access Toolbar.

2. Use the File Open dialog box to locate the resource.
For information on using the File Open dialog box, refer to Chapter 3, “Getting Started.”

To copy a resource file, complete the following steps:
1. Open the resource file.
2. On the File menu, click Save As » Save As New File.
3. In the Save As dialog box, enter the name for the copy of the file, change the description
(optional), and click OK.
You cannot perform Save As on a file if there is another file open which refers to it. For
example, if you open project CLEAN and then try to perform a Save As on the
resource file CLEANRES, the Save As command is disabled.

To delete a resource file from a project, complete the following steps:
1. From the target project folder, select the resource folder.
2. Press the Delete key.
3. When Open Plan asks you to confirm the deletion, click Yes.
Deleting a resource file from a project removes any activity resource assignments from
the project.

To delete a resource file from the database, complete the following steps:
You cannot delete a data file that is referenced by another file. For example, you cannot delete a
resource file if any project still uses it.

1. Display the Select File to Delete dialog box with one of the following actions:


On the file menu, point to Manage Files, and click Delete on the submenu.



Right-click the resource folder, point to Manage Files, and click Delete on the submenu.

2. On the Select File to Delete dialog box, locate the appropriate resource file, and click OK.
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For more information on using the Select File to Delete dialog box, refer to Chapter 3,
“Getting Started.”

To assign a resource file to a project, complete the following step:
1. Take one of the following actions:


Drag the resource file from the Open Plan Library to the project folder.



Specify the name of the resource file on the Files tab of the Project Properties dialog box.
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Defining Resources
To define a resource in Open Plan, use the Resource Details dialog box. The Resource Details dialog
box displays basic information about each resource. Open Plan automatically displays this tabbed
dialog box each time you add or edit a resource.
The Resource Details dialog box contains the following tabs for the various types of information
associated with the resource:


General tab



Code tab



Availability tab



Escalation tab



Skills tab



User Fields tab



Notes tab

You can display the Resource Details dialog box for an existing resource in the following ways:


By double-clicking the resource



Selecting the resource and clicking Details from the Dialogs group on the Edit tab



Right-clicking the resource and clicking Edit on the context menu

The Resource Details dialog box is also displayed when you create a new resource by taking one of
the following actions:


Double-clicking an empty area of the view



Pressing Ctrl+A



Clicking Add Resource from the Data group on the Edit tab



Right-clicking an empty area of the view and clicking Add Resource on the context menu

Because you can update multiple resources without having to close the Resource Details dialog box
each time, Open Plan automatically saves any changes you make to a resource before displaying the
next record. Notice also that OK and Cancel usually found on dialog boxes have been replaced with
the following buttons:


Close — This button closes the dialog box and returns to the display of resources. If you have
not saved the information currently displayed, Open Plan saves the changes before returning to
the display.



Undo — Provided that you have not clicked Apply, this button returns the dialog box to its
previous state.



Apply — This button saves the changes you have made to the current record.
You must enter information for a resource before the Undo and Apply buttons become active.

You can also use the New command to create a new resource while the Resource Details dialog box
is open. This command functions identically to the Add Resource command available from the Edit
tab.
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General Resource Information
The General tab of the Resource Details dialog box displays the basic information about each
resource:

For each resource, you can enter the following information:


ID — A resource ID is an alphanumeric code unique to the resource and consists of from 1 to 59
characters, including periods that are used to indicate hierarchical levels.
By default, Open Plan defines a maximum field length of 59 characters for resource IDs and 60
characters for resource descriptions. It is possible, however, to modify the standard data structure
and data dictionary so that these field lengths can be as long as 255 characters for new files.
For information about customizing the Open Plan standard data structure and data
dictionary, contact the Deltek technical support staff.

When you enter a resource ID on the Resource Details dialog box, enter only the local portion of
the resource ID. Open Plan automatically enters the parent portion of the ID.
Open Plan does not distinguish between upper and lower case characters in an ID and will flag
resource R0001 as a duplicate of resource r0001.


Description — You can enter an extended description of up to 60 characters for each resource.



Type — Open Plan supports the following types of resources:


Normal — An individual resource that does not get “used up” (for example, a person or a
facility).



Consumable — An individual resource that can be consumed or “used up” over the course
of a project. Building materials such as bricks used in a construction project are a typical
example of a consumable resource. Units of consumable resources that are not required
during one period of availability are carried forward to the next period. For example, assume
that the availability of bricks is defined as 3,000 units on a particular day. If the requirement
for the bricks is only 2,000 units on that day, Open Plan carries forward the remaining 1,000
units to the next day. Open Plan assumes that the total quantity of a consumable resource is
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available on the date specified in the From Date field on the Availability tab, and that some
quantity of the resource is available until it has been totally consumed or used up.


Perishable — Consumable resources with an expiration date. This type of resource is
sometimes called “use it or lose it” and is frequently used to model budgets that cannot be
carried forward past a particular date. When entering the availability of a perishable resource
(on the Availability tab), enter dates in both the From Date and the To Date fields.



Resource Pool — A higher-level resource. It is important to be aware of which resources are
serving as pools because of the following ramifications:
Information defined at the pool level (for example, availabilities or unit costs) is ignored by the
child resources belonging to the pool.
If you delete a pool, you delete all child resources belonging to that pool as well.



Unit — For each resource, you can enter a description of how you measure the resource (for
example, hours, tons, etc.).



Unit Cost — You can enter a cost per resource unit.



Threshold — Thresholds specify an additional number of units of availability for a resource that
can be used to avoid project delays if necessary. The value of a resource threshold represents an
incremental amount on top of all existing availabilities for that resource. Open Plan ignores
thresholds for consumable resources.
Open Plan interprets a threshold value based on the default duration unit and the conversion
settings for a project. For example, assume that you enter a threshold of 2 for a labor resource
used in a project in which the default duration unit is defined as days and in which one day
converts to 8 hours. Open Plan interprets the threshold for that resource as 16 labor-hours. Note
that one implication of this approach is that the interpretation of a threshold value may vary since
it depends on the settings stored on the Preferences tab of the Project Properties dialog box for
the project.
For more information about the Preferences tab of the Project Properties dialog box,
refer to Chapter 5, “Project Properties.”



Project — This field contains a list of projects that are assigned to the resource file of the
selected resource. If you select a project from the list, Open Plan reserves 100 percent of the
resource's availability to the project.
Lower level reservations can override higher level ones. This allows you to reserve an entire
resource pool for one project and then override this for resources at a lower level in the resource
hierarchy.
If the selected resource is an individual resource (as contrasted with a pool) you can use the
Availability tab to apportion the availability to multiple projects.
For more information on reserving resources, refer to the “Reserving Resources for
Projects” section in this chapter.



Email Address — You can use this field to store an email address for the resource. This
information can be used as an Address field in the Email Advisor.



Category — Open Plan supports the following resource category types:


Labor



Material
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Other Direct Costs



Subcontract

Open Plan uses Other Direct Costs to monitor costs at an activity level.


Effort Factor — The effort factor setting is used for the calculation of durations for effort-driven
activities. The effort factor indicates to what extent the resource is available for any one activity.
For example, assume that a resource, while available for 8 hours per day, cannot devote more
than 4 hours of his or her time to any one activity. Enter an effort factor of 4 to reflect this
situation.
This setting does not indicate efficiency and has no effect on resource scheduling calculations.
For a description of effort-driven activities, refer to Chapter 8, “Resource Assignments.”



Employee ID — If the resource category is Labor, you can enter the employee ID used by the
Human Resources Department in this field.



Suppress in Lists — If you do not want to use the resource for assignment or reporting
purposes, you can have Open Plan suppress the display of the resource in all lists.



Suppress for Scheduling — You can have Open Plan ignore a resource during resource
scheduling. This is useful in cases where you want to track requirements for a particular resource
but ignore any potential impact it may have on the project schedule. During resource scheduling,
Open Plan treats suppressed resources as though they have unconstrained availabilities.



Roll up for Scheduling — Roll-up resource scheduling allows you to look at resources and
schedule the activities from a summary perspective by specifying the hierarchical level for
resource availabilities and assignments. When you indicate that the resource is to be rolled up for
scheduling purposes, you specify that all references to that resource should be treated as a
reference to the first parent of the resource in the hierarchy that is not rolled up to a higher level.
(Thus, every rolled-up resource must have at least one hierarchical parent that is not rolled up.)
The only restriction to this technique is that you cannot roll up both consumable and nonconsumable resources to the same pool.
Using this feature, you can produce a more general resource schedule without a detailed
consideration of individual resources. This effectively reduces the number of calculations required
to produce a resource-based schedule, thereby improving processing times for larger projects.
For example, assume that MARY and JANE are individual resources in the following hierarchy:

The roll-up settings for these resources have been defined as follows:
Resource

Availability

Roll-up

EC

Not defined

No
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Resource

Availability

Roll-up

EC.PROG

Not defined

No

EC.ENG

Not defined

No

EC.ENG.MARY

8 hours/day

Yes

EC.ENG.JANE

8 hours/day

Yes

EC.ENG is the first parent of MARY and JANE that is not rolled up to a higher level. Therefore,
Open Plan considers any request for either MARY or JANE as a request for EC.ENG.
Furthermore, Open Plan assumes that EC.ENG has an availability of 16 hours per day since it
combines the availabilities of both MARY and JANE.
This roll-up feature is incompatible with the use of alternate resource assignments involving pools
and skills.
For information about alternate resource assignments, refer to Chapter 8, “Resource
Assignments.”



Progress Based on Activity Progress — Use this option to automatically progress the resource
based on the schedule status of the activity. For example, if you have statused the activity as
50% complete, Open Plan assumes that the resource assignment corresponding to the first half
of the activity duration has occurred as planned.
For information about entering resource progress, refer to Chapter 16, “Status
Information.”



Actual Cost Based on Progressed Quantity — Use this option if you want Open Plan to
automatically calculate actual costs from the number of resource units used. For example, if you
define the unit cost for a resource as $10.00, and you indicate that 5 units of the resource have
been used, then Open Plan calculates the actual cost for the resource as $50.00.
For information about calculating actual costs automatically, refer to Chapter 10, “Cost
Information.”



Consider in Cost Calculations — If this option is selected, Open Plan includes the resource in
cost calculations.

Resource Codes
Resource codes are designed to summarize or manage an entire group of resources. Codes can be
predefined, then assigned to resources within the resource file. The ability to create custom reports
based on user-defined coding structures provides virtually unlimited reporting possibilities.
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The Code tab of the Resource Details dialog box allows you to assign codes to resources:

You can use the following settings to control the code assignments:


Code — The code field in the resource table to which a code file is assigned. For example, many
organizations use WBS and OBS code files.



Value — The specific code within the code file. Clicking the ellipsis at the right edge of the input
field displays the Select Code dialog box that you can use to select a code from a hierarchical
code structure.

Resource Availabilities
Availability information defines periods during which a resource is available and in what quantity. To
represent more complex resource availabilities, you can define multiple availability levels for a single
resource. This allows you, for example, to model how seasonal changes in your staffing levels can
affect the project schedule.
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The Availability tab of the Resource Details dialog box displays information about the availability of
each resource:

To define the availability for a resource, use the following settings:


Availability — The availability of each resource is defined as the number of resource units
available each period for a specified span of time. Open Plan interprets the availability by
examining the calendar assigned to the resource. For example, if you define the availability of a
labor resource as 1 unit and the availability calendar defines each working day as comprising 8
hours, then 8 labor-hours (or 480 labor-minutes) of the resource are available each working day.
Note, however, that the interpretation of the calendar depends on the calendar file that is
assigned to the resource file.



From Date — The From Date is the first date on which the resource is available.



To Date — The To Date is the last date on which the resource is available.



Calendar — A calendar specifies that the resource is available only for valid working times in that
calendar. The list of calendar names displayed comes from the calendar file associated with the
resource file. If no calendar is specified for the availability, the resource is assumed to be
available according to the definition of the default calendar for the resource file. The resource
calendar is ignored for consumable resources.
In certain cases, it may be impossible to schedule an activity if its calendar differs from that of one
or more required resources.
For more information about how calendars affect resources, refer to Chapter 10,
“Resource Scheduling Calculations,” in the Deltek Open Plan Developer’s Guide.



Project — Selecting a field in this column displays a list of projects stored in the same data
source for which the resource can be reserved for the date range.
If you do not specify a project for a particular period, Open Plan reserves the resource for that
period to the project specified on the General tab of the Resource Details dialog box.
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Consumable and Perishable Availabilities
If you are defining the availability of a consumable or a perishable resource, Open Plan treats
information in the Availability, From Date, and To Date fields slightly differently than for normal
resources.


For normal resources, Open Plan considers the Availability quantity to be available in the period
defined by the From Date and the To Date, both of which are required.



For consumable resources, Open Plan considers the total Availability quantity to be delivered on
the From Date and to be available until used up.



For perishable resources, Open Plan considers the total Availability quantity to be delivered on
the From Date and any quantity remaining to be no longer available after the To Date.

Interpreting Zero Availabilities
For any particular resource, there will be certain periods in which the availability is zero. The way in
which these periods are entered in the resource definition has ramifications during resource
scheduling.
Open Plan defines two types of zero availability: hard zeros and soft zeros. In the case of hard zeros,
a zero availability is treated as an absolute, indicating that the resource is not available during that
period under any circumstances. In the case of soft zeros, the availability can be exceeded when
necessary during time-limited resource scheduling.


In Open Plan, the gaps between specified availability dates can be treated as either hard zeros or
soft zeros depending on whether the hard zeros processing option is in effect during resource
scheduling.



Open Plan treats a specific availability of zero as a soft zero, allowing the resource to be
scheduled during that period if necessary.
For further information about the hard zeros processing option, refer to Chapter 14, “Resource
Scheduling.”
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Cost Escalations
The cost escalations feature in Open Plan allows you to model the effects of changes in the unit cost
of a resource over time. With this feature, you use the Escalation tab of the Resource Details dialog
box to specify multiple unit costs for a resource and when each new cost takes effect:

For example, assume that a resource costs $25.00 per unit as of 01Jan04, and the cost escalates by
$.50 every three months. Enter $25.00 as the current unit cost and describe the cost escalation with
the following information:
Date

Cost

01Apr04

25.50

01Jul04

26.00

01Oct04

26.50

01Jan05

27.00

User-Defined Fields
The User Fields tab allows you to specify the values that Open Plan should include for user-defined
fields on the project table:

Chapter 07 Resource Definitions
Deltek Open Plan 8.0 User Guide

184

Defining Resources

User-defined fields are created on the project table outside of an open project and may be used
by any project stored in the database. In order to use a user-defined field in your project, you
must specify a value for it on this tab.

This tab features a grid containing two columns:


Field — This column displays a list of all the user-defined fields that have been defined for the
project table.



Value — For each user-defined field that you want to use in your project, you should enter an
appropriate value.
For example, if the Field is Proj_Sec, you might enter the name of the project secretary as the
value for the field.
For information on creating user-defined fields, refer to Chapter 23, “Project Utilities.”
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Resource Notes
The Notes tab allows you to attach text information to resources:

You can use the following fields to attach a note to a resource:


Note — This text box can contain up to 29 KB of text. You can enter the text by typing directly in
this field or by using the Windows Cut (Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) commands to
insert text from another Windows application such as a word processor or spreadsheet.



Category — This field controls the category of the note. You can select a category from the list of
global categories.

Clicking abc checks the spelling of the text you enter.
You can enter links to files, Web pages, and e-mail addresses by entering the information in one of
the following formats:


File links must be entered in the format of: file://c:\document.doc
If the file link you enter contains spaces, you must enclose the link with angle
brackets ( < > ) in order for the link to work properly: <file://C:\Documents and
Settings\All Users\Desktop\test.txt>



Universal Resource Locators (URLs) must be entered in the format of: http://deltek.com



E-mail addresses must be entered in the format of: mailto:sales@deltek.com
While you can use drag and drop functionality to create links in the Note field, the
Windows Cut (Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) commands are not
available for links.
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Reserving Resources for Projects
Resources can be reserved for use with particular projects. This can be done at any level in the
resource hierarchy. For example, you can reserve a whole department or an individual resource for a
project. When you reserve an individual resource, you have two options:


Reserving a resource completely



Reserving a portion of a resource

If you are reserving an individual resource, as opposed to a resource pool, the resource can be
reserved for a particular period of time and/or at a partial level. Thus an individual might have 50% of
his time reserved for a given project during a specific 6-month period.
To reserve an individual resource or branch of the resource hierarchy completely, complete
the following steps:
1. In the resource view, double-click the resource to be reserved.
2. On the Resource Details dialog box, click the General tab.
3. From the Project field list, select the project for which you want to reserve the resource.
4. Click Close.
To reserve a portion of an individual resource’s availability, complete the following steps:
1. In the resource view, double-click the resource to be reserved.
2. On the Resource Details dialog box, click the Availability tab.
3. In the Project column, specify the project to which you want to reserve the resource.
4. Click Close.
Lower-level reservations override higher-level ones. For example, you can reserve a whole
department for a particular project by assigning a project on the General tab for a resource pool. Then
you can countermand this for individual members of that department (or pool) by one of two ways:


Assign a different project on the General tab for that particular resource



Assign a different project in the Project column on the Availability tab
Since a lower-level reservation takes precedence over the higher-level one, a child resource
reservation is checked before the parent resource pool. Open Plan first checks for a reservation
on the Availability tab. If a reservation is found then the search ends. If not, the General tab is
checked. If no reservation is found in either spot, the parent reservation is used.

Effect of Reservations on the Select Resource Dialog Box
The availability levels shown on the Select Resource dialog box do not include any resource
availability reserved for another project.
When an activity belongs to an external subproject, the availability shown includes:


The availability reserved for that subproject



The availability for any higher-level external subprojects to which it belongs



The availability of the main project.
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Entering Resources
When you create a new resource file, Open Plan displays a window containing an empty workspace.
To add a resource to the file, click the Add Resource command on the Edit tab or simply double-click
an empty area in the workspace.
Although you can define a resource file as a “flat” structure in which all resources occupy the top
hierarchical level, a more common practice is to develop a tree-like resource breakdown structure
that can be used to summarize groups of related resources for reporting purposes:

Open Plan makes it easy to work with hierarchies of resources. For example, you can assign an
entire group of resources to a different resource pool simply by dragging the resources to a different
position in the resource hierarchy. You can also expand and collapse individual resource pools in
order to display the appropriate level of detail.
To add a resource, complete the following steps:
1. Take one of the following actions:


From the resource display, click Add Resource from the Data group on the Edit tab.



Double-click an empty area of the workspace.



Right-click an empty area of the workspace, and click Add Resource on the context
menu.

2. Enter the information for the resource in the Resource Details dialog box.
3. When the information is complete, click Close.
You can rearrange the order in which Open Plan displays resources from left to right on the
same hierarchical level by simply dragging a resource to the desired location.

To add a child resource, complete the following steps:
1. Take one of the following actions:


Select the resource pool to which you want to add a child, and click Add Child Resource

for the Data group on the Edit tab.


Right-click the resource pool to which you want to add a child, and click Add Child on the
context menu.
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Double-click the resource pool while holding down the Shift key.
If you add a child to a normal resource, Open Plan automatically converts the resource
to a resource pool.

2. In the Resource Details dialog box, enter the information for the resource.
3. When the information is complete, click Close.
To edit a resource, complete the following steps:
1. Take one of the following actions:


Double-click the resource you want to update.



Select the resource you want to update, and click Details on the Edit tab.



Right-click the resource, and click Edit on the context menu.

2. In the Resource Details dialog box, enter the information for the resource.
3. When the information is complete, click Close.
To find a resource, complete the following steps:
1. Take one of the following actions:


On the Edit tab, click Find And Replace



Right-click an empty area of the workspace, and click Find on the context menu.



Pres Ctrl+F.

.

2. In the Find Node dialog box, enter the ID of the resource you want to find, and click OK.
To delete a resource, complete the following steps:
1. Select the resource you want to delete.
2. Take one of the following actions:


Press the Delete key.



On the Edit tab, click Delete Resource.



Right-click the resource, and click Delete on the context menu.

If you are deleting a resource pool, Open Plan warns you that the child resources will be
deleted along with the pool.
If you delete a resource that has been assigned to an activity in a project, the assignment is
deleted as well.

To move a resource in the hierarchy, complete the following step:
1. Drag the resource to the desired position in the resource hierarchy.
If you move a resource pool, all child resources of the pool are moved as well.
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When you move a resource (or group of resources) to a different position in the resource
hierarchy, Open Plan automatically renumbers the resource IDs of the moved resources. If this
renumbering duplicates existing resource IDs, Open Plan allows you to renumber the resources
yourself. In addition, Open Plan also updates the assignments for renumbered resources in any
projects that are open at the time of the move. (Assignments in closed projects are not affected.)

To collapse a resource pool, complete the following steps:
1. Select the resource you want to collapse.
Collapse button

2. On the Edit tab, select Collapse from the Data group.
To collapse all resource pools, complete the following step:
1. On the Edit tab, click Collapse All from the Data group.

Collapse All button

To expand a resource pool, complete the following steps:
1. Select the resource you want to expand.

Expand button

2. On the Edit tab, click Expand.
To expand all resource pools, complete the following step:
Expand All button

1. On the Edit tab, click Expand All.

Automatic Numbering within a Resource View
Resource IDs can be generated automatically from within a resource view. If you leave the ID field
blank on the Resource Details dialog box when creating a new resource, Open Plan generates an ID
for the new item automatically according to the following rules:


If the previous resource ID at a given level is all alphabetic, the program increments
alphabetically.



If the previous resource ID at a given level is a mixture of alphabetic and numeric characters, the
numeric part is incremented numerically.



If there is no previous resource ID, the program uses a numeric ID. Therefore, the first ID in the
file is numbered "1."

Open Plan attempts to find a pattern in the ID numbering scheme for IDs that are incremented
numerically by looking at the last two IDs in the hierarchy. If a pattern can be established, Open Plan
uses the pattern when automatically creating a new ID.
For example, assume that your resource file has the following hierarchy:
A11
A12
A13
A14
A15
A20
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Open Plan looks at the last two IDs in the hierarchy and determines that there is a difference of 5
between the two. Therefore, if you use automatic numbering to create the next ID, Open Plan creates
ID A25.
On the other hand, if there is only one resource ID in the hierarchy and you have Open Plan create
the other IDs , it uses the ID’s value as the incremental pattern.
For example, if you enter 12 for the first ID in the hierarchy and then have Open Plan create the
remaining IDs, it increments the IDs by 12 resulting in the following hierarchy:
12
24
36
48
60
For information on using automatic numbering when creating new resources in a spreadsheet
view, refer to Chapter 20, “Spreadsheet Views.” For information on using automatic numbering
when creating new codes in a code view, refer to Chapter 11, “Project Codes.”
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Resource Skills
A skill is an attribute of an individual resource, which can have any number of skills. In general, the
skills assigned to different individual resources will be different but overlapping. Furthermore, skill
sets can cross hierarchical boundaries within an RBS. Thus, an individual resource may have a
different set of skills than other resources in its pool while sharing skills with resources belonging to
another pool.
Just as you can define resource assignments for an activity, Open Plan allows you to define skill
assignments as well. These assignments can be satisfied by any individual resource that possesses
the required skill.
For example, assume the following set of resources and skills:

For an activity requiring a knowledge of C++, Open Plan could suggest either DEVEL.TECH.WAYNE
or DEVEL.PROG.GAIL.
To use resource skills in Open Plan, perform the following steps:


Step One — Define the skills in a resource file.



Step Two — Assign skills to individual resources.



Step Three — Define skill assignments for activities.

To define skills for a resource file, use the Skills command from the Edit tab. Open Plan displays any
skills assigned to resources at the bottom level of the resource breakdown structure.
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Managing Skills
The Skills command from the Edit tab allows you to set up the skills for a resource file:

When you indicate that you want to create a new skill, Open Plan displays the following dialog box:

Use the following settings to define each new skill.


Skill ID — A skill ID is an alphanumeric code unique to the skill and cannot exceed 10
characters.



Description — You can enter an extended description of up to 60 characters for each skill.



Unit Cost — A base cost for the skill. Typically, this is the average cost of all the resources that
possess the skill.
By defining costs for skills, you can calculate resource budgets in cases where you request a
skill rather than an individual resource for an activity.

To define a new skill, complete the following steps:
1. From the resource display, click Skills from the Manage group on the Edit tab.
2. On the Skills dialog box, click New.
3. Enter the information about the skill.
4. When the information for the skill is complete, click OK to return to the Skills dialog box.
5. To return to the resource display, click Close.
To update a skill, complete the following steps:
1. From the resource display, click Skills from the Manage group on the Edit tab.
2. From the list of skills, select the skill you want to update, and click Edit.
3. Update the information about the skill.
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4. When the information for the skill is complete, click OK to return to the Skills dialog box.
5. To return to the resource display, click OK.
To delete a skill, complete the following steps:
1. From the resource display, click Skills from the Manage group on the Edit tab.
2. From the list of skills, select the skill you want to delete, and click Delete.
3. When Open Plan asks you to confirm the deletion, click Yes to perform the operation and
return to the Skills dialog box.
4. To return to the resource display, click OK.

Assigning Skills
Once you have created the skills for a resource file, you can assign these skills to resources.
Information about the skills assigned to a resource appears on the Skills tab of the Resource Details
dialog box:

You can assign one or more skills to any individual resource in a resource file.
To assign skills to a resource, complete the following steps:
1. Select the resource for which you want to enter a skill assignment.
2. Display the Resource Details dialog box.
3. Click the Skills tab.
4. Enter the information for the skill assignment, and click Close.
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Displaying Resource Information
Open Plan provides a number of features related to the display of resource information:


Display options



Box layout definition



The Zoom Out and Zoom In commands

Each of these features is described in the following sections.

Defining Display Options
To define the display options for resource information, use the Options tab of the Resource Display
Preferences dialog box:

Use this dialog box to specify the following options for displaying resource information:


Box Color — The color used to draw the resource boxes.



Box Style — The style used to display the resource boxes. Open Plan allows you to select a box
style from a list displayed when you enter the field.



Show Full ID — You can display the entire resource ID or just the local portion of each ID.



Show Skills — You can control the display of skills. (Skills appear as children of individual
resources.)



Minimum Height — You can control the height of the resource boxes.



Minimum Width — You can control the width of the resource boxes



Spread/Ladder — You can display the lowest level of the resource hierarchy in a “ladder” format
to conserve horizontal space.



Compressed/Uncompressed — You can display the resource hierarchy in a compressed mode
in which individual resources belonging to one pool can be displayed beneath another pool.
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Sideways — You can display the resource hierarchy in a horizontal orientation.



Centered — You can display the resource hierarchy centered in the workspace, or left-justified.
(If you are displaying the hierarchy using the Sideways option, turning off the Centered option
results in the resources being aligned along the top of the workspace.)

To define resource display options, complete the following steps:
1. Take one of the following actions:


On the Tools tab, click Preferences.



Right-click an empty area of the workspace, and click Preferences on the context menu.

2. On the Options tab of the Resource Display Preferences dialog box, enter the information for
the display options.
3. When the information is complete, click OK to return to the display.

Customizing Box Layout
You can define which resource fields are displayed when you view a resource hierarchy. Boxes can
contain as many as 50 different data items, displayed on a maximum of 20 lines. You can also display
blank lines in a box.
To customize the layout of resource boxes, display the Box Layout tab of the Resource Display
Preferences dialog box:

Change the order of the
items

Enter the data field, line
number, format, etc. for each
item

The preview area of the dialog box displays the current definition of the resource boxes. (Note that
this representation may differ slightly in size and aspect ratio from the actual display of boxes in the
view.)
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Notice that Open Plan displays data items in the dialog box in order of line number. When you add,
delete, or change data items, you must exit and return to the dialog box to display the items in the
correct line sequence.
Open Plan displays items sharing the same line from left to right based on the order in which the
items appear in the list. To move an item to a different position in the list, use Change Order.
You can customize the layout of the resource box with the following settings:


Field — You can select any resource field for display.



Line — For each field appearing in the resource box, you must assign a line number. Resource
boxes can contain up to 20 lines, and each line can display one or more fields. If you assign
multiple fields to a single line, the order in which the fields are listed in the dialog box determines
how Open Plan displays the fields in the box. To display a blank line in the resource box, do not
enter settings for those lines. For example, to display resource boxes with a double-high blank
line, use the following settings:
Field

Line

Format

Res. ID

1

1 line

Res. Desc.

4

1 line

This results in the following resource box:





Format — This setting has the following options to control the display of the data in the box:


1 Line



Wrap over 2 lines



Wrap over 4 lines



Wrap over 4 lines

Suppress Box Lines — Selecting this option hides the display of lines within the resource boxes.

To customize the resource box layout, complete the following steps:
1. Take one of the following actions:


On the View tab, click Preferences.



Right-click an empty area within the workspace, and click Preferences on the menu.

2. On the Resource Display Preferences dialog box, click the Box Layout tab.
3. Enter the information for each data item.
To change the order of the items, select any cell in a row, and click one of the Change Order
buttons.
To delete an item from the list, select any cell in the row, and press the Delete key.
4. When your changes are complete, click OK to return to the view.
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Using the Zoom Out and Zoom In Commands
Open Plan provides a Zoom Out and Zoom In command for showing resource structures that cannot
be displayed on a single screen.
If you select Zoom Out from the normal display mode, Open Plan applies a reduced display mode to
the window. In this display mode, the resource boxes are reduced so that all the resources in the
structure are visible:

If the entire resource structure can be displayed at once, the Zoom Out command is not
available.

In order to return to the normal display mode, Open Plan provides a Zoom In command. When the
display mode has been reduced, the Zoom In command becomes enabled.
To zoom out from the normal display mode, complete the following step:
1. Take one of the following actions:
Zoom Out button



On the Edit tab, click Zoom Out from the View group.



Right-click an empty area of the window, and click Zoom Out on the context menu.

To zoom in from a reduced display mode, complete the following step:
1. Take one of the following actions:
Zoom In button



On the Edit tab, click Zoom In.



Right-click an empty area of the window, and click Zoom In on the context menu.
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Resources in Spreadsheet and Barchart Views
Open Plan includes three standard views in which you can update resource description information:


Resource/Activity spreadsheets



Multi-Table barcharts



Single-table spreadsheets based on the Resource table

In each view, you can display the Resource Details dialog box by double-clicking the appropriate row
in the view:

Double-click to display resource information.

Multi-table barchart views allow you to display a time-scaled bar representing the assignments for a
resource:
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For information about displaying resource-related bars in a barchart view, refer to Chapter 6,
“Customizing Barchart Views,” in the Deltek Open Plan Developer’s Guide.

To display resources in a single-table spreadsheet, complete the following steps:
1. Display a single-table spreadsheet view.
2. Take one of the following actions:


On the View tab form the Table group, click Preferences.



Right-click an empty area of the spreadsheet, and click Preferences on the context
menu.

3. From the Table Name list on the Options tab, select Resource Data.
4. Click OK.
For more information, refer to the “Support for All Tables” section of Chapter 20,
“Spreadsheet Views.”
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Overview

Overview
Resource assignments define which resources are required for the completion of one or more
activities in a project. Open Plan provides a rich set of features for defining resource assignments.
For example:


You can describe assignments that apply for the entire duration of an activity or for only a portion
of the duration.



You can define assignments using profile curves that vary the amount of the resource required
over the course of the assignment.



You can define alternate resources that can be used in the absence of the requested resource.



You can assign a resource pool or skill for an activity and have Open Plan select an available
resource for you.

Resource assignments at the subproject level have no direct effect on the dates calculated by
resource scheduling. However, these types of assignments may impact the availability of resources
assigned to subsequent activities, thus resulting in delays
For more information about resource-related issues and subprojects, refer to Chapter 12,
“Hierarchical Projects.”

This chapter begins with a description of the different methods you can use to enter resource
assignments. This is followed by a section on resource allocation — acting upon the resource
assignments suggested by Open Plan. The chapter concludes with sections on effort-driven activities
and defining assignment profiles manually.
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Entering Resource Assignments
Open Plan provides two methods for entering resource assignments:


The Resources tab of the Activity Details dialog box



Spreadsheet views

Each of these methods is described in the following sections.

Using the Activity Details Dialog Box
To enter resource assignments using the Activity Details dialog box, display the dialog box, and click
the Resources tab. Open Plan allows you to enter resource information in either of the following two
modes: Normal and Time Phase.

Normal Mode
The default view is Normal:

In Normal mode, Open Plan controls resource assignments for the selected activity. Each activity
contains the following fields:


ID — The identifier of the selected activity. An activity ID can contain 1 to 59 characters, including
the periods that are used to indicate hierarchical levels.
IDs containing the following four symbols " , | ; are used as delimiters in Open Plan and should
not be used in the ID field.

The activity ID serves as the default sort order for most views and reports.
Although Open Plan supports almost any activity numbering system, most organizations use
activity IDs that have some significance built in such as a prefix that refers to the project.
Another approach might be to use the activity ID to associate activities with specific elements in
a work breakdown structure.
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Desc — The description of the selected activity
A description can contain up to 60 characters. You may use both upper- and lowercase
characters.

In addition, this dialog box also features the following fields:




Status — The status of an activity can be one of the following:


Planned — The activity has not yet started.



In Progress — The activity has started, but is not yet complete.



Complete — The activity is complete.

Duration — Durations may use any of the following duration units:


m — months



w — weeks



d — days



h — hours



t — minutes

While duration may contain decimal values (for example, 4.5 D), you cannot enter duration using
mixed duration units. (For example, 4D4H is not allowed.) Open plan interprets an activity with a
blank duration field as having zero duration.
You can avoid having to specify a time unit when entering durations by assigning a default
duration unit for a project through the Preferences tab on the Project Properties dialog box.
If the activity type is Subproject, Hammock, Effort Driven, or External Subproject, Open Plan
ignores any value you enter in this field and recalculates the duration each time you perform
time analysis.

The grid in this view contains the following columns:


Skill ID — Once you have specified a skill in this column, when you add a resource on the same
row using the Select Resource dialog box, the Skill Filter is preset to the intended skill,
displaying only those resources that match the skill.



Resource ID — You must select the resource ID for each resource assignment. This can be the
ID for either a resource pool or an individual resource.
Clicking the ellipsis next to the list field displays the Select Resource dialog box that you can use
to quickly select the appropriate resource.
For more information on the Select Resource dialog box, refer to the “Using the Select Resource
Dialog Box” section later in this chapter.



Resource Curve — In Open Plan, the amount of a resource requirement can be interpreted as
either a total quantity or a level-per-time unit. For example, if a 5-day activity has a resource
requirement of 10 units, this information can be interpreted in two different ways: as a total
requirement of 10 units or as a level of 10 units per day.
If you leave the Resource Curve setting blank, Open Plan interprets the amount of the resource
requirement as a level-per-time unit. Thus, if the activity duration changes, the amount of the
resource requirement changes as well.
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If you want Open Plan to interpret the amount of the requirement as a total rather than as a level,
change the Curve setting to one of the following values:


B – Back Load



D – Double Peak



E – Early Peak



F – Front Load



L – Late Peak



N – Bell (Normal)



T – Linear

For a description of each profile curve, refer to Chapter 13, “Spread Curve Profiles,” in the
Deltek Open Plan Developer’s Guide. For information on how to customize or create a spread
curve, refer to Chapter 23, “System Utilities,” in this user guide.

For requirements defined as totals, the time unit for the requirement is based on the default
duration unit specified for the project. For example, a total requirement for 10 people for a project
scheduled in days is interpreted as a requirement for 10 labor-days.
For information on setting the default duration unit for a project, refer to Chapter 5, “File
Properties.”



Resource Level — The amount of the resource required. This numeric value is interpreted by
Open Plan as either a level-per-activity time unit or as a total requirement, depending on the
Resource Curve setting for the assignment.
For a discussion of how Open Plan interprets resource requirement levels and totals, refer to
Chapter 10, “Resource Scheduling Calculations,” in the Deltek Open Plan Developer’s Guide.
For a discussion of how Open Plan deals with resource profiles of in-progress activities, refer to
Chapter 9, “The Effect of Progress Information,” in the Deltek Open Plan Developer’s Guide.



Alternate Resource ID — You can enter an alternate for any required resource, pool, or skill. If
Open Plan determines that the original required resource is not available during resource
scheduling, it attempts to substitute the alternate resource. Following resource scheduling, you
can use the resource allocation feature to confirm or change any substitutions Open Plan has
suggested.



Resource Offset — The assignment offset is a duration relative to the start of the activity when
the resource is first required. For example, if you define the offset of an assignment as 5 days,
the assignment will begin on the sixth day of the activity duration.



Resource Period — The assignment period defines the duration for which the resource is
required. If this parameter is left blank, the period duration defaults to the activity duration minus
the offset duration.
For standard (that is, non-cost) resources, Open Plan does not allow you to enter values for an
assignment offset and period that extend beyond the duration of the activity.
For more information about the differences between standard resources and cost resources,
refer to Chapter 10, “Cost Information.”
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Cost Class — Cobra users can enter a cost class for each resource assignment in this column.
This information is transferred to Cobra during cost/schedule integration.

Time Phase Mode
Click Normal to toggle to Time Phase mode:

In Time Phase mode, Open Plan allows resource assignments to be displayed and edited in a timephase manner. This allows resource levels to be more precisely allocated within the duration of the
activity.
When this mode is selected, any assignments displayed in the Normal mode are translated into timephase periods starting at the activity early start date and spread based on the assignment’s spread
curve, offset, period, and cost class.
Multiple assignments of the same resource with differing cost classes are treated as separate
assignments when translated into time-phase periods.
The grid contains the following columns:


Skill ID — Once you have specified a skill in this column, when you add a resource on the same
row using the Select Resource dialog box, the Skill Filter is preset to the intended skill,
displaying only those resources that match the skill.



Resource ID — Open Plan uses the resources displayed in this column for the activity.
If you let your cursor hover over this field, Open Plan displays the description associated with
the resource.



Cost Class — Cobra users can enter a cost class for each resource assignment in this column.
This information is transferred to Cobra during cost/schedule integration.



Total Qty — The total amount of the resource requirement. If a resource assignment exists in
Normal mode, the total quantity is calculated in one of the following ways:


Level — The Total Quantity is the Level of the resource assignment multiplied by the
Duration. For example, if you assign a resource to work 8 hours per day on a 10 day activity,
the resource requirement equates to 80 hours. Now, assume that the activity actually takes
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12 days. Since the resource was assigned as a level per time unit, the resource will work on
the activity for a total of 96 hours.


Total — The Total Quantity is the Level entered spread over the duration of the activity
according to the assigned spread Curve. For example, if you assign a resource to work on
the same 10 day activity for a total of 80 hours, you still have a fixed 80 hours of the resource
to spread over the duration of the activity regardless of whether the activity duration is 10 or
12 days.



Cutoff Dates — The time-phase cutoff dates are based on the project’s fiscal calendar (if one
has been assigned to the project). If there is no fiscal calendar, the cutoff dates are generated
using weekly periods.



Total Labor Qty — This summary row displays the total quantity for Labor resources for the
Total Qty column and each time-phase cutoff date column.

The following additional options are available:


Show As Levels — This option allows time-phase resource assignments values to be displayed
and edited using a level-per-period value instead of a total-per-period value. When in this mode,
the Total Qty column is disabled and used for reference only, and the Spread and Reconcile
buttons are dimmed.



Spread — This option displays the Spread Method dialog box that you can use to re-spread the
total quantity over time-phase periods.



Reconcile — If there is a discrepancy between the total quantity and the sum of the time-phase
periods, you can use Reconcile to quickly fix the problem. When you click this button, the
Reconcile command calculates the difference between the total quantity and the sum of the
periods. The difference is placed into the selected period after you confirm the operation.



Show Time Phase Based On —This option allows the direct updating of the integration baseline
to apply a scope change, integrate the data with Cobra and analyze the Cost impact. You may
select either Current Plan (Early Dates) or Selected Baseline. By default, Current Plan (Early
Dates) is selected. You must click Apply to commit any changes you select.



Date Range — The activity Start and End dates are displayed here.

To enter a resource assignment using the Activity Details dialog box, complete the following
steps:
1. Select the activity for which you want to enter an assignment.
2. Take one of the following actions:


On the Edit tab, click Assign.



Display the Activity Details dialog box, and click the Resources tab.

3. Enter the information for the assignment, and click OK.
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If you assign a resource to an activity that already has one assigned to it, the new resource will
be an addition to, not a replacement of, the existing resource.

Using the Assign Multiple Resources to Multiple Activities Dialog
Box
It is possible to assign one or more resources to multiple activities using the Assign Multiple
Resources to Multiple Activities dialog box:

The fields on this dialog box are the same as those on the Resources tab of the Activity Details dialog
box (discussed in the previous section) with the following additions:


From ID — This field identifies the first activity in the activity hierarchy to which you are assigning
resources.



To ID — This field identifies the last activity in the activity hierarchy to which you are assigning
resources.
The information in these fields does not imply that you are assigning resources to all the activities
in the range. For example, if you have selected activities such as the following:
1.03.01
1.03.04
1.03.06
Open Plan would show 1.03.01 in the From ID field and 1.03.06 in the To ID field.

To assign one or more resources to multiple activities, complete the following steps:
1. Hold down Shift or Ctrl, and click the activities for which you want to assign a resource or
resources.
2. On the Edit tab, click Assign Resource.
3. Open Plan automatically displays the Select Resource dialog box.
4. Select the resource(s) to assign to the activities, and click OK.
5. On the Assign Multiple Resources to Multiple Activities dialog box, enter the information for
the resource(s), and click OK.
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Using the Select Resource Dialog Box
The Select Resource dialog box is displayed when you click the ellipsis next to the list field when
assigning a resource ID on the Resources tab of the Activity Details dialog box:

You can use the following controls on this dialog box when selecting a resource or resources to
assign to an activity:


Resources — This area displays a hierarchical representation of the resources in the currently
assigned resource file. Different resources are displayed here as you apply or remove a skill filter.
Resources that have had skills assigned to them can display in this list followed by two numbers
in parentheses. For example, a resource appearing as “Bob Johnson (10) (3)” indicates that Bob
Johnson has an availability of 10 units (as defined on the Preferences tab of the Project
Properties dialog box). It further indicates that this resource has a proficiency rating of “3”.
Proficiencies are assigned to resources on the Skills tab of the Resource Details dialog box.
In general, resource availabilities that are reserved for another project are not displayed in this
field. However, when an activity is part of an external subproject, Open Plan includes resources
that have been reserved for the following elements of the hierarchical project:





The subproject to which the activity belongs



Any higher-level external subprojects



The master project

Skill Filter — This field contains a list of skills that you can use to filter the hierarchy of resources
that is displayed:


All Skills — When selected, all resources are displayed in the Resources list and are
available for selection on the activity. This is the default selection.
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Remaining entries in the list — The remaining entries in the list are the skills that have
been defined for resources in your company. When you click a skill in the list, the hierarchy in
the list of available resources is updated to display only those resources possessing the
selected skill.
If you select multiple skills by holding down the Ctrl or Shift key while making a selection, the
hierarchy displays only those resources that possess all the selected skills.





Resource Category Filter — This field contains a list of resource categories that you can use to
filter the hierarchy of resources that is displayed:


All Resource Categories — If you select this value, Open Plan does not limit the display of
resources to those with a specific resource category. All resource categories are displayed.
This is the default selection.



Labor — If you select this value, Open Plan displays only labor resources in the hierarchy of
resources.



Material — If you select this value, Open Plan displays only material resources in the
hierarchy of resources.



Other Direct Costs — If you select this value, Open Plan displays only other direct cost
resources in the hierarchy of resources.



Subcontract — If you select this value, Open Plan displays only subcontract resources in the
hierarchy of resources.



Skills — If you select this value, Open Plan displays only subcontract skills in the hierarchy
of resources.

Code — If one or more code files have been assigned to the resource file, you can filter the
display of available resources using a selected code. When you select a code file in this field, the
Code Filter field is populated with the codes that you can use to filter the view.
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Clicking the ellipsis button next to the Code selection list displays the Select Code dialog box:

This dialog box allows you to filter the displayed codes in the Code Filter list. (This is useful if you
are dealing with a very large, hierarchical code file.)


Code Filter — When you select a code file from the Code field, the Code Filter list displays the
codes available in the code file. Selecting a code from the list and clicking Apply filters the
display of resources by that code.



Hide Unreferenced Resources — This option allows you to hide resources that are not used in
your project. This feature is useful if you always use the same group of resources for the project.



Display Only Available Resources — When you select this option, Open Plan provides the
following information about available resources that meet the selection filters:


Resources that are 100% available for the specified date range are listed with no additional
information.



Resources that are available but who have less than 100% availability are listed with the
minimum and maximum availability during the required period.

If no resources are available to meet the resource requirements of the activity, Open Plan
displays the earliest date on which each resource meeting the selection filters is available.
When determining a resource's availability, Open Plan considers not only the current project, but
also any other higher priority projects that share the same resource pool and for which Open
Plan saves summary resource information.

Open Plan also displays the Early Start and Early Finish dates of the activity. This information is
useful in the event that no suitable resource is available during the specified date range.
For example, assume that the early dates for the activity are as follows:


Early Start — 02Feb02



Early Finish —15Feb02

Assume, too, that a resource with the required skills is not available until February 23. Under
these circumstances, you might want to change either the skills required for the activity or the
logic of the project so that the early start date for the activity coincides with the dates when the
resource is available.
Once you have chosen the filter(s) to use for the resource display, click Apply to put them into
effect. Clicking Clear removes all the filter choices you made.
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The following buttons are located along the right-hand side of the dialog box:


OK — Clicking this button assigns the selected resource to the activity.



Cancel — Clicking this button closes the dialog box without assigning any resources.



Find — Clicking this button displays the Find dialog box that you can use to find a resource
with a specified ID, description, or skill.



Find Next — Once you have located a resource using Find, clicking Find Next locates the
next resource that meets the same search criteria.



Expand All — Clicking this button fully expands the hierarchy of resources.
You can selectively expand portions of the hierarchy by clicking the appropriate plus
sign (+) icon.



Select All — Clicking this button selects all the resources in the hierarchy of resources
regardless of whether the hierarchy is expanded.



Clear All — Clicking this button clears the selections for all the resources in the hierarchy of
resources regardless of whether the hierarchy is expanded.



Help — Clicking this button displays the Help topic for this dialog box.

Using Spreadsheet Views
Open Plan allows you to display and, in some cases, update resource assignment information in a
spreadsheet view. These views include:


Single-table spreadsheet based on the Resource Assignment table



Activity/resource spreadsheet



Resource/activity spreadsheet

In a single-table spreadsheet view based on the Resource Assignment table, the resource
assignment information appears in a tabular format, with each assignment displayed in a single row:
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In this type of view, you can add assignments in one of two ways. If the activity already has at least
one assignment, you can edit the Resources tab of the Activity Details dialog box. You can also insert
a new row in the spreadsheet and specify both the activity and the assigned resource.
Activity/resource spreadsheets display multiple assignments for each activity using an outlining
format:

Click to expand or collapse the assignments for an activity

In an activity/resource spreadsheet view, Open Plan displays a plus (+) sign or a minus (-) sign on
the outlining button to the left of the row to control the display of assignment information. If the
outlining button displays a plus sign, you can expand the activity to see all of its assignments. If the
outlining button displays a minus sign, the activity is already expanded, and clicking the outlining
button will collapse the display of assignments. If the outlining button on an activity row is blank, the
activity does not have any resource assignments.
For more information about expanding and collapsing items in a spreadsheet view, refer to
Chapter 12, “Hierarchical Projects.”

In this type of view, you can display the Activity Details dialog box for an activity and edit the
Resources tab.
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Resource/activity spreadsheets allow you to see multiple assignments for each resource:

Click to expand or collapse the assignments for a resource

This type of view is used mainly for reporting purposes, but you can edit the Resources tab of the
Activity Details dialog box for an activity.
The activity/resource spreadsheet view and the resource/activity spreadsheet view are found in
the Open Plan Library Views folder. The names of the views are AVLSPDVW and RCSPDVW
respectively.

To add an assignment to a single-table spreadsheet based on the Resource Assignment table,
complete the following step:
1. Display the Resource Assignment table in a single-table spreadsheet view.
2. On a blank row, select the Activity ID cell.
3. Click the ellipsis button to the right of the edit box at the top of the spreadsheet.
Open Plan displays the Choose a Value dialog box that lists the available activities.
4. Select the activity from the list, and click OK.
5. Select the Res. ID cell for the row, and repeat steps 2 and 3.
6. Enter the rest of the information for the assignment.
For information on how to display resource assignments in a single-table spreadsheet, refer to
the “Support for All Tables” section of Chapter 20, “Spreadsheet Views.”

To add an assignment using the Activity Details dialog box, complete the following steps:
1. In a spreadsheet view, double-click the selection button to the left of the activity to which you
want to add an assignment.
2. On the Activity Details dialog box, click the Resources tab.
3. Enter the information for the assignment.
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4. When done, click Apply, then Close.

Using Barchart Views
In addition to spreadsheet views, Open Plan includes two standard barchart views for displaying
resource assignment information — activity/resource barcharts and resource/activity barcharts.
In an activity/resource barchart, resource assignments can appear as bars beneath an activity bar:

In a resource/activity barchart, you can display all of the assignments for a specific resource:

Both of these types of views are designed primarily for reporting purposes and have limited data input
features.
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Resource Allocation
During resource scheduling, Open Plan suggests a resource for each resource assignment. If you
defined the assignment using an alternate resource, this suggested resource may be the requested
resource, or it may be the alternate resource you specified. It is also possible that you assigned either
a pool or a skill to the activity. In that case, Open Plan suggests an individual resource that fulfills the
requirement.
After performing resource scheduling, you have the opportunity to review these suggested resources
and take an appropriate action. In Open Plan, this process is referred to as “resource allocation,” and
the results of this process appear in the Activity Resource Allocation dialog box:

Resource requested by
planner

Resource suggested by
Open Plan

This dialog box is modeless; in other words, you can leave the dialog box open when performing
other operations. Four navigation arrows in the lower-right corner of the dialog box allow you to scroll
through the records in the file.
For more information on modeless dialog boxes, refer to Chapter 2, “Basic Skills.”

If Open Plan suggested the requested specific resource, you do not need to take any action.
However, if Open Plan suggests an alternate resource, a resource from a pool, or a resource with a
specified skill, you need to decide whether you want to act on the suggestion at this time.
There are two different actions you can take during a resource allocation session:


You can replace the requested resource with the one suggested by Open Plan.



You can lock the requested resource, which has the effect of removing the alternative resource
from future consideration for the assignment.

These actions take effect the next time you perform resource scheduling on the project.
Your role in resource allocation is to review the resources Open Plan suggests for each activity. You
can either accept the suggestion by replacing the requested resource with the suggested resource or
ignore the suggestion for the time being.
In general, you should use the following steps when calculating a schedule using pools, skills, or
alternate resources:
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Step 1 — After making your initial resource assignments and conducting a time analysis of the
project, perform resource scheduling.



Step 2 — Use the Activity Resource Allocation dialog box to review the suggested resources for
each activity and make any necessary changes.
You cannot display this dialog box for activities without resource assignments.



Step 3 — Perform resource scheduling again.



Step 4 — To see the effect of your choices in resource allocation on the schedule and resource
utilization, display a histogram view showing the resources you are most interested in.

Typically, you would repeat this procedure several times until you are satisfied with the resource
assignment for each activity.
To display the Activity Resource Allocation dialog box, complete the following step:
1. Take one of the following actions:


Select the activity for which you want to review the resource allocations, and click
Allocate on the Edit tab,



Right-click the activity, and click Allocation on the context menu.

Allocate button

Replacing Requested Resources for an Activity
During resource scheduling, if Open Plan suggests that you use the alternate resource for an activity,
you have the option of acting on the suggestion. This instructs Open Plan to replace the assignment
for your requested resource with the alternate suggested by Open Plan.
For example, assume that you have specified RES.LAB.ENG.MECH.IKE for an activity, but will
accept RES.LAB.ENG.MECH.KELLEY as an alternate if the requested resource is not available. As
the result of resource scheduling, Open Plan suggests that RES.LAB.ENG.MECH.KELLEY be used.
In the Activity Resource Allocation dialog box, Open Plan identifies the requested, alternate, and
suggested resources:
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If you choose to accept the suggestion, Open Plan makes the alternate resource the requested one:

Note, however, that this action may not have a permanent effect. Unless you lock the resource
requirement (discussed later in this chapter), Open Plan may suggest either your requested resource
or an alternate resource the next time you run resource scheduling. Therefore, it is possible for you to
replace the requested resource with the suggested resource during one resource scheduling session
and have Open Plan suggest your originally requested resource during a subsequent resource
scheduling session.
Once you have replaced the originally requested resource, future resource scheduling sessions
may not allow you to undo the replacement. In the above example, for instance, restrictions on
the availability of RES.LAB.ENG.MECH.IKE may result in Open Plan never suggesting that
resource as an alternative to RES.LAB.ENG.MECH.KELLEY. You can, of course, always
restore the original assignment by re-entering the information for the assignment in the Activity
Details dialog box. However, to maintain flexibility in your resource assignments for as long as
possible, consider replacing requested resources only for activities planned in the near future.

To replace a requested resource with a suggested resource, complete the following steps:
1. Take one of the following actions:


Select the activity for which you want to replace resources, and click Allocate on the Edit
tab.



Right-click the activity, and click Allocation on the context menu.

2. In the Activity Resource Allocation dialog box, select the assignment, and click Accept.
3. To return to the view, click OK.

Using Resource Locking
The objective of resource locking is to inhibit future alternate resource scheduling. If you lock a
selection, you are telling Open Plan that you do not want to consider any other resource for the
specified activity. You may want to lock a resource selection in any number of situations. For
example:


As Time Now approaches the date on which an activity is scheduled to start, you should consider
locking resources for that activity.
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It may be important that you use the same resource for a series of activities.



You may feel particularly comfortable using the suggested resource for the activity.

For example, assume that Open Plan suggests that RES.LAB.ENG.MECH.IKE be used for an activity,
and you do not want to consider any other resource for the activity:

When you lock the resource for the activity, Open Plan deletes the alternate resource specification
and makes the requested resource the required resource. (On the following screen, note that the
Alternate field is now blank.)

You can lock a resource assignment regardless of whether Open Plan suggests your requested
resource or an alternate resource.

Once you have locked a resource for an activity, the only way to re-assign an alternate resource
requirement is to return to the Activity Details dialog box. For this reason, consider locking resources
only for activities planned in the near future.
To lock a requested resource, complete the following steps:
1. Take one of the following actions:
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Select the activity for which you want to lock resources, and click Allocate on the Edit
tab.



Right-click the activity, and click Allocation on the context menu.

2. In the Activity Resource Allocation dialog box, select the assignment, and click Lock.
3. To return to the view, click OK.
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Effort-Driven Activities
With effort-driven activities, you can have Open Plan calculate the activity duration based on resource
assignments. Typically, you might enter resource assignments at an early stage of the planning
process and then use this feature to generate durations for activities automatically.
To calculate an effort-driven duration, Open Plan determines the longest span implied by any
assignment for the activity by dividing the amount of the assignment by the resource effort factor.
(Notice that the availability or non-availability of the resource does not affect the results of this
calculation.) The result of the calculation is expressed in the default duration units used by the
project.
For example, assume that the activity has a single resource assignment based on the following
information:


Resource assignment level for the activity — 10 units



Resource effort factor — 0.5



Default duration unit for project — days

Open Plan would calculate the effort-driven duration as 20 days (10/0.5).
To perform this calculation, Open Plan interprets any assignment level as a total requirement and
ignores any assignment offsets and periods.
Defining an activity as effort-driven also affects the behavior of the activity during subsequent
resource scheduling sessions as follows:


The activity is assigned the reprofilable attribute. (You can override this setting if you wish.)



Resource assignments defined as levels are treated as totals using a linear spread curve.



Assignment offsets and periods are ignored.
To change an effort-driven activity back to one with a fixed duration, you can change the activity
type to ASAP, or you can simply overwrite the calculated duration manually. If you enter a fixed
duration but keep the activity type set to Effort Driven, Open Plan automatically recalculates the
duration the next time you enter or change resource assignment information.

To define an activity as effort-driven, complete the following steps:
1. Click the General tab of the Activity Details dialog box for the activity.
2. Select Effort Driven for the activity Type, and click OK.
3. When Open Plan asks you to confirm the selection, click OK.

Chapter 08 Resource Assignments
Deltek Open Plan 8.0 User Guide

221

Defining Assignment Profiles Manually

Defining Assignment Profiles Manually
Although it is possible to define a simple profile for each assignment using one of the standard
curves, the use of assignment offsets and periods, combined with the ability to specify more than one
assignment for the same resource, allows you to define much more complex resource profiles for an
activity.
Using offsets and periods, for example, you can construct the following profile by defining 3 resource
assignments for an activity with duration of 5 days:
Resource

Curve

Level

Offset

Period

TUBING

(blank)

50

0 (or blank)

5d (or blank)

TUBING

(blank)

25

2d

3d

TUBING

(blank)

100

3d

1d

This would result in the following resource profile:
175 units

75 units
50 units

Activity Start

1

2

3

4

Activity Finish

A potential disadvantage of this approach, however, is that subsequent changes in the planned
duration of an activity may have unintended consequences for the definition of offsets and periods.
In cases where activity progress has been recorded and an activity is partially complete, Open Plan
takes the offset duration relative to the original activity duration when calculating resource usage but
bases this calculation on the end of an activity duration rather than its beginning.
For more information about the effect of progress information on resource scheduling, refer to
Chapter 9, “The Effect of Progress Information,” in the Deltek Open Plan Developer’s Guide.
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Overview

Overview
By defining the days and hours during which work can be scheduled, calendars allow you to create a
realistic project plan. Typically, calendars are standardized across an entire organization and define a
standard working day (for example, 8:00 A.M. to 4:00 P.M.), a normal workweek (for example,
Monday through Friday), and a set of observed holidays. In some cases, you may want to define
more detailed calendars that contain information such as a specific activity work schedule or an
employee vacation schedule.
Open Plan has a flexible calendar function that allows you either to define calendar files on a projectby-project basis or to create a single calendar file that can be used with multiple projects. Calendars
can also be defined for resource files. Within each calendar file you can define a default calendar,
which can then serve as the model for subsequent calendars. You can also define a standard
workweek for a calendar and then define any holidays or extra days as exceptions.
These features can help you create and maintain project and resource calendars that can be used for
planning purposes throughout your organization.
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Calendar Files
Open Plan stores information about working and non-working times in calendar files. Each time you
perform a scheduling operation that calculates dates (for example, time analysis), Open Plan refers to
the calendar file assigned to the project. In this way, work is scheduled to take place only during valid
working times.
User-defined dates such as target dates or actual dates are not restricted to valid working days.

Because activities and resources within the same project can have different work schedules, calendar
files can include multiple calendars, each defining a specific set of working and non-working times.
Think of a calendar file as a container storing all the possible calendars that activities, resources, and
relationships in a project might use. For example, a single calendar file might contain calendars that
define different shift patterns, workweeks, or sets of holidays. This design allows the same project to
use different definitions of working hours, working days, and holidays. There are no limits to the
number of calendars you can define in a single calendar file.
In the Open Plan Explorer, calendar files are stored in the Calendar folder of the Open Plan Library.
You can open calendar files from within either the Open Plan Library or a specific project or
resource folder. You can assign a calendar file to projects and resource files using either of the
following methods:


By using the Files tab of the appropriate Properties dialog box.



By dragging the calendar file from the Open Plan Library to the project or resource folder.

Calendar files can be project-specific, or they can be shared by multiple projects. If you make
changes to the information in a calendar file, the changes will affect all of the projects to which the
calendar file is assigned. To make changes in a calendar file to affect only a single project, make sure
that the calendar file is not assigned to other projects.
If you do not assign a calendar file to a project, Open Plan assumes that work can be scheduled
using a 40-hour workweek (8 hours per day, 5 days per week, and no holidays).

To create a calendar file, complete the following steps:
1. Take one of the following actions:

New button



On the File menu, click New.



Press Ctrl+N.



On the Quick Access Toolbar, click New.



Double-click an empty area of the Open Plan Explorer.

2. From the list of file types, select Calendar.
3. Enter the information for the new calendar file.
4. Take one of the following actions:


To start the New File Wizard where you can define the settings for the calendar file, click
Next.



To create the calendar file using default settings, click Finish.
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Open Plan creates a new calendar file and displays the default calendar.
For more information on using the New File Wizard, refer to Chapter 4, “Creating a
New File.”

To open a calendar file, complete the following step:
1. Take one of the following actions:

Open button



Double-click the calendar file.



Right-click the calendar file, point to Open on the context menu , and select the mode in
which to open the file from the submenu.



On the Quick Access Toolbar, click Open to display the File Open dialog box.

To copy a calendar file, complete the following steps:
1. Open the calendar file.
Save As button

2. On the File menu, click Save As New File.
3. Enter the name for the copy of the file, and click OK.
You cannot perform Save As on a file if there is another file open which refers to it. For
example, if you open project CLEAN and then try to perform a Save As on the calendar
file CLEANCAL, the Save As command is disabled.

To delete a calendar file, complete the following steps:
1. Take one of the following actions:


Select the calendar file, and press the Delete key.



Right-click the calendar file, point to Manage Files, and click Delete on the context menu
to display the Select File to Delete dialog box.

2. When Open Plan asks you to confirm the deletion, click Yes.
Deleting a calendar file from a project folder removes any activity calendar assignments
from the project.

To assign a calendar file to a project or resource, complete the following step:
1. Take one of the following actions:


Drag the calendar file from the Open Plan Library to the project or resource folder.



On the Files tab of the Project Properties dialog box, specify the name of the calendar
file.
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Open Plan calendar files consist of one or more calendars, each defining a specific set of working
and non-working times. Each day can have one of four possible definitions:


Working day — A work day as defined by the standard workweek



Non-working day — A non-work day as defined by the standard workweek



Holiday — A standard working day that has been designated as non-working



Extra work day — Either a non-working day that has been designated as working or a working
day with non-standard hours

For each working or extra work day, it is possible to define up to 10 spans of valid working times. For
example, to describe your standard office hours as 8:00 A.M. to 4:30 P.M. with a 30-minute lunch
break, you could define two working periods: 8:00 A.M. to 12:00 P.M., and 12:30 P.M. to 4:30 P.M..
How you set up your calendars for a particular calendar file largely depends on your scheduling
requirements. In some cases, you may want to set up a simple calendar file containing only a handful
of calendars: one calendar for activities that must be performed Monday through Friday and another
calendar for activities that can be scheduled over weekends. In other cases, you may need to set up
individual calendars for each resource. This approach allows resource scheduling calculations to take
into account such varied factors as part-time status, availability for overtime, and personal vacation
schedules.

The Default Calendar
Each time you create a new calendar file, Open Plan automatically creates a default calendar that
defines a Monday-through-Friday workweek with no holidays. Each work day has 8 working hours —
8:00 A.M. to 4:00 P.M.. This default calendar serves as the model for all new calendars added to the
file.
In addition to using the default calendar as a model for subsequent calendars, Open Plan applies the
default calendar to all activities and to resources that have not been assigned specific calendars.
You can modify the contents of a default calendar at any time. Although changing a default calendar
has no effect on existing calendars in the file, any calendars you add thereafter will be based on the
new defaults. Thus, you can customize a default calendar using the most commonly used work
calendar (which might include, for example, a list of standard corporate holidays) and then set up
subsequent calendars on an exception basis.
If all of the activities and resources in a project use the same calendar, you can, in effect, define
a project calendar by customizing the default calendar of the calendar file assigned to the
project.
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Activity and Relationship Calendars
You can specify both a default activity calendar and a default relationship calendar on the
Preferences tab of the Project Properties dialog box:

The Def. Activity Calendar field is used to specify that an existing calendar is to be used as the
default calendar for new activities.
The Def. Relationship Calendar field is used to specify that an existing calendar is to be used as the
default calendar for new relationships.
To display the Preferences tab of the Project properties dialog box, complete the following
steps:
1. Take one of the following actions:


Select the project, and click Properties on the Processes tab.



Right-click the project folder, and click Properties on the context menu.

2. Click the Preferences tab.
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Resource Calendars
You can assign a calendar file to a resource file either by dragging it from the Open Plan Library to
the resource folder or by using the Files tab of the resource file’s Properties dialog box:

Clicking the ellipsis button to the right of the Calendar field displays the Select dialog box from which
you can select the appropriate calendar file.
The calendar file you assign to the resource file helps to define the availability of resources. Since the
calendars you assign to resources are defined in the resource calendar file, resource availabilities are
consistent when viewed by different projects.
For information on resource availabilities, refer to Chapter 7, “Resource Definitions.”
For information on creating codes, refer to the “New File Wizard — Files Page” section of
Chapter 4, Creating a New File.”

To assign a calendar file to a resource file using the Properties dialog box, complete the
following steps:
1. Right-click the resource folder, and click Properties on the context menu.
2. Click the Files tab.
3. Click the ellipsis button at the right edge of the Calendar field.
4. From the Select dialog box, select the calendar file to assign to the resource file.
5. Click OK.
To assign a calendar file to a resource file using drag and drop, complete the following steps:
1. Locate the appropriate calendar file in the Open Plan Library.
2. Drag it to the target resource file folder.

Be sure to drag the calendar file to the resource file folder and not to the project folder.
Dragging it to the project folder will replace the project calendar.
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Adding Calendars
If you want to define more patterns of work than can be described using the default calendar, you can
add additional calendars to a calendar file. Any new calendar you add inherits all of the information
stored for the default calendar.
When adding a new calendar as a child, the child calendar inherits its settings from the parent. For
example, a parent calendar can be defined to show company and public holidays while child
calendars can be defined to show additional personal holidays for individual employees. Using this
feature, the individual employee calendars will also include both the company and public holidays that
have been defined in the parent calendar.
There is no limit to the number of calendars that you can define for a single calendar file.
To add a calendar to a calendar file, use the Calendars command to display the following dialog box:

To add a calendar, complete the following steps:
1. Open the appropriate calendar file.
2. Take one of the following actions:


On the Edit tab, click Calendars.



Right-click the calendar display, and click Calendars on the context menu.

3. On the Calendars dialog box, click New.
4. Enter the name for the new calendar, and click OK.
5. Open Plan creates the new calendar based on the default calendar in that calendar file.
6. To display the new calendar, select the calendar, and click Select.
To display different calendars in a calendar file, complete the following steps:
1. Open the appropriate calendar file.
2. Take one of the following actions:


On the Edit tab, click Calendars.



Right-click the calendar display, and click Calendars on the context menu.

3. In the Calendars dialog box, select the calendar you want to display, and click Select.
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Defining a Standard Workweek
For each calendar in a calendar file, you can define a standard workweek, that is, the normal working
hours and days for the calendar. Typically, you would want to do this immediately after creating a new
calendar.
Once you have defined a standard workweek for a calendar, you need specify only those working
times or days that deviate from the standard.
Use the following dialog box to define the standard workweek for a calendar:

Asterisks indicate standard
working days.

You can define up to 10 working periods for each working day.
To define the standard workweek, complete the following steps:
1. Open the appropriate calendar file.
2. Take one of the following actions:


On the Edit tab, click Work Week.



Right-click the calendar display, and click Work Week on the context menu.

3. From the Calendar list, select the name of the calendar for which you want to define the
workweek.
4. Select one or more days from the list, and click Working or Non-Working.
5. For working days, enter the work start and stop times.
When entering start and stop times, the following conditions apply:


You must enter a start and stop time for each period. The start time of a period cannot be
earlier than the stop time of the previous period.



You can define working times for more than one day at a time. Select multiple days by
dragging in the list or by pressing the Shift key in combination with the Up or Down
arrow key. Then enter the working times.



If you enter work times using a 24-hour format (where, for example, 22:00 represents
10:00 P.M.), you cannot define a work period that spans midnight by entering a time
such as 26:00.

6. When the definition of the workweek is complete, click OK.
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Entering Calendar Information
When you open a calendar file, Open Plan displays the information for the first calendar in the file.
This display allows you to view an entire year at one time.

Press the Spacebar to change the working status
of a day. Press Ctrl+Spacebar to change the
working hours.

You can also use the keyboard to move through the calendar dates as follows:
Key

Action

Left arrow

Go to previous day

Right arrow

Go to next day

Ctrl+Left arrow

Go to same day in previous month

Ctrl+Right arrow

Go to same day in next month

Up arrow

Go to same day in previous week

Down arrow

Go to same day in next week

Page Up

Go to previous year

Page Down

Go to next year

Home

Go to first day of year

End

Go to last day of year
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To change the work status of a day, you can simply select the day and press the Spacebar. You can
also double-click a date or press Ctrl+Spacebar to display the working hours for a date:

Enter the working times for the day.

Click Reset to return to standard
working times.

Unless you specify otherwise, the working times for a day default to the definition for that day in the
standard workweek. If standard working times have not been defined for the day, Open Plan defaults
to an 8-hour workday — 8:00 A.M. to 4:00 P.M.
To change the work status of a day, complete the following step:
1. Take one of the following actions:


Select the day, and press the Spacebar.



Double-click the date, and click Working of Non-Working on the Define Work Hours
dialog box.



Right-click the date, and click Working or Non-Working on the context menu.

To define working hours for a day, complete the following steps:
1. To display the Define Work Hours dialog box, take one of the following actions:


Double-click the date.



Select the date, and press Ctrl+Spacebar.



Select the date, and click Work Hours on the Edit tab.



Right-click the date, and click Define Work Hours on the context menu.

2. Define the work times for the selected days.
3. To restore the working hours to the standard workweek for that calendar, click Reset.
4. To return to the calendar, click OK.
To go to a specific date, complete the following steps:
1. Take one of the following actions:


On the Edit tab, click Go To Date.



Right-click the calendar display, and click Go To Date on the context menu.

2. Enter the date you want to display, and click OK.
Open Plan displays the appropriate year with the date selected.
If you did not enter a year for the date, Open Plan assumes the current year.
To go to the previous year, complete the following step:
Previous Year
button

1. Take one of the following actions:


Press Page Up.
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On the Edit tab, click Previous Year.



Right-click the calendar display, and click Previous Year on the context menu.

To go to the next year, complete the following step:
1. Take one of the following actions:

Next Year button



Press Page Down.



On the Edit tab, click Next Year.



Right-click the calendar display, and click Next Year on the context menu.

Setting Up a Holiday List
In Open Plan, holidays are standard or extra working days that have been designated as nonworking. You can define each holiday individually, or if you prefer, you can enter and maintain the
holidays for a calendar as a list:

You can define holidays that repeat each year. For example, you might define January 1 as a
repeating holiday.
You can enter a holiday on a non-working day only if the holiday is repeated yearly. If it is not
repeated yearly, Open Plan continues to display the day as non-working.

If a given date is defined as a holiday in a parent calendar, it is marked with the holiday color in all its
child calendars. However, the date is not identified as a holiday on the Holidays dialog box displayed
from the child calendar. The dialog box shows only those holidays defined for that child calendar from
which it is accessed.
To enter a list of holidays, complete the following steps:
1. Open the appropriate calendar file.
2. Take one of the following actions:


On the Edit tab, click Holidays.



Right-click the calendar display, and click Holidays on the context menu.

3. From the Calendar list, select the name of the calendar for which you want to define
holidays.
4. Enter the date for the holiday, and indicate whether the holiday is to be repeated each year.
5. When finished, click OK.
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Working with Calendars
Open Plan offers a number of ways to manage the calendars in a calendar file:


You can add a new calendar that is based on the default calendar for the calendar file.



You can add a calendar as a child of an existing calendar.



You can create a new calendar by copying an existing calendar.



You can rename an existing calendar.



You can delete a calendar from the file.

To perform these functions, use the Calendars dialog box:

For a description of how to add a new calendar to a calendar file, refer to the “Adding Calendars”
section in this chapter.

To add a new calendar as a child of an existing calendar, complete the following steps:
1. Open the appropriate calendar file.
2. Take one of the following actions:


On the Edit tab, click Calendars.



Right-click the calendar display, and click Calendars on the context menu.

3. In the Calendars dialog box, select the calendar to which you want to add a child.
4. Click Add Child.
5. Enter the name for the child calendar, and click OK to return to the Calendars dialog box.
Notice that the parent portion of the calendar name is automatically entered for you.

To copy a calendar, complete the following steps:
1. Open the appropriate calendar file.
2. Take one of the following actions:


On the Edit tab, click Calendars.



Right-click the calendar display, and click Calendars on the context menu.
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3. In the Calendars dialog box, select the calendar you want to copy.
4. Click Copy.
5. Enter the name of the new calendar, and click OK to return to the Calendars dialog box.
To rename a calendar, complete the following steps:
1. Open the appropriate calendar file.
2. Take one of the following actions:


On the Edit tab, click Calendars.



Right-click the calendar display, and click Calendars on the context menu.

3. In the Calendars dialog box, select the calendar you want to rename.
4. Click Rename.
5. Enter the new name for the calendar, and click OK to return to the Calendars dialog box.
To delete a calendar, complete the following steps:
1. Open the appropriate calendar file.
2. Take one of the following actions:


On the Edit tab, click Calendars.



Right-click the calendar display, and click Calendars on the context menu.

3. In the Calendars dialog box, select the calendar you want to delete.
4. Click Delete.
5. When Open Plan asks you to confirm the deletion, click Yes to return to the Calendars dialog
box.
Deleting a calendar from a calendar file removes any assignments for that calendar in a
project.

Controlling the Display of Calendars
Open Plan offers a number of settings that allow you to control how calendar information is displayed.
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The Layout tab of the Calendar Preferences dialog box controls how Open Plan arranges dates in a
calendar.

The following options are available:


Start Day of Week — You can define which day is displayed as the first day of each week.



Start Month of Year — You can define which month is used to start the year. This allows you, for
example, to display calendars that show fiscal rather than chronological years.

Use the Color tab of the Calendar Preferences dialog box to define a color and a fill pattern for the
different types of days in a calendar.

You can also set the font for the calendar display with the Font command from the Tools tab.
To set calendar preferences, complete the following steps:
1. Take one of the following actions:


On the Tools tab, click Preferences.



Right-click the calendar display, and click Preferences on the context menu.

2. In the Calendar Preferences dialog box, select the appropriate tab, and enter the information
for your preferences.
3. When your changes are complete, click OK to return to the calendar.
To change the calendar font, complete the following steps:
1. Take one of the following actions:


On the Edit tab, click Font.



Right-click the calendar display, and click Font on the context menu.
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2. In the Font dialog box, select the font and style for the calendar.
3. When your changes are complete, click OK to return to the calendar.
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Overview

Overview
Managing the cost of a project may be at least as important as managing the schedule for most
project managers. Yet the cost management functions provided by most project management
packages seldom yield satisfactory results — in large part because these types of cost systems
cannot cope with the wide variety of methods employed by different organizations to plan, track, and
report on costs. In Open Plan, cost-related features are designed to provide basic functionality while
allowing planners and managers the maximum amount of flexibility to set up cost management
systems tailored for their specific environments.
This chapter begins with a brief discussion of basic earned value management concepts and then
examines each of the following topics in turn:


Planning costs



Setting the Performance Measurement Baseline



Capturing actual costs



Reporting on costs
If you require extensive cost management and reporting features for your projects, Deltek
Cobra, Deltek’s cost management software, may be more appropriate to your needs. Cobra is a
powerful and sophisticated earned value management package that can use project-related data
generated by Open Plan. For more information about Cobra, contact your Deltek representative.
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Earned Value Management
Although it is possible to set up a rudimentary cost management system that simply tracks budgeted
and actual costs for a project, most organizations find such an approach far too limiting. Budgeted
and actual costs do not, in themselves, provide enough information for a manager to determine if the
work currently in progress is, in fact, over- or under-budget. For example, assume you have planned
an activity with an initial budget of $1000 spread evenly over the course of the activity. Midway
through its planned duration, the activity has recorded actual costs of $500. Is the activity over or
under budget? That depends entirely on an estimate of the physical completion of the activity. If the
activity has achieved only 25% of its intended results, for example, it is clearly over budget — it has
taken $500 to achieve what was originally planned to cost $250. If the activity is 50% complete,
however, the same actual costs indicate that the activity is being performed according to its budget.
Since earned value is measured as a percentage of the budget, it is necessary to create a
Performance Measurement Baseline (PMB) against which performance, or earned value, is
measured. The PMB is a copy of the project plan at the beginning of the project and represents the
approved budget. When approved budget changes occur, these changes are reflected in the PMB.
Thus, you have a separation between the forecasted cost and the approved budgeted cost once the
project is underway.
For information on creating a PMB, refer to Chapter 16, “Status Information.”

Measuring the work performed against a performance measurement baseline is typically called an
earned value management system. To establish the systematic accounting of earned value, a project
manager must have access to the following information:


Performance Measurement Baseline



Physical percent complete (an estimate of the work that has actually been performed by Time
Now)



Actual costs to date



Forecast

With this information, the five principal elements of earned value cost control can be defined:


Budgeted cost of work scheduled (BCWS) — The budgeted cost of the work that should have
been completed to Time Now, according to the PMB.



Budget at complete (BAC) — The total budgeted cost of the work according to the PMB.



Budgeted cost of work performed (BCWP) — The budgeted cost of the actual portion of the
scheduled work that has been completed (or earned value)



Actual cost of work performed (ACWP) — The actual costs expended to perform the work
completed



Estimate at Complete (EAC) — The estimated remaining costs plus the actual costs expended.
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Typically, these values are represented as cumulative cost curves in graphic displays:

Taken together, these values (BCWS, BAC, BCWP, ACWP, and EAC) form the core of an earned
value cost control system.

Cost and Schedule Variances
Once the principal elements of cost control are established, two important variances can be
calculated: cost variance and schedule variance.
Cost variances are calculated by subtracting ACWP from BCWP:

Using this convention, a “favorable” cost variance (that is, a cost underrun) is represented by a
positive value while a negative value represents an “unfavorable” cost variance (a cost overrun).
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We can also use the same set of curves to calculate schedule variances by subtracting BCWS from
BCWP:

As in the case of cost variances, “favorable” schedule variances are represented as positive values
while “unfavorable” variances produce negative values.
As you can see, the budget does not figure in calculating the cost variance while the actual cost
expended does not figure in calculating the schedule variance. The link between the two variances is
BCWP or earned value, which is used as the starting point for both calculations.
Using BCWP in this manner makes it possible to measure schedule variance in terms of cost (for
example, dollars) or hours. This may seem strange, but this value gives a convenient summary of the
budget, actual cost, and project status in numbers that can be compared to each other. Keep in mind,
however, that this approach is not a true alternative to critical path scheduling for measuring the likely
impact of potential delays since the amount budgeted for particular activities may or may not
accurately reflect the importance of those activities to the overall schedule of the project.
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Planning Costs
For planners who want to fully utilize Open Plan as an earned value management system, there are a
number of features for working with cost information.


You can report on high-level summaries of resource costs based on the resource category or the
hierarchy of a resource breakdown structure.



You can choose which resources to consider in cost calculations.



You can define escalated and unescalated rates for resources, resource pools, and skills.

Setting Up Categories
If you wish to roll up resource costs into categories, you need to specify the appropriate category for
the resource. There are four resource categories:


Labor



Material



Other Direct Costs



Subcontract

You can select a resource’s category on the General tab of the Resource Details dialog box:

Select resource category.

Selecting the Progress Based on Activity Progress option instructs Open Plan to calculate the
actual and remaining resource requirements based on the activity progress during progress
calculations. Select the Consider in Cost Calculations option if you want these resource costs to
appear in the cost summaries.
For more information on using the General tab of the Resource Details dialog box, refer to
Chapter 7, “Resource Definitions.”
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Setting up Resource Rates
For each resource, you should enter a base unit cost. If the resource is a Labor resource, the units
are typically hours and the unit cost will be the present value of the direct labor rate. If the resource is
a Material or Other Direct Cost, unit cost is typically 1 and the units are dollars. However, if you
have very large dollar values, you can enter units of 1000 and enter the resource level in thousands
of dollars. Depending on your needs, Subcontract resources may be treated as either labor or
material. As an option, you can also define a set of escalations for the cost.
For more information on setting up resource files and defining resources, refer to Chapter 7,
“Resource Definitions.”

Assigning Resources
To define budgets using resources, you must first define the resources in a resource file and then
attach the resource file to the project. Then you add resource assignments to the activities:

Resource assignment

Material assignment

You can define the assignment as a total to be spread based on a curve. This allows you, for
example, to enter budgets as totals that are front- or back-loaded over the duration of the activity. By
using a total, the budget does not change as the duration changes. Resources can also be assigned
as a rate per day by leaving the curve field blank.
For more information on attaching resource files to projects, refer to Chapter 7, “Resource
Definitions.” For more information on entering resource assignments, refer to Chapter 8,
“Resource Assignments.”

Calculating Costs
Open Plan calculates costs and stores them at the detail level, allowing you to store time-phased
quantity, cost, and escalated cost by resource and activity. All activity costs represent a roll up of
these detailed costs. Because open Plan stores both costs and quantities, the resource rates that are
in effect when the progress is calculated are locked in.
For more information on how detail costs are calculated, refer to Chapter 12, “Cost
Calculations,” in the Deltek Open Plan Developer’s Guide.
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Once you have assigned resources to your activities, you can have Open Plan roll up these costs to
the activity level. To calculate budget costs for activities, click Cost Calculations on the Processes
tab to display the following dialog box:

Using this dialog box, you can indicate the following settings for the calculation of costs:


You can select the cost values to calculate:


Budget Cost



Remaining Cost



Actual Cost,



Earned Value



You can base the Remaining Cost calculations on early, late, or scheduled dates.



You can indicate if Open Plan should use only base unit costs for the calculation or consider cost
escalations as well.



You can include child activity values in subproject costs.



You can run Time Analysis before calculating cost to make sure that dates are current for the
calculation of Remaining Cost.

Group Process Cost Calculations
You can also perform cost calculations in Batch Mode. This allows you to run cost calculations for
multiple projects at one time. To run cost calculations in Batch Mode, select more than one project
from the Details pane of the Open Plan Explorer, and click Cost Calculations. The Cost
Calculations [Batch Mode] dialog box will be displayed. Set your options, and click OK.
If a project is closed, Open Plan will open it in Exclusive mode, perform the process, save the
changes, and then close the project. If a project cannot be opened in Exclusive mode (because
another user has it open in Exclusive or Shared mode), it will be skipped.
If you have a project open when the batch process is run, a cost calculation will be performed on the
project, but the changes will not be saved and the project will remain open. You must manually save
the changes yourself.
Cost calculations for multiple projects can also be run by selecting a group of projects and
clicking Cost Calculations on the Processes tab.
Open Plan creates one cost calculation session log, listing the project results in the order in
which the projects were processed in the batch.
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Budget Cost
By default, Open Plan normally calculates budget values by rolling up the (escalated/unescalated)
cost from a baseline. If a PMB exists, Cost Calculations will use this baseline. If no PMB exists,
Open Plan calculates budgets using the currently selected baseline or the first selected baseline if
multiple baselines are selected.
By always using the same baseline (regardless of which baseline is selected) for calculating
budgets, Open Plan provides consistency and reliability.

If no baseline (PMB or otherwise) exists, Open Plan will calculate budgets from resources directly
assigned to activities as versions prior to 3.x did. You can set this as the default project behavior by
selecting the Use Version 2 Cost Calculation Method option on the Cost tab of the Project
Properties dialog box.
To calculate budget costs for activities, complete the following steps:
1. Open the project for which you want to calculate budget costs.
2. Take one of the following actions:

Cost Calculations
button



On the Processes tab, click Cost Calculations.



Right-click a project and select Cost Calculations from the context menu.

3. In the Calculate Costs dialog box, select Budget Cost.
4. Set the options for the operation, and click OK.

Creating and Using a Baseline
Once your project is well-planned and the schedule and resource loading is the way you want it, you
will want to create a performance measurement baseline (PMB). Creating a PMB ensures that all
future budget and earned value calculations will be based on these values.
For information on creating a PMB, refer to Chapter 16, “Status Information.”
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Progress and Cost
The following sections discuss how to progress an activity by entering the physical percent complete
and resource progress and how it impacts earned value, actual costs, and forecast.

Entering Physical Percent Complete
Open Plan allows you to progress an activity by entering the physical percent complete (PPC) at
either at the activity level or the resource level.
To status an activity, display the Activity Progress dialog box:

On the Activity tab, you can enter an actual start date and select one of the statusing methods.

Activity physical percent
complete

Resource physical percent
complete

On the Resources tab, you can enter the PPC for each resource, or you can have Open Plan
calculate the PPC based on the activity progress. If you enter the PPC at the resource level, Open
Plan calculates the activity PPC for you based on the rolled up earned value of each resource. If you
enter the PPC at the activity level, Open Plan calculates each resource’s PPC with regard to duration,
curve, offsets, and periods.
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You can also have Open Plan calculate physical percent complete for you based on activity progress
using the Progress Calculations dialog box.
For more information on using the Progress Calculations dialog box, refer to Chapter 16, “Status
Information.” For a detailed discussion on how Open Plan calculates PPC at both the resource
level and activity level, refer to Chapter 12, “Cost Calculations,” in the Deltek Open Plan
Developer’s Guide.

The Activity Progress dialog box is resizable. You can resize this by dragging any corner or side of
the dialog box.

Calculating Earned Value
Open Plan calculates earned value by multiplying the physical percent complete by the budget cost.
For more information about calculating earned value, refer to Chapter 12, “Cost Calculations,” in
the Deltek Open Plan Developer’s Guide.

To calculate earned value, complete the following steps:
1. Open the project for which you want to calculate earned value.
2. Take one of the following actions:

Cost Calculations
button



On the Processes tab, click Cost Calculations.



Right-click a project and select Cost Calculations from the context menu.

3. In the Calculate Costs dialog box, select Earned Values (BCWP and BCWS).
4. Click OK.

Capturing Actual Costs
You can capture actual costs in the following ways:


Entering actual costs manually on the Resources tab of the Activity Progress dialog box



Calculating actual costs based on reported progress



Importing actual costs from a third-party system
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Entering Actual Cost
If you plan to enter actual costs manually (or to import actual costs using the Import General utility),
you must clear the Actual Cost Based on Progressed Quantity option on the General tab or the
Resource Details dialog box:

Select or clear option here.

If you select this option, the actual costs for a resource will be calculated and posted to the file when
you run progress calculations. The actual costs posted will be calculated from the actual units
(reported or calculated) multiplied by the resource rate.
To enter actual costs manually, you use the Resources tab of the Activity Progress dialog box:

Since actual costs are spread over a date range, you must enter the start of the period for which you
are entering actual costs; the end date is not required. You can enter both the actual quantity and
actual cost for each resource.
To add a new resource that was unbudgeted, add it to the bottom of the list.
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For information about entering resource progress, refer to Chapter 16, “Status Information.”

Calculating Actual Costs
Open Plan calculates activity actual cost during the cost calculations process by rolling up userentered actual costs or by multiplying the actual quantity by the resource rate for resources set to
automatically calculate costs.
To calculate actual costs for activities, use the Cost Calculations command to display the following
dialog box:

If you indicated that Open Plan should calculate actual costs for resources based on resource
progress, the Cost Calculations command also generates these costs at this time.
When you select Actual Cost or Remaining Cost, the cost calculations roll up the actual or
remaining labor units to the activity and subproject level.
For information about generating actual costs from progress, refer to Chapter 7, “Resource
Definitions,” and Chapter 16, “Status Information.”

To calculate actual costs for activities, complete the following steps:
1. Open the project for which you want to calculate actual costs.
2. Take one of the following actions:

Cost Calculations
button



On the Processes tab, click Cost Calculations.



Right-click a project and select Cost Calculations from the context menu.

3. In the Cost Calculations dialog box, select Actual Cost, and click OK.
You can also perform cost calculations in Batch Mode. This allows you to run cost calculations for
multiple projects at one time. To run cost calculations in Batch Mode, select more than one project
from the Details pane of the Open Plan Explorer, and click Cost Calculations. The Cost Calculations
[Batch Mode] dialog box displays. Set your options, and click OK.
If a project is closed, Open Plan will open it in Exclusive mode, perform the process, save the
changes, and then close the project. If a project cannot be opened in Exclusive mode (because
another user has it open in Exclusive or Shared mode), it will be skipped.
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If you have a project open when the batch process is run, cost calculations will be performed on the
project, but the changes will not be saved and the project will remain open. You must manually save
the changes yourself.
Open Plan creates one cost calculations session log, listing the project results in the order in
which the projects were processed in the batch.

Forecasting
Forecast of remaining cost (ETC) and work is always based on the schedule and can be calculated
from early, late, or schedule dates using the remaining quantity of the resource and either escalated
or un-escalated rates. If the activity has not yet started, the resource assignments on the activity are
the forecast. For activities in progress, the remaining quantity and cost represent the forecast. This
plus the actual costs comprise the estimate at complete. Changing the resource assignments on
activities changes the forecast without changing the budget.

Viewing cost and earned value data
Once you have calculated budget costs for activities, you can display this cost information using the
Cost tab of the Activity Information dialog box:

This tab displays budgeted and actual costs calculated at the activity level for the following by
resource category:


BAC — Budget at Completion



BCWS — Budgeted Cost of Work Scheduled



BCWP — Budgeted Cost of Work Performed (also referred to as Earned Value.)



ACWP — Actual Cost of Work Performed



EAC — Estimate at Complete

Labor Quantity values are also shown.
For more information of the costs displayed in the grid, refer to the beginning of this chapter and
also the Help system for the Activity Information Cost tab. For more information on the Activity
Information dialog box, refer to Chapter 6, “Activity Information.”

Chapter 10 Cost Information
Deltek Open Plan 8.0 User Guide

252

Progress and Cost

Finally, it is possible to display budgeted costs rolled up to the project level. To see these values,
display the Cost tab of the Project Properties dialog box:

For more information of the costs displayed in the grid, refer to the online Help system for the
Project Properties Cost tab. For more information on the Project Properties dialog box, refer to
Chapter 5, “File Properties.”
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To facilitate the reporting of cost information, Open Plan provides a number of standard calculated
fields related to costs at the activity level. These fields are available for display in any view and are
defined as follows.
Field

Description

Calculation

BACcum

Budget at complete

BAC_LAB + BAC_MAT +
BAC_ODC + BAC_SUB

ACWPcum

Actual cost of work performed

ACWP_LAB + ACWP_MAT +
ACWP_ODC + ACWP_SUB

BCWScum

Budgeted cost of work scheduled

BCWS_LAB + BCWS_MAT +
BCWS_ODC + BCWS_SUB

BCWPcum

Budgeted cost of work performed

BCWP_LAB + BCWP_MAT +
BCWP_ODC + BCWP_SUB

ETC

Estimate to complete

ETC_LAB + ETC_MAT +
ETC_ODC + ETC_SUB

EAC

Estimate at complete

ACWPcum + ETC

CV

Cost variance

BCWPcum – ACWPcum

SV

Schedule variance

BCWPcum – BCWScum

VAC

Variance at complete

BACcum – EAC

CPI

Cost performance index

BCWPcum / ACWPcum

SPI

Schedule performance index

BCWPcum / BCWScum

For more information on these calculated fields, refer to Chapter 12, “Cost Calculations,” in the
Deltek Open Plan Developer’s Guide.

In addition to these values, Open Plan calculates the planned baseline progress for each activity
using the following approach:


If no baseline dates have been set for the activity, Open Plan sets the value of planned baseline
progress to –1.



If the baseline finish date is before Time Now, Open Plan sets the value of planned baseline
progress to 100%.



If the baseline start date is after Time Now, Open Plan sets the value of planned baseline
progress to zero.

If none of these cases apply, Open Plan calculates the value by first subtracting the baseline start
from Time Now, dividing the result by the original duration, and then multiplying by 100. For activities
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with an original duration of zero, Open Plan divides the result by the difference between the baseline
start and finish dates.
The calculation of the planned baseline progress takes into account the effect of calendars in all
date calculations.

Chapter 10 Cost Information
Deltek Open Plan 8.0 User Guide

255

11
Project Codes
Overview ...................................................................................................................................... 257
Coding Systems in Open Plan..................................................................................................... 258
Creating Code Files ..................................................................................................................... 260
Using Code Files ......................................................................................................................... 262
The Code Details Dialog Box ...................................................................................................... 265
Entering Codes ............................................................................................................................ 268
Displaying Code Information ....................................................................................................... 271
Entering Code Assignments ........................................................................................................ 275

Overview

Overview
By setting up a coding system and assigning codes to activities, projects, and resources, you can
facilitate the communication of project information in formats ranging from high-level summaries to
activity-level detail. With the appropriate coding system in place, even the largest networks can
provide clear, concise pictures of vital project information. Open Plan allows you to assign up to 90
codes to each activity.
This chapter includes discussions on the following topics related to code files in Open Plan:


Working with code files



Entering codes



Displaying code information



Entering code assignments
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Coding Systems in Open Plan
Coding systems typically describe some type of hierarchy of project information. The types of
hierarchies that can be represented by coding structures can be work breakdown structures,
organizational breakdown structures, or any other classification that can be represented by a
hierarchy. By assigning codes based on breakdown structures to various project elements, you can
summarize project and resource data to appropriate levels for specific reporting requirements.
A particular breakdown structure can be used with more than one project. This might be the case, for
example, if a number of projects were being performed by the same organization and therefore could
share the same organizational breakdown structure. As a result, Open Plan does not force you to
define coding systems that are project- or resource file-specific. Instead, you can define a code file
that is independent of a particular project or resource file and associate it with subsequent projects or
resource files as needed.
Codes in Open Plan can use one of two types of self-defining coding systems — punctuated
significant codes and fixed-form significant codes. The term “self-defining” refers to the ability to
determine where an individual element appears in the hierarchical structure by inspecting the
element’s code.
In punctuated significant coding systems, periods within the code are used to distinguish between
different hierarchical levels in the structure. The following illustration shows a portion of a punctuated
significant coding system that might represent a portion of a work breakdown structure. In this
example, 1.1.1, 1.1.2, and 1.1.3 are children of 1.1, which is a child of 1.
1

1.1

1.2

1.1.1

1.1.2

1.1.3
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Fixed-form significant codes rely on the length of the code to represent the structure level. As a result,
you must define both the number of levels in the coding system and the number of characters
representing each level. In the following illustration, for example, the first character of the code
represents the top level of the structure, the first two characters represent the next level, and the first
three characters represent the lowest level:
1

11

12

111

112

113

In this example, higher-level codes use spaces as “pad characters” that fill out each code in the
system to the same length.

In both punctuated significant and fixed-form significant coding systems, higher-level codes are
referred to as “parent” codes. All lower-level codes that are directly or indirectly connected to a
particular parent may be called descendants or “children” of that code. When a report is produced at
a particular level, all data associated with that code itself or any of its descendants is summarized or
“rolled up” into a single set of data.
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Creating Code Files
When you create a new code file using Open Plan default settings, Open Plan displays the New Code
Structure dialog box:

When you create a new code using the New File Wizard, the Code Structure page of the
wizard contains the same fields as the New Code Structure dialog box.

Use this dialog box to enter the following information about a new code file:


Code Type — Indicates whether the code file uses punctuated significant or fixed format
significant codes.



Fixed Level Length — If you are creating a code file using fixed-form significant codes, you must
define the number of levels in the coding structure and the number of characters representing
each level. The number of characters you assign to each level is cumulative — that is, it must be
greater than the number of characters assigned to the previous level. For example, to use a 7character code that represents three different hierarchical levels, you might enter the following
information:


Level 1: 2



Level 2: 4



Level 3: 7
You can add levels later using the Structure tab of the Properties dialog box for the code file, but
you cannot change existing levels.



Pad Character — If you create a code file using fixed-form significant codes, you can assign a
pad character to be appended as a suffix to codes less than the specified length. Common pad
characters are blanks (the default) and zeros.
If you select Punctuated Significant for the Code Type, the Fixed Level Length fields and
Pad Character field are disabled.
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There are two methods for creating a code file depending on whether you want to use Open Plan
default settings or define all the settings for the code file yourself.
To create a code file using default settings, complete the following steps:
1. Take one of the following actions:

New button



On the File menu, click New.



Press Ctrl+N.



On the Quick Access Toolbar, click New.



Double-click an empty area of the Open Plan Explorer.

2. From the file types list, select Code File or Code.
3. Enter a name and description for the code file, and click Finish
Open Plan displays the New Code Structure dialog box.
4. Enter the information for the code file, and click OK.
Open Plan creates a new code file and allows you to enter information for the first code.
To create a code file using user-defined settings, complete the following steps:
1. Take one of the following actions:


On the File menu, click New.



Press Ctrl+N.



On the Quick Access Toolbar, click New.



Double-click an empty area of the Open Plan Explorer.

2. From the file types list, select Code File or Code.
3. Enter a name and description for the code file, and click Next.
Open Plan displays the first page of the New File Wizard.
4. Complete each page as appropriate, and on the last page click Finish.
Open Plan creates a new code file and allows you to enter information for the first code.
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Using Code Files
Code files in Open Plan can be project- or resource file-specific, or they can be shared by multiple
projects or resource files. It is possible to assign more than one code file to the same project or
resource file.
If you make changes to the information in a code file, the changes will affect all of the projects or
resource files to which the code file is assigned. To make changes in a code file that only affect a
single project or resource file, make sure that the file is not assigned to other projects or resource
files.
In the Open Plan Explorer, code files are located in the Open Plan Library:

Code file folder

You can open code files from within either the Open Plan Library or a specific project or resource
folder. When you assign a code file to a project or resource file, Open Plan asks you to assign the file
to a specific activity code field. If you replace an existing assignment for a code field, Open Plan
prompts you for confirmation.
To open a code file, complete the following step:
1. Take one of the following actions:

Open button



On the File menu, click Open.



Press Ctrl+O.



On the Quick Access Toolbar, click Open.
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Double-click the code view file.



Right-click the code view file, and click Open on the context menu.

2. Select Code or Code File.
To copy a code file, complete the following steps:
1. Open the code file.
2. On the File menu, click Save As.
3. Enter the name for the copy of the file, and click OK.
You cannot perform Save As on a file if there is another file open which refers to it. For
example, if you open project CLEAN and then try to perform a Save As on the code file
CLEANOBS, the Save As command is disabled.

To remove a code file from a project, complete the following steps:
1. Open the appropriate project.
2. Display the Project Properties dialog box using one of the following methods:


Select the project folder and click Properties on the Processes tab.



Right-click the project folder, and click Properties on the context menu.

3. On the Files tab, click the ellipsis button next to the Code Files field.
4. In the right pane of the Assign Code dialog box, select the code to remove, and click
Remove.
Repeat the above step if there is more than one code you want to remove.

5. When finished removing codes, click OK.
6. On the Project Properties dialog box, click OK.
Deleting a code file from a project folder removes any activity code assignments based
on that code file.

To remove a code file from a resource file, complete the following steps:
1. Open the appropriate project.
2. Right-click the resource file folder, and click Properties on the context menu.
3. Open Plan displays the Properties dialog box for the resource file.
4. On the Files tab, click the ellipsis button next to the Code Files field.
5. In the right pane of the Assign Code dialog box, select the code to remove, and click
Remove.
Repeat the above step if there is more than one code you want to remove.
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6. When finished removing codes, click OK.
7. On the Properties dialog box, click OK.
To delete a code file from the database, complete the following steps:
You can only delete a code file from the database if the file is not open, if it is not being used by
another project or resource file, and if you have the appropriate rights to the file.

1. Take one of the following actions:


On the File menu, point to Manage Files, and click Delete File on the submenu.



Right-click the code file folder in the hierarchical pane, point to Manage Files, and click
Delete File on the submenu.

2. On the Select File to Delete dialog box, select the code file, and click OK.
3. When Open Plan asks you to confirm the deletion, click Yes.
To assign a code file to a project, complete the following steps:
1. Take one of the following actions:


Drag the code file from the Open Plan Library to the project folder.



On the Files tab of the Project Properties dialog box, click the ellipsis button to the right
of the Code Files field.

2. In the Assign Code dialog box, indicate the code field to which you want to assign the file.
3. When done, click OK.
To assign a code file to a resource file, complete the following steps:
1. Take one of the following actions:


Drag the code file from the Open Plan Library to the resource folder.



On the Files tab of the resource file’s Properties dialog box, click the ellipsis button to
the right of the Code Files field.

2. In the Assign Code dialog box, indicate the code field to which you want to assign the file.
3. When done, click OK.
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The Code Details Dialog Box
Open Plan automatically displays the Code Details dialog box each time you add or edit a code in a
code file.
You can display the Code Details dialog box for an existing code by double-clicking the code,
selecting the code and clicking Details on the Edit tab, or by right-clicking the code and clicking Edit
on the context menu.
Because you can update multiple codes without having to close the Code Details dialog box each
time, Open Plan automatically saves any changes you make to a code before displaying the next
record. Notice also OK and Cancel found on many dialog boxes have been replaced with the
following buttons:


Close — Closes the dialog box and returns to the code view. If you have not saved the
information currently displayed, Open Plan saves the changes before returning to the display.



Undo — Returns the dialog box to its previous state.



Apply — Saves the changes you have made to the current record.
You must update information for a code before the Undo and Apply buttons become active.

You can also use the New command to create a new code element while the Code Details dialog box
is open. This command functions identically to the Add Code command available from the Edit tab.
The Code Details dialog box contains three tabs: Code, User Fields, and Notes.

The Code Tab
When you click the Code tab on the Code Details dialog box, the following is displayed:

This tab allows you to enter the following information:


Code — An alphanumeric identifier unique to the code. At each hierarchical level, this identifier
can consist of a maximum of 10 characters. However, the total length of the code, including
periods, cannot exceed 59 characters.



Desc — An extended description of up to 60 characters can be stored for each code.
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The User Fields Tab
When you click the User Fields tab on the Code Details dialog box, the following is displayed:

This tab allows you to specify the values that Open Plan should include for user-defined fields on the
code, using the following fields:


Field — This column displays a list of all the user-defined fields that have been defined.



Value — For each user-defined field that you want to use, you should enter an appropriate value.
User-defined fields are created outside of an open code and may be used by any code file
stored in the database. In order to use a user-defined field for your code, you must specify a
value for it on this tab.

The Notes Tab
When you click the Notes tab on the Code Details dialog box, the following is displayed:

You can use the following fields to attach a note to a code:


Note — This text box can contain up to 29 KB of text. You can enter the text by typing directly in
this field or by using the Windows Cut (Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) commands to
insert text from another Windows application such as a word processor or spreadsheet.
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Category — This field controls the category of the note. You can select a category from the list of
global categories.
Clicking abc checks the spelling of the text you enter.
You can enter links to files, Web pages, and e-mail addresses by entering the information in one
of the following formats:


File links must be entered in the format of: file://c:\document.doc
If the file link you enter contains spaces, you must enclose the link with angle brackets ( < > ) in
order for the link to work properly: <file://C:\Documents and Settings\All
Users\Desktop\test.txt>



Universal Resource Locators (URLs) must be entered in the format of: http://deltek.com



E-mail addresses must be entered in the format of: mailto:sales@deltek.com
While you can use drag and drop functionality to create links in the Note field, the Windows Cut
(Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) commands are not available for links.
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When you create a new code file, Open Plan displays a window containing an empty workspace. To
add a code to the file, click Add Code on the Edit tab or simply double-click an empty area in the
workspace.
Although you can define a code file as a “flat” structure in which all codes occupy the top hierarchical
level, a more common practice is to develop a tree-like breakdown structure that can be used to
summarize groups of related codes for reporting purposes:

Open Plan makes it easy to work with code hierarchies. For example, you can assign an entire group
of codes to a different parent simply by dragging the codes to a different position in the code
hierarchy. You also have the ability to expand and collapse individual codes in order to display the
appropriate level of detail.
To add a code, complete the following steps:
1. From the code display, take one of the following actions:


On the Edit tab, click Add Code.



Double-click an empty area of the workspace.



Right-click an empty area of the workspace, and click Add Code on the context menu.

2. Enter the information for the code in the Code dialog box.
You can rearrange the order in which Open Plan displays codes from left to right on the
same hierarchical level by dragging a code to the desired location.

To add a child, complete the following steps:
1. Take one of the following actions:


Right-click the code to which you want to add a child, and click Add Child on the context
menu.



Double-click the code while holding down the Shift key.
If you add a child to a normal code, Open Plan automatically converts the code to a
parent.
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2. Enter the information for the code.
3. When the information is complete, click Close.
To edit a code, complete the following steps:
1. Take one of the following actions:


Double-click the code.



Select the code you want to update, and click Edit Code on the Edit tab.



Right-click the code, and click Edit on the context menu.

2. Enter the information for the code.
3. When the information is complete, click Close.
To find a code, complete the following steps:
1. Take one of the following actions:


On the Edit tab, click Find And Replace



Right-click an empty area of the workspace, and click Find on the context menu.

.

2. Enter the ID of the code you want to find, and click OK.
To delete a code, complete the following steps:
1. Select the code you want to delete.
2. Take one of the following actions:


On the Edit tab, click Delete Code



Right-click the code and click Delete on the context menu.



Press the Delete key.

.

If you are deleting a parent code, Open Plan warns you that the child codes will be
deleted along with the parent.

3. When Open Plan asks you to confirm the delete, click OK.
If you delete a code that has been assigned to an activity in a project, that assignment
is deleted as well.

To move a code in the hierarchy, complete any of the following steps:


Drag the code to the desired position in the code hierarchy.



To move the code to the top level of the hierarchy, drag the code to the top of the workspace.



If you move a parent, all child codes of the parent are moved as well.
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When you move a code (or group of codes) to a different position in the code hierarchy,
Open Plan automatically renumbers the code IDs of the moved codes. If this
renumbering potentially duplicates existing code IDs, Open Plan allows you to
renumber the codes yourself. In addition, Open Plan also updates the assignments for
renumbered codes in any projects that are open at the time of the move. (Assignments
in closed projects are not affected.)

To collapse a parent code, complete the following steps:
1. Select the code you want to collapse.
2. Take one of the following actions:

Collapse button



On the View tab, click Collapse.



Right-click the code, and click Collapse on the context menu.



On the toolbar, click Collapse.

To collapse all parent codes, complete the following step:
1. Take one of the following actions:
Collapse All button



On the View tab, click Collapse All.



On the toolbar, click Collapse All.

To expand a parent code, complete the following steps:
1. Select the code you want to expand.
2. Take one of the following actions:

Expand button



On the View tab, click Expand.



On the View tab, clear Collapse.



Right-click the code, and clear Collapse on the context menu.



On the toolbar, click Expand.

To expand all parent codes, complete the following step:
1. Take one of the following actions:

Expand All button



On the View tab, click Expand All.



On the toolbar, click Expand All.
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Displaying Code Information
Open Plan provides a number of features related to the display of code information:


Display options



Box layout definition



The Zoom Out and Zoom In commands

Each of these features is described in the following sections.

Defining Display Options
To define the display options for code information, use the Options tab of the Code Display
Preferences dialog box:

You can use this dialog box to specify the following options for displaying code information:


Box Color — The color used to draw the code boxes.



Box Style — The style used to display the code boxes. Open Plan allows you to choose a style
from a list displayed when you enter the field.



Box Contents You can display the entire code ID or just the local portion of each ID.



Minimum Height— You can set the minimum height for the boxes.



Minimum Width — You can set the minimum width for the boxes.



Spread/Ladder — You can display the lowest level of the coding hierarchy in a “ladder” format to
conserve horizontal space.



Compressed/Uncompressed — You can display the coding hierarchy in a compressed mode in
which individual codes belonging to one parent can be displayed beneath another parent.



Sideways — You can display the coding hierarchy in a horizontal orientation.
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Centered — You can display the coding hierarchy centered in the workspace or left-justified. (If
you are displaying the hierarchy using the Sideways option, turning off the Centered option
results in the codes being aligned along the top of the workspace.)

To define code display options, complete the following steps:
1. Take one of the following actions:


On the View tab, click Preferences.



Right-click an empty area of the workspace, and click Preferences on the context menu.

2. On the Options tab of the Code Display Preferences dialog box, enter the information for the
display options.
3. When the information is complete, click OK to return to the display.

Customizing Box Layout
You can define which code fields are displayed when you view a code hierarchy. Boxes can contain
as many as 50 different data items. You can also display blank lines in a box.
To customize the layout of code boxes, click the Box Layout tab on the Code Display Preferences
dialog box:
Enter the data field, line
number, and format for
each item.

Change the order of the
items.

Y
The preview area of the dialog box displays the current definition of the code boxes.
Note that this representation may differ slightly in size and aspect ratio from the actual display of
boxes in the view.

Notice that Open Plan displays data items in the dialog box in order of line number. When you add,
delete, or change data items, you must exit and return to the dialog box to display the items in the
correct line sequence.
Open Plan displays items sharing the same line from left to right based on the order in which the
items appear in the list. To move an item to a different position in the list, use the Change Order
buttons.
You can customize the layout of the code box with the following settings:
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Field — You can select any code field for display.



Line — For each field appearing in the code box, you must assign a line number. Code boxes
can contain up to 20 lines, and each line can display one or more fields. If you assign multiple
fields to a single line, the order in which the fields are listed in the dialog box determines how
Open Plan displays the fields in the box. To display a blank line in the code box, do not enter
settings for those lines. For example, to display code boxes with a double-high blank line, use the
following settings:
Field

Line

Format

Code

1

1 Line

Code Description

4

1 Line

This results in the following code box:





Format — This setting has the following options to control the display of the data in the box:


1 Line



Wrap Over 2 lines



Wrap Over 3 lines



Wrap Over 4 lines

Suppress Box Lines — Selecting this option hides the display of lines within the code boxes.

To customize the code box layout, complete the following steps:
1. Take one of the following actions:


On the View tab, click Preferences.



Right-click an empty area within the workspace, and click Preferences on the context
menu.

2. On the Code Display Preferences dialog box, click the Box Layout tab.
3. Enter the information for each data item.
To change the order of the items, select any cell in a row, and click one of the Change Order
buttons.
To delete an item from the list, select any cell in the row, and press the Delete key.
4. When your changes are complete, click OK to return to the view.

Using the Zoom Out and Zoom In Commands
Open Plan provides a Zoom Out and Zoom In command for showing code structures that cannot be
displayed on a single screen.
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If you select Zoom Out from the normal display mode, Open Plan applies a reduced display mode to
the window where the code boxes are reduced so that all the codes in the structure are visible:

In this mode you can continue to work with the codes as though you were in the normal display mode.
If the entire code structure can be displayed at once, the Zoom Out command is not available.

In order to return to the normal display mode, Open Plan provides a Zoom In command. When the
display mode has been reduced, the Zoom In command becomes enabled.
To zoom out from the normal display mode, complete the following step:
1. Take one of the following actions:
Zoom Out button



On the View tab, click Zoom Out.



Right-click an empty area of the window, and click Zoom Out on the context menu.



On the toolbar, click Zoom Out.

To zoom in from a reduced display mode, complete the following step:
1. Take one of the following actions:
Zoom In button



On the View tab, click Zoom In.



Right-click an empty area of the window, and click Zoom In on the context menu.



On the toolbar, click Zoom In.
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Entering Code Assignments
Depending on the number of code files you have assigned to the project or resource file, Open Plan
allows you to enter one or more code assignments for the project, activities, or resources.

Project Code Assignments
To enter code assignments for a project, display the Project Properties dialog box for the project, and
click the Codes tab:

Clicking the ellipsis to the right of the edit field displays the Assign Code dialog box that you can use
to quickly select the appropriate code to assign.
To enter a code assignment using the Project Properties dialog box, complete the following
steps:
1. Display the Project Properties dialog box by taking one of the following actions:


Select the project folder, and click Properties on the Processes tab.



Right-click the project folder, and click Properties on the context menu.

2. Click the Codes tab.
3. Enter the information for the code assignment, and click OK.
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Activity Code Assignments
To enter code assignments for an activity, display the Activity Details dialog box for the selected
activity, and click the Codes tab:

Clicking the ellipsis to the right of the edit field displays the Select Code dialog box that you can use
to quickly select the appropriate code to assign.
To enter a code assignment using the Activity Details dialog box, complete the following
steps:
1. In an activity view, display the Activity Details dialog box using for the activity to which you
want to enter an assignment.
2. Click the Codes tab.
3. Enter the information for the code assignment, and click OK.
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Resource Code Assignments
To enter code assignments for a resource, display the Resource Details dialog box for the selected
resource, and click the Code tab:

Clicking the ellipsis to the right of the edit field displays the Select Code dialog box that you can use
to quickly select the appropriate code to assign.
To enter a code assignment using the Resource Details dialog box, complete the following
steps:
1. In the resource view, display the Resource Details dialog box for the resource to which you
want to enter an assignment.
2. Click the Code tab.
3. Enter the information for the code assignment, and click OK.
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Using an Activity Spreadsheet View
It is also possible to enter information about code assignments using an activity spreadsheet view. In
this type of view, code assignment information is displayed in a tabular format:

You can use an activity spreadsheet view to add or update any information about code assignments.
For information about adding or modifying columns in a spreadsheet view, refer to Chapter 20,
“Spreadsheet Views.”
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Overview

Overview
The multi-project capabilities of Open Plan allow planners to create hierarchies of project information.
With project hierarchies, you can break large projects down into multiple subprojects, which can serve
as high-level cost and schedule summarizations for lower-level detail. Organizations can also use
these features to roll up smaller projects into a single master project in order to perform scheduling
and resource planning functions at a more comprehensive level.
This chapter contains a number of discussions related to project hierarchies in Open Plan, including
setting up a project hierarchy and working with hierarchical projects in different views.
The chapter concludes with a discussion of reporting hammocks, a traditional feature for rolling up
project information.
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Setting Up Project Hierarchies
To define a hierarchy of project information, Open Plan allows you to designate any activity as a
“parent” of lower-level “child” activities. Children of a parent activity can, in turn, have child activities of
their own. Thus, there are no limits on the number of hierarchical levels you can define in a project.
Nor is there a requirement that a single top-level activity exist for each project.
When defining hierarchies of project information, Open Plan allow you to set up internal subprojects,
which represent child activities belonging to the same project as the parent. Users can also set up
external subprojects, which represent activities belonging to a different project. Both internal and
external subprojects, however, function in the same way, and the same master project can contain
both types of subprojects.
Periods in the activity ID indicate the hierarchical relationships between activities. For example, the
subproject SUB1 might have child activities named SUB1.01, SUB1.02, and so on. Children of
SUB1.01 might be named SUB1.01.01, SUB1.01.02, and so on. Depending on the context, you may
have to identify an activity by using its complete ID, or you may need to enter only the local portion of
the code.
Activities that you designate as subprojects are identical to standard activities with the following
exceptions:


The duration of a subproject is dependent on its child activities. You cannot enter a duration for
an activity that has been converted to a subproject.



Resource requirements assigned to the subproject level do not result in delaying the subproject
during resource scheduling.



Once you have designated an activity as a subproject, you cannot change the activity type unless
you remove all the child activities belonging to that subproject.



When you copy a subproject, you copy all child activities belonging to that subproject as well.



When you delete a subproject, you delete all child activities belonging to that subproject as well.

Like standard activities, you can assign target start and finish dates to subproject activities. It is also
possible to define relationships between subprojects or between a subproject and an activity within
another subproject.
The assignment of target dates and relationships to subprojects can have important implications
when time-analyzing a network.
For more information, refer to Chapter 8, “Time Analysis Calculations,” in the Deltek Open Plan
Developer’s Guide.
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Defining Internal Subprojects
To convert an existing activity to an internal subproject, change the Type setting to Subproject on
the General tab of the Activity Details dialog box:
Duration field disabled for
subproject.

Change Type to Subproject

Notice that you cannot enter the duration of an activity that has been converted to a subproject.

To convert an activity to an internal subproject, complete the following steps:
1. Display the Activity Details dialog box for the activity to be converted, and click the General
tab.
2. From the Type list, select Subproject.
3. Click Close.

Defining External Subprojects
You can designate activities as external subprojects. To convert an activity to an external subproject,
you must change the Type setting to External Subproject and indicate the project file for the SubProject setting:
Change Type to External
Subproject.

Click to select the project to be
used as the external
subproject.
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After clicking Apply, you can then click the ellipsis to the right of the Sub-Project field. Open Plan
responds by displaying the following dialog box:

You can use this dialog box to select the name of the project to become the external subproject.
Open Plan automatically saves any external subprojects as internal subprojects when you use the
Save As command to save project information. This automatic conversion also occurs the first time
you save a new project. As a result, to set up a project hierarchy that includes external subprojects,
you must first create and save the master project before converting any activities into external
subprojects.
For information on creating a multiproject project using the New File Wizard, refer to Chapter 4,
“Creating a New File.”

To convert an activity to an external subproject, complete the following steps:
1. Display the Activity Details dialog box for the activity to be converted, and click the General
tab.
2. From the Type list, select External Subproject.
3. Click the ellipsis to the right of the Sub-Project field.
4. From the Select dialog box, select the name of the project to be used as the external
subproject, and click OK to return to the General tab.
5. When the information for the activity is complete, click OK.
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Subprojects in Network Views
Network views include the following features related to hierarchical projects:


Displaying project hierarchies



Adding child activities



Cutting and pasting activities in different subprojects.

The following sections discuss each of these features in turn.

Displaying Project Hierarchies
Open Plan provides two sets of commands for displaying different hierarchical levels of a project that
includes internal or external subprojects and navigating between them:


The Expand, Expand All, Collapse Subproject, and Collapse All commands allow you to
expand and collapse the display of multiple hierarchical levels of a project within a single view.



The Go To Subproject, Go To Parent, and Go To Top Level commands allow you to move
through the different hierarchical levels by either “drilling down” into a subproject or moving up to
the parent or top level.

These commands are available for use with both internal and external subprojects.
When you expand a subproject in a network view, Open Plan can display the child activities in a
frame that includes the subproject ID:

Expanded subproject

Once you expand a subproject, you can edit the displayed activities and relationships. You can also
create relationships between activities both within the same subproject and in different subprojects.
You cannot, however, add new activities or relationships to the expanded subproject. Instead, you
must drill down to the appropriate level using the Go To Subproject command to add new activities
and relationships.
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For an example of how to display multiple hierarchical levels using the Expand and Go To
Subproject commands, refer to Chapter 19, “Network Views.”

To drill down into a subproject, complete the following steps:
1. Select the parent of the subproject you want to drill down to.
2. Take one of the following actions:
Go To Subproject
button



On the View tab, click Go To Subproject.



Right-click the activity, and click Go to Subproject on the context menu.

To go to the parent activity of the current level, complete the following step:
Go To Parent
button

1. Take one of the following actions:


On the View tab, click Go To Parent.



Right-click an empty area of the view, and click Go to Parent on the context menu.

To go to the top level of the project, complete the following step:
1. Take one of the following actions:
Go To Top



On the View tab, click Go To Top.



Right-click an empty area of the view, and click Go To Top Level on the context menu.

To expand a subproject, complete the following steps:
1. Select the subproject you want to expand.
2. Take one of the following actions:
Expand button



On the Edit tab, click Expand.



Right-click the activity, and click Expand on the context menu.

To expand all subprojects, complete the following step:
Expand All button

1. On the Edit tab, click Expand All.
To collapse a subproject, complete the following step:
1. Take one of the following actions:

Expand All button



On the Edit tab, click Expand All.



Right-click the subproject area, and click Collapse on the context menu.

To collapse all subprojects, complete the following step:
1. Take one of the following actions:
Collapse All button



On the Edit tab, click Collapse All.



Right-click the top level activity, and click Collapse on the context menu.
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Adding Child Activities
In a network view, use the Add Child command to add child activities to a parent. If you use this
command for a standard activity, Open Plan automatically converts the activity type to Subproject
before allowing you to add a child. This means that Open Plan will ignore any durations for the parent
activity for subsequent time analysis.
When adding a child to a parent, you enter only the local portion of the activity ID. Once you have
completed entering information about the child activity, Open Plan goes to the appropriate subproject
level so that you can continue entering children at that level. To return to the parent activity after
entering a child, you must use the Go To Parent command.
For an external subproject, the Add Child command is available only if the external subproject
is open.

To add a child activity, complete the following steps:
1. Take one of the following actions:

Add Activity button



Select the parent activity, and click Add Activity on the Edit tab.



Right-click the activity, and click Add Child on the context menu.

2. Enter the information for the child activity.
Note that Open Plan allows you to enter only the local portion of the activity ID.

3. To return to the parent activity, take one of the following actions:


On the View tab, click Go To Parent.



Right-click an empty area of the view, and click Go To Parent on the context menu.

Moving Activities Between Subprojects
To move activities from one subproject to another, use the Cut and Paste commands. You can also
use the Copy and Paste commands to place copies of activities into different subprojects. When you
move or copy activities between subprojects, Open Plan automatically adds the appropriate prefix to
the local portion of the activity ID to indicate the new parent. If Open Plan detects the presence of
existing activities with potentially duplicate IDs, the local portion of the new activity IDs are
renumbered as well.
You can also move an activity to a different subproject by changing the parent portion of the
activity ID. When you move an activity using this technique, Open Plan retains all the
relationships for the activity.

To move activities to a subproject, complete the following steps:
1. Select the activity or activities you want to move.
2. Take one of the following actions:
Cut button



On the Edit tab, click Cut.



Right-click the activity, and click Cut Activities on the
context menu.
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3. Go to the appropriate subproject in the project.
4. Take one of the following actions:

Paste button



On the Edit tab, click Paste.



Right-click an empty area of the view, and click Paste on the context menu.

The cursor shape changes to a paste tool.
5. Click the position where you want to paste the activities.
Paste cursor

Open Plan automatically renumbers the moved activities, including the local portion of the ID
if necessary, to avoid duplicating existing activity IDs.
To copy activities to a subproject, complete the following steps:
1. Select the activity or activities you want to copy.
2. Take one of the following actions:

Copy button



On the Edit tab, click Copy.



Right-click the activity, and click Copy Activities on the context menu.

3. Go to the appropriate subproject in the project.
4. Take one of the following actions:
Paste button



On the Edit tab, click Paste.



Right-click an empty area of the view, and click Paste on the context menu.

The cursor shape changes to a paste tool.
5. Click the position where you want to paste the activities.
Paste cursor

Open Plan automatically renumbers the copied activities, including the local portion of the ID
if necessary, to avoid duplicating existing activity IDs.
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Subprojects in Spreadsheet Views
In a spreadsheet view (or in the spreadsheet pane of a barchart view), you can convert an activity into
an internal subproject simply by adding an activity with an ID that indicates that it is a child of the
subproject. For example, if the project contains an activity ACT01, adding the activity ACT01.1 to the
project automatically converts ACT01 into an internal subproject.
To control the display of subprojects and their children, you can use the outlining feature of
spreadsheet views to display project information hierarchically:

Click to expand or collapse
the subproject.

In a spreadsheet view using outlining, subprojects are displayed with a plus (+) sign or a minus (-)
sign on the outlining button to the left of the row. If the outlining button displays a plus sign, you can
expand the subproject to see more detailed information. If the outlining button displays a minus sign,
the subproject is already completely expanded — clicking the outlining button collapses the
subproject in this case.
For information about turning outlining on or off in a spreadsheet view, refer to Chapter 20,
“Spreadsheet Views.”

To add a child activity, complete the following step:
1. Create an activity with an ID that indicates the desired parent/child relationship.
For example, to add a child to activity ACT01, create activities ACT01.01, ACT01.02, and so
on.
When you add a child in a spreadsheet view, Open Plan automatically converts the parent
activity into an internal subproject.

To expand a collapsed subproject, complete the following step:
1. Take one of the following actions:
Expand button



Click the outlining button next to the row.



Select the subproject, and click Expand on the Edit tab.

To collapse an expanded subproject, complete the following step:
1. Take one of the following actions:
Collapse button



Click the outlining button next to the row.



Select the subproject, and click Collapse on the Edit tab.
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To expand all subprojects, complete the following step:
Expand All button

1. On the Edit tab, click Expand All.
To collapse all subprojects

Collapse All button

1. On the Edit tab, click Collapse All.

Indent
The indent feature allows you to quickly renumber hierarchical IDs while in a spreadsheet view. When
you use this feature, Open Plan renumbers the relevant ID according to the rules for automatic
numbering.
For more information on automatic numbering in spreadsheets, refer to Chapter 20,
“Spreadsheet Views.”

By indenting an ID, Open Plan makes it into a child of the previous activity in the hierarchy and
changes that previous activity into a subproject if it is not already one. For example, assume you have
a project with the following hierarchy:
10
20
30
40
50
Indenting ID 20 instructs Open Plan to make it a child of ID 10 and to make ID 10 a subproject.
Therefore, the following hierarchy results:
10
10.20
30
40
50
Indenting is not available when subsectioning is in effect or in multi-table views.
Indenting may cause loops in the network logic. You can detect these loops by running time
analysis and examining the log generated.

To indent a hierarchical ID, complete the following steps:
1. Display a spreadsheet containing the ID you want to indent. For example, you might display
one of the following views:


Activity spreadsheet



Resource assignment spreadsheet



Code assignment spreadsheet

2. Select the ID that you want to indent.
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3. On the Edit tab, click Indent.
Indent button

Outdent
The outdent feature allows you to promote an ID in a hierarchy to the level of its parent. In assigning
an ID to an outdented element, Open Plan follows the rules for automatic numbering.
For more information on automatic numbering in spreadsheets, refer to Chapter 20,
“Spreadsheet Views.”

For example, assume you have a project with the following hierarchy:
10
10.1
30
40
50
If ID 10.1 were to be outdented, the system would assign it ID 11. Notice that although the remaining
IDs in the hierarchy are numbered in increments of 10, Open Plan assigns the outdented activity the
first available ID number.
Outdent is not available when subsectioning is in effect or in multi-table views.

To outdent an activity, resource, or code ID, complete the following steps:
1. Display a spreadsheet containing the ID you want to outdent. For example, you might display
one of the following tables in the spreadsheet:


Activity



Resource assignment



Code assignment
For more information on changing the table in a spreadsheet, refer to Chapter 20,
“Spreadsheet Views.”

2. Select the ID that you want to outdent.
Outdent button

3. On the Edit tab, click Outdent.
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Working with External Subprojects
If you are using hierarchical projects that include external subprojects, you may want to consider
issues related to the following:


Opening external subprojects



Ancillary data (resource, calendar, and code) files



Converting external subprojects to internal subprojects



Displaying foreign activities

Opening External Subprojects
Each time you open a project containing external subprojects, Open Plan displays a hierarchical list
of external subprojects (and externals embedded within the top layer of externals). In the Open
External Subprojects dialog box displayed below, all projects are available and selected to be
opened. If you want to open only certain subprojects, deselect the project(s) you do not want to open.
You may also use Select All or Deselect All on the right.
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All externals opened under a master project must be opened in the same mode (exclusive, shared,
read-only) as the master project. If the current user has opened one of the externals independently of
the master project, the list will show a red “X” before the name of the external, indicating that it cannot
be opened as part of the master. If another user has opened one or more of the externals in a mode
that will prevent the current user from opening the external in the same mode as the master, the list
will show a warning sign before the name of the external, indicating that it should be deselected
unless the other user corrects the conflict before the current user continues. The graphic below
displays a project that has been opened in exclusive mode. Placing your cursor over one of the
“flagged” external subprojects that is open displays the User ID, Machine ID, Open Mode, Opened
On, and User Name (Phone) of the person who opened the project.

In addition, each column in the Open External Subprojects dialog box (Name, Owner ID, and
Description) can be sorted in ascending or descending order by clicking the appropriate column
heading.
Even if you did not open an external subproject at the time you opened the master project, Open Plan
allows you to open the appropriate subproject later by using Expand or Expand All in the
spreadsheet, barchart, or network views or by using Go To Subproject in the network view.
When opening an external subproject, Open Plan attempts to use the same access mode as used to
open the master project.
For information about multi-user access to project information, refer to Chapter 24, “System
Utilities.”

If an external subproject is open, you can display and update the information for the activities in the
external subproject just as if they belonged to the master project. For example, if you perform time
analysis on the master project, Open Plan updates the early and late dates of the external subproject
activities as well.
For closed external subprojects, however, Open Plan has access only to the summarized information
stored on the subproject record. If you perform time analysis on a master project that includes a
closed external subproject, for example, the early and late dates of a subproject can influence the
dates calculated for the master project. On the other hand, the operation does not result in the dates
for the individual activities in the closed subproject being recalculated.
For a description of the effect of external subprojects on time analysis calculations, refer to
Chapter 8, “Time Analysis Calculations,” in the Deltek Open Plan Developer’s Guide.
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External Projects and Ancillary Data Files
When you open a hierarchical project that contains external subprojects, the program checks that the
master project has the same ancillary data files attached to the various external subprojects. For
example, the master project must have the same code slots populated as those in the external
subprojects, but the code slots can be different as long as the projects have the same structure (for
example, fixed format).

Converting External Projects
You can convert an external subproject into an internal subproject by using the Save As command to
save the master project. This feature allows you to build large projects quickly out of existing
subprojects and applies to all external subprojects that are open at the time you invoke the command.

Displaying Foreign Activities
Because Open Plan allows you to define relationships between activities in different subprojects as
well as relationships that cross hierarchical levels, it is possible for a relationship between an activity
(or subproject) in the master project and an activity in an external subproject to exist.
To represent such a relationship when opening an external subproject outside of the context of a
master project (or when opening an external subproject that has a relationship to an activity in
another subproject), Open Plan displays a dimmed “foreign activity” in the network view. Open Plan
displays the top-level foreign subproject only, any external subproject beneath the master is shown as
a foreign activity.
Foreign project

Foreign activity

You cannot update the information for a foreign activity or any of its parents. You can delete foreign
activities appearing in a subproject, but this does not delete the relationship stored in the master
project.
For a description of the effect of foreign activities on time analysis calculations, refer to Chapter
8, “Time Analysis Calculations,” in the Deltek Open Plan Developer’s Guide.
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Reporting Hammocks
A hammock is an activity that does not influence the time analysis of a project but provides a means
for reporting on the start and finish of a group of related activities. Open Plan calculates the duration
of a hammock based on the early start date of the earliest activity serving as the hammock start and
the early finish date of the latest activity serving as the hammock finish, as in this example:

To set up a hammock in Open Plan, you must first create an activity and define it as a hammock.
Once you have created the hammock activity, you must define at least one relationship between the
start of the hammock and the activity (or activities) that represent the beginning of the hammock. You
can then define relationships between the finish of the hammock and the activity (or activities) that
represent the end of the hammock.
Like subprojects, the durations of hammock activities are calculated each time the network is timeanalyzed. In addition, resource requirements assigned to hammocks have no effect on resource
scheduling calculations other than restricting resource availabilities for other activities.
Open Plan allows multiple starts and finishes to a hammock, and some or all of these can themselves
be hammock activities. You cannot, however, define a hammock as a predecessor to a nonhammock. This restriction means that hammocks can never have any impact on the schedules of
non-hammock activities.
Although hammocks in Open Plan have many flexible features (you can, for example, include
hammocks within other hammocks), their use is limited by the fact that it may be difficult to determine
exactly which activities are included in a given hammock. They are also limited by the fact that they
do not summarize costs or resources.

Chapter 12 Hierarchical Projects
Deltek Open Plan 8.0 User Guide

294

13
Time Analysis
Overview ...................................................................................................................................... 296
What is Time Analysis? ............................................................................................................... 297
Time Analysis Operations ............................................................................................................ 300

Overview

Overview
The ability to schedule a network that contains thousands (or tens of thousands) of activities is the
hallmark of all high-end project management systems. The time analysis calculations performed by
Open Plan are specifically designed to schedule large networks with speed, accuracy, and efficiency.
A number of processing options allow you to modify the results of the standard calculations in order to
model specific situations.
This chapter begins with a brief introduction to time analysis features followed by a description of how
to perform time analysis in Open Plan.
For a complete discussion of the calculations performed by time analysis, refer to Chapter 8,
“Time Analysis Calculations,” in the Deltek Open Plan Developer’s Guide.
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What is Time Analysis?
Time analysis is the process of determining the overall schedule of a project by calculating start and
finish dates for each activity in the project. Time analysis calculations are based solely on the Time
Now date, the duration of the activities, and the logical relationships between them. Unlike resource
scheduling, therefore, time analysis does not take into consideration the availability or non-availability
of resources required by activities.
When you perform time analysis in Open Plan, the following data is calculated:


Early and late dates



Float



Activity information



Subproject information



Project information

Each of these types of data is discussed in the following sections.

Early and Late Dates
Time analysis calculates four dates for each activity in a project: early start, early finish, late start, and
late finish.


Early Start — The earliest date on which an activity can start



Early Finish — The earliest date on which an activity can finish



Late Start — The latest date on which an activity must start if the project completion date and
target dates are to be met



Late Finish — The latest date on which an activity must be completed if the project completion
date and any finish target dates are to be met

Open Plan calculates the early start and early finish dates in what is known as the forward pass
through the project data. During the forward pass, Open Plan starts at the Time Now date and moves
forward through the project in the order determined by the relationships between the activities. As it
moves through the project, Open Plan adds the durations of the individual activities as well as any
lags on the relationship between them.
Open Plan calculates the late start and late finish dates in what is known as the backward pass.
During the backward pass, Open Plan starts at the project finish date and considers the relationships
between activities to move through the project in reverse order. As it moves through the project in
reverse, Open Plan subtracts the durations of the individual activities and considers any lags between
them.

Float Calculations
In general, float is the number of time periods by which an activity can be delayed without affecting
other activities in a project. Open Plan calculates two principal float values during time analysis: total
float and free float.


Total float — Total float is the difference between the early and late start dates measured in
working periods of the activity calendar. Total float can be either positive or negative. For
example, assume a 7-day work week. If an activity has an early start date of July 1 and a late
start date of July 10, that activity would have a total float of 9 days. On the other hand, if the
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activity has an early start date of July 10 and a late start date of July 1, the activity would have a
total float of –9 days. If the target date is not set, no floats will be negative. If all activities in a
project use the same calendar and if target dates have not been set, there is always at least one
path through the project with exactly zero total float. This is known as the critical path.
There can be more than one critical path.



Free float — Free float is the maximum amount by which an activity can be delayed beyond its
early dates without delaying any successor activity beyond its early dates. If target finish dates
have not been set, free float is always less than or equal to total float. Free float can never be
negative.

Time analysis also calculates two float values related to relationships (relationship total float and
relationship free float) and two float values that have special relevance to discontinuous activities and
subprojects (finish total float and finish free float).
For information about these calculations, refer to Chapter 8, “Time Analysis Calculations,” in the
Deltek Open Plan Developer’s Guide.

Supplemental Activity Information
In addition to early dates, late dates, and float, the time analysis function in Open Plan provides the
following information about each activity in the project:


The computed remaining duration of the activity



The computed status of the activity as follows:









Planned



In-progress



Complete

A flag for the following activity types:


Start activity — an activity without predecessors



Finish activity — an activity without successors



Start/finish activity — a discontinuous activity that has successors only from its start and
predecessors only from its finish

One of the following indicators of activity criticality:


Not critical



Critical — total float less than or equal to zero



Most critical — total float equal to the smallest value for the entire project



Controlling critical — has float due to its own calendar but causes a successor to be critical

Out of Sequence (OUTOFSEQ) — a flag to indicate if the activity has been progressed out of
sequence

Subproject Information
Open Plan calculates the following information for each subproject (both internal and external) during
time analysis:
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The duration of the subproject



Early and late dates



The remaining duration for the subproject if it’s activities are in progress

Project Information
Each time you perform a time analysis, Open Plan calculates the following information for the project:


The computed status of the project as follows:


Planned



In-progress



Complete



The latest early finish date in the project



The latest late finish date in the project



Percentage of the total project duration that is complete



The minimum value for total float for any activity (or activities) in the project



The number of in-progress activities



The number of completed activities
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Time Analysis Operations
Although you can perform time analysis at any time, typically you would do so when you have:


Entered all the activities for a project



Changed the logic of the project, for example:


You have added or deleted one or more activities and their relationships.



You have changed the target dates or durations of one or more activities.



You have changed the relationship between any two activities.



Changed the calendars used by the project



Changed Time Now



Entered progress information for any activities in the project



Changed the target start or finish date for the project

Open Plan provides three ways to perform time analysis on a project:

Time Analysis
button



The Time Analysis dialog box



The Perform Time Analysis button on Processes tab



Automatic time analysis

Each time you perform time analysis using either the Time Analysis dialog box or the Time Analysis
button, Open Plan creates a session log file that records any system or error messages issued during
the operation. Open Plan saves the file (Opp_ta.log) and allows you to examine its contents at the
conclusion of each session.
Included in each session log is a list of all start and finish activities in a project.
Open Plan does not produce a session log file if you have enabled the automatic time analysis
mode.

Using the Time Analysis Dialog Box
When you select a project and click Time Analysis on the Processes tab, Open Plan displays a
dialog box with two tabs: the Options tab and the Advanced tab.
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The Options tab displays the basic settings for a time analysis session:

Enter Time Now

Enter an optional target type date and
target finish for the project

Select the appropriate options.

You can use this tab to enter the following settings:


Time Now — If this is the first time you have time-analyzed the project, Open Plan requires you
to enter a date for Time Now. Time Now is the current project status date, and Open Plan will not
calculate any dates prior to this date. If the project is not yet underway, enter the planned project
start date for Time Now. If the project has started and you have entered progress information for
one or more activities, Time Now should be the latest date for which all progress information is
correct.
You can also specify the Time Now date on the Processes tab from the Schedule
group.





Target Type — If you enter a target start or target finish date for the project, you can define the
target date as one of the following types:


Not earlier than



Not later than



On target

Target Finish — You can enter an optional target finish date for the project. In general, however,
you should not enter a target finish date for projects that have not been previously analyzed.
In addition to using the Time Analysis dialog box, you can enter Time Now and target dates and
types using the Status tab of the Project Properties dialog box.
For a description of the Status tab, including an extended discussion of project target
dates, refer to Chapter 5, “Project Properties.”



Analyze Each Time Data Changes — This option enables automatic time analysis. If selected,
Open Plan automatically calculates time analysis whenever you make a date-related change to
the project.
This can also be toggled by clicking

on the Processes tab.

If this option is selected, Perform Time Analysis on the Processes tab is not enabled.
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Actual Date Option — You can enable an option to have Open Plan substitute actual dates
(where present) for the early and late dates generated by time analysis calculations. This option
does not otherwise affect the calculations of time analysis. If you do not enable this option, the
early dates calculated by time analysis relate only to the remaining portion of the activity.
For more information about this option, refer to Chapter 4, “The Open Plan
Configuration Files,” in the Deltek Open Plan Developer’s Guide.



Show Summary Dates in Subprojects — This option controls whether Open Plan should copy
the dates calculated for the child activities into the record of the activity representing the
subproject.


If selected, subproject activities display a summary of the dates calculated for their child
activities. This is the default setting.



If not selected, subproject activities display the dates calculated for the subproject activity
itself.

The Advanced tab of the Time Analysis dialog box displays settings that are seldom changed:

You can use this tab to enter the following settings:


Multiple Ends — A final consideration arises if the multiple ends processing option has been
specified. In that case, Open Plan treats each end activity as if the activity had a target finish
equal to its early finish. This can result in a different starting point for the backward pass from
each end activity.
Once the project completion date has been determined, the calculation of late dates during the
backward pass proceeds in a manner entirely analogous to the calculation of early dates during
the forward pass.



Out of Sequence Options — You can select one of the following options for calculating dates for
activities for which progress has been entered “out-of-sequence”:


Ignore Positive Lag of Predecessor — Observe relationships but ignore positive lags on
relationships leading into out-of-sequence events (that is, the start of an activity marked as inprogress or the finish of an activity marked as complete).



Observe Positive Lag of Predecessor — Observe all relationships and lags leading into
out-of-sequence events.



Ignore Predecessor Relationship — Ignore all relationships and all lags leading into out-ofsequence events (including the finish of a continuous activity marked as in-progress). If you
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select this option, Open Plan does not report out-of-sequence warnings in the session log
and does not delay the successors of out-of-sequence activities.
To use the Time Analysis dialog box, complete the following steps:
1. Select the project for which you want to perform time analysis.
2. From the Processes tab, click Perform Time Analysis » Options from the Schedule Group.
3. Enter the information for the session.
4. If this is the first time to time-analyze the project, you must enter a date for Time Now.
5. When the information is correct, click OK to perform the operation.
Open Plan informs you if an error condition is detected during the session. You can use the
Log Viewer to examine the error in the session log.
For more information on the Log Viewer, refer to Chapter 24, “System Utilities.”

Using the Perform Time Analysis Button
If you wish to perform time analysis without displaying the Time Analysis dialog box, simply click
Perform Time Analysis on the Processes tab. When you perform time analysis using this method,
the settings that were last set on the Time Analysis dialog box control the operation. If you have not
entered a Time Now for the project, Open Plan automatically displays the Time Analysis dialog box
before allowing you to proceed.
To perform time analysis, complete the following steps:
1. Select the project for which you want to perform time analysis.
2. From the Processes tab, click Perform Time Analysis.
Open Plan informs you if an error condition is detected during the session. You can use the
Log Viewer view the contents of the session log.
For more information on the Log Viewer, refer to Chapter 24, “System Utilities.”

Group Process Time Analysis
You can also perform time analysis in Batch Mode. This allows you to run time analysis for multiple
projects at one time. To run time analysis in Batch Mode, select more than one project from the
Details pane of the Open Plan Explorer, and click Perform Time Analysis. The Time Analysis
[Batch Mode] dialog box will be displayed. Set your options, and click OK.
If a project is closed, Open Plan will open it in Exclusive mode, perform the process, save the
changes, and then close the project. If a project cannot be opened in Exclusive mode (because
another user has it open in Exclusive or Shared mode), it will be skipped.
If you have a project open when the batch process is run, time analysis will be performed on the
project, but the changes will not be saved and the project will remain open. You must manually save
the changes yourself.
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Time analysis for multiple projects can also be run by selecting a group of projects and clicking
Perform Time Analysis on the Processes tab.

Open Plan creates one time analysis session log, listing the project results in the order in which
the projects were processed in the batch.

Using Automatic Time Analysis
Open Plan includes an automatic mode that performs time analysis whenever you:


Change the logic of the project by cutting, pasting, adding, or deleting an activity



Change activity information such as target dates or durations



Enter progress information about activities



Change project information such as the target dates or Time Now

To enable or disable the automatic time analysis mode, select the Analyze Each Time Data
Changes option on the Time Analysis dialog box:

Select to enable automatic time analysis

Also available on the Processes tab, you can click
analysis mode.

to enable or disable the automatic time

Time Now is the project status date. All project information is assumed to be complete up to
Time Now, and Open Plan will not schedule any activities prior to this date. If this is not
appropriate for your project, you can set the value of Time Now on either the Time Analysis
dialog box or the Status tab of the Project Properties dialog box.

To use automatic time analysis, complete the following steps:
1. Select the project for which you want to perform time analysis.
2. From the Processes tab, click the Perform Time Analysis button.
3. On the Options tab, select Analyze Each Time Data Changes.
4. Click OK.
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Time analysis will be performed at this point and subsequently every time relevant data
changes.
You can also set automatic time analysis by clicking
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Overview

Overview
Open Plan provides a sophisticated and comprehensive resource scheduling algorithms designed to
produce resource solutions across a wide range of situations. Open Plan resource scheduling
includes extensive modeling capabilities that allow planners to juggle schedules based on various
combinations of time and resource constraints.
This chapter begins with a brief introduction to resource scheduling in Open Plan, followed by a
description of the different scheduling attributes available for activities. The chapter continues with a
description of how to perform resource scheduling in Open Plan, including information about
advanced resource scheduling options. The chapter concludes with discussions on using resource
scheduling information and reporting the results of resource scheduling results.
For a complete description of the calculations performed by resource scheduling, refer to
Chapter 10, “Resource Scheduling Calculations,” in the Deltek Open Plan Developer’s Guide.
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What is Resource Scheduling?
The purpose of resource scheduling is to calculate a project schedule that takes into account the
limited availabilities of resources as well as the durations, logical relationships, and target dates of the
activities. To help you understand how resource scheduling works, this section contains discussions
of the following topics:


Resource scheduling methods



Effect of reservations on resource scheduling



The results of resource scheduling calculations



Resource scheduling rules

Resource Scheduling Methods
Open Plan provides two basic methods for calculating resource scheduling data:


Time-limited resource scheduling



Resource-limited resource scheduling

Time-limited resource scheduling places a priority on maintaining the overall project completion date
while attempting to minimize the extent to which any resource is over utilized. In time-limited resource
scheduling, constraints on resource availabilities are not allowed to delay the overall completion date
of the project. As a result, resources may be overloaded if necessary to prevent an activity from
finishing after its late finish date.
Time-limited resource scheduling places all scheduled dates between the early and late dates of
activities. Thus, only activities not on the project critical path can be delayed by resource constraints.
By specifying a sufficiently low resource availability, you can use time-limited resource scheduling to
calculate activity dates that minimize the over-utilization of resources without interfering with the
project completion date. (This process is sometimes referred to as “resource leveling.”)
In contrast to time-limited scheduling, resource-limited resource scheduling places a priority on
preventing the over utilization of resources, even if that means delaying the project finish beyond its
early finish. In the absence of thresholds or immediate activities (discussed later in this chapter),
resource-limited resource scheduling delays project completion if necessary to ensure that the
resource requirements do not exceed availabilities.

Effect of Reservations on Resource Scheduling
Open Plan offers the ability to reserve resources for particular projects, either for all time or for
specific periods. Resource Scheduling does not include resource availability reserved for another
project. The effect of reservations on resource scheduling depends on the type of resource
scheduling that is performed and the options that have been set.
When an activity belongs to an external subproject, the availability considered for scheduling that
particular activity includes:


The availability reserved for the subproject



Any higher-level subprojects to which it belongs



The main project
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For more information on reserving resources for projects, refer to Chapter 7, “Resource
Definitions,” and also Chapter 10, “Resource Scheduling Calculations,” in the Deltek Open Plan
Developer’s Guide.

The Results of Resource Scheduling Calculations
When you perform resource scheduling in Open Plan, the following data is calculated.


Scheduled dates — A set of activity start and finish dates as follows:


Scheduled start — The proposed date on which an activity should start based upon both
project logic and resource constraints. A scheduled start date for an activity can never be
earlier than its early start date calculated by time analysis.



Scheduled finish — The proposed date on which an activity should finish based on both
project logic and resource constraints. A scheduled finish date for an activity must be the
same or later than its early finish date calculated by time analysis.



Earliest feasible date — The earliest date on which the activity could be scheduled to start
based on the scheduled dates of all its predecessors but in the absence of any resource
constraints on the activity itself.



Scheduled duration — The computed duration of the activity. The scheduled duration of an
activity can never be shorter than its original duration. A scheduled duration can, however, be
longer than the original duration in cases where the activity was split, stretched, or reprofiled
during resource scheduling.
For information about activity splitting, stretching, and reprofiling, refer to the “Resource
Scheduling Attributes for Activities” section later in this chapter.

Resource Scheduling Rules
When performing resource scheduling, Open Plan follows a number of general rules regarding the
calculation of dates.


Open Plan uses a serial method of resource scheduling. This means that activities are scheduled
one at a time. Once an activity is scheduled, it is not reconsidered based on the needs of
subsequent activities. The order in which activities are scheduled is determined by the project
logic and can be modified only to a limited extent by defining the priority fields used for the
calculations.
For information on defining priority fields, refer to the “Resource Scheduling Processing Options”
section later in this chapter.



Open Plan uses the late dates to determine when an activity is being delayed enough to delay the
project completion. Therefore, if you change Time Now, you should rerun time analysis before
performing resource scheduling.



Activity durations are never shortened but may be lengthened due to stretching, splitting, or
reprofiling. If lengthened in any of these ways, the new duration is placed in the scheduled
duration field, not in the original activity duration field.
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Resource scheduling does not violate project logic. This means that activities are available to be
scheduled only after all of their logical predecessors have been scheduled. This means that no
activity will be scheduled before its early dates.



Resource-limited resource scheduling does not consider availability in excess of the defined
resource availability except for immediate activities (which are scheduled on the earliest feasible
date whether or not resources are available) or when thresholds are in use.
For information about immediate activities, refer to the “Resource Scheduling Attributes
for Activities” section in this chapter.



Time-limited resource scheduling schedules within the late finish date of the activity if there is no
negative float. If an activity has negative float, Open Plan schedules on the early finish date of
this activity.
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Resource Scheduling Attributes for Activities
Splitting, stretching, and reprofiling are three activity attributes that can be used to add flexibility to the
treatment of an activity during resource scheduling. Each of these techniques can be regarded as a
way to improve the performance of a project by relaxing the rules of resource scheduling in a
particular way.
It is also possible to assign the Immediate attribute to an activity. The Immediate attribute removes
flexibility from resource scheduling calculations by forcing Open Plan to schedule an activity on the
earliest date possible.
Each attribute is described in the following sections.
For more information about activity attributes, refer to Chapter 10, “Resource Scheduling
Calculations,” in the Deltek Open Plan Developer’s Guide.

Activity Splitting
Activity splitting allows an activity duration to be split into two or more pieces. Use of this attribute
may permit the activity to be scheduled earlier than would otherwise be possible due to gaps in the
availability of a required resource. For example, suppose that 3 units of a resource are available on
January 1 and January 2. On January 3, only 1 unit of the resource is available, and on January 4
and January 5, 3 units of the resource are again available. This is illustrated in the following profile:

Normally, a 4-day activity with a requirement of 3 units per day could not be scheduled during this
period since there are not 4 consecutive days in which the necessary resources are available. As a
result, either the activity must be delayed or the resource availability exceeded. If the activity can be
split, however, it is possible to schedule the activity in two pieces with one 2-day piece starting on
January 1 and the second 2-day piece starting on January 4.
Two parameters control the splitting of an activity during resource scheduling: the minimum duration
of an activity piece and the maximum number of pieces.

Activity Stretching
A stretchable activity is an activity whose duration can be lengthened by Open Plan during resource
scheduling in order to reduce the peak requirement for a constraining resource and thus obtain an
earlier scheduled date. For example, assume that a 2-day activity with a requirement of 6 resource
units per day is scheduled against a resource with an availability of only 4 units per day:
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If the availability of the resource cannot be exceeded, Open Plan delays the activity. However, by
stretching the duration of an activity to 3 days (reducing the requirement to 4 units per day), it is
possible to reduce the peak requirement of the activity enough to permit the scheduling of the activity:

The total resource requirement of the activity remains unchanged.

To control the effects of stretching during resource scheduling, Open Plan allows you to enter a
maximum duration for the activity.

Activity Reprofiling
Reprofiling provides Open Plan with the most flexibility in scheduling an activity. An activity with this
attribute can be scheduled in any way consistent with available resources so long as the following
criteria are met:


The duration of the reprofiled activity cannot be shorter than the specified duration.



The reprofiled requirements cannot exceed the original requirements profile (on a cumulative
basis).

Thus a 10-day activity with a resource requirement of 3 units per day cannot be reprofiled so that it
has a 1-day duration with a requirement of 30 units.
To see how reprofiling works, assume that a 3-day activity has a resource requirement of 5 units per
day for a total of 15 units. Depending on the availability of the resources, the activity can be reprofiled
in any number of ways, including the following examples:


5 days at 3 units per day



4 days at 2 units per day, followed by 1 day at 7 units per day



5 days at 1 unit per day, followed by 1 day at zero units per day, followed by 1 day at 10 units per
day

To control the effects of reprofiling during resource scheduling, Open Plan allows you to enter a
maximum duration for the activity.
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The Immediate Attribute
By assigning the Immediate attribute to an activity, you instruct Open Plan to start the activity on its
earliest feasible date even if that means overloading a resource. The earliest feasible date for an
activity is a date calculated by resource scheduling and represents the earliest possible date an
activity can start, taking into account delays in preceding activities but in the absence of any
constraints on its own resources.

Assigning Scheduling Attributes to Activities
To assign scheduling attributes to an activity, display the Advanced tab of the Activity Details dialog
box.

This tab allows you to enter the following settings.


Type — You can define the scheduling attribute of the activity as one of the following types:


Normal (the default)



Splittable



Stretchable



Reprofilable



Immediate



Min Duration — If you define the activity as splittable, you can specify the minimum duration for
each piece.



Max Splits — If you define the activity as splittable, you can specify the maximum number of
splits allowed.



Max Duration — If you define the activity as either stretchable or reprofilable, you can specify the
maximum duration allowed.



Priority — This field controls the priority Open Plan gives the activity during resource scheduling
and acts as a tie-breaker. You can enter any 3-digit number. Lower numbers indicate a higher
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priority than higher numbers. The default for this field is zero (and, therefore, top priority).
Negative numbers are allowed.
For this setting to take effect, you must also select Priority as one of the priorities on
the Advanced tab of the Resource Scheduling dialog box.



Separate Resources — You can define whether Open Plan should consider multiple
assignments to the same pool separately.



Suppress Requirements — You can define whether Open Plan should ignore resource
requirements for the activity during resource scheduling.



Earned Value — You can specify the performance measurement technique (EVT) for the activity.
When the Base Physical Percent Complete on EVT option is selected on the Progress
Calculations dialog box, Open Plan uses the selected EVT to update the earned value of the
activities when progress calculations are run.
The Earned Value section contains two data fields:


EVT — You can select from the list of EVT’s as described below.



Start % — This field is enabled when you select User-Defined Percentage for the EVT. You
can enter the starting percentage an activity earns in this field. The remainder is earned when
the activity is completed.

EVT options for selection:


Level of Effort — This EVT assumes that if the activity has started, it will progress (and,
thus, earn value) according to the original budget without deviation. By definition, the value
earned by an activity using this EVT is equal to the budget up to Time Now. In other words,
starting a Level of Effort (LOE) activity results in the activity immediately earning its entire
budget up to Time Now.



Percent Complete — With this EVT, the user enters percent complete directly. Percent
complete places the burden of objective performance measurement on the individual or
system that provides the information.



50-50 — With this EVT, 50% of the value is earned as soon as the activity is started, and the
rest is earned when it is completed. Since value cannot be earned in any intervening periods,
this EVT is best used for activities that span a maximum of two fiscal periods.



0-100 — With this EVT, no value is earned until the activity is completed. At which point, the
entire budget is earned. This method is best used if the activity is scheduled to start and
finish in the same fiscal period.



100-0 — With this EVT, all the value is earned as soon as the activity is started. This method
is best used if the activity is scheduled to start and finish in the same fiscal period.



User-Defined Percentage — This EVT is a variation of the 50-50 EVT. The percentage
earned at the start of the activity (1 to 99%) is defined in advance by the user by entering the
percentage in the Start % field. The remainder is earned when the activity is completed. This
method is best used for activities whose schedule dates span a maximum of two fiscal
periods



Planning Package — Activities using this EVT are used for planning purposes only and do
not earn value. This causes earned value to always be calculated as zero regardless of any
progress that has been applied.



Resource Assignment % Complete — This EVT allows you to enter status and calculate
earned value at the resource assignment level. This option is useful when you have long
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activities and your resources are not spread across the entire activity. An example is when
you have many resources assigned to a single work package.
There are few hard and fast rules about selecting performance measurement techniques. The
general rule is to select a method that allows you to "earn how you plan." For example, if an activity
spans two periods and the budget spread is $50 in the first period and $50 in the second period, you
should select a EVT that, if on schedule, would allow you to earn half of the $100 budget when the
activity is started and the other half when it is finished. (This scenario would most likely use the 50-50
EVT.)
50-50, 0-100, 100-0, and User-Defined Percentage EVTs are normally used on activities that
span nor more than two periods.

To assign scheduling attributes, complete the following steps:
1. Display the Activity Details dialog box for the desired activity.
For information on displaying the Activity Details dialog box, refer to Chapter 6, “Activity
Information.”

2. Click the Advanced tab.
3. Enter the information for the scheduling attributes of the activity.
4. When the information is correct, click OK.
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Performing Resource Scheduling
When you click the Resource Scheduling command on the Processes tab, Open Plan displays the
Options tab of the Resource Scheduling dialog box:

Use this tab to enter the following settings about the resource scheduling operation:


Scheduling Method — You can choose either of the following methods:


Time Limited — Time-limited resource scheduling places a priority on maintaining the overall
project completion date while attempting to minimize the extent to which any resource is
over-utilized. In time-limited resource scheduling, constraints on resource availabilities are
not allowed to delay the overall completion date of the project. As a result, resources may be
overloaded if doing so prevents an activity from finishing after its late finish date.
Time-limited resource scheduling places all scheduled dates between the early and late
dates of activities. Thus, only activities not on the project critical path can be delayed by
resource constraints.
By specifying sufficiently low resource availability, you can use time-limited resource
scheduling to level the overall resource requirements for a project.



Resource Limited — Resource-limited resource scheduling places a priority on preventing
the over-utilization of resources, even if that means delaying the project beyond its early
finish date.
In the absence of thresholds, immediate activities, or subproject requirements, resourcelimited resource scheduling uses only those resource availabilities that have not been
reserved for another project and delays project completion to ensure that the resource
requirements do not exceed availabilities.
The use of resource availability thresholds, immediate activities, or resource
assignments on subprojects may cause resource overloads even when performing
resource-limited resource scheduling.



Time Analysis — If you wish, you can have Open Plan perform a time analysis of the project
before the resource scheduling operation. To invoke time analysis, select Time Analyze
Before Scheduling. (If you have not already performed time analysis on the project, Open
Plan selects this option automatically.) To set the time analysis options, click Options.
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For information about time analysis processing options, refer to Chapter 13, “Time
Analysis.”



Consider Usage on Higher Priority Projects — If this option is selected, Open Plan will not
use resources that are currently scheduled to be used by other projects that have a higher
priority. (Project priority is defined on the Scheduling tab of the Project Properties dialog box
where lower numbers represent higher priorities.)
If another project has reserved a portion of a resource's availability, the reserved portion is
not available to your project regardless of whether you select this option or of the relative
priorities of the projects.
A resource is not double-counted if it is used by the project to which it was reserved and is
not available to the current project.
For example, 75% of a resource is reserved for a particular project, leaving 25% not reserved
available for the current project.


If the project uses only 60% of the resource instead of 75%, there is still only 25%
available for the current project. (Open Plan does not recognize the difference between
what was used and what was reserved if the usage is lower than quantity reserved.)



If, on the other hand, the project uses 80% of the resource, the difference between what
is used and what is reserved is subtracted from the 25% not reserved. This leaves only
20% available for the current project.

When scheduling a number of projects together (using external subprojects), the scheduling
priority is that for the master project. (Of course, this does not prevent you from using the
individual project priorities as one of the priority fields used to break ties between individual
activities.) To do this, you need to create a calculated field with the Project Priority field
(_PRJ.RS_PRIORTY) as the expression.
For more information on how to create a calculated field, refer to Chapter 23, “Project
Utilities.”



Ignore Actual Dates — This option controls whether Open Plan should ignore actual dates
when performing resource scheduling:


If this option is selected, Open Plan ignores actual dates when performing resource
scheduling.



If this option is cleared, Open Plan does not ignore the actual dates when performing
resource scheduling. This is the default setting.

At the conclusion of each resource scheduling session, Open Plan creates and saves a session log
that records any system or error messages issued during the operation. You can view the session log
file (Opp_rs.log) once the processing is complete.
To perform resource scheduling using the Resource Scheduling dialog box, complete the
following steps:
1. Select the project for which you want to perform resource scheduling.
2. On the Processes tab, click Resource Scheduling.
3. Enter the information for the session, and click OK.
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Open Plan informs you if an error condition is detected during the session. You can use the
Log Viewer to examine the error in the session log.
For more information on the Log Viewer, refer to Chapter 24, “System Utilities.”

Using the Perform Resource Scheduling Button on the Processes
Tab
To perform resource scheduling without displaying the Resource Scheduling dialog box, simply click
Resource Scheduling on the Processes tab.
When you perform resource scheduling using this method, the settings stored on the Resource
Scheduling dialog box control the operation. If you have not performed resource scheduling for the
project, Open Plan automatically displays the Resource Scheduling dialog box before allowing you to
proceed.
To perform resource scheduling using the Perform Resource Scheduling button, complete the
following steps:
1. Select the project for which you want to perform resource scheduling.
Resource
Scheduling button

2. On the Processes tab, click the Perform Resource Scheduling button.
Open Plan informs you if an error condition is detected during the session. You can use the
Log Viewer to examine the error in the session log.
For more information on the Log Viewer, refer to Chapter 24, “System Utilities.”

Group Process Resource Scheduling
You can also perform resource scheduling in Batch Mode. This allows you to run resource
scheduling for multiple projects at one time. To run resource scheduling in Batch Mode, select more
than one project from the Details pane of the Open Plan Explorer, and click the Resource
Scheduling button. The Resource Scheduling [Batch Mode] dialog box will be displayed. Set your
options, and click OK.
If a project is closed, Open Plan will open it in Exclusive mode, perform the process, save the
changes, and then close the project. If a project cannot be opened in Exclusive mode (because
another user has it open in Exclusive or Shared mode) it will be skipped.
If you have a project open when the batch process is run, resource scheduling will be performed on
the project, but the changes will not be saved and the project will remain open. You must manually
save the changes yourself.
Resource scheduling for multiple projects can also be run by selecting a group of projects and
clicking the Perform Resource Scheduling button on the Processes tab.
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Open Plan creates one time analysis session log, listing the project results in the order in which
the projects were processed in the batch.
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Advanced Resource Scheduling Options
The Advanced tab of the Resource Scheduling dialog box displays resource scheduling options that
are seldom changed. Once you have specified a set of resource scheduling options for a particular
project, these options remain the defaults for that project each time it is scheduled.

Use the Advanced tab to set the following options:


In-Progress Priority



Hard Zeros



Resource Smoothing



Priority Fields



Scheduling Interval



Resource Selection



Force Overloaded Activities to Late Dates



Try Alternate Resource to Avoid Delay



Limit Reprofiling to Original Level

In-Progress Priority
The In-Progress Priority option allows you to specify that in-progress activities have priority access
to limited resources. This tends to prevent the splitting (and thus the delay) of activities that have
already started.
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Hard Zeros
The Hard Zeros option exempts any resource availability of zero from being incremented through the
use of thresholds or during time-limited resource scheduling. For example, assume that a resource
availability has been defined as the following:
Level

From

To

5

01Jan04

10Jan04

5

20Jan04

31Jan04

Since there is no entry for the dates between 11Jan04 and 19Jan04, there is an implied availability of
zero for this resource during that period. In normal time-limited scheduling (or in resource-limited
scheduling when resource thresholds are involved), the availability of the resource between these
dates could be increased from its implied level of zero if it were necessary to prevent a delay in the
project.
By contrast, if the Hard Zeros option were in effect, the availability of the resource during that period
would never be increased under any circumstances.
For information about interpreting zero availabilities, refer to Chapter 7, “Resource Definitions.”
For more information on the hard zeros processing option, refer to Chapter 10, “Resource
Scheduling Calculations,” in the Deltek Open Plan Developer’s Guide.

Resource Smoothing
During time-limited resource scheduling, the Smoothing option attempts to even out or “smooth” the
way in which resources are assigned to activities. Without this option set, Open Plan assumes that if
the availability of a resource has been exceeded once, the amount of the overload should be used
again in preference to using float. With this option set, Open Plan assumes that even though an
availability has been exceeded, available float should be used in preference to overloading the
resource again.
For example, assume that four independent activities require a resource whose availability is 1 unit
per day. Three of the activities have 1-day durations and 3 days of total float each. They require 1 unit
of the resource per day. The fourth activity has a duration of 4 days and zero total float. This activity
requires 3 units of the resource but only on the fourth day of its duration. Because it has zero float,
the fourth activity assumes the default settings and is scheduled first. With normal time-limited
scheduling, Open Plan assumes that since it is necessary to exceed the resource availability once by
2 units to schedule the fourth activity, it is permissible to exceed that availability by 2 units at any
time. As a result, it proceeds to schedule the first three activities on their early dates:
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With the Smoothing option in effect, however, no resource availability is exceeded unless it is strictly
necessary to schedule the activity:

If smoothing is turned off when you perform resource scheduling, the error log includes a message
only for the first time the resource requirement exceeds the availability.
It is important to remember that in certain situations, the Smoothing option may result in an increase
in the total resource requirements for the project. Therefore, if you wish to minimize the extent to
which resources may be overloaded, do not use smoothing.
In general, the following guidelines may help you decide whether to turn the Smoothing option on or
off:


Turn smoothing on if only a few activities have a large resource overload but the rest of the
project does not.



Turn smoothing off if the project as a whole has a large resource overload. This has the effect of
scheduling activities close to their early dates where possible, minimizing the possibility of
causing an unnecessary overload later.

To determine the best way to set the Smoothing option for your situation, compare the results of
resource scheduling with smoothing turned on and with smoothing turned off.
For a complete discussion of resource smoothing, refer to Chapter 10, “Resource Scheduling
Calculations,” in the Deltek Open Plan Developer’s Guide.

Priority Fields
Open Plan provides three priority fields that are used as tiebreakers during resource scheduling. You
can use any activity-related field as a tiebreaker with the exception of enumerated fields (for example,
Activity Type) since there is no defined sort order for such fields and note categories. Lower values
or earlier dates indicate a higher priority. Negative numeric values are allowed.
If the In-Progress Priority option is on, activities in progress always have the highest priority in
resource scheduling regardless of the values stored in their priority fields.

The default for the first priority tiebreaker is set to Total Float. Since lower values have a higher
priority than higher values, this field tends to schedule activities on the project’s critical path first. In
most cases you should leave this field selected as the first priority field because it tends to produce
the most efficient schedules. (If critical activities are delayed, the project is automatically delayed by
that same amount of time.)
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You may want to design your own priority system to control the scheduling of activities. Typically, you
might define a numbering system based from 1 to 10 or perhaps 1 to 100. The numbering system and
the range you use should be based on the size of the project and the degree of detail necessary. A
field labeled Priority on the Advanced tab of the Activity Details dialog box is available for this
purpose, but it would also be possible to specify a calculated field as a priority field.

Priority field
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Open Plan also provides two special-purpose priority fields that you can use for resource scheduling
purposes: <Hierarchical Priority Field> and <Remaining Float>.

Special-purpose priority fields

These special fields function as follows:


<Hierarchical Priority Field> — Open Plan refers to the priority field of the parent activities
when attempting to break a tie between two activities.



<Remaining Float> — Open Plan uses the activity’s remaining float (that is, the difference
between the late start and the earliest feasible start — this value is calculated during the course
of resource scheduling) when determining priorities.
For a complete discussion of the effect of priority fields, refer to Chapter 10, “Resource
Scheduling Calculations,” in the Deltek Open Plan Developer’s Guide.

Scheduling Interval
The Scheduling Interval setting defines the granularity with which Open Plan matches up resource
assignments and availabilities. Thus, if you define the scheduling interval for resource scheduling as
hours, Open Plan schedules an activity only when the required resources are available for each hour
of the activity duration. By increasing the scheduling interval to days, you allow Open Plan to
schedule the activity on any day for which sufficient resource availability exists, even if the hours of
the assignment and the hours of the availability do not exactly match.
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By reducing the scheduling interval, you increase the precision of the resource scheduling results. On
the other hand, you also increase the processing time required to yield these results. Increasing the
scheduling interval should speed up resource scheduling calculations at the cost of slightly less
precise results.
To specify the largest scheduling interval that still maintains maximum accuracy, select an interval
that matches the lowest common denominator of all durations. For example, if you know that all
activity durations are defined as multiples of 2 hours, then select 2 hours as the scheduling interval.
For most projects, a daily interval is appropriate.

As a general rule, never define a scheduling interval that is smaller than necessary. For example, if
you have defined all activity durations in days, changing the scheduling interval to minutes or hours
will not result in more accurate resource calculations and will result in significantly increased
processing times.
For more information about scheduling intervals, refer to Chapter 10, “Resource Scheduling
Calculations,” in the Deltek Open Plan Developer’s Guide.

Resource Selection
By default, all resources in the resource definition file that are required by project activities represent
a potential constraint on when activities are scheduled. By clearing some resources, you instruct
Open Plan to schedule the project as though an unlimited quantity of those resources were available.
The first time you run resource scheduling, you typically want to have all resources selected.
However, if you determine that the availability of a particular resource is causing the schedule to be
delayed, you may want to run resource scheduling again with that resource cleared. You might also
want to see how selecting or clearing various resources would affect the schedule.
Resources remain selected or cleared until the option is changed in a subsequent resource
scheduling session.

Force Overloaded Activities to Late Dates
This option controls whether Open Plan should force overloaded activities to their late dates rather
than to their early dates:


If selected, this option forces overloaded activities to their late dates.



If cleared, this option forces overloaded activities to their early dates.

Try Alternate Resource to Avoid Delay
This option controls the use of alternate resources in resource scheduling:


If selected, this option instructs Open Plan to try using the alternate resource if using the original
resource would cause the activity to be delayed beyond its earliest feasible date.



If cleared, this option instructs Open Plan to use the alternate resource only to avoid overloading
(time-limited resource scheduling) or exceeding the late dates (resource-limited resource
scheduling).
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Limit Reprofiling to Original Level
This option controls whether Open Plan should limit the reprofiling of a resource assignment to a level
that does not exceed the original profile for any given unit of duration:


If selected, this option instructs Open Plan to limit reprofiling to the original profile.



If cleared, this option instructs Open Plan to not limit reprofiling to the original profile.
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Using Resource Scheduling Information
Although the procedures for performing resource scheduling in Open Plan are relatively
straightforward, the use of resource scheduling information for planning purposes is usually an
iterative process that must be repeated until acceptable results are obtained. The following procedure
may provide some guidelines about the steps you should follow when integrating resource scheduling
information in the overall planning process.
Step 1 — Perform time analysis and evaluate the schedule. By default, Open Plan uses the total float
calculated by time analysis in resource scheduling. In addition, since the dates calculated by time
analysis do not consider resources, resource scheduling never produces earlier dates than time
analysis. Therefore, there is little point in proceeding with resource scheduling if the dates produced
by time analysis are later than those acceptable to your organization.
For information on time analysis, refer to Chapter 13, “Time Analysis.”

Step 2 — If necessary, replan the project. It is important that you have a finish date that is acceptable
before proceeding.
Step 3 — Perform resource scheduling. There are two basic approaches to resource scheduling:
time-limited and resource-limited.


Time-limited resource scheduling asks the question, “When and where do I need extra resources
in order to meet the dates?”



Resource-limited scheduling asks the question, “How much will the project be delayed because I
do not have enough resources?”

Although you will certainly want to try both methods so that you can compare the results, your
circumstances will dictate which method you should try first. (Time-limited and resource-limited
scheduling are discussed in greater detail elsewhere in this chapter.)
Step 4 — To see the effect of resources on the project schedule, compare the scheduled dates
calculated by resource scheduling to the early and late dates calculated by time analysis. In resourcelimited scheduling, a large difference between an activity’s early start date and its earliest feasible
date indicates that resource bottlenecks earlier in the project are producing delays in the schedule.
Step 5 — To identify cases of resource over utilization, display a resource histogram view that
compares resource requirements to availabilities.
Step 6 — If you are not satisfied with either the scheduled dates or the levels of resource utilization,
you can make adjustments to the resource usage in a number of ways:


You can identify over-utilized resources and substitute under-utilized resources for them.



You can permit Open Plan to split, stretch, or reprofile activities whose durations do not have to
be uninterrupted.



You can select a different processing option and rerun resource scheduling. Processing options
include resource smoothing, giving in-progress activities higher priority, and using different fields
for establishing project priorities.

Step 7 — Recalculate the schedule using time analysis (if you have made any changes to the project
logic) and resource scheduling.
Step 8 — Repeat the entire procedure as needed to develop a workable schedule.
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Reporting on Resource Scheduling
Although it is possible to display any data calculated by resource scheduling in a tabular format, Open
Plan also provides a number of views that display resource scheduling results graphically. For
example, to show the potential effects of resource constraints on activity schedules, open the
standard resource barchart view after you have performed resource scheduling:
Delaying resource

In this view, Open Plan displays bars for both early and scheduled dates. If the scheduled start date
is later than the earliest feasible start date for an activity (that is, if a resource assigned to the activity
is causing it to be delayed beyond its earliest possible start), Open Plan changes the color of the bar,
displays an arrow indicating the earliest feasible start date, and displays the name of the resource
causing the delay.
By enlarging the histogram portion of the view, it is possible to compare availability and assignment
information for specific resources:

This type of view makes it easy to focus in on the resource problems that have a direct impact on
schedule performance.
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Overview

Overview
Project management decisions are concerned with the future. While planners hope to influence the
outcome of events by the decisions they make, everything about the future is, to a greater or lesser
extent, uncertain. The techniques of risk analysis were developed to provide a consistent
methodology for quantifying this uncertainty with the ultimate goal of improving the quality of
decisions.
By definition, project management involves the planning and coordination of large numbers of
activities for which there are often no precise precedents. The durations and costs of the individual
activities making up the project cannot be known exactly before the project begins. Clearly a project
plan is, by its very nature, a forecast and thus contains elements of uncertainty.
Using the tools of risk analysis, Open Plan allows you to quantify the uncertainties associated with
project durations. When using this feature, you enter three durations (optimistic, pessimistic, and
most likely) for activities. During the risk analysis process, Open Plan estimates the duration for these
activities using random numbers and runs time analysis a large number of times. By precisely
defining the probable range of the durations of each activity, Open Plan provides you with the means
to model the impact of these uncertainties on such critical areas as:


The project completion date



The feasibility of achieving specific target dates

Briefly stated, Open Plan risk analysis works by:


Allowing you to enter three durations (optimistic, pessimistic, and most likely) and probability
distributions for each activity.



Allowing you to enter probability distributions for duration for some or all of the activities in a
project



Performing a risk analysis using Monte Carlo simulation to establish estimates of the effects on
project dates



Producing views and reports that can be used in analyzing the impact of uncertainties on the
performance of the project

This chapter provides introductions to these topics.
For an in-depth discussion on risk analysis, begin by displaying the Help system topic “Using
Risk Analysis.” For a complete description of risk analysis calculations in Open Plan, refer to
Chapter 11, “Risk Analysis Calculations,” in the Deltek Open Plan Developer’s Guide.
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Defining Activity Risk
To use the risk analysis feature in Open Plan, you must enter duration probability information for at
least one activity in a project. More typically, you enter probable durations for all activities that involve
at least some degree of uncertainty in their planning.
You can enter probability information for any type of activity that does not use a calculated
duration (for example, subprojects, external subprojects, or hammocks).

To enter risk information at the activity level, use the Risk tab of the Activity Details dialog box:

For each activity on which you want to model risk, you can enter an optimistic (minimum estimated)
duration and a pessimistic (maximum estimated) duration in addition to an original duration. You can
also enter a weight factor (0-100) for the Probability of Occurrence that indicates the probability that
the activity will exist at all. For example, assume you have the following three activities:
Activity

Probability of Occurrence

A — Write Software

100

B — Test Software

100

C — Fix Software

20

Activities A and B will always happen, but we might judge that there is only a 20% chance that
following testing, we have to go back and fix the software. All regular Open Plan features ignore this
field (and always consider all tasks) except Risk Analysis, which would only consider activity C 20%
of the time. If Risk Analysis chooses to ignore the task on any given iteration, then any successors of
C are deemed to follow immediately on from B (as if C had zero duration).
You must also enter one of the following distribution shapes to define how Open Plan will sample the
range of possible durations:
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Beta — Probable outcomes cluster around the mode value of the distribution. Outcomes at the
extreme values of the distribution are very unlikely.



Normal — Probable outcomes cluster symmetrically around the center of the distribution.



Triangular — Probable outcomes cluster around the mode (most likely) value of the distribution.
Outcomes close to optimistic and pessimistic values of the distribution still possess a significant
probability.



Uniform — Each outcome is equally likely.
For a complete description of these distribution shapes, refer to Chapter 11, “Risk Analysis
Calculations,” in the Deltek Open Plan Developer’s Guide.

Note that Open Plan requires a mode or “most likely” duration for the triangular and beta distribution
shapes. In these cases, the original duration of the activity is assumed to be the mode duration. For
symmetrical distribution shapes (uniform and normal), a mode duration is not required for risk
analysis processing. However, since virtually all processing by Open Plan other than risk analysis
uses the original duration field, you should always enter this duration, no matter what type of
distribution shape is specified for the activity. In fact, Open Plan checks for the validity of the duration
field by verifying that its value falls between the optimistic and pessimistic duration before allowing
you to store the information for the activity. An activity with a blank duration field is interpreted by
Open Plan as having zero duration.
The following examples show how to specify duration probabilities for activities.
Example 1 — You estimate that an activity can have a duration of 3, 4, or 5 days. Each duration is
equally likely.


Optimistic = 3d



Pessimistic = 5d



Duration = 4d (not used during risk analysis)



Shape = Uniform

Example 2 — You estimate that an activity could have a duration anywhere between 10 and 30 days
based on a normal probability distribution.


Optimistic = 10d



Pessimistic = 30d



Duration = 20d (not used during risk analysis)



Shape = Normal

Example 3 — You estimate that an activity could have a duration anywhere between 10 and 30 days.
You predict the most likely duration to be 12 days.


Optimistic = 10d



Pessimistic = 30d



Duration = 12d



Shape = Triangular

Example 4 — You know that an activity has a duration of 2 days.


Optimistic = blank



Pessimistic = blank
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Duration = 2d



Shape = blank

Open Plan also allows you to designate one or more activities in a project as “key activities.” For key
activities, Open Plan stores the most detailed risk analysis information possible. You can then use a
risk histogram view to display detailed histograms for the probability distributions for such information
as the early dates of selected milestone activities.
The designation of a large number of key activities can result in the creation of an
unmanageably large Risk table when risk analysis is performed. Therefore, it is recommended
that the number of activities flagged as key activities never exceed a dozen or so per project.

To enter risk information for an activity, complete the following steps:
1. Display the Activity Details dialog box for the activity.
2. Click the Risk tab.
3. Enter the information for the activity, and click Close.
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Risk Analysis Operations
You can perform a risk analysis of a project at any time. In many ways, the risk analysis function in
Open Plan is similar to the time analysis process. Activities are sorted according to project logic and
then subjected to a forward and backward pass in order to establish the earliest and latest dates for
each activity.
In risk analysis, however, the process of calculating the early and late dates for each activity is based
on a sampling of the probable durations. This sampling is repeated many times in order to build up a
statistical picture of the probable outcomes of the project based on the combinations of the activities’
individual durations.
Unlike time analysis, the resulting dates and values for early dates, late dates, and activity floats are
not calculated as single, deterministic values. Instead, statistical means and standard deviations are
used to express these values.
Another statistical measure calculated for each activity during risk analysis is a “criticality index.” This
index represents the percentage of simulation trials that resulted in the activity being placed on the
critical path.
Open Plan provides two ways to perform risk analysis on a project:

Risk Analysis
button



The Risk Analysis dialog box



The Perform Risk Analysis button on the Processes tab

Each time you perform risk analysis using either the Risk Analysis dialog box or the Perform Risk
Analysis button, Open Plan creates a session log file that records any system or error messages
issued during the operation. Open Plan saves the file (Opp_risk.log) and allows you to examine its
contents at the conclusion of each session.

Using the Risk Analysis Dialog Box
When you click the Risk Analysis command on the Processes tab, Open Plan displays a tabbed
dialog box with two tabs: the Options tab and the Advanced tab.
The Options tab displays the basic settings for a risk analysis session:

Use this tab to specify the following settings:


Number of Simulations — The more simulations performed, the more accurate the results of
risk analysis, but the longer the process will take. Depending on the number of activities in a
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project and what kind of information you are seeking, a number between 100 and 1000
simulations is usually appropriate.


Use Fixed Seed Point — If you enable this setting, Open Plan uses the same starting point each
time it generates random numbers to use as activity durations during the trial simulations. Thus,
multiple risk analyses of identical project information will produce identical results each time.



Use Activity Calendar When Calculating Std. Deviation —This option controls whether Open
Plan should use the activity calendar when calculating standard deviations or calculated dates:





If this option is selected, Open Plan uses the activity calendar when calculating standard
deviations.



If this option is cleared, Open Plan uses elapsed time when calculating standard deviations.

Time Now — If this is the first time you have analyzed the project, Open Plan requires you to
enter a date for Time Now. Time Now is the current project status date, and Open Plan will not
calculate any dates prior to this date. If the project is not yet underway, enter the planned project
start date for Time Now. If the project has started and you have entered progress information for
one or more activities, Time Now should be the latest date for which all progress information is
correct.
You can also specify the Time Now date on the Processes tab from the Schedule
group.



Time Analyze before Risk Analysis — Select this option if you want Open Plan to conduct a
time analysis of the current project information before continuing with risk analysis calculations.
(Note that Open Plan does not require you to perform time analysis before performing risk
analysis.)

There is one additional risk analysis option available on the Advanced tab of the Options dialog box:
For key activities, Open Plan provides a cumulative distribution for each calculated date and
float. This information is output to the Risk table. By default, values are provided for 21
percentile points (0, 5, 10… 100).



RiskPercentileArraySize — This option allows you to control this granularity by specifying the
number of intervals (which will be evenly spaced).
For more information on using the Advanced tab of the Options dialog box, refer to Chapter 25,
“System Defaults.”

You can also use the Advanced tab of the Risk Analysis dialog box to set additional options for the
operation.
For information about these options, refer to Chapter 13, “Time Analysis.”

To use the Risk Analysis dialog box, complete the following steps:
1. Select the project for which you want to perform risk analysis.
2. On the Processes tab, click Risk Analysis.
3. Enter the information for the session.
If this is the first time you have analyzed the project, you must enter a date for Time Now.
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4. When the information is correct, click OK.
Open Plan informs you if an error condition is detected during the session. You can use the
Log Viewer to examine the error in the session log.
For more information on the Log Viewer, refer to Chapter 24, “System Utilities.”

Using the Perform Risk Analysis Button on the Processes Tab
If you wish to perform risk analysis without displaying the Risk Analysis dialog box, simply click the
Perform Risk Analysis button on the Processes tab. When you perform risk analysis using this
method, the settings stored on the Risk Analysis dialog box control the operation. If you have not
entered a Time Now for the project, Open Plan automatically displays the Risk Analysis dialog box
before allowing you to proceed.
To perform risk analysis, complete the following steps:
1. Select the project for which you want to perform risk analysis.
2. On the Processes tab, click the Perform Risk Analysis button.
Risk Analysis
button

Open Plan informs you if an error condition is detected during the session. You can use the
Log Viewer to examine the error in the session log.
For more information on the Log Viewer, refer to Chapter 24, “System Utilities.”

Group Processing Risk Analysis
You can also perform risk analysis in Batch Mode. This allows you to run risk analysis for multiple
projects at one time. To run risk analysis in Batch Mode, select more than one project from the
Details pane of the Open Plan Explorer, and click the Perform Risk Analysis button. The Risk
Analysis [Batch Mode] dialog box will be displayed. Set your options, and click OK.
If a project is closed, Open Plan will open it in Exclusive mode, perform the process, save the
changes, and then close the project. If a project cannot be opened in Exclusive mode (because
another user has it open in Exclusive or Shared mode), it will be skipped.
If you have a project open when the batch process is run, risk analysis will be performed on the
project, but the changes will not be saved and the project will remain open. You must manually save
the changes yourself.
Risk analysis for multiple projects can also be run by selecting a group of projects and clicking
the Perform Risk Analysis button on the Processes tab.

Open Plan creates one risk analysis session log, listing the project results in the order in which
the projects were processed in the batch.
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Interpreting the Results of Risk Analysis
Once the risk analysis is complete, Open Plan stores the following statistical information about each
activity:






Mean and standard deviation of:


Early start date



Late start date



Early finish date



Late finish date

Mean and standard deviation of:


Total float



Free float

Criticality index

This information appears in a risk spreadsheet view:

The mean value of a distribution is one measure of central tendency and may be roughly thought of
as the weighted average of the possible values in a distribution. It is important to remember that the
value for standard deviation is not the maximum amount of variation possible in either direction from
the mean value. Instead, you can use the standard deviation value as a measure of confidence as
follows:


There is an approximately 68% probability of an outcome occurring that falls within one standard
deviation of the mean.



There is an approximately 95% probability of an outcome occurring that falls within two standard
deviations of the mean.



There is an approximately 99% probability of an outcome occurring that falls within three standard
deviations of the mean.

Thus, you could expect with 95% confidence that an activity with a mean early start of May 1 and a
standard deviation of six days would start within 12 days of that date.
This technique only provides an approximation of confidence levels. For one thing, the actual
distribution is often skewed in one direction or the other, rendering confidence estimates based on
mean and standard deviation values less effective. To get a complete picture, an activity should be
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designated as a key activity as shown in a risk histogram (as described in the next section of this
chapter).
It is also possible to show clearly the relationship between criticality index of an activity and the mean
and standard deviation of the total float. Activities whose total floats have large standard deviations
relative to their means are more likely to be critical than activities with relatively small standard
deviations.
Open Plan calculates values for free float and total float based on the project calendar.
Depending on the option you select on the Options tab of the Risk Analysis dialog box, standard
deviations for dates can be calculated with or without regard to the activity calendar.
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Risk Histograms
A risk histogram view presents the detailed picture of the probability distribution for calculated dates
for a key activity. Open a risk histogram view, select a key activity from the project, then select any of
the following dates for use in a risk histogram view:


Early start



Early finish



Late start



Late finish

The following is an example of a risk histogram based on early start dates:

The histogram represents the percentage of trials which resulted in an early start within each time
interval. Against the left-hand axis, Open Plan prepares a scale representing the percentage of risk
analysis iterations that occurred in a given time interval. In this example, the mode or “most likely”
early start for the activity was May 5 with 40% of the simulations falling in that interval.
The right-hand axis represents the cumulative distribution of the dates. In this example, we can see
that 50% of the simulations resulted in dates no later than May 5, making it the median early start
date.
Notice also how Open Plan displays the following information to the left of the histogram:


The early and late start dates (calculated by time analysis)



The mean early and late start dates



The standard deviation for the mean early start



The standard deviation for the mean late start
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Overview

Overview
The progressing function in Open Plan allows you to enter status information about both activities and
resources in a project that is underway. For activities, you can enter actual start and finish dates,
estimates of remaining durations, and completion status. For resources, you can enter actual dates,
costs, and quantities as well as estimates of future usage.
This chapter starts with discussions on creating and managing project baselines, and then provides
discussions of the following topics:


Entering activity progress information



Entering resource progress information



How Open Plan uses progress information when calculating schedules

The chapter concludes with a discussion of the automatic progressing features in Open Plan.
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Project Baselines
Baselines provide a “snapshot” of project status by storing a complete set of project data for a specific
point in time. By comparing baseline schedules and costs with current information, you can see the
areas of the project that are deviating from the original plan. In many cases, project baselines serve
as the basis of contractual agreements related to project performance.
Open Plan allows you to store multiple project baselines so that you can, for example, create a
baseline each time a major re-planning of the project occurs. For some planners, a single baseline is
sufficient for determining subsequent project performance. Other planners prefer to create new
baselines on a regular basis in order to maintain a historical record of changes over the life of the
project.
Open Plan also allows you to create a performance measurement baseline (PMB) that is used for
cost calculations.

Creating, Copying, and Updating a Baseline
You can create, copy, and update a project baseline at any time. Typically, you might create a
baseline after the initial plans are complete, but before you begin entering progress information.
Later, you may need to update it or copy it. To create, copy, or update a baseline, use the Baselines
command from the Processes tab to display the following dialog box:

You can also display the Baselines dialog box by clicking Select Baseline on the Summary tab of
the Project Properties dialog box.

Chapter 16 Status Information
Deltek Open Plan 8.0 User Guide

342

Project Baselines

When you create a new baseline, Open Plan displays the following dialog box:

Use this dialog box to enter the following information about the new baseline:


Name — Enter the name of the baseline. If this baseline is to serve as the basis of Earned Value
calculations the name should be PMB, short for Performance Measurement Baseline.



Description — Enter a description for the baseline.



Based On — Indicate whether you want to use Early, Late, or Scheduled dates for storing
information related to resources and costs. The choice you make determines which set of dates
Open Plan stores in the Baseline Start and Baseline Finish fields for the baseline.
The Baseline Start and Baseline Finish fields serve as base dates for the calculation of earned
value costs – BCWS, ACWP, and BCWP.
Unless you have performed resource scheduling on the project, the Scheduled Dates
option is not displayed in this field.

For information about earned value calculations in Open Plan, refer to Chapter 10,
“Cost Information.”



Ignore Progress, Use Original Project Start Date — Select this option to create baseline dates
by performing a time analysis from the project start date. This option is not available when the
baseline is based on Schedule Dates.



Use Baseline of Same Name on External Subprojects — Select this option for Open Plan to
use baseline information from external subprojects.
If the master project and its external subprojects contain a baseline with the same
name, then selecting this option instructs Open Plan to use the external subprojects'
baseline when performing calculations.
If the external subprojects do not have a baseline with the same name as the master
project, this option will not have an effect on that external subproject.



The Filter section contains the following fields and options:
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Filter — Specify a filter to limit the baseline to a defined group of activities. To limit the scope
of the operation, you can either select an existing filter or create a new filter by clicking the
ellipsis displayed next to the Filter text box.
For information about defining filters, refer to Chapter 23, “Project Utilities.”





Exclude In-Progress Activities — Select this option to exclude in-progress activities from
the baseline.



Exclude Complete Activities — Select this option to exclude complete activities from the
baseline.

The Planned Activities section contains the following option:


Use Resource Remaining Quantity Instead of Budget Quantity — Select this option to
create baseline activity resource requirements from the remaining resource requirements,
instead of the budget resource requirements for activities that are not in-progress or
complete. This option is not available when the baseline is based on Schedule Dates.

Once you create a baseline, you can update it with the current project information at any time. When
updating an existing baseline, you can have Open Plan update information for activities already
present in the baseline as well as for new activities (that is, activities missing from the original
baseline).
When you copy an existing baseline, Open Plan displays the following dialog box:

When the Copy Baseline dialog box appears, the baseline is given the name COPY_<baseline
name>. You are able to change the name as well as the description if you so desire. You cannot,
however, change the dates that the baseline is based on.
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When you update an existing baseline, Open Plan displays the following dialog box:

Use this dialog box to enter the following information about the existing baseline:


Description — Update the description for the baseline.



Ignore Progress, Use Original Project Start Date — Select this option to create baseline dates
by performing a time analysis from the project start date. This option is not available when the
baseline is based on Schedule Dates.



Update External Subproject Baselines — This option is enabled only if the Use Baseline of
Same Name on External Subprojects option was selected when this baseline was created.
If this option is selected, in order for the external subproject baselines to be updated, you must
have rights to update the external baseline. These rights are granted in the Baseline Access
Control dialog for each of the external baselines. The Update In Master field must be set to Yes
for each external baseline to be updated.



The Filter section contains the following fields and options:


Filter — Specify a filter to limit the baseline to a defined group of activities. To limit the scope
of the operation, you can either select an existing filter or create a new filter by clicking the
ellipsis displayed next to the Filter text box.
For information about defining filters, refer to Chapter 23, “Project Utilities.”



Exclude In-Progress Activities — Select this option to exclude in-progress activities from
being updated



Exclude Complete Activities — Select this option to exclude complete activities from being
updated.
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Update Activities Already in Baseline — This option is allows you to control the action that
Open Plan should take for activities already in the baseline that you are updating:
Open Plan adds baseline information for new activities and, if this option is selected, updates
information for activities already present in the baseline. This is applicable to all activities that
meet the chosen filter, excluding those activities that fall under the Exclude InProgress/Completed Activities that meet the filter option.
If this option is not selected, Open Plan adds baseline information for only new activities (that
is, activities missing from the original baseline).
The following options are not enabled when the Update Activities Already in Baseline that
meet the filter option is not selected:





Update Activity Data (Codes, UDFs, Description) — Select this option to update
baseline activity data, including codes, user-defined fields, and description fields. This
includes all the fields that are populated during the creation of a new baseline except for
dates and resources that are controlled separately.



Replace Existing Baseline Dates — Select this option to instruct Open Plan to replace
the baseline dates of activities that already exist in the baseline. If selected, the baseline
dates will be replaced with either the current plan dates or the dates calculated by the
option ‘Ignore Progress, Use Original Project Start Date’ if selected.



Update Resource Quantities — Select this option to instruct Open Plan to update
baseline activity resource usage.


When baseline dates are to be replaced, the resources will be updated.



When not replacing the baseline dates, and if resources have changed, the current
quantity will be evenly spread across the original baseline dates or a subset of the
original baseline dates, depending on actual cost record dates and other factors.

The Planned Activities section contains the following option:


Use Resource Remaining Quantity Instead of Budget Quantity — Select this option to
update baseline activity resource requirements from the remaining resource requirements
instead of the budget resource requirements for activities that are not in-progress or
complete.
This option is not available when the baseline is based on Schedule Dates.



Roll-up Data to All Baseline Parents — Select this option to roll up all dates, budget cost, and
labor quantity data in the baseline to its parent level.



Delete All Activities no Longer in Current Project — Select this option to remove any activities
from the baseline that no longer exist in the current project.

To create a baseline, complete the following steps:
1. Select the appropriate project, and take one of the following actions:


On the Processes tab, click Baselines.



On the Summary tab of the Project Properties dialog box, click Select Baseline.

2. On the Baselines dialog box, click New.
3. On the Add Baseline dialog box, enter the information for the baseline, and click OK.
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To update a baseline, complete the following steps:
1. Select the appropriate project, and take one of the following actions:


On the Processes tab, click Baselines.



On the Summary tab of the Project Properties dialog box, click Select Baseline.

2. From the Baselines dialog box, select the baseline that you want to update, and click Update.
3. On the Update Baseline dialog box, update the information for the baseline, and click OK.
To copy a baseline, complete the following steps:
1. Select the appropriate project, and take one of the following actions:


On the Processes tab, click Baselines.



On the Summary tab of the Project Properties dialog box, click Select Baseline.

2. From the Baselines dialog box, select the baseline to copy, and click Copy.
3. On the Copy Baseline dialog box, enter a new name and description for the baseline if you so
desire, and click OK.
If you rename the baseline copy to the name of an existing baseline, Open Plan displays
the Overwrite Existing Baseline dialog box. Click OK to overwrite the existing baseline.

Defining Access Rights to a Baseline
You can define the access rights to a baseline for which you are the “owner.” By default, the owner of
a file or baseline is the user who creates the file or baseline. By creating the file, the owner is
automatically given full read/write access rights to the data and can grant rights to other users.
For information on defining access rights to projects, resource files, calendar files, code files, and
view templates, refer to Chapter 24, “System Utilities.”

When you select a baseline on the Baselines dialog box and click Access Control, the following
dialog box is displayed:

You can use the following fields to define access rights to the baseline:
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Group — This field allows you to grant access rights to an entire user group. User groups are
created within Deltek Security Administrator.



User ID — This field allows you to grant access rights to individual users. User IDs are created
within Deltek Security Administrator.



Copy — This field controls whether the group or user has the right to copy the baseline.



Delete — This field controls whether the group or user has the right to delete the baseline.



Update In Project— This field controls whether the group or user has the right to update the
baseline.



Update In Master - This field controls whether the group or user has the right to update this
baseline when this project is opened in the context of a master project. The master project must
have a baseline with the same name that was created with the Use Baseline of the Same Name
on External Subprojects option selected.
The Update in Project and Update in Master options are independent of each other.
For example, if Update in Project was set to No, and Update in Master set to Yes,
then the group or user will not be able to update the baseline if the project is opened on
its own, but will be able to update the baseline if the project is opened as an external
subproject.



View — This field controls whether the baseline is included on the Baselines dialog box for the
group or user.

To define access rights to a baseline, complete the following steps:
You must be the owner of the baseline or have SYSADMIN rights in order to define access rights to
it.

1. Select the project that contains the baseline to which you want to define access rights.
2. Take one of the following actions:


On the Processes tab, click Baselines.



On the Summary tab of the Project Properties dialog box, click Select Baseline.

3. From the Baselines dialog box, select the baseline, select the appropriate baseline, and click
Access Control.
4. On the Baseline Access Control dialog box, assign access rights to the baseline.
5. When finished, click OK.

Managing Baselines
Although your project can have more than three baselines, Open Plan allows up to three baselines to
be available for reporting purposes at a time. You also can change the current baseline(s) at any
time.
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The Summary tab of the Project Properties dialog box displays the current baseline(s) selected for
the project:

Current baseline(s)

This can also be seen in the Baselines dialog box:

From the Baselines dialog box, when you select <Multiple Baselines> and click the Select button,
Open Plan displays the Multiple Baselines dialog box:

For information on displaying the Baselines dialog box, refer to the previous section in this chapter.

You can use this dialog box to select up to three baselines for the project. If the PMB does not exist,
Open Plan uses the first selected baseline for cost calculations when you have multiple baselines
selected.
If you are not interested in having access to baseline information, you can also specify that no
baseline should be loaded with the project. When <No Baseline> is selected, this option has the
effect of reducing the memory requirements of a project, and thus has the potential of improving
performance. You can also select the Clear baseline data when No Baseline is selected option to
clear activity baseline data. This option is only enabled when you selected <No Baseline>.
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You can also use the Baselines dialog box to do this, by selecting <No Baseline>.
It is also possible to delete unneeded project baselines, which can help reduce the overall size of the
project data file.
To select a single current baseline, complete the following steps:
1. Select the appropriate project, and take one of the following actions:


On the Processes tab, click Baselines.



On the Summary tab of the Project Properties dialog box, click Select Baseline.

2. From the Baselines dialog box, select the baseline that you want as the current baseline.
If you do not want to load a baseline at this time, select <No Baseline> from the list.
3. Click Select.
To select multiple current baselines, complete the following steps:
1. Select the appropriate project, and take one of the following actions:


On the Processes tab, click Baselines.



On the Summary tab of the Project Properties dialog box, click Select Baseline.

2. From the Baselines dialog box, select <Multiple Baselines>.
Open Plan displays the Multiple Baselines dialog box.
3. Select up to three baselines, and click OK.
To delete a baseline, complete the following steps:
1. Select the appropriate project, and take one of the following actions:


On the Processes tab, click Baselines.



On the Summary tab of the Project Properties dialog box, click Select Baseline.

2. Select the baseline that you want to delete, and click Delete.
3. When Open Plan asks you to confirm the deletion, click Yes.

Using Baseline Information
Once you have loaded the baseline(s) for a project, you can access baseline fields just as though
they were part of the standard project database. To use these fields in a view, select a baseline field
(identified by the name of the current baseline) from the list of available field names:

When selecting fields, you can choose which of the current baselines you want to display. In a multitable view, you can link to all the current baselines and display the data for each on different rows.
In resource histogram views, you can display baseline resource assignments. These assignments are
based on either early, late, or scheduled dates, depending on which dates were used to create the
baseline. If you are displaying the results of earned value calculations, the calculations of BCWP and
BCWS are based on the Baseline Start and Baseline Finish fields stored with the baseline.
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If it exists, the performance measurement baseline (PMB) is always used for the calculation of
budget value regardless of whether it is selected or not.

You can also use baseline fields in filters, sorts, and calculated field expressions. Keep in mind,
however, that the values of baseline fields depend on which baseline is currently loaded for a project
and cannot be edited from within the view.
A common issue in many reports showing baseline information is that the set of activities stored in
the baseline no longer matches the set currently defined in the project. For example, the baseline
can include records of activities that were deleted in the project after the baseline was created. It is
also possible to have activities in the project that were added since the last time the baseline was
updated. In spreadsheet, barchart, and network views, therefore, baseline data appears only in
cases where an activity exists in both the baseline and the current project. In resource histogram
views, on the other hand, the resource and cost totals are based on all activities stored in the
baseline, even if they no longer exist in the current project.
It is also possible to define a spreadsheet view that will show the baseline activity data as the main
table in which case all baseline activities are visible. See chapter 20 for more information on
Spreadsheet views.
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Activity Progress
In general, entering status information about activity progress consists of specifying the following
information so that a revised time analysis of the project can be performed:


Has the activity started? If so, when?



Has the activity ended? If so, when?



If the activity has started but not yet ended, how long is the remaining duration?

It is important to make sure that all progress information up to Time Now has been entered. The Time
Now date (sometimes referred to as the status date) refers to the date for which all the progress data
in a project has been reported. Open Plan assumes that no future work for the project (including
activities which have not yet started and activities which have been started but not completed) can be
scheduled prior to the Time Now date. For example, a Time Now of 01Jun06 means that all progress
data in the project up to and including 31May06 has been reported, and that Open Plan does not
schedule any work for the project prior to 01Jun06.
Time Now is a date for statusing purposes only and does not have any relationship to the actual
current calendar date.

It is recommended that you enter actual dates for progressed activities whenever possible. If you omit
an actual start or actual finish date when entering project progress, Open Plan deduces the dates for
the purposes of internal calculations based on the status code entered and Time Now.
One proven way to gather progress information in a systematic fashion is to work from a turnaround
report created especially for the managers responsible for those particular activities. The managers
can use this document to enter their progress against a list of activities scheduled to be in progress
during a particular time period.
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Entering Activity Progress
To enter progress information in Open Plan, you can use the Activity tab of the Activity Progress
dialog box. You can display this dialog box in three ways:


By clicking the Progress button on the Activity Details dialog box



By selecting an activity and clicking Progress on the Edit tab in any activity view



By right-clicking the row button of an activity and clicking Progress on the context menu.

This dialog box displays the original duration of the activity along with the current date of Time Now
and the current status of the activity. You can also enter the following additional progress information
using this dialog box:


Actual Start — You can enter an actual start date for the activity. (Note that entering an actual
start date automatically changes the activity status from planned to in-progress.)



Actual Finish — You can indicate that the activity is complete by changing the activity status to
complete or by entering an actual finish date. If you enter an actual finish date without changing
the activity status, Open Plan treats the activity as complete during time analysis.



Expected Finish — You can describe the status of an activity by entering an expected finish
date. In this case, the remaining duration of the activity is calculated by Open Plan based on the
difference between that date and Time Now. If you enter an expected finish date that implies a
start date before Time Now, Open Plan treats the activity as in-progress during time analysis.
If you enter both an actual and an expected finish date for an activity, Open Plan ignores
the expected finish date except in cases where the actual finish date is after Time Now.



As Planned — You can indicate that the activity is progressing according to plan. (Notice
however, that Open Plan does not progress activities automatically unless you enter an actual
start date.)



Remaining Duration — You can enter the remaining portion of the activity duration.



Elapsed Duration — You can enter an elapsed duration since the start of the activity.



Percent Complete — You can enter a completion estimate as a percentage.



Complete — You can indicate that the activity is complete.
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The Elapsed Duration progress type is exported by updating MSP Actual Duration.
Like the Activity Details dialog box, the Activity Progress dialog box is modeless, which allows you to
keep it open while performing other operations in Open Plan. The navigation buttons and the Close,
Undo, and Apply commands function identically to their counterparts in the Activity Details dialog
box. You can, in fact, keep both the Activity Details dialog box and the Activity Progress dialog box
open at the same time, updating the information in either dialog box as appropriate.
By default, Open Plan synchronizes multiple activity dialog boxes so that using the navigation buttons
on one dialog box will result in Open Plan scrolling to the appropriate activity on another dialog box.
For information about disabling this feature, refer to Chapter 25, “System Defaults.”

To enter progress for an activity, complete the following steps:
1. In an activity view, select the activity for which you want to enter progress information.
2. Take one of the following actions:


On the Edit tab, click Progress.



Right-click the row button of an activity, and click Progress on the context menu.



Double-click the activity, and click Progress on the Activity Details dialog box.

3. On the Activity tab of the Activity Progress dialog box, enter the progress information for the
activity, and click Close.
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Entering Progress in a Spreadsheet View
To facilitate the entry of progress information for multiple activities, Open Plan provides a standard
progress spreadsheet view that you can use to enter any progress information:

When entering progress information using this view, note that the setting of the Progress Type field
determines how Open Plan interprets the Progress Value field. For example, if you entered Percent
Complete for the Progress Type field, Open Plan interprets the Progress Value field as a
percentage.
The Accomplished Duration and Remaining Duration fields are calculated by Open Plan and
cannot be modified by the user.

Entering Progress in a Barchart View
It is possible to status an activity displayed in a barchart view by manipulating the bar. By dragging
the cursor from the start of the bar toward the end of the bar, you can indicate how much of the
activity is complete.
For a bar to be eligible for manipulation, the bar type must display early dates and must have the
Drag option set to Yes. These settings are defined in the Bar Types dialog box.
For information about defining activity bar types, refer to Chapter 18, “Barchart Views.”

To enter activity progress in a barchart view, complete the following steps:
Bar Data Mode
button
Progress cursor

1. Verify that the view is in the bar data mode. You do this by selecting Bar Data mode from the
View tab.
2. Position the cursor to the left of the activity bar.
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3. When the cursor changes shape to a progress arrow, drag to the right to indicate the
percentage completion of the activity.

Viewing Project Progress Information
You can display project information at any time by opening a project and issuing the Properties
command. The Status tab of the Project Properties dialog box displays a summary of the current
project status:

You can also use this tab to enter information about the project such as Time Now or project target
dates and types.
For information about these fields, refer to Chapter 5, “File Properties.”

Any progress information you enter will have no effect on this summary until you recalculate the
project schedule using time analysis.
To view project progress information, complete the following steps:
1. Select the appropriate project.
2. Take one of the following actions:


On the Processes tab, click Properties.



Right-click the project, and click Properties on the context menu.

3. On the Project Properties dialog box, click the Status tab.
You can view the Project Properties dialog box without having to first open the project.

Chapter 16 Status Information
Deltek Open Plan 8.0 User Guide

356

Activity Progress

The Effect of Activity Progress Information
Once you have entered progress for activities, you can calculate new early start/finish and late
start/finish dates using time analysis and new scheduled start/finish dates using resource scheduling.
After progressing the activities, if you run resource scheduling without first running time analysis,
the scheduled start and finish dates calculated will be inaccurate.

The following guidelines explain how Open Plan uses the progressing information when it calculates
the new schedule.


If an activity has an actual start date but no other indication of activity status, Open Plan deduces
the elapsed duration of the activity by comparing the actual start date to the Time Now date.



If activity status and progress information imply that the activity is complete (for example, if the
elapsed duration of the activity exceeds its total duration), Open Plan assumes that the activity is
complete.



If an activity has out-of-sequence progress (that is, progress has been reported even though
activities deemed as predecessors in project logic have not been completed), Open Plan accepts
the information but issues a warning in the time analysis session log.



Open Plan ignores actual dates later than Time Now (although a warning is issued in the session
log).



Open Plan calculates progress on a subproject from progress entered at the activity level. Open
Plan ignores any progress entered at the subproject level.



After evaluating the progress information, Open Plan calculates the early and late dates for the
remaining portion of the activity duration only. (Completed activities have their late dates
calculated as though the activity duration was zero.) This convention allows Open Plan to retain
the maximum information for reporting purposes, including tracing out-of-sequence progress.
For a more complete discussion about how Open Plan interprets progress information, refer to
Chapter 9, “The Effect of Progress Information,” in the Deltek Open Plan Developer’s Guide.
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Resource and Cost Progress
In addition to entering information about the schedule status of activities, you can enter information
about resource costs, usage, and forecasts. Open Plan uses this information to calculate project
costs that can be displayed in views such as a cost histogram. If you enter a value for the physical
completion of an activity, you can also use this cost information to calculate the earned value of a
project.
Open Plan does not restrict you to entering progress for budgeted resources only. For example,
assume that you planned to use one resource for an activity but actually used another. Instead of
returning to the original assignment, deleting it, and entering an assignment for the new resource, you
can simply set the remaining quantity of the original assignment to the appropriate level and enter
progress information for the unbudgeted resource.
You can also enter costs that are not associated with any resource. Entering costs not associated
with a resource allows you to define costs at the activity level. These costs can be reported
separately from the costs you have entered at the resource level.
You can make as many entries for a specific resource as you wish. Each entry consists of a date or a
pair of dates defining the period for the cost and then the actual usage or costs. It is also possible to
enter a forecast of remaining usage for a resource. Once you enter progress for a resource and save
your changes, Open Plan automatically rolls up the information for the resource, displays the results
in the Previous fields, and clears the entry fields.
To enter resource progress information in Open Plan, use the Resources tab of the Activity Progress
dialog box. You can display this dialog box by selecting an activity and clicking Progress on the Edit
tab in any activity view or by right-clicking the row button of an activity and clicking Progress on the
context menu.

If you scroll through the fields displayed in this dialog, you can see the current actual costs and usage
for each resource as well as the budgeted costs and units for all assigned resources. Budgeted costs
of resources reflect any cost escalations defined for the resource based on the period of the original
assignment.
This dialog contains the following elements:


Activity Physical % Complete — An estimate of the percent of the work of the activity that is
complete.
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Changing the Activity Physical % Complete triggers a recalculation of the resource
physical percent complete. When you tab out of this field, the numbers automatically
update.

For example, assume that the activity consists of paving a 5-mile stretch of road. When the first
mile has been paved, you could enter 20 in this field to indicate that the work of the activity is
20% complete. This information is completely independent of the amount of the activity duration
that has elapsed.
Open Plan uses the information from this field to calculate earned value (budgeted cost of
work performed or BCWP) and does not affect any subsequent time analysis or resource
scheduling calculations.



Start Date — The start of the period covered by the actuals entered. The date in this field applies
to all of the resource progress records entered during the current session.



End Date — The end of the period covered by the actual quantity and actual cost values entered.
If a date is entered in this field, the actual values are spread between the start and end dates. If
this field is left blank, the actual values are applied on the start date. The date in this field applies
to all the resource progress records entered during the current session.



Resource — Each resource assigned to the activity is identified on two lines in this column.


On the first line, Open Plan displays the ID of the resource.



On the second line, Open Plan displays the description associated with the resource ID.

In addition, you can enter valid resource IDs in blank rows at the bottom of the table to indicate
actual quantity and actual cost for unbudgeted resources. You can also enter actuals on a row
that does not contain a resource ID to have Open Plan roll up the actuals to the activity directly.
If you indicated that Open Plan should use activity progress information to automatically
calculate resource progress, you cannot enter progress information for a budgeted
resource. For more information about the automatic calculation of resource progress, refer
to the “Calculating Resource Progress Automatically” section in this chapter and also
Chapter 7, “Resource Definitions.”



Phy. % — Open Plan displays the resource physical percent complete in this field. This is the
amount of the activity’s requirement for that resource that has been used.
Adjusting this value triggers a recalculation of the Activity Physical % Complete. When you tab
out of this field, the numbers automatically update.
For detailed information on how Open Plan calculates the physical percent complete at
both the activity level and resource level, refer to Chapter 12, “Cost Calculations,” in the
Deltek Open Plan Developer’s Guide.



Actual — This column controls the following types of data: START HERE


Qty — The actual quantity of the resource used during the period defined by the start and
end dates. You can enter actual quantity information for some resources and have Open Plan
calculate the actual quantity based on activity progress (by selecting that option on the
Resource Details dialog box) for others.
You cannot enter actual quantity information for a resource for which resource progress is
automatically calculated based on activity progress. (This setting is defined on the General
tab of the Resource Details dialog box.)
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Cost — The actual cost of the quantity of the resource used. You can enter actual costs
directly for some resources and have Open Plan calculate the actual cost based on
progressed quantity (by selecting that option on the Resource Details dialog box) for others.
You cannot enter actual cost information for a budgeted resource for which actual cost is
automatically calculated based on progressed quantity. For more information about the
automatic calculation of resource progress, refer to Chapter 7, “Resource Definitions,” and
the “Calculating Resource Progress Automatically” section in this chapter.



Remaining — This column controls the following types of data:


Qty — When you tab to this field from the actual quantity field, Open Plan calculates the
remaining quantity for resources assigned to the activity by subtracting the actual quantity
from the quantity of the original resource assignment. You may overwrite the value displayed
in this field. Open Plan ignores this value for unbudgeted resources or for costs entered at
the activity level without reference to a resource.
The remaining quantity can never be less than zero. Therefore, if you have entered an actual
quantity that is greater than the original resource assignment, Open Plan reports that the
remaining quantity is zero.
If you have decided not to use a resource assigned to the project, overwrite the remaining
resource assignment calculated by Open Plan with a zero.



Cost — When you tab away from the Actual Cost field, Open Plan displays the remaining
resource cost. Open Plan calculates this value as follows:
Budget Cost — Previous Cost
This value is calculated only for display purposes and is not stored in the database.
Since Open Plan ignores this value for unbudgeted resources or for costs entered at the
activity level without reference to a resource, it is important to adjust the remaining
quantities of budgeted but unused resources in cases where you have substituted
unbudgeted resources or activity-level costs.





Previous — This column displays the following types of data:


Qty — Open Plan displays the sum of all the actual quantity records for the resource entered
or calculated during previous sessions.



Cost — Open Plan displays the sum of all the actual cost records for the resource entered or
calculated during previous sessions.

Budget — This column displays the following types of data:


Qty — Open Plan displays the budget quantity for the resource calculated from the resource
assignment records.



Cost — Open Plan displays the escalated value of the resource’s budget cost in this cell.

To enter resource progress for an activity, complete the following steps:
1. Select the activity for which you want to enter progress information.
2. Take one of the following actions:


On the Edit tab, click Progress.



Right-click the row button of an activity, and click Progress on the context menu.
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Double-click the activity, and click Progress on the Activity Details dialog box.

3. On the Activity Progress dialog box, click the Resources tab.
4. Enter the dates for the progress information to be entered during this session.
5. Enter the resource progress information for the activity, and click Apply.
Open Plan responds by rolling up the information for the resource, displaying the results in
the Current Cost and Current Quantity fields, and clearing the entry fields.
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Calculating Activity Progress Automatically
The automatic progressing feature in Open Plan allows you to advance Time Now and update the
status information for all the activities of a project in a single operation. You must have performed
time analysis on the project at least once before Open Plan can calculate activity progress
automatically.
Open Plan can automatically generate actual start and finish dates and calculate activity progress
based on the early or late dates produced by time analysis, the scheduled dates produced by
resource scheduling, or baseline dates. For in-progress activities, you can have Open Plan
automatically calculate any of the following measures of progress:


Remaining duration



Elapsed duration



Percent complete



Expected finish

Typically, project managers might use the automatic progressing feature to calculate status for large
projects and then enter information for any exceptions manually. Automatic progressing does not
overwrite any existing actual dates, nor does it change the status of an activity marked as complete.
However, estimates of progress for in-progress activities may be modified by the operation.
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To have Open Plan calculate activity progress automatically, click Progress on the Processes tab to
display the following dialog box:
Progress
Calculations button

Normally, you would perform progress calculations before time analysis for the next progressing
period. If this is the case, you use this dialog box to set new Time Now values.

Use this dialog box to define the dates that Open Plan should use for calculating progress as well as
how in-progress activities should be handled.
You also have the opportunity to set the following options for the operation:


Time Now — By default, the current date populates this field. Click the ellipsis to select a
different date.
You can also specify the Time Now date on the Processes tab from the Schedule
group.



Matching Filter — To limit the scope of the operation, you may select either an existing filter or
create a new filter by clicking the ellipsis displayed next to the Matching Filter text box.
For information about defining filters, refer to Chapter 23, “Project Utilities.”



Update Activity Status and Actual Dates — Selecting this option allow you to specify the
following additional options:


Based On — You can specify which of the types of dates Open Plan should use in
performing the calculations:
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Early Dates



Late Dates



Scheduled Dates



Baseline Dates

Complete if Finished Before Time Now — If this option is selected, Open Plan treats the
type of dates selected in the Based on field as complete if they finish before Time Now and
enters the appropriate (early, late, scheduled, or baseline) finish date into the actual finish
date field.
The automatic progress function does not affect any actual finish dates already recorded
on complete activities.



In Progress if Started Before Time Now — If this option is selected, Open Plan treats
activities that meet all of the following criteria as in progress:


Activity starts before Time Now



Activity has an early finish date after Time Now



Activity is not already marked as complete
The automatic progress function does not affect any actual start dates recorded on
activities already statused as in-progress.

For activities that it treats as in-progress, Open Plan allows you to specify which of the
following values it should calculate:


Remaining Duration



Elapsed Duration



Percent Complete



Expected Finish



Update Resource Remaining Quantity — When selected, this option recalculates the remaining
resource quantity for each resource assignment for the activity. This option should be selected if
you want Open Plan to progress resource assignments for you. Otherwise, if you wish to
manually update remaining quantity, clear the option.



Update Resource Actual Quantity — When selected, this option calculates the actual resource
quantity used during the progress period. This will generate a resource Cost record time phased
using the Progress Start and End dates defined in the progress calculations dialog. If this option
is not selected then actual resource usage will need to be entered manually.



Update Physical Percent Complete


Base Physical Percent Complete on EVT — If the Base Physical Percent Complete on
EVT option is selected (and only when the option to update physical percent complete is
enabled) the Physical Percent calculated will take into account the Earned Value Type
(Performance Measurement Type) defined for the activity in the Advanced Tab of the Activity
Details dialog box. For example if the EVT is 50/50, then Open Plan will set the Physical
Percent Complete to 50% when the activity is started and to 100% when the activity is
completed. Otherwise, if this option is not selected, the Physical Percent complete would be
derived from Budget versus Remaining hours or time percent complete (if no resources are
assigned).
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Start Date — The Progress Start Date, together with the End Date, define the period over which
any Actual Resource Quantities and costs are spread. Typically, the Progress Start date is the
Time Now (status date) from the previous reporting cycle unless a greater degree of detail is
required. If more detail is required, it would represent the actual date the resource started to be
used and the costs that were incurred.



End Date — The Progress End Date, together with the Start Date, define the period over which
any Actual Resource Quantities and Costs are spread. Typically, the Progress End Date is the
time period before the Time Now (status date) of the current reporting cycle unless a greater
degree of detail is required. If more detail is required, it would represent the date the resources
stopped being used and the costs stopped being incurred.

Each time you perform automatic progressing, Open Plan creates a session log file that records any
system or error messages issued during the operation. Open Plan saves the file (Opp_prog.log) and
allows you to examine its contents at the conclusion of each session.
You must open a project in the exclusive mode to perform automatic progressing.

To calculate activity progress automatically, complete the following step:
1. On the Processes tab, click Progress Calculations.
2. Enter the information for the operation, and click OK.
Open Plan informs you if an error condition is detected during the session. You can use the
Log Viewer to examine the error in the session log.
For more information on the Log Viewer, refer to Chapter 24, “System Utilities.”
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Calculating Resource Progress Automatically
If you do not want to enter resource progress manually, you can have Open Plan calculate resource
progress automatically based on the current status of the activity. To use this feature, you must first
indicate on the General tab of the Resource Details dialog box that resource progress can be based
on activity progress:

Select to allow automatic resource
progressing.

After you enter progress information for activities, you can have Open Plan calculate the quantity of
resource units that correspond to the recorded activity progress for all eligible resources. For
example, if you have indicated that an activity is 50% complete, Open Plan calculates the number of
resource units corresponding to the first half of the activity duration, taking into account factors such
as spread curves, offsets, and periods, which may affect the distribution of the resource assignment.
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To have Open Plan calculate resource progress automatically, click Progress on the Processes tab
to display the following dialog box:
Progress
Calculations button

You can update the resource remaining quantity and the resource actual quantity separately or at the
same time. Open Plan performs the calculations based on options selected on the General tab of the
Resource Details dialog box for the resources defined as supporting progress calculations in the
Resource (OPP_RES) table.
Each time you perform automatic resource progressing, Open Plan creates a session log file that
records any system or error messages issued during the operation. Open Plan saves the file
(Opp_prog.log) in your Open Plan working directory, and allows you to examine its contents at the
conclusion of each session.
To see the results of this calculation, display the Resources tab of the Activity Progress dialog box.

To calculate resource progress automatically, complete the following step:
1. On the Processes tab, click Progress Calculations.
2. Enter the dates for the operation, and click OK.
Open Plan informs you if an error condition is detected during the session. You can use the
Log Viewer to examine the error in the session log.
For more information on the Log Viewer, refer to Chapter 24, “System Utilities.
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Group Processing Resource Progress
You can also perform progress calculations in Batch Mode. This allows you to run time analysis for
multiple projects at one time. To run progress calculations in Batch Mode, select more than one
project from the Details pane of the Open Plan Explorer, and click the Progress Calculations
button. The Progress Calculations [Batch Mode] dialog box will be displayed. Set your options, and
click OK.
If a project is closed, Open Plan will open it in Exclusive mode, perform the process, save the
changes, and then close the project. If a project cannot be opened in Exclusive mode (because
another user has it open in Exclusive or Shared mode), it will be skipped.
If you have a project open when the batch process is run, a progress calculation will be performed on
the project, but the changes will not be saved and the project will remain open. You must manually
save the changes yourself.
Resource progress can be calculated automatically for multiple projects by selecting a group of
projects and clicking the Progress Calculations button on the Processes tab.

Open Plan creates one progress calculation session log, listing the project results in the order in
which the projects were processed in the batch.
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Calculating Earned Value Progress Automatically
You can have Open Plan update the earned value of the project by selecting the Update Physical
Percent Complete option.

When the Update Physical Percent Complete option is selected and the Base Physical Percent
Complete on EVT option is not selected, Open Plan updates the physical percent complete for
activities that match the selected filter based on activity status using the following formula:
PPC = (Elapsed duration / Expected duration) x 100
Where:
Elapsed duration is calculated as (Time Now – Actual Start)
Expected duration is calculated as (Finish Date – Actual Start Date)
The Finish Date is based on the user’s selection of (early, late, or scheduled) dates.

The Base Physical Percent Complete on EVT option allows you to use the EVT assigned to the
activities on the Advanced tab of the Activity Details dialog box when updating the physical percent
complete.
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Progress Dates
The Start Date and End Date fields are enabled when you choose to update resource progress or
earned value.
Open Plan stores the BCWP time-phased. Therefore, you must enter a start date in the Progress
Dates section of the dialog box.

Open Plan uses the dates to spread actual costs and quantify for the purpose of cost reporting:


Start Date — The start of the period covered by the automatic resource calculation. The date in
this field is recorded as the From date on the resource actual quantity/cost record in the cost file.
If the actual start date of the activity is later than the start date defined in this field (but
within the Start date – End date range), the activity actual start date is used as the Start
Date in the progress calculation.



End Date — The end of the period covered by the automatic resource calculation. If a date is
entered in this field, the actuals are spread between the start and end dates. If this field is left
blank, the actuals are applied on the start date. The date in this field is recorded as the To date
on the resource actual quantity/cost record in the cost file.
If the actual finish date of the activity is earlier than the end date defined in this field (but
within the Start date – End date range), the activity actual finish date is used as the End
Date in the progress calculation.
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Overview

Overview
Views are the means through which you can add, update, and display information about a project in
Open Plan. Although you are free to create as many custom views as you wish, all Open Plan views
fall into one of the four following types:


Barchart view — A composite view displaying a barchart, a spreadsheet, and a resource/cost
histogram



Code view — A logic diagram of the project codes



Network view — A logic diagram of the project activities and relationships



Resource view — A display of the resource breakdown structure



Spreadsheet view — A display of project information in a tabular format. Spreadsheet views can
be based on a single table like activities or on multi-tables like resource and activities.



Histogram view — A display of resource/cost or risk analysis information in a graphical format



Tornado view – A display of risk information as a numerical barchart

You can designate predefined or custom views as favorites. You can do this by clicking the Add to
Favorites button or by using the Organize Favorites dialog box.
This chapter contains discussions of a number of topics related to the reporting of project data in
Open Plan:


Views



Printing reports



Reporting calendars

The chapter concludes with a discussion of the notes feature in Open Plan.
For information about features specific to a particular type of view, refer to the appropriate
chapter: Chapter 18, “Barchart Views”; Chapter 11, “Project Codes”; Chapter 19, “Network
Views”; Chapter 7, Resource Definitions”; Chapter 20, “Spreadsheet Views”; or Chapter 21,
“Histogram Views.”
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Views
All views in Open Plan are listed in the Open Plan Library. Here the views store all the information
about how Open Plan should display a particular view. You can customize an existing view and then
share the new view with multiple projects. However, since a view in the Library is not associated with
a specific project, it cannot display data. As a result, before you can open or change its definition, you
must first assign it to a project.
When you assign a view to a project, you create a link from the project to the view in the Open Plan
Library. If you modify the appearance of the view and save the view, your changes may affect other
projects that use that view.

Working with Views
You can assign a view to a project by using one of the following techniques:


Drag the view from the Open Plan Library to the appropriate project folder.



Double-click a view in the Open Plan Library to display a list of the projects that are currently
open. Then select one of the projects from the list for the assignment.



With a project open, click the Select icon on the Edit tab and choose Other Views. Chose from
the list of views in the Library and you will be asked it you would like to link the selected view to
the project.

Provided that the project to which you want to assign the view is open, Open Plan displays the
Choose a Project dialog box when you double-click a view in the Open Plan Library. If there are no
projects open when you double-click the view, Open Plan informs you that the view is not associated
with a project and advises you to drag the view from the library to the project folder to create a link.
A project does not need to be open if you use drag and drop to assign a view.

If you double-click a code view to attach to a code file or a resource view to attach to a resource
file, the dialog box displayed is titled Choose a Code File or Choose a Resource Pool
respectively and the appropriate open files are displayed. The functionality of the dialog boxes
remains the same.
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This dialog box allows you to do two things:


You can open a view without creating a permanent link to the project. This allows you, for
example, to sample the various views available in the Open Plan Library without filling the
project’s Views folder with view links that you do not need.



You can create a permanent link to the project for a view. Selecting the Make a Permanent Link
to Project setting instructs Open Plan to create a link to the view for the selected project. The
linked is placed in the selected project’s Views folder when you click OK
Open Plan remembers your selection for the next time you display the Choose a Project dialog
box. In other words, if you select the Make a Permanent Link to Project setting, the next time
you display the Choose a Project dialog box, this setting will automatically be selected.

If you make changes to a view, you can use the Save View command on the File menu to save your
changes or use the Copy View to display the Save Current View As dialog box:

You can use this dialog box to give the view a new name and description.
Open Plan also asks if you want to save your changes when you exit the view.
If you indicate that you want to save your changes, Open Plan displays a dialog box and allows you
to perform the following actions:


To update the original view with your changes, save the view under its current name.



To create a new view and leave the original one unmodified, save the view with a new name.
Open Plan automatically adds this new view to the Open Plan Library and creates a link to it in
the project folder.

To assign a view to a project, complete the following step:
1. Take one of the following actions:


Drag the view from the Open Plan Library to the project folder.



Double-click the view in the Open Plan Library, and use the Choose a Project dialog box
to select an open project.



Click Other Views on the Edit tab » Select menu from an open project and choose an
available view.

To open a view, complete the following steps:
1. Locate the view in the appropriate project folder.
2. Take one of the following actions:


Double-click the view.



Right-click the view, and click Open on the context menu.



Click Open a view located at the top of the left pane of the Open Plan Explorer and
select from the list.



Click Select on the Edit tab of an open project
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You can display a view without first having to open the project. When you display the
view, the project is automatically opened in default mode.

To save a view, complete the following steps:
1. Open the view you want to save.
2. Make any required changes to the view.
3. Take one of the following actions:


On the File menu, click Save View to save your changes.



On the File menu, click Copy View on the Save View submenu.

4. On the Save Current View As dialog box, enter the name and description for the view.
5. Click OK.
To remove a view from a project, complete the following steps:
1. From the project Views folder, select the view.
2. Take one of the following actions:


Press the Delete key.



Right-click the view, and click Delete on the context menu.

3. When Open Plan asks you to confirm the deletion, click Yes.
Deleting the view from the project folder merely removes the link to the view in the
Open Plan Library. The view is not removed from the database.

To remove a view from the database, complete the following steps:
1. From the Open Plan Library, select the view.
2. Take one of the following actions:


Press the Delete key.



Right-click the view, and click Delete on the context menu.

3. When Open Plan asks you to confirm the deletion, click Yes.
Deleting the view from the Open Plan Library removes the view from the database and
any links to it in the project folders.

Favorite Views
After assigning a predefined or a custom view to a project, you can use the Add to Favorites button to
designate the view as your favorite.
The feature allows you to easily access a favorite view.
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You can also use the Organize Favorites dialog box to manage your favorite views. For more
information, see Chapter 03, “Getting Started”.

Add to Favorites
button

To designate a view as a favorite, complete the following steps:
1. Open a view.
2. Click the Add to Favorites button from the Favorites group of any View tab.

Browser Views
A browser view allows a Windows shortcut, Internet shortcut, or Open Plan Add-In to be stored as a
view in the Views folder of the Open Plan Library. The browser view can then be accessed directly
from this folder. It can also be assigned to a project, resource, or code so that it is opened in a
particular context.
Once created, a browser view can be used the same as any other view.

Clicking Browser Views on the Tools tab, displays the Browser Views dialog box populated with all
previously defined browser views: You can create, copy, edit, and delete browser views from this
dialog box.

If you click the New button, the New Browser View dialog displays:

In the Name field, enter a name for the new browser view and click OK. Open Plan displays the
Browser View Definition dialog box that you can use you to define the elements of the view:
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The following fields are displayed on this dialog box:


Name — Displays the name of the browser view and cannot be edited unless you are copying a
browser view, in which case the default name displayed is Copy_<name>, where <name> is the
name of the existing browser view.
While you cannot use this dialog box to change the name of an existing browser view,
you can change the name in the Open Plan Explorer. Right-click the browser view in
the Open Plan Explorer that you wish to change, and click Rename on the context
menu.



Owner — Displays the name of the user who created the browser view. This field is required and
cannot be edited in this dialog box.
If you are the owner of a browser view or you have system administrator access, you
can use the Access Control tab of the view’s Properties dialog box to change the
owner.



Description — Displays the description of the browser view. This field is optional and can be
edited at any time.



Command — Displays the command line to be executed when the browser view is run. For
example, the command line could be the path to an executable file or a WebWindow. It can also
be a URL to a specific Webpage.
You can enter a fully realized command line or you can make the command relative to either the
Open Plan System folder or User folder. To make the command relative to the System folder,
you would preface the command with <SYSDIR>. To make the command relative to the User
folder, you would preface the command with <USERDIR>.
Example: Assume you want to make a custom integration available as a view in Open Plan. You
can take one of the following actions:


Specify a fully qualified file name, such as C:\Program Files\MyCompany\MyApp.exe.



If the application is installed under the Open Plan installation folder, you can use
<SYSDIR>Sample Tools\VBApps\MyApp.exe.
You have the option to specify parameters, such as %P and %A, in the Arguments
field.

If you wanted to create a browser view to your company Web site, you would enter a fully realized
URL address for the command. For example,
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http://deltek.com/
To make the Web site open in an internal Open Plan window, add %i in the
Arguments field.



Arguments — You can specify any number of the following parameters to be passed
automatically to the application on the command line. Open Plan supplies these parameters on
the command line when launching the browser view.
Parameter

Description

%P

The currently selected project (View or Open Plan Explorer)

%S

The currently selected project in Open Plan Explorer

%A

The currently selected Activity ID

%R

The currently selected Resource file (View or Open Plan Explorer)

%r

The currently selected resource

%b

The currently selected code

%B#

Passes the name of the code file in position # in the active open
project

%C

The currently selected calendar name (View or Open Plan Explorer)

%c

The currently selected calendar

%M

Allow multiple concurrent instances of the selected tool

%U

The currently logged in user’s ID

%W

The encrypted password for the current user

%V

The current view

%E

Launch the file/link in an external Internet browser window

%I

Allows Internet browser to open within an Open Plan window. If the
%I is specified, Open Plan formats the other parameters as a URL
query string (for example, %P and %A will be passed as
?P=ProjectName&A=ActivityId)
Note: If data specific parameters are used, Open Plan will reload
the page that was initially loaded in the internal window with an
updated query string each time the selected value (project, activity
ID, resource, etc.) changes.

%T
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Parameter

Description

%D

Launches the file/link in a dockable internal browser

%X

Maximizes an internal browser window

<SYSDIR>

Open Plan System Directory: Deprecated Syntax

<USERDIR>

Open Plan User Directory: Deprecated Syntax

%SYSTEMDIR%

Open Plan System Director (Location of OPP30.EXE)

%USERDIR%

Open Plan User Directory (Location of Open Plan user files)

%APPLICATIONDIR%

Open Plan Application Directory (Location of Config.dat)

%LOGDIR%

Open Plan Log Directory (Location of Open Plan log files)

%WINUSERNAME%

Windows User Name

%OPPUSERNAME%

Open Plan User Name

%OPPUSEREMAIL%

Open Plan user Email (From the Open Plan User account)

If the %I, %D, or %E argument is specified, Open Plan attempts to execute the command line
using a browser object or application, respectively. In this situation, you may specify a data file
to be launched (in conjunction with an application) or a URL. If the executable must be specified
in the command line, omit the %I (for example, Wordpad.exe MyNotes.txt). In this case, the
executable is launched within its own (external) window. If the document type is associated on
your computer with an application, an internal browser view may be created using the syntax
<Document_Name> %I (for example, MyNotes.txt). Remember, if you use either the %I or %E
parameters, you need to specify the document to be launched, rather than the application that
will launch it. In addition, if a Visual Basic application is launched, you should not use any of the
Internet-specific parameters because Open Plan will "canonicalize" the command-line (that is,
question marks will be inserted before the arguments). Since VB applications do not understand
"canonicalized" arguments, they will fail.

Windows-type shortcuts must be brought up externally if the command line references an application.
The shortcuts may be brought up internally if they reference a document whose associated launch
application is known to the system.
Internet links may be brought up as either internal (the Internet browser is contained within an Open
Plan window) or external (the browser itself is launched as a separate application) browser views.
The custom WebWindows that are shipped with Open Plan as part of the Add-Ins tab can easily
be added as browser views. Refer to "The Addins.dat File" section of Chapter 4, "The Open Plan
Configuration Files," in the Deltek Open Plan Developer's Guide for command line and argument
parameter information for each WebWindow.



Access Control — Select this option to grant rights to other users in the data source to use the
definition.
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For more information on available WebWindows, refer to Chapter 4, “The Open Plan
Configuration Files,” in the Deltek Open Plan Developer’s Guide.
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Custom Symbols
You can include custom symbols in many Open Plan Views. For example, you can use a custom
symbol for the left and right end of a bar type in a barchart view, or you can include a custom logo in
the title block of a printed report.
The Symbols dialog box allows you to add, edit, and delete Open Plan custom symbols.

This dialog box has the following controls:


Shape — This pane of the dialog box contains a list of currently defined shape categories. The
categories are an easy way to organize the numerous symbols included with Open Plan as well
as custom symbols you might add. Selecting a category displays the symbols included in that
category in the Symbols pane. Two special categories are also included:


<All Shapes> — Selecting this category displays all the symbols in all the shape
categories.



<Uncategorized Shapes> — Selecting this category displays those shapes that have
not been assigned to a category. The <Uncategorized Shapes> category does not
appear if there are no uncategorized shapes in the system.



Symbols — This pane of the dialog box contains a list of the symbols that are currently available
in the selected category. When you select a symbol in this list, it is displayed as a preview on the
right side of the dialog box.



Add — Clicking this button displays the Add Symbol dialog box that you can use to locate and
select a file to use as a custom symbol. Open Plan allows you to use both Meta Files (.wmf) and
Enhanced Meta Files (.emf) graphics.



Edit — Selecting a symbol from the list and clicking this button displays the Edit Symbol dialog
box that you can use to edit the description and shape category of the symbol.



Delete — Selecting a symbol from the list and clicking this button instructs Open Plan to delete
the symbol. Before actually performing the action, however, Open Plan asks that you confirm the
deletion. If you delete the last symbol in a category, the category is removed from the list of
categories.
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To display the Symbols dialog box use one of the following methods, complete any of the
following steps:
Method 1
1. On the File menu, click Preferences » Application. The Options dialog box opens.
2. On the General tab of the Options dialog box, click Symbols.
Method 2
1. On the View tab, click Title Blocks.

Title Blocks
button

2. On the Title Blocks dialog box, click either New or Edit to display the Title Block Definition
dialog box.
3. On the Title Block Definition dialog box, click the ellipsis under the Logo preview.
Method 3
1. On the View tab, click Bar Sets.

Bar Set button

2. On the Bar Sets dialog box, click either New, Copy, or Edit to display the Bar Set
Preferences dialog box.
3. Click Bar Types.
4. From the grid on the Bar Types dialog box, select a cell in either the Left or Right column.
5. Click the ellipsis next to the entry field at the top of the dialog box.

Using the Add Symbol Dialog Box
The Add Symbol dialog box allows you to locate custom symbols and add them to Open Plan for use
in numerous views:

This dialog box contains the following controls:


Name — The filename for the custom symbol you wish to add.



Select File — Clicking this button displays an Open dialog box that you use to locate the Meta
File (.wmf) or Enhanced Meta File (.emf) graphic file for the symbol. Selecting the file and then
clicking Open places the filename in the Name field.



Description — Additional information you wish to include about the symbol. The description
appears next to the symbol name in the Symbols pane of the Symbols dialog box.



Shape Category — You can create a new shape category by entering a unique name in this
field. Otherwise, entering an existing category name places the new symbol in that category.
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To add a custom symbol, complete the following steps:
1. On the Symbols dialog box, click Add.
2. On the Add Symbol dialog box, click Select File.
3. Using the Open dialog box, navigate to the desired .wmf or .emf file, and select it.
4. Click Open.
5. Enter a description for the new symbol. (This step is optional.)
6. Enter a shape category for the new symbol.
Leaving this field blank will place the new symbol in the <Uncategorized Shapes> category.
7. To return to the Symbols dialog box, click OK.

Using the Edit Symbol Dialog Box
The Edit Symbol dialog box allows you to edit the description and shape category of a selected
symbol:

To edit an existing symbol, complete the following steps:
1. From the Symbols dialog box, select the symbol to edit.
2. Click Edit.
3. On the Edit Symbol dialog box, enter a new description and shape category.
4. When finished, click OK.
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Printing Reports
You can output any Open Plan view or data file display to external devices such as a printer or a
plotter to produce a report. Open Plan functions related to the creation of reports include:


The Print command



The Print Setup command



General print options



Print options for barcharts and histograms



The definition of title blocks



The Print Preview command

Each of these functions is described in the following sections.
You should have a default printer selected in Windows before using any of the above options.
For information about setting up a default printer in Windows, refer to either the Windows
documentation or the documentation supplied with the printer.

Using the Print Command
The operation of the Print command differs slightly depending on the type of report you are
producing.
When you select the Print command from barchart views, network views, spreadsheet views,
histogram views, resource displays, or code displays, Open Plan displays the following dialog box:

Using this dialog box, you can enter the following settings about the print operation:


Printer — You can select a default printer as well as a specific printer for a report.
To set advanced options for your output device, click Properties. The options that can
be set using this dialog box depend on the device type.



Print Range — You can print all the pages of the view or define a range of pages to print.
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The Selection option is not supported in Open Plan.



Copies — You can specify how many copies of the report to be print.



Collate — Depending on the capabilities of your output device, you can indicate if multiple copies
of the report should be collated.

When you select the Print command from a calendar display, Open Plan displays slightly different
versions of the Print dialog box that allow you to define the range of data to print by entering a time
span.
To produce a report, complete the following steps:
1. Take one of the following actions:


Press Ctrl+P.



On the File menu, click Print » Print.



From the Quick Access Toolbar, click the Print button.



From the Print Preview tab, click the Print button

2. Enter the information for the report.
3. When the information is correct, click OK.

Using the Print Setup Command
You can use the Print Setup command to select a printer and related information. When you click
Print » Print Setup on the File menu, Open Plan responds by displaying the following dialog box:

You can use this dialog box to enter the following information:


Printer — You can select a default printer as well as a specific printer for a report.
To set advanced options for your output device, click Properties. The options that can
be set using this dialog box depend on the device type.



Paper — You can specify a size and tray source for paper.
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Orientation — You can specify either portrait (vertical) or landscape (horizontal) orientation for a
report. This setting is saved with each view.
If you change the Orientation option in the Print Setup dialog box, Open Plan
automatically changes the Orientation option in the Print Options dialog box as well.



Network — Clicking this button allows you to connect to a shared network printer.

To use the Print Setup command, complete the following steps:
1. Take one of the following actions:


On the File menu, click Print » Print Setup.



From the Print Preview tab, click the Setup button

2. Enter the information for the printer, page size, and orientation.
3. When the information is correct, click OK.

General Print Options
The Print Options command allows you to define a number of parameters that affect the general
appearance for reports based on any type of view or display other than a calendar display. If you
select this command, Open Plan displays the following tabbed dialog box:

The Preview button will not be available when you invoked the Print Options dialog box from the
Print Preview pane.

You can use the General tab of this dialog box to enter the following settings:


Margins in Inches — Open Plan allows you to enter the top, left, right, and bottom margins in
1/100ths of an inch. These values are added to any margins defined for the output device driver
and are saved with the view.
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Orientation — You can specify either portrait (vertical) or landscape (horizontal) orientation for a
report. This setting is saved with each view.
Changing the Orientation option in the Print Options dialog box has no effect on the setting of
the Orientation option in the Print Setup dialog box.



Include Notes — You can specify the type (project, activities, resources, or codes) and category
for notes included in the report.
For more information about notes, refer to the “Notes” section in this chapter.



Select Categories — Clicking this button displays the Select Note Categories dialog box that
contains a list of all defined note categories in the data source. Simply select the note category
you want, and click OK.

You can select multiple categories from the list in the Select Note Categories dialog
box.



Display Line Numbers in Spreadsheet — If you are printing a spreadsheet report (or the
spreadsheet portion of a barchart report), you can have Open Plan number the rows of the report.



Suppress Color in Spreadsheet Headings — Selecting this option instructs Open Plan to
suppress the use of color in spreadsheet column headings and to print column headings with
black text on a white background.



Expand Columns to Fill Page — This option applies to barchart views. Selecting this option
instructs Open Plan to stretch columns in a spreadsheet to eliminate white space between the
spreadsheet and barchart panes of the view.

To set general print options, complete the following steps:
1. Take any of the following options:


On the File menu, click Print » Print Options.



On the Quick Access Toolbar click the Print Preview button, then click Options.

2. Enter the information for the report.
3. When the information is correct, click OK to return to the view.
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Print Options for Barcharts and Histograms
If you are displaying a time-scaled view such as barchart or histogram at the time you use the Print
Options command, the Print Options dialog box includes a View tab:

Use the View tab to enter the following settings:


Date Range — You can enter a specific range of dates for the report, or you can have Open Plan
calculate the range of dates for you using the Calculate button.



Calculate — Clicking this button displays the Date Range Options dialog box that you can use to
specify how Open Plan should calculate the range of dates for the report.
For more information, refer to the “Using the Date Range Options Dialog Box” section
later in this chapter.



Horizontal — This option controls whether Open Plan should adjust the horizontal scaling of the
report to fit to a specified number of pages.



Spreadsheet — If you are printing a barchart report, you can indicate whether Open Plan should
include the spreadsheet portion of the view when producing the report. You have the option of
printing all columns or just those columns visible on the screen. For multi-page barchart reports,
you can also indicate whether the spreadsheet columns should appear on all pages or on the first
page of the report only.



Resource Data — For barchart reports, you can indicate whether Open Plan should include the
histogram pane of the view when producing the report. For multi-page barchart reports, you can
also indicate whether the histogram should appear on all pages or only on the last page of the
report.



Legend — For barchart reports, you can include a legend for the different bars. This legend can
appear on each page of the report in one of the following locations:


Upper left corner



Upper right corner
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Lower left corner



Lower right corner
You must have the appropriate title block enabled to display a legend in a report. For
information about title blocks, refer to the “Defining Title Blocks” section in this chapter.

To set view print options, complete the following steps:
1. Take one of the following actions:


On the File menu, click Print » Print Options.



On the Quick Access Toolbar, click the Print Preview button, then click Options.

2. Click the View tab.
3. Enter the information for the report, and click OK to return to the view.

Using the Date Range Options Dialog Box
The Date Range Options dialog box allows you to specify how Open Plan should calculate the date
range that is displayed in a printed barchart, resource histogram, and risk histogram view. Clicking
Calculate on the View tab of the Print Options dialog box displays the following:

You can instruct Open Plan to base the date range on any of the following:


Range of Data — Bases the date range on the range of data in the barchart, resource histogram,
or risk histogram view. The data that is included in the printed report can include a larger date
range than that currently displayed in the view.



Current Display — Bases the date range on what is currently displayed in the barchart, resource
histogram, or risk histogram view. If you resize the window in which the view is displayed, Open
Plan recalculates the date range to print only the data that is actually displayed.



Time Now —Bases the date range on your settings relative to Time Now.



Project Start — Bases the date range on your settings relative to the date the project started.
Also, if you choose to base the date range on either Time Now or the project start date, Open
Plan enables the following additional options:



Start printing at offset — Using these fields, you can specify the starting date on the printed
report as a specified number of hours, days, weeks, months, quarters, or years before or after the
Time Now date. (Entering a negative number in this field tells Open Plan to start the report before
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the Time Now date, while entering a positive number tells Open Plan to start the report after that
date.)


Finish (offset from start) — Using these fields, you can specify the last date on the printed
report as a specified number of hours, days, weeks, months, quarters, or years after the start
date of the printed report.



Finish at Project Finish — If you select this option, Open Plan uses the last date in the project
as the last date in the printed report.

To display the Date Range Options dialog box, complete the following steps:
1. Take any of the following actions:


On the File menu, click Print » Print Options.



On the Quick Access Toolbar, click the Print Preview button, then click Options.

2. Click the View tab.
3. On the View tab, click Calculate.

Print Options for Network Views
It is only in the Network View that you can adjust the physical size of the print output, as well as
specify the size of the output and fit your output on the number of pages you indicate. These options
can be set in the View tab:

Use the View tab to enter the following settings:


Adjust to — You can specify the size you want the view to be printed. This option adjusts the
physical size of your output.



Fit to — This option is used to size the output to fit on the number of page(s) you have indicated.

To set view print options, complete the following steps:
1. Take one of the following actions:


On the File menu, click Print » Print Options.
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On the Quick Access Toolbar, click the Print Preview button, then click Options.

2. Click the View tab.
3. Enter the information for the report, and click OK to return to the view.

Defining Title Blocks
A title block can display information about the project such as the project name, Time Now, or the
project start and finish date as well as a legend of the different bars for barchart reports:

To define a title block for a report, click Title Blocks on the View tab from the Printing group to display
the following dialog box:
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From this dialog box, you can create, copy, edit, or delete a title block. Clicking New, Copy, or Edit
displays the following dialog box:

If you edit an existing title block, you cannot change its name.

The Title Block Definition dialog box allows you to define the contents for as many as six different title
blocks for the report:


Top left



Top center



Top right



Bottom left



Bottom center



Bottom right

You can specify the percentage of the header or footer that a title block can occupy by defining the
location of divider lines marking the left or right title blocks. For example, by setting the divider lines
for both left and right title blocks to 25%, you can define a header in which the central title block
occupies 50% of the available space, or you can have Open Plan calculate the required width by
using –1.
The contents of each defined title block can contain up to 5 lines of text defined and formatted by the
user. Open Plan automatically aligns text appearing in title blocks as follows:


Text appearing in a top left or bottom left title block is left-aligned in relation to the left page
margin.



Text appearing in a top center or bottom center title block is centered.
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Text appearing in a top right or bottom right title block is left-aligned in relation to the divider line.

Each line can include literal text as well as text fields stored by Open Plan. To see the available text
fields, click Fields to display the following dialog box:

Text fields include the following types of information:


The project name, description, and manager



The project start and finish dates



The name and description of the current project baseline



The names of the project calendar and resource files



The client or company name (entered on the Summary tab of the Project Properties dialog box)



The current page number of the report



The total number of pages in the report



Time Now



The system date and time



The filter or sort that is currently in effect



The view description (entered using the Properties dialog box)

You can combine variable text items with literal text to define title blocks such as:


Report Created for <Client>



Time Now: <Time Now>



Page <Current Page> of <Total Pages>

A title block can also include a user-defined logo. To specify the logo for a title block, select Include
and use the ellipsis button to display the Symbols dialog box that you use to select the logo.
For more information on using the Symbols dialog box, refer to the “Custom Symbols” section
earlier in this chapter.

The Access Control option is used to grant rights to other users in the data source to use the
definition.
The References option displays the References dialog box, which has a list of items that use the title
block. This list of items includes the file type, name of the project or file, description, and owner.
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To define a title block for a report, complete the following steps:
1. On the View tab, click Title Blocks.
2. On the Title Blocks dialog box, take on of the following actions:


To create a new title block, click New.



To copy an existing title block, select the title block, and click Copy.



To edit an existing title block, select the title block, and click Edit.

3. Enter the information for the title block.
To include variable text in the title block, place the insertion cursor in the entry box for a line,
and click Fields.
To define the boundaries for a left or right title block in the header or footer, enter a value for
the Divider Line setting.
This setting is not available for center title blocks.

To insert a graphic to appear as a logo in a title block, select Include, display the Symbols
dialog box, and select the appropriate graphic file.
4. When the information for the report is correct, click OK.
5. To return to the view, select the title block, and click OK.
Print Preview
button

To see a preview of the printed report, click Print » Print Preview on the File menu, or click
the Print Preview button on the Quick Access Toolbar.
To insert a right-alignment tab in a left title block or a left-alignment tab in a right title
block, use /t.
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Previewing a Report
The Print Preview command allows you to see exactly how a report will be printed based on the
current settings in the Print, Print Setup, Print Options, and Title Blocks dialog boxes.

Zoom cursor

The print preview window includes a zoom cursor that allows you to zoom in on any portion of the
report you want to examine in greater detail.
Other features available as buttons in the print preview window include:


Print — Prints the report



Setup — Changes the printer and the printer settings



Options — Changes the printing options for the view
This button is disabled when you are previewing a Calendar view. Calendar views do not have
options to set.



Capture — Creates a .jpg image of the report in a directory you specify
This button is disabled when you are previewing multiple pages. You can view multiple pages by
clicking the Two Page option from the Zoom group.



Zoom In — Magnifies the display of the indicated area of the report



Zoom Out — Shrinks the display of the report in the window



One/Two Page — Toggles the display between showing one page or two pages of the report



Next Page — Displays the next page of the report



Prev Page — Displays the previous page of the report



Close — Closes the print preview window and returns to the current view

To preview a report, complete the following steps:
1. Take one of the following actions:


On the File menu, click Print » Print Preview.



On the Quick Access Toolbar, click the Print » Print Preview button.
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Open Plan displays a print preview window of the current view.
To zoom in on an area of the window, click the desired area with the zoom cursor.
2. To return to the view, click Close.
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Reporting Calendars
Reporting calendars allow you to view time-scaled data in a barchart or histogram view using a nonlinear date scale. Using reporting calendars you can, for example, display a histogram that shows
resource usage on a monthly basis for the next three months, on a quarterly basis for the four
quarters following that, and on a yearly basis for the remaining years of the project.
Reporting calendars are a useful reporting tool since planners and project managers tend to be more
interested in detailed information for events happening relatively soon. For events happening in the
more distant future, on the other hand, information summarized to a higher level is often perfectly
adequate and may be more understandable.
You can define multiple reporting calendars that can be used with any project. This makes it easy to
create views and reports that show the same data summarized against different sets of reporting
periods. Using this feature you can, for example, set up one view that shows the project cost
estimates against your standard fiscal reporting periods and another view that shows the same data
using the client’s reporting periods.
To see the list of available reporting calendars, click Reporting Calendars on the Tools tab to display
the following dialog box:

To define a reporting calendar, you can enter a set of cut-off dates and labels using the following
dialog box:

Notice in this example how labels are used to indicate whether the dates represent the end of a
month, a quarter, or a year.

For data prior to the first date, Open Plan uses the first reporting periods to extrapolate the period
interval in order to report the data. For data after the last date, Open Plan extrapolates the period
interval using the last two reporting periods. For example, assume you have defined the reporting
calendar to report data in weeks for 4 weeks and then in months for 11 months. For data prior to the
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first date in the reporting calendar, Open Plan will use the first two reporting periods to determine the
period interval is weeks and report the data accordingly. Data following the last date in the reporting
calendar is displayed in months.
For information about using a reporting calendar in a barchart or histogram date scale, refer to
Chapter 18, “Barchart Views.”

To create a reporting calendar, complete the following steps:
1. On the Tools tab, click Reporting Calendars.
2. On the Reporting Calendars dialog box, click New.
3. In the Add Reporting Calendar dialog box, enter a name for the reporting calendar, and click
OK.
4. In the Edit Reporting Calendar dialog box, enter the cut-off dates and the labels for the
reporting periods in the calendar.
5. When the information for the reporting calendar is complete, click OK to return to the
Reporting Calendars dialog box.
To edit a reporting calendar, complete the following steps:
1. On the Tools tab, click Reporting Calendars.
2. Select the reporting calendar you want to update, and click Edit.
3. In the Edit Reporting Calendar dialog box, update the dates and labels for the reporting
calendar.
4. When the information for the reporting calendar is complete, click OK to return to the
Reporting Calendars dialog box.
To copy a reporting calendar, complete the following steps:
1. On the Tools tab, click Reporting Calendars.
2. Select the reporting calendar you want to copy, and click Copy.
3. In the Copy Reporting Calendar dialog box, enter a new name for the copy, and click OK to
return to the Reporting Calendars dialog box.
To delete a reporting calendar, complete the following steps:
1. On the Tools tab, click Reporting Calendars.
2. Select the reporting calendar you want to delete, and click Delete.
3. When Open Plan asks you to confirm the deletion, click Yes.
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Assigning a Reporting Calendar
You can specify a default reporting calendar on the Cost tab of the Project Properties dialog box:

The Reporting Calendar field is used as a default reporting calendar for the date scale if the
reporting calendar option is chosen. When creating or updating a baseline, Open Plan uses the data
in this file to break any usage records that span more than one calendar period into additional
records.
While this feature may be used with any Open Plan project, it is particularly useful to Cobra
users as it improves the ability of Cobra to display Open Plan baseline information accurately.
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Notes
As an aid to reporting, Open Plan allows you to attach notes consisting of text information to the
following:


Projects



Resource files



Code files



Activities



Individual resources



Individual codes

These notes can be included in reports based on many of the standard project views.
To attach a note to a project, resource file, or code file, display the appropriate Properties dialog box,
and click the Notes tab. To attach a note to an activity, individual resource, or individual code, display
the appropriate Details dialog box, and click the Notes tab.
The Notes tab uses the same format regardless of the dialog box:

You can use the following fields to attach a note to an object:


Note — This text box can contain up to 29 KB of text. You can enter the text by typing directly in
this field or by using the Windows Cut (Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) commands to
insert text from another Windows application such as a word processor or spreadsheet.



Category — This field controls the category of the note. You can select a category from the list of
global categories.
Clicking the abc button checks the spelling of the text you enter.
An asterisk (*) next to a category name means that the category has a note.
You can enter links to files, Web pages, and e-mail addresses by entering the information in one
of the following formats:
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File links must be entered in the format of: file://c:\document.doc
If The file link you enter contains spaces, you must enclose the link with angle brackets
( < > ) in order for the link to work properly: <file://C:\Documents and Settings\All
Users\Desktop\test.txt>



Universal Resource Locators (URLs) must be entered in the format of: http://deltek.com



E-mail addresses must be entered in the format of: mailto:sales@deltek.com
While you can use drag and drop functionality to create links in the Note field, the
Windows Cut (Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) commands are not
available for links.

Once you enter a note for an activity, resource, or code, Open Plan marks the object so that you can
see which items have notes attached. In a spreadsheet view, for example, Open Plan adds a note
icon to the selection button:

Indicates activity has note attached.

When displaying a resource or code structure, on the other hand, objects with notes are indicated by
the lower right corner of the element box being shaded:

To delete a note attached to an object, simply delete all the text displayed in the Note text box.

Using Note Categories
Note categories allow you to group related types of notes for reporting purposes. For example, you
might want to set up two categories of notes: one for information related to subcontractors and
another for documenting changes in scope that occur over the course of a project.
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To define note categories, click Notes on the Tools tab to display the following dialog box:

From this dialog box you can add a category, edit the name of an existing category, or delete a
category.
If you delete an existing category, Open Plan deletes all the notes assigned to that category.

Once you have set up categories, they are stored in the database and are available to all projects,
resource files, and code files. You can assign a particular note to one of the defined categories from
the Category list displayed above the Note text box:

To define a note category, complete the following steps:
1. On the Tools tab, click Notes.
Open Plan displays the Note Categories dialog box.
2. From the Table list, select a table for which to create the note category.
3. Click New.
4. Enter a name and description for the new note category, and click OK.
To edit a note category, complete the following steps:
1. In the Tools tab, click Notes.
2. In the Note Categories dialog box, select the note category to edit.
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3. Click Edit.
4. Enter a new description, and click OK.
You can edit only the Description of a note category.

To delete a note category, complete the following steps:
1. In the Tools tab, click Notes.
2. In the Note Categories dialog box, select the note category to delete.
3. Click Delete.

Including Notes in Reports
You can produce reports that include notes from any activity view (with the exception of relationship
and assignment spreadsheets), resource display, or code display. For activity-based reports, you can
include project notes, activity notes, or both.
To include notes in a report, display the General tab of the Print Options dialog box:
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Click Select Categories to display the Select Note Categories dialog box:

To print all the notes attached to items in the report, select all the categories by either Shift+clicking
or Ctrl+clicking the categories.
When you include notes in a report, Open Plan displays them on one or more separate pages
following the main body of the report. Each note is labeled with the category, the author (if known),
and the creation date.
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Overview

Overview
Since they provide an easy-to-understand graphical representation of important project dates,
barcharts are widely used by many organizations to communicate information about the project
schedule. The interactive barchart views supplied with Open Plan are designed to facilitate the entry
and display of scheduling information appropriate for many conventional types of projects. However,
Open Plan also includes some powerful customizing features that allow you to prepare barcharts that
meet any special requirements your organization might have.
This chapter discusses customizing the bar display portion of a barchart view. You can modify the
appearance of the date scale used in the barchart, the barchart legend, and the settings of options for
a view.
For information about more extensive customization of a barchart view, including the
appearance of bars and the display of time-phased cost data, refer to Chapter 6, “Customizing
Barchart Views,” in the Deltek Open Plan Developer’s Guide. For information about the
spreadsheet and the resource histogram portions of a barchart view, refer to Chapter 20,
“Spreadsheet Views,” and Chapter 21, “Histogram Views,” in this user guide.
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Customizing the Date Scale
Because reporting standards vary widely between organizations, Open Plan allows you to define the
components of the date scale on the barchart view. This date scale controls both the display of bars
and the aggregation of resources in the histogram portion of the view. (The histogram bars
correspond to the smallest date unit defined for the date scale.)
You can define the settings for the date scale using any of the following methods:


Using autoscaling.



Defining the settings manually.



Creating a date scale based on one or more custom reporting calendars.

To select a method for defining the date scale, display the Options tab of the Date Scale Preferences
dialog box:

You can use this dialog box to control the text and background color for the date scale.
You can also manually adjust the spacing of any date scale by dragging within the date scale area.
To display the Date Scale Preferences dialog box, complete the following steps:
1. Open the appropriate barchart view.
2. Take one of the following actions:


On the View tab, click Date Scale.



Right-click anywhere in the date scale, and click Edit Date Scale on the context menu.
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Defining a Date Scale Manually
To define the appearance of a date scale manually, click the Manual option on the Options tab of the
Date Scale Preferences dialog box. You can then display the Manual tab:
Enter the number of
lines in the date scale.

Select a date scale
line to define.

Use the # of Axes setting to specify how many lines you want to appear in the date scale. If you are
displaying relative dates in one or more lines in the date scale, you can define a starting (reference)
date for these labels.
You can define up to six different lines for a date scale. For each line, you can control the following
options:


Time Unit — To determine the frequency with which date labels and vertical tick marks appear
on the date scale, select a time unit from the list. Possible units include: hours, days, weeks,
months, quarters, and years.



Count — You can specify a multiple for the selected time unit. This allows you, for example, to
define an axis with labels for each two week period.



Format — You can specify the appearance of the dates in the date scale by defining a date
format. To define a format, click the ellipsis button next to the Format field, and select a format
from the Date Formats dialog box, or enter the format manually using one or more of the following
parameters:
Parameter

Definition

Example

%T

Minute

15

%H

Hour

08

%Z

AM or PM

A or P

%OZ

am or pm (lower case)

a or p

%D

Day of the month

31

Chapter 18 Barchart Views
Deltek Open Plan 8.0 User Guide

408

Customizing the Date Scale

Parameter

Definition

Example

%V

Day

Tuesday

%OV

Day (lower case)

Tuesday

%UV

Day (upper case)

TUESDAY

%W

Day abbreviation

Tues

%OW

Day abbreviation (lower
case)

tues

%UW

Day abbreviation (upper
case)

TUES

%K

Numeric week

22

%M

Numeric month

10

%L

Month

October

%OL

Month (lower case)

october

%UL

Month (upper case)

OCTOBER

%A

Month abbreviation

Oct

%OA

Month abbreviation (lower
case)

oct

%UA

Month abbreviation (upper
case)

OCT

%Q

Numeric quarter

4

%C

Year

2004

%OL

Month (lower case)

october

You can combine parameters to define date formats. You can also include spaces and literal
characters in the format, as shown in the following examples:
Format

Example

%H:%T %Z.M.

07:15 P.M.

%W %D %A %H:%T

Mon 15 Sep 19:15

%M/%D/%C

09/15/2004
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Format

Example

Q%Q

Q1
To show hours and minutes using the 24-hour (military) convention, do not use the %Z or the
%OZ parameter in the definition of the format.

To display relative dates in a date scale, use the following parameters:
Parameter

Definition

%R%H

Relative hours

%R%D

Relative days

%R%K

Relative weeks

%R%M

Relative months

%R%Q

Relative quarters

%R%Y

Relative years

The values displayed for dates using a relative format are based on the Reference Date setting
on the Manual tab of the Date Scale Preferences dialog box. To have Open Plan convert the
currently selected date format to a relative date format, select the Relative to Reference Date
option in the Date Formats dialog box.

All of these different types of format parameters can be combined with literal characters to produce
the following types of labels:
Format

Example

%R%H Hours

100 Hours

Day %R%D

Day 3

Week %R%K

Week 15

FY%R%Y

FY1



Position — This setting positions the label left-justified, right-justified, or centered within the
vertical tick marks.



Full Scale — To extend the vertical tick marks on the scale into the area containing the bars,
select Full Scale.

Chapter 18 Barchart Views
Deltek Open Plan 8.0 User Guide

410

Customizing the Date Scale

Open Plan always draws these tick marks behind bars, relationships, and bar text.



Line Width — You can specify the width of the lines in the date scale.



Font — You can define the text font, size, and style for the scale by clicking Font.



Axis Height — Enter the height for the date scale line in 1/100ths of an inch.

To define a date scale manually, complete the following steps:
1. Take one of the following actions:
On the View tab, click Date Scale.
Right-click the date scale or the histogram portion of the view, and click Edit Date Scale on
the context menu.
2. On the Options tab of the Date Scale Preferences dialog box, click Manual.
3. Click the Manual tab, and enter the information for each line in the date scale.
To display the settings for a specific line, select the line number in the Axis Number box, or
click the line in the preview window.
4. When your changes are complete, click OK to return to the view.

Defining a Date Scale Using Autoscaling
The autoscaling feature in Open Plan allows you to automatically define a barchart date scale based
on any of the following intervals:


One week



Two weeks



One month



Three months



Entire project

You can also specify a custom interval to use with this feature.
Once you have indicated which interval to use, Open Plan automatically generates a date scale
based on the width of the barchart pane and appropriate to the interval you specified. You can then
further modify the date scale using the procedure described in the “Defining a Date Scale Manually”
section in this chapter.

Chapter 18 Barchart Views
Deltek Open Plan 8.0 User Guide

411

Customizing the Date Scale

To define the appearance of a date scale using the autoscaling feature, click the Manual option on
the Options tab of the Date Scale Preferences dialog box. You can then display the Manual tab:

You can use the # of Axes setting to specify how many lines you want to appear in the date scale.
Then click the Autoscaling command to display the following dialog box:

Use this dialog box to define the range of dates Open Plan should display on a single screen for
autoscaling.
To define a date scale using Autoscaling, complete the following steps:
1. Take one of the following actions:


On the View tab, click Date Scale.



Right-click the date scale or the histogram portion of the view, and click Edit Date Scale
on the context menu.

2. On the Options tab of the Date Scale Preferences dialog box, click Manual.
3. Click the Manual tab.
4. Specify the number of axes you want to display in the date scale, and click Autoscaling.
5. Select a range of dates for the operation, and click OK.
If you select Custom, you must enter a start and end date for the interval.
6. When your changes are complete, click OK to return to the Date Scale Preferences dialog
box.
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Using Reporting Calendars
If you have set up one or more reporting calendars in order to display data using a non-linear time
scale, you can base a date scale on this type of calendar. This allows you, for example, to create a
“rolling wave” barchart report in which the units on the date scale can refer to different spans of time.

It is also possible to use multiple reporting calendars in a single date scale by assigning a different
reporting calendar to each axis.

With multiple reporting calendars, however, you must designate one of the axes as the “controlling”
axis that determines how Open Plan scales the other axes. Typically, the controlling axis displays the
smallest intervals to be displayed in the date scale.
To use a reporting calendar to define the appearance of a date scale, you must have already defined
the calendar using the Reporting Calendars command from the Tools tab.
For information about creating reporting calendars, refer to Chapter 17, “Views and Reports.”

Once you have created a reporting calendar, click the Report Calendar option on the Options tab of
the Date Scale Preferences dialog box. You can then display the Report Calendar tab:

Select a reporting
calendar.

Use this tab to indicate the number of axes you want to appear in the date scale. If you are displaying
relative dates in one or more lines in the date scale, you can define a starting (reference) date for
these labels. If you want to use multiple axes in the date scale, you must specify which axis will
control the scaling of the other axes.
For each axis you can define the name of the reporting calendar. You can also define how the labels
from the reporting calendar appear with the following settings:


Format — You can define the appearance of the dates using the formatting conventions
described in the “Defining a Date Scale Manually” section in this chapter.
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Position — This setting positions the label left-justified, right-justified, or centered within the
vertical tick marks.



Full Scale — To extend the vertical tick marks on the scale into the area containing the bars,
select Full Scale.
Open Plan always draws these tick marks behind bars, relationships, and bar text.



Line Width — You can specify the width of the lines in the date scale.



Font — You can define the text font, size, and style for the scale by clicking Font.



Axis Height — Enter the height for the date scale line in 1/100ths of an inch.

To define a date scale with a reporting calendar, complete the following steps:
1. Take one of the following actions:


On the View tab, click Date Scale.



Right-click the date scale or the histogram portion of the view, and click Edit Date Scale
on the context menu.

2. On the Options tab of the Date Scale Preferences dialog box, click Reporting Calendar.
3. Click the Report Calendar tab, and assign one or more reporting calendars to the axes of the
date scale.
You can also define how the labels in the date scale should appear.
4. When your changes are complete, click OK to return to the view.

Adjusting the Date Scale with a Mouse
Open Plan allows you to expand or compress the spacing of any date scale by simply dragging within
the date scale area of the view:
Drag to stretch or shrink
the date scale.

With this feature, it is possible to make small adjustments to the date scale without having to redefine
one or more of the elements making up the scale.
This feature also works on the Manual tab and Reporting Calendar tab of the Date Scale
Preferences dialog box.

To adjust the date scale, complete the following steps:
1. Position the cursor over the date scale area of the view. The cursor shape changes to a
double-headed arrow.
2. Drag to adjust the spacing of the date scale as follows:


To compress the date scale, drag to the left.



To expand the date scale, drag to the right.
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Barchart Display Options
You can customize a barchart view by controlling the display of relationships, the Time Now marker,
and non-work periods. You can access these controls from the Barchart Preferences dialog box:

Open Plan provides the following options regarding relationships:


Do Not Show Relationships



Show Relationships — If a bar represents a summary of activities, Open Plan displays only
those relationships external to the bar.



Show Whole Relationships Only — Show relationships only if both the successor and
predecessor are currently displayed in the view.

If you are displaying relationships in a view, you have the option to treat controlling relationships (that
is, relationships with zero free float) in a special manner.


You can show all relationships and display controlling relationships in the color of the successor
activity bar. This normally results in highlighting the critical path in the view in red.



You can highlight controlling relationships in blue.
For information about controlling relationships, refer to Chapter 8, “Time Analysis
Calculations,” in the Deltek Open Plan Developer’s Guide.

Two relationship lines styles are available in barchart views:


Direct — Allows diagonal relationship lines



Routed — Restricts the display of relationships to either horizontal or vertical lines.

You can control the appearance of the Time Now marker using this dialog box. If you display a line for
Time Now, you can specify:


The color of the Time Now line and label



The thickness of the line
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A label that Open Plan displays to the left of the line. You can also combine literal text with any
project level field. For example, entering “Time Now- ” + str(statdate) will display Time Now19Apr04.
The date is displayed using the Default Date Format setting on the Preferences tab of
the Project Properties dialog box. Also, literal text must always be entered within
quotation marks (""). Statdate is the field name for Time Now.

You can control the display of non-work periods by selecting Shade Non-work. If you select this
option, Open Plan enables the following fields:


Color — Allows you to select which color to use for shading



Using Calendar —Allows you to specify the calendar that Open Plan should use when
determining whether a particular time period should be shaded. If you do not select a calendar in
this field, Open Plan uses the project default activity calendar.
You may need to change your date scale to show the appropriate work periods. For
example, in order for a non-work week to be identified, the smallest level on the date
scale must be no greater than weeks. Similarly, in order for non-work days, such as
weekends, to be identified, the smallest level on the date scale must be no greater than
days.

To customize display options, complete the following steps:
1. Take one of the following actions:


On the View tab, click Preferences from the Barchart group.



Right-click an empty area in the barchart, and click Preferences on the context menu.

2. Enter the information for the display options.
3. When your changes are complete, click OK to return to the view.
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Multi-Table Barcharts
Multi-table barcharts allow you to display both activity and resource bars and multiple baselines.
Open Plan includes two standard multi-table barchart views: an activity/resource barchart, which
groups resource assignments by activity, and a resource/activity barchart, which groups activity bars
by resource assignment. Both types of views allow you to display time-phased cost data aggregated
by the barchart date scale:

Resource bars based on early and late dates take into account assignment information such as
offsets and periods. Bars based on scheduled dates display a single segment for each record of
usage.

You can control the display of resource and activity bars using the Bar Attributes tab of the Bar Set
Preferences dialog box. To control the display of time-phased cost data, use the Crosstable tab of the
Bar Set Preferences dialog box.
For information about customizing the appearance of resource bars and time-phased data in a
multi-table barchart, refer to Chapter 6, “Customizing Barchart Views” in the Deltek Open Plan
Developer’s Guide.

To display the Bar Set Preferences dialog box, complete the following steps:
1. Take one of the following actions:


From the barchart view, click Bar Sets on the View tab.



Right-click an empty area of the barchart view, and click Bar Sets on the context menu.
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2. From the Bar Sets dialog box, select the bar set to edit, and click Edit. The default bar set for
the view is automatically selected.
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Overview

Overview
Favored by many experienced project planners, network views stress the clear depiction of
relationships between activities and are often used to display a logical diagram of a project. Network
views are particularly well suited for communicating the critical path of a project, which may have
important ramifications for the execution of the overall project plan.
The network views in Open Plan are fully interactive and allow you to enter and update any type of
project information. You can also customize the appearance of a network view in many areas:


The size of activity boxes



The appearance of view legends



The display of text annotations



The display of subprojects



The placement of activities and relationships



The zoning of activities based on one or more criteria



The use of special display options



The use of the Conditional Formatting dialog box

This chapter discusses the customization of a network view in each of these areas.
For information about customizing the display of activity boxes, refer to Chapter 7, “Customizing
Network Views” in the Deltek Open Plan Developer’s Guide.
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Customizing a Network View
In Open Plan, you can customize a network view in many ways. For example, you can define the
following aspects of the network view:


How relationship information is displayed



Whether or not the view should display where page breaks occur in a printed report



Whether or not controlling relationships should be highlighted



If, and where, a legend should be printed in a report



The size and placement of activity boxes in the view



Annotations that can be attached to either the view or to a specific activity

You can also control the following attributes of the activity boxes:


The appearance of the activity boxes based on criteria that you define



The data fields displayed in the activity boxes



The appearance of the activity boxes, when you want to override default settings by specifying
the conditions under which the properties of the activity boxes will change.
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Controlling Box Sizes
Open Plan calculates the overall size needed to display an activity box based on criteria specified in
the Network Preferences dialog box on the Box Layout tab (font, font size, maximum lines used,
maximum width, etc.) when applied to the field values for that activity.
Once an activity box has been manually resized, the new custom size will be saved with the view.
This may be changed, however, by right-clicking the activity and choosing Dynamically Size Box. If
you wish to change ALL custom-sized boxes in the view back to dynamic sizing, right click an activity
and choose Dynamically Size All Boxes.
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Network View Legends
Network views can include a legend that describes the various types of activity boxes appearing in
the view as well as a definition of the activity data appearing in each box.
Legends are not normally displayed on the screen but are produced when the view is output to
devices such as printers or plotters. You can, however, display the legend by using either a special
option to place the legend manually or by using the Print Preview command from the File menu.

Open Plan provides a number of options for the placement and contents of a network legend. To set
these options, click the Legend tab on the Network View Preferences dialog box:

If you choose to display the legend on every page, Open Plan allows you to specify if the legend
should appear on the top, bottom, left, or right side of the page. You can also choose to output the
legend to a separate legend page.
The Manual option provides the most flexibility for displaying the legend. If you select this option,
Open Plan displays the legend box in the view and allows you to position it manually or resize it. If a
legend is too large to appear on a single page, you can place the legend across page breaks so that
it appears on two or more pages.
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Another way to customize a legend is to use the Manual option to display the legend in the view
and then use the annotation feature to add additional information such as the name of the
project or a signature block. For information about network annotations, refer to the
“Annotations” section in this chapter.

To customize a legend, complete the following steps:
1. Take one of the following actions:


On the View tab, click Preferences.



Right-click an empty area within the view, and click Preferences on the context menu.

2. On the Network View Preferences dialog box, click the Legend tab.
3. Enter the information for the legend.
4. When your changes are complete, click OK to return to the view.
To position a legend manually, complete the following steps:
1. Take one of the following actions:


On the View tab, click Preferences.



Right-click an empty area within the view, and click Preferences on the context menu.

2. On the Legend tab of the Network View Preferences dialog box, click Manual.
3. To return to the view, click OK.
Open Plan displays the legend in the lower left corner of the view. (You may need to use the
Zoom Out command to determine the location of the legend.)
4. Position the legend manually as follows:


To move the legend, position the cursor on the legend frame. When the cursor shape
changes to a hand, drag the legend to the desired location.



To resize the legend, position the cursor on the lower right corner of the legend frame.
When the legend shape changes to a double-headed arrow, drag the frame to the
desired size and shape.
If no boxes appear in a legend, enlarge the area of the legend by resizing it.
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Annotations
Another way you can customize a network view is to add an annotation. The annotation feature
allows you to store and display simple text objects on a project-specific basis:

As an option, you can attach an annotation to an activity. When attached, an annotation maintains the
same position relative to the activity, even if the activity moves. If you delete the activity, Open Plan
deletes the annotation.
Only one annotation can be attached to an activity at a time. If you attach a new annotation to an
activity that already has an annotation, the existing annotation will remain displayed but will no
longer be attached to the activity.

To define an annotation, use the Add Annotation command on the View tab to display the following
dialog box:
Text for the annotation

Activity ID to attach the annotation

Annotations can contain multiple lines of text. To insert a line break in annotative text, press
Ctrl+Enter. It is also possible to cut or copy text from an annotation to the Clipboard as well as to
paste text from the Clipboard into an annotation.
In addition to the text for the annotation, you can specify the following settings:


Attach to Activity ID — You can assign the annotation to any activity currently displayed in the
view.
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Style — Four options are available for the border style of the annotation:


No Border



Square Box



Round Box



Ellipse



Text Color — You can define the text color of the annotation.



Background Color — You can define the background color of the annotation. If you select No
Border for the annotation, this setting controls the color of the annotation text.



Use Default Font (Arial, 50) — You can opt to use the default font type and size that was
selected in the Network Preferences dialog box. To use another font type, deselect this option to
enable the Font button. This opens the Font dialog box.



Resize Box to Fit Data — Selecting this option allows Open Plan to resize the annotation box
depending on the amount of text you entered in the Text field.
Selecting the <Default> options in the Style, Text Color, and Background Color fields in this
dialog box allows for the annotation to take on the values that were set in the Network
Preferences dialog box. These fields in the Network View Annotation dialog box are also
updated when you make changes in the Network Preferences dialog box.
The little rectangle preceding <Default> for both text color and background color shows the
default colors that were chosen on the Network Preferences dialog box » Options tab for
default annotation properties.

Once you have created an annotation, you can move it or resize it using the mouse. You can also use
commands to display the annotation behind other objects, to edit its contents, or to delete it.
To create an annotation, complete the following steps:
1. Take one of the following actions:


On the View tab, click Add Annotation.



Right-click an empty area or an activity in the view, and click Add Annotation on the
context menu.



Right-click an activity, and click Annotate Activity on the context menu.

2. In the Network View Annotation dialog box, enter the information for the annotation.
To attach an annotation to an activity, enter the activity ID in the appropriate field.
If you access the dialog box by right-clicking an activity, the Activity ID is automatically
entered in the appropriate field.
3. When the information is complete, click OK.
To move an annotation, complete the following steps:
1. Position the cursor over the annotation.
2. When the cursor shape changes to a hand, drag the annotation to the desired location.
To resize an annotation, complete the following steps:
1. Click the annotation to select it.
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2. When a rectangle appears around the annotation, drag the lower right corner of the rectangle
to resize the annotation.
To modify an annotation, complete the following steps:
1. Right-click the annotation.
2. Click one of the following commands on the context menu:


To display the annotation behind other objects in the view, click Send to Back.



To display the Network View Annotation dialog box, click Edit.



To delete the annotation, click Delete.
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Displaying Subprojects
By default, network views display only one hierarchical level at a time. However, it is possible to show
multiple levels of a hierarchical project simultaneously in Open Plan:

Features related to the display of hierarchical projects work identically for projects containing both
internal and external subprojects.
You can use automatic placements to display activities from all levels in a format slightly
different from that illustrated above. For more information, refer to the “Automatic Placements”
section in this chapter.

By default, Open Plan positions an expanded subproject just below any activities already displayed.
(On large projects, you can use the Zoom commands to see the rectangle containing the subproject.)
Once you have expanded a subproject, however, you can move it by dragging it to a new position
within the view. If you wish, you can turn off the display of the frame surrounding the subproject. You
can also collapse any subproject by right-clicking within the subproject area and clicking the Collapse
Subproject command.
The position of an expanded subproject is not saved between sessions. If you close a view and
reopen it, you must expand and reposition any subprojects you adjusted in the previous session.
However, Open Plan does save information about the drill-down level when you save the view
using the Save View command. Thus, if you drill down to a specific subproject and then save a
network view, Open Plan automatically drills down to the same subproject the next time you
open the view.
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When you display expanded subprojects in a view, you can draw relationships between activities both
within an expanded subproject and to activities outside of the subproject area.

Relationship between activities in different subprojects

For information about creating relationships in a network view, refer to Chapter 6, “Activity
Information.”

Items such as activities, relationships, and annotations displayed in an expanded subproject do not
behave identically to the same items displayed at the current level of the view. For example, you can
continue to edit activities, relationships, and annotations appearing in the subproject by right-clicking
the item you want to update. However, you cannot reposition these items within the subproject area
or drag them outside of the subproject area.
To expand a subproject, complete the following steps:
1. Select the parent activity of the subproject you want to expand.
2. Take one of the following actions:
Expand button



On the Edit tab, click Expand.



Right-click the activity, and click Expand on the context menu.

To expand all subprojects, complete the following step:
Expand All button

1. On the Edit tab, click Expand All.
To move an expanded subproject, complete the following steps:
1. Position the cursor on the frame of the subproject you want to move.

Move cursor

2. When the cursor shape changes to a hand, drag the subproject to the desired position.
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To collapse a subproject, complete the following step:
1. Right-click the subproject area, and click Collapse Subproject on the context menu.
To collapse all subprojects, complete the following step:
1. On the Edit tab, click Collapse All.
Collapse All
button

To suppress the frame around a subproject, complete the following step:
1. Right-click the subproject area, and clear Display Subproject Frame on the context menu.

Displaying Multiple Subprojects
Displaying expanded subprojects from multiple hierarchical levels usually requires the use of two
commands:


Go To Subproject — Drill down to the next level of the project. The level from which you drilled
down is no longer displayed in the view.



Expand — Maintain the current level of the view, but display the children of the selected activity
as an expanded subproject.

To understand how you might use these commands to expand subprojects from different levels,
assume that you want to represent the following project in a single network view:
Activity ID

Description

1

Project

1.1

Subproject 1

1.1.1

Detail activity 1

1.1.2

Detail activity 2

1.2

Subproject 2
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When you first display this project in a network view, only the top level activity appears:

By selecting this activity and clicking Expand, you can display the following:
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To display the detail activities in the project, you must first drill down a level and expand Subproject 1:

Once you have displayed the lowest level of detail in the project, click the Go To Top Level
command to display all of the expanded subprojects in the same view:
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Automatic Placements
In network views, the term “placements” refers to the positioning of activities and relationship lines.
You can position activities in a view manually, or you can have Open Plan calculate placements
automatically using an algorithm designed to minimize the need for relationship lines to cross each
other. Placements calculated in this fashion can result in network diagrams that are much easier to
decipher, particularly in the case of very large projects.
Initially, the position of an activity in a network view depends on how you create it:


If you add an activity by double-clicking in the view or by drawing a relationship from an existing
activity, Open Plan places the activity in the position you indicated.



If you create an activity using the Add Activity command, Open Plan places it in the middle of
the current view.



If you create an activity in a view other than a network view, Open Plan places the new activity
below the existing activities when you return to the network view.
You cannot change the size of an activity box while placements are set to automatic.

If you choose to have Open Plan calculate placements automatically, you can control these
calculations with options to avoid displaying activities across page breaks, to show activities from all
hierarchical levels of the project, to filter the activities displayed, or to arrange activities either in
zones based on the contents of an activity field such as a code or along a time scale.
In addition to allowing for options such as filters, zoning, and time-scaling, automatic placements
differ from manual placements in how Open Plan preserves the placement information for the view
between sessions. For automatic placements, Open Plan stores your settings for how the placements
are calculated. It does not, however, store the actual placements themselves. Placements are
recalculated each time the view is opened.
If you perform automatic placements and want to preserve them for future sessions, you can save
them as manual placements. You also have the ability to perform automatic placement calculations
and then make adjustments to the activity positions manually. You can then save these modified
automatic placements if you want to preserve them between sessions.
Open Plan stores placement settings separately for each network view assigned to a project. This
means, for example, you can define one set of placement options for FLOWVW in the project Clean,
and another set for DEVFLOW (another network view) in the same project. You can also define
different placement settings for these same views when they are opened within a different project.
Open Plan does save the state of the automatic placements option (enabled or disabled) when
you save the view using the Save View command. Thus, if you save a network view with
automatic placements on, Open Plan automatically calculates placements for the view the next
time you open it.
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The Placements dialog box controls the operations of the placements feature.

Select Automatic or Manual placements.

These buttons are available after Automatic is selected

The following settings control automatic placement calculations:


Automatic — This option calculates placements automatically. Once you have performed
automatic placements, you can modify the view manually.
When calculating automatic placements, Open Plan positions all isolated activities (that
is, activities that do not have relationships with other activities) in one or more rows
below any activities with relationships.



Manual — This option turns off automatic placements and returns the view to the last manual
placements.



Save As Manual — If you have performed automatic placements and remain in the automatic
placements mode, you can save the current set of placements by clicking this option. When you
select this feature, Open Plan returns to the manual placements mode.
The Save As Manual option is available only when automatic placements are in effect
and filtering is not enabled.



Avoid Page Breaks — If you have enabled automatic placements, this option controls how Open
Plan positions activities that fall across page breaks of printed output. By selecting this setting,
you can have Open Plan shift activities that would otherwise fall across page breaks.



Show All Levels — If you have enabled automatic placements, this option displays all the
activities from a project in the same view, regardless of their hierarchical level. When you
calculate placements with this option turned on, Open Plan may not position all activities from the
same subproject together.



Time Scale Project — If you have enabled automatic placements, this option groups activities
based on a user-specified date field.



Time Scale — Click this button to display the Scaling Specifications dialog box that you can
use to define the time scaling parameters Open Plan uses when you select the Time Scale
Project option.
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For information about setting up time scaling, refer to the “Defining Time Scaling”
section in this chapter.



Zone Project — If you have enabled automatic placements, this option places activities in zones
based on user-defined criteria.



Zoning — Click this button to display the Zone Attributes dialog box that you can use to define
how Open Plan displays zones when you select the Zone Project option.
For information about setting up time scaling, refer to the “Defining Time Scaling”
section in this chapter.



Filter Project — If you have enabled automatic placements, this option allows you to assign a
filter to the view.



Filters — Click this button to display the Filters dialog box that you can use to define the filter
Open Plan uses when you select the Filter Project option.



Display Interface Activities — If you have enabled automatic placements, this option allows
Open Plan to show either the predecessor activities, successor activities, or both, even though
these activities might be excluded by the current filter.
For more information about view filters, refer to Chapter 24, “Project Utilities.”

To perform automatic placements, complete the following steps:
1. Take one of the following actions:


On the View tab, click Placements.



Press Shift+P.



Right-click an empty area of the view, and click Placements on the context menu.

2. In the Placements dialog box, click Automatic for the placements method
3. Select the desired option(s) for the operation.
4. Click OK.
Open Plan responds by returning to the view and calculating new placements for the
activities and relationships.
If you perform automatic placements with the Relationship Line Options set to Direct in the
Network View Preferences dialog box, Open Plan staggers the display of relationship lines
where necessary to avoid any ambiguity.

To turn automatic placements off, complete the following steps:
1. Take one of the following actions:


On the View tab, click Placements.



Press Shift+P.



Right-click an empty area of the view, and click Placements on the context menu.
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2. In the Placements dialog box, click Manual.
3. Click OK.
Open Plan responds by turning automatic placements off and restoring the view to the last
manual placements.
To save automatic placements, complete the following steps:
1. Perform automatic placements.
You can manually modify the placements calculated by Open Plan before saving them.
2. Display the Placements dialog box.
3. Click Save As Manual.
4. Click OK.
Open Plan responds by saving the current placements and returning to the manual
placements mode.

Defining Custom Zoning
If you enable the zoning option for automatic placements, you can have Open Plan group activities in
zones defined by criteria that you specify. For example, you can zone a project based on an activity
code:

Zoning header
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You can define as many as 50 zoning criteria for the calculation of automatic placements. To define
how the view should be zoned, click Zoning on the Placements dialog box to display the Zone
Attributes dialog box:
Define attributes of each
zone header

Field to appear in zone
header

You can customize zone headings with the following settings:


Criterion — Changes in this field trigger the appearance of a zone header in the view. You can
designate a calculated field as a zoning criterion.



Heading Field — The heading field specifies the field displayed by Open Plan in the zone
header. For example, if you use a code field as a zoning criterion, you might use the code
description for the heading field.



Font — The font used for the zone header.



Color — The color used for the zone header.
Once you define zoning and perform automatic placements, you can treat the zone
headers as annotations to the view. In other words, you can edit, reposition, and resize
zone headers just as you can annotations. You can also attach zone headers to
activities so that a header moves with the specified activity.

To define custom zoning, complete the following steps:
1. On the Placements dialog box, click Zoning.
2. In the Zone Attributes dialog box, enter the information for each attribute.
To delete an attribute, delete the contents of the Criterion field for that attribute.
To define the font for a zoning header, select the Font field, and click the ellipsis button next
to the edit box.
3. When your changes are complete, click OK to return to the Placements dialog box.
To adjust the position of a zone header, complete the following steps:
1. Position the cursor over the header.
Move cursor

2. When the cursor shape changes to a hand, drag the header to the desired location.
To resize a zone header, complete the following steps:
1. Select the zone header.
2. When a rectangle appears around the header, drag the lower right corner of the rectangle to
resize the header.
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To modify a zone header, complete the following steps:
1. Right-click the zone header.
2. Click one of the following commands on the context menu:


To display the header behind other objects in the view, click Send to Back.



To display the Network View Annotation dialog box for the header, click Edit.



To delete the header, click Delete.

Defining Time Scaling
If you enable the time scaling option for automatic placements, you can have Open Plan group
activities based on activity dates. For example, you can group activities in a project based on early
start dates:

Time-scaled header

To define how the view should be time-scaled, click the Time Scale button on the Placements dialog
box to display the Scaling Specification dialog box:

You can customize time scaling with the following settings:


Base on Date Field — You can select any activity date field as the basis of time scaling.



Group Every — You can specify the granularity of the time scale.
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Date Format — You can use this setting to define the format used by Open Plan when
generating the time scale headers.
For a complete description of date formats in Open Plan, refer to the “Defining a Date
Scale Manually” section in Chapter 18, “Barchart Views.”



Reference Date — If you have specified a date format that includes relative dates, use this
setting to define the reference date.

To define custom time scaling, complete the following steps:
1. On the Placements dialog box, click Time Scale.
2. In the Scaling Specification dialog box, enter the information for the operation.
To define the font for the time-scaled headers, select the Font field, and click the ellipsis
button next to the edit box.
3. When your changes are complete, click OK to return to the Placements dialog box.
To adjust the position of a time-scaled header, complete the following steps:
1. Position the cursor over the header.
Move cursor

2. When the cursor shape changes to a hand, drag the header to the desired location.
To resize a time-scaled header, complete the following step:
1. Click the zone header to select it.
2. When a rectangle appears around the header, drag the lower right corner of the rectangle to
resize the header.
To modify a time-scaled header, complete the following step:
1. Right-click the zone header.
2. Click one of the following commands on the context menu:


To display the header behind other objects in the view, click Send to Back.



To display the Network View Annotation dialog box for the header, click Edit.



To delete the header, click Delete.
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Using the Zoom Commands
In a network view, Open Plan provides a Zoom In and Zoom Out command for projects that cannot
be displayed on a single screen.
There are three display mode types for the network view:


Normal — This is the default display mode when you first open a network view.



Intermediate — There will be one or multiple intermediate zoom modes, depending on the size
of your project. The first (or sole) intermediate mode is displayed when you apply the Zoom Out
command from the normal display mode.



Fully Reduced — This mode is displayed when you apply the Zoom Out command from the final
intermediate display mode.
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To assure that the text within activity boxes will be legible, at any zoom level where the network is
shrunk to 75% or less, you may hover the cursor over the activity to see the activity drawn at normal
size.

In one of the intermediate display modes, you can continue to work with the activities and
relationships just as though you were in the normal display mode. To enlarge an area of the window,
select an activity, and apply the Zoom In command.
If you go to the fully-reduced display mode, Open Plan reduces the activity boxes to whatever size is
necessary to display the entire project.

Drag this frame to zoom in on a specific area.
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You can use the fully-reduced display mode for navigating through very large projects. A rectangular
frame appearing in this mode indicates the area of the view that will be displayed if you apply the
Zoom In command to return to an intermediate display mode. If you move this frame, when you
release the mouse, the view will return to normal display mode at approximately the position you
selected.
If the entire project can be displayed at once, the Zoom commands are not available.

To apply the Zoom commands, complete the following step:
1. Take one of the following actions:

Zoom Out button

Zoom In button



In the normal display mode, click Zoom Out on the View tab.



In one of the intermediate display modes, click either Zoom In or Zoom Out on the View
tab.



In the fully reduced display mode, click Zoom In on the View tab.

You can also invoke these commands by right-clicking an empty area of the view and clicking
the appropriate command on the context menu.
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Network View Display Options
You can control the display of a network view with a number of settings accessed from the Options
tab of the Network View Preferences dialog box:

The settings for network display options are as follows:






View Options


Draft Mode — Displays all activity boxes with black text, no box ends, no fill colors, and no
diagonals.



Snap Boxes To Grid — Forces both new activity boxes and boxes being moved to align
themselves to an invisible grid in the view.



Show Page Breaks — Displays lines indicating the boundaries of a page as defined by the
current Print Setup command. (You can also control this setting with the Show Page Breaks
command on the View tab.)



Row Spacing — This field allows you to specify the horizontal spacing between activity
boxes. The spacing unit used is pixels.



Column Spacing — This field allows you to specify the vertical spacing between activity
boxes. The spacing unit used is pixels.

Annotation Properties


Style — You can select the border style for the annotation: No border, Square box, Round
box, or Ellipse.



Text Color — You can select the text color to be used for the annotation.



Background Color — You can select the fill color for the annotation’s border, if any.



Font — You can select the font to be used for the annotation.

Zone Heading Properties


Text Color — You can select the text color to be used for the zone heading.



Font — You can select the font to be used for the zone heading.
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Time Scale Heading Properties


Text Color — You can select the text color to be used for the timescale heading.



Font — You can select he font type to be used for the timescale heading.
The definitions in Annotation Properties and Zone Heading Properties fields are the default
values when you are creating new annotations, zone headings, and time scale headings.

To customize display options, complete the following steps:
1. Take one of the following actions:


On the View tab, click Preferences.



Right-click an empty area within the view, and click Preferences on the context menu.

2. On the Options tab of the Network View Preferences dialog box, enter the information for
the display options.
3. When your changes are complete, click OK to return to the view.
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Network View Box Attributes
The Box Attributes tab controls the appearance of the activity boxes based on criteria that you define.
In this way, you can use attributes such as box styles or colors to represent activity data.

Open Plan uses the following settings to define the attributes of an activity box:


Criterion — The criterion of a box refers to a predefined expression that determines whether the
attributes you are defining are displayed for an activity. You can set the criterion to any filter
defined for a project. This allows you to use the box attributes to display very different types of
information. The text color, left and right box end styles, left and right box fill colors, and the
diagonals can each be set to display a different type of information.
For example, you can define attributes that differentiate between planned, in-progress, and
complete activities. One common way to do this is to use different diagonal markings in the box.
In addition, you can use another attribute, such as the left box end style, to indicate the code in a
WBS or an activity with less than a certain amount of free float. The possibilities are unlimited.
You select the criterion from a list containing:





Filter expressions supplied with Open Plan



Custom filters

Text Color — You can select from the following text color options:


Default — Selecting this option keeps the attribute undefined. This allows the text color to be
controlled by another criterion.
For example, assume that you have defined the text color red for critical activities and that
you are now defining an attribute for activities in a certain department. Assume also, that on
the list of attributes, the new attribute is below the one for critical activities. The Default option
would color the text red for critical activities in that department.



Select Color — Selecting this option displays a color picker popup that you can use to select
a color for the both the lines that make up the box and any text it contains.
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The color picker popup offers an initial choice of 70 standard colors, but any 24-bit color
value may be chosen by clicking “Other” to invoke the Colors dialog box.


Bk. Color — Open Plan allows you to select the background color for the annotation’s border, if
any, by clicking the down arrow. The color picker popup that is displayed offers an initial choice of
70 standard colors.
You can define custom colors using an enhanced version of the Color dialog box accessed from
the Color tab of the Options dialog box.



Left Style — You can select a style for the left end of the box from a list of twelve styles. You can
also select Default to allow the style for the left end of the box to be controlled by another
criterion.
For example, assume that you have defined a left box style for completed activities and that you
are now defining an attribute for activities in a certain department.
Assume also, that on the list of attributes, the new attribute is below the one for completed
activities. The Default option would use the left box style defined for completed activities for all
completed activities in that department.



Left Color — You can select from the following color options:


Default — Selecting this option keeps the attribute undefined. This allows the left color to be
controlled by another criterion.
For example, assume that you have defined the color red for critical activities and that you
are now defining an attribute for activities in a certain department. Assume also, that on the
list of attributes, the new attribute is below the one for critical activities. The Default option
would color the left end of the box red for critical activities in that department.



Select Color — Selecting this option displays a Color dialog box that you can use to select a
color for the left end of the box. The Color dialog box offers a choice of 70 standard colors.
You can define custom colors using an enhanced version of the Color dialog box accessed
from the Color tab of the Options dialog box.
If a color has already been defined for the left end of the box but is not currently used, you
can also select that color from the list.



Right Style — You can select a style for the right end of the box from a list of twelve styles. You
can also select Default to allow the style for the right end of the box to be controlled by another
criterion.
For example, assume that you have defined a right box style for completed activities and that you
are now defining an attribute for activities in a certain department. Assume also, that on the list of
attributes, the new attribute is below the one for completed activities. The Default option would
use the right box style defined for completed activities for all completed activities in that
department.



Right Color — You can select from the following color options:


Default — Selecting this option keeps the attribute undefined. This allows the right color to
be controlled by another criterion.
For example, assume that you have defined the color red for critical activities and that you
are now defining an attribute for activities in a certain department. Assume also, that on the
list of attributes, the new attribute is below the one for critical activities. The Default option
would color the right end of the box red for critical activities in that department.



Select Color — Selecting this option displays a Color dialog box that you can use to select a
color for the right end of the box. The Color dialog box offers a choice of 70 standard colors.
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You can define custom colors using an enhanced version of the Color dialog box accessed
from the Color tab of the Options dialog box.
If a color has already been defined for the right end of the box but is not currently used, you
can also select that color from the list.


Left Diag — You can select from three diagonal options for the box – Default, None, or (\).
The Default option keeps the attribute undefined, allowing the display of the diagonal to be
controlled by another criterion. The None option does not insert the diagonal for activities meeting
the criterion. The (\) option inserts the diagonal for activities meeting the criterion.



Right Diag — You can choose from three diagonal options for the box – Default, None, or (/).
The Default option keeps the attribute undefined, allowing the display of the diagonal to be
controlled by another criterion. The None option does not insert the diagonal for activities meeting
the criterion. The (/) option inserts the diagonal for activities meeting the criterion.



Label — You can enter a label to describe the criterion you are defining. For example, if you label
a particular set of box attributes as "Critical In-progress," Open Plan uses this label to identify the
box style and prints the label on the report legend.

The default activity box has the following attributes: black text color, square ends, and no diagonals.
Sometimes an activity meets the criteria set for more than one set of attributes. To determine how to
display that activity, Open Plan uses the order in which the activity box attributes are listed in this
dialog box. For each activity, Open Plan starts at the bottom of the list and uses the attributes defined
for the first criterion that the activity satisfies. If the activity does not meet any of the defined criteria,
Open Plan uses the default activity box.
Initially, Open Plan displays the activity box attributes in the order in which you entered them.
However, you can delete an attribute simply by selecting any cell and pressing Delete. And you can
change the order in which the box attributes appear by using the selection and change order buttons.
When defining box attributes, it is not necessary to define box attributes for every conceivable
situation. Unless you want a particular attribute to be controlled by a particular criterion, use the
default setting. Open Plan displays an activity that conforms to more than one criterion by using a
combination of the colors and styles defined for those criteria to which it conforms. If more than one of
these criteria have non-default settings for the same attribute, Open Plan uses the higher criterion on
the list. (This is the only circumstance under which the order of the criteria on the list matters.)
A Preview window shows how Open Plan would display an activity meeting the selected criterion. If
you select multiple rows, the Preview window displays how an activity meeting all the criteria would
be displayed.
The three buttons across the bottom of the Network Preferences dialog box apply to all tabs. The OK
button accepts your input and closes the dialog box. The Cancel button cancels your input and closes
the dialog box. The Help button provides access to help about the current tab.

Chapter 19 Network Views
Deltek Open Plan 8.0 User Guide

447

Network View Box Layout

Network View Box Layout

The word “cell” will be used to refer to a smaller box within the activity box that displays a field.
For the preview activity shown in the screenshot, there are 6 cells within the activity box.

This tab controls both the selection and the display of data fields within an activity box:


The Field column specifies the field on the activity table to be displayed. This field can be either
one of the standard activity fields or a calculated field that you have added to the table.



The Line column specifies the line position in the box for the field that is displayed. Open Plan
can display any number of fields on the same line. These fields appear in the same order as
shown on this tab.
To add space to any activity box, leave out some lines. For example, you might specify fields for
lines 1 and 8. This would leave space in the activity box that could be used for handwritten notes
in a turn-around report.
Buttons located at the bottom of the tab allow you to change the order of fields displayed on the
same line.



The Font column specifies the font for the field.



The Text Color column specifies the text color for the field.



The Horz. Align column specifies the horizontal alignment of the text. The options available for
this column are the following: Center, Left, and Right.



The Vert. Align column specifies the vertical alignment of the text. The options available for this
column are the following: Bottom, Center, and Top.



The Max. Lines column specifies the maximum lines for the cell within the activity box.



The Max. Width column specifies the maximum width of the cell within the activity box. This
setting is ignored unless Max. Lines > 1.
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The selections available in the Format column vary depending on the type of data displayed:


Text — Fixed (always use maximum lines) and Variable (text can use <= maximum lines
specified).



Date — <Default> and various predefined date formats



Numeric — <Default> and various predefined numeric and currency formats. A special
format, Progress Bar, means that Open Plan interprets the numeric value as percentage and
fills that percentage of the field box with the specified text color. While an activity box can
have any number of progress bars, no other field can be displayed on the same line as a
progress bar.



Duration — <Default>, Days, Hours, Minutes, Months, and Weeks.

The maximum box width (in characters) slider determines the maximum drawing width for an activity
box (including box ends). This width is determined by taking the width of an average character for the
font specified for the view and multiplying it by the number of characters specified in this dialog. For
example, if we have chosen a font with an average character width of 8 pixels, and specify that we
want a maximum width in characters of 60, the widest box possible (including box ends) will be 8 * 60
= 480 pixels.
To delete a row, select the field to be deleted, and press Delete.
A preview window allows you to see an approximate representation of the layout of the activity box.
The three buttons across the bottom of the Network Preferences dialog box apply to all tabs. The
OK button accepts your input and closes the dialog box. The Cancel button cancels your input and
closes the dialog box. The Help button provides access to help about the current tab.
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This tab specifies how Open Plan displays the relationships for a network view.


Relationship Line Options
The options allow you to specify whether the relationship line style should be direct or routed.





Direct — When selected, Open Plan draws the relationship lines as straight lines between
the predecessor and successor activities.



Routed — When selected, Open Plan draws the relationship lines in a series of horizontal
and vertical segments.



Highlight Controlling Relationships — When selected, this option instructs Open Plan to
highlight controlling relationships. When this option is enabled, controlling relationships are
heavier than other relationship lines and are displayed in the color of the successor activity.



Smooth Relationship Line Corners — When selected, this option instructs Open Plan to
smooth the corners of relationship lines.

Relationship Text Options


Show Relationship Type — When selected, this option instructs Open plan to show the
relationship type on relationship lines. In addition, the following option is also enabled:
Only Non-FS Types — Selecting this option inhibits the display of the relationship type for
FS relationships.



Show Lags — When selected, this option instructs Open Plan to display the relationship lags
between activities. In addition, the following option is also enabled:
Only Non-Zero — Selecting this option inhibits the display of lag information for lags with a 0
duration.



Position — Select a position in which to display the relationship type and/or lag. The options
available are the following: Left Top, Left Center, Left Bottom, Center Top, Center Center,
Center Bottom, Right Top, Right Center, and Right Bottom.
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The Left position is near the Predecessor, and the Right position is near the
Successor.
With some relationship types, the routing of the lines and the positions of the
predecessor and successor activities may preclude using the specified position. In this
case, Open Plan will substitute a different position that does not obscure the type/lag
information.



Font —Select the font type, font style, and font size for the relationships information.
For more information, see the Creating Interproject Relationships (Network) section in the Deltek
Open Plan 8.0 Online Help.
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Conditional Formatting
You may customize the display of the activity boxes for the Network View by using the Conditional
Formatting dialog box:

With the Conditional Formatting dialog box, you can override these default settings by specifying
the conditions under which the properties of the activity boxes will change. For example, you may
want an activity box that exceeds a particular criterion or filter to appear in bold red text, show a
symbol, or display against a different background.
The following columns in the grid are used to define each formatting rule:


Applies To — Select any of the field displayed in the activity box.



Criterion — Select one of the following:


A calculated field that evaluates to a Boolean (True/False) value or a filter



An on-the-fly expression that evaluates to a Boolean



A blank, indicating that the rule will be unconditionally applied



Font — Select a font, font style, and size.



Text Color — Select from the color palette.



Background — Select from the color palette



Alignment — Select either Center, Left, or Right.



Image — select the appropriate symbol from either the drop-down list or the Symbols dialog box.



Image Context — select one of the following:


< None > — Removes any image that may have been set in a rule on a higher row in the
grid.



< Default > — Retains the attributes of the prevailing rule on a higher row in the grid.



Centered in cell — Data is superimposed on the symbol which is centered.



Adjacent to data — Both data and symbol are displayed in the same cell.



Replaces data — Only symbol is displayed.
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Show This Explanation — Enter the explanation why the activity box has that specific formatting
such as font type, text color, background color, image, and so on, and what conditions or rules
are set for the formatting to be applied.

Change Order buttons — Use these buttons (
list.

or

) to move items to a different position in the

Display Explanation When Hovering over Applied Rule(s) — Select this option when you want to
display the hover text that you entered in the Show This Explanation column.
Once you have entered the explanation in the Show This Explanation column for a field and
selected the Display Explanation When Hovering over Applied Rule(s) option, hovering your
mouse over the said field in the activity box displays the explanatory text.
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However, when you zoom out and the network view is shrunk to 75% or less, the hover text is
replaced by the activity drawn at normal size, which is the default hover display.

To customize the display of the activity boxes for the Network View using the Conditional
Formatting dialog box, complete the following steps:
1. Open the project in Network View.
2. Right-click within the view, and select Conditional Formatting.
3. The Conditional Formatting dialog box opens.
4. Select a field under the Applies To column.
5. Once you have selected a field to format, you may choose a criterion or any other attribute to
modify the same field.
6. To make a formatting selection, click the drop-down list and/or the ellipsis box, if present.
7. To change the order of the items, select any cell in a row, and click one of the Change Order
buttons.
8. To delete an item from the list, select the row, and press the Delete key.
9. When finished making selections, click OK.
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Splitting the Network View
Open Plan allows you to “split” a network view in two. Both panes function normally, and each is
independent of the other. For example, scrolling one pane does not scroll the other.
There are three ways to split a network view:

Split view
cursor



Clicking Split View on the View tab



Double-clicking the splitter control.



Using the split view cursor to drag the splitter bar to the desired location.

The splitter control is located at the left edge of the horizontal scrollbar.

Splitter control

Hovering the cursor over the splitter control displays the split view cursor.
This feature is handy when you have to add a relationship between two activities that are not located
next to each other in a large network. To do so, display the predecessor in one pane and the
successor in the other. Then Alt+drag the cursor from the predecessor to the successor.

Once the link is created, both panes will show the new relationship line.
For more information on adding relationships, refer to Chapter 6, “Activity Information.”
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To split the network view, complete the following steps:
1. Open the appropriate network view.
2. Take one of the following actions:

Split view cursor



On the View tab, click Split View.



Double-click the splitter control located at the left edge of the horizontal scrollbar.



Point to the splitter control, and use the split view cursor that is displayed to drag the
splitter bar to the desired location.

To add a relationship using the split network view, complete the following steps:
1. Split the network view.
Add Relationship
cursor

2. Display the predecessor activity in one pane and the successor activity in the other.
3. Alt+drag the add relationship cursor from the start or finish of the predecessor to the start or
finish of its successor
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Overview

Overview
Spreadsheet views display the information for multiple records in a tabular format. This makes these
views well-suited for reports designed to show detail information at a relatively low level. Since they
are fully interactive, spreadsheet views are also useful for data entry purposes, particularly in cases
where large numbers of records are involved.
Open Plan uses a single-table spreadsheet to display information about activities. The spreadsheet
can be based on any table. For example, to view resource assignments, you would base the
spreadsheet on the resource table. You can also set up subsections or use outlining to display the
appropriate level of information.
Open Plan also provides standard versions of multi-table spreadsheet views that can display
information stored in different data tables.
You can customize all types of spreadsheets by defining the layout of data columns and setting a
number of preferences that control the display of data in these views.
This chapter discusses each of the ways you can customize a spreadsheet view and applies to both
stand-alone spreadsheets as well as the spreadsheet portion of barchart views.
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Customizing Spreadsheet Columns
All Open Plan spreadsheet views allow you to customize the layout of columns in a number of ways:


You can add or insert a column at a specific position.



You can define the formatting for a column.



You can delete a column.



You can change the column width or heading.



You can move the position of a column.

You can also customize columns in a spreadsheet view using a mouse.

Drag the column heading to
reposition the column.

Drag the header boundaries to
change the column width.

You can display the column header field name when you hover your mouse over the column
header.
This is particularly useful when you have renamed the column in the view and want to find the
source field.
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When you add or insert a new column or update an existing column, Open Plan displays the following
dialog box:

Format the text appearing in the column.

Click for automatic sizing.

Enter column width in characters.

The only difference between the Add Column, Insert Column, and Edit Column dialog boxes is
the name of the dialog box.

You can use the following settings to define the column to add:


Table Name — This field is enabled for multi-table spreadsheet views and specifies the table on
which the field to be displayed is located. This field is also enabled for single-table spreadsheets
based on the Activity table.
For single-table spreadsheets based on the Activity table, the list contains filters that you can
use to quickly locate a specific field within the Activity table.



Field Name — Specifies the field to be displayed. This field can be either one of the standard
Open Plan fields or a calculated field that has been added to a file.

In addition, you can simply type a calculated field that you create "on-the-fly” calculations in this field.


Title — Displays the text used to identify the field. While you can enter any text you wish in this
field, the default provided by Open Plan is the field name that is stored in the data dictionary.



Wrap Text — You can specify if Open Plan should wrap the data in the column cells and/or in the
column headings. If you do not choose these options, Open Plan truncates the display of any
data that does not fit within the column width.



Width — If you click the Best Fit option, Open Plan automatically adjusts the column width so
that either the column heading or the widest data item in the column can be displayed. You can
also enter a Specific width in characters for the column.



Text — You can format the text of the spreadsheet using the following options:
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Indent — Selecting this option indents the data in the column to indicate the hierarchical level
of the item.



Overwrite Default Font Settings — Selecting this option enables the following options that
you can use to override the default settings








Italics



Bold

Alignment — This option allows you to specify how data in the column should be aligned:


<Default> — This setting is based on the data type: alphanumeric fields are left-aligned
and numeric fields are right-aligned



Left



Center



Right

Color — This option allows you to override the default color for the text with a specific color
that has been predefined for the application.

Formatting — If the column contains numeric, duration, or date information, you can specify a
display format for the data. For example, you can have Open Plan display durations using any of
the following formats:


Minutes



Hours



Days



Weeks



Months
You can continue to enter duration information using any format regardless of the
display format you have selected.

In the case of numeric values, you can specify the number of decimal places to display as well as
the format.
The display of currency values can also be affected by the settings of the Control Panel in your
copy of Windows.
For more information about how Open Plan handles the display of currency values, refer to the
discussion of the Formatting setting in the online help system.

To add a column, complete the following steps:
1. Select a cell or column immediately to the left of the position for the new column.
You can select the column by clicking the column heading or by selecting a cell in the
column.
2. Take one of the following actions:


On the View tab, click Add.



Right-click the column heading, and click Add Column on the context menu.
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3. In the Add Column dialog box, enter the information for the new column.
4. When the information for the new column is complete, click OK.
Open Plan adds the column to right of the currently selected cell or column.
To insert a column, complete the following steps:
1. Select a cell or column immediately to the right of the position for the new column.
You can select the column by clicking the column heading or by selecting a cell in the
column.
2. Take one of the following actions:


On the View tab, click Insert.



Right-click the column heading, and click Insert Column on the context menu.

3. In the Insert Column dialog box, enter the information for the new column.
4. When the information for the new column is complete, click OK.
Open Plan adds the column to left of the currently selected cell or column.
To delete a column, complete the following steps:
1. Select the column you want to delete.
You can select the column by clicking the column heading or by selecting a cell in the
column.
2. Take one of the following actions:


On the View tab, click Remove.



Right-click the column heading, and click Remove Column on the context menu.

To edit a column, complete the following steps:
1. Select the column you want to edit.
You can select the column by clicking the column heading or by selecting a cell in the
column.
2. Take one of the following actions:


On the View tab, click Edit.



Double-click the column heading.



Right-click the column heading, and click Edit Column on the context menu.

3. Enter the new information for the column, and click OK.
To reposition a column, complete the following step:
Move cursor

1. Drag the column heading to the desired location.
To resize a column with a mouse, complete the following step:

Resize cursor

1. Drag the column boundary to the desired width.
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Using the Organize Spreadsheet Columns Dialog Box
You can insert and/or remove multiple columns in the spreadsheet or barchart by displaying the
Organize Spreadsheet Columns dialog box:

From this dialog box, you can perform the following actions:


Add columns for display



Remove columns from display



Rearrange the display order of the fields



Rename column properties using the Properties dialog box for a selected field



Filter items that will be displayed using the options in the Include group box



Add fields, such as calculated field expressions, to be included in the Available fields and
Display these fields panes. You can use the Add button to quickly add a calculated field as a
column in the spreadsheet. Clicking this button opens the Add column dialog box.
The Organize Spreadsheet Column is resizable. You can resize this by dragging any corner or
side of the dialog box. You can also resize the relative widths of the Available fields and Display
these fields panes by clicking between the two panes (near the bottom of the panes) and
dragging the mouse to either the left or right.

To add columns, complete the following steps:
1. Display the Organize Spreadsheet Columns dialog box by taking one of the following actions:


Right-click the spreadsheet, and click Organize Columns… on the context menu



On the View tab, click Table Layout

2. For each column you want to display in the spreadsheet, take one of the following actions:


Select the fields from the Available fields list and click the
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If a field is selected in the Display these fields list, the available field(s) selected will be
inserted before that field. You can click multiple fields by selecting the appropriate
check boxes.



Double-click the field from the Available fields.

This action moves the selected fields to the Display these fields list.
You can expand or collapse the category or table by clicking

or

.

You can also deselect all selected fields by clicking Clear All.

3. You can apply filters to manage the items that you want to be displayed by using the Include
group box.
The filters that can be used are the following:


Dates



Durations



Numerics



Text



Costs — Fields in the OP data dictionary used in the cost process when in the activity
table are displayed.



Logical — Filters and calculated fields with logical results are displayed
You can simultaneously activate all of the filters by clicking Select All. Click Deselect
All to deactivate all of the filters.
All filters are selected by default.

4. When finished, click OK.
To remove columns, complete the following steps:
1. Display the Organize Spreadsheet Columns dialog box by taking one of the following actions:


Right-click the spreadsheet, and click Organize Columns… on the context menu.



On the View tab, click Table Layout.

2. For each column you want to remove from the spreadsheet, take one of the following actions:


Select the fields from the Display these fields list and click the



Double-click the field from the Display these fields list.

button.

You can select multiple fields under the Display these fields list by holding the Shift or
Ctrl key and clicking the fields in the list.

This action moves the selected fields to the Available fields list.
3. When finished, click OK.
To rearrange the display of the fields, complete the following steps:
1. Display the Organize Spreadsheet Columns dialog box by taking one of the following actions:
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Right-click the spreadsheet, and click Organize Columns… on the context menu.



On the View tab, click Table Layout.

2. Select a field in the Display these fields list and click either
or down in the list.

or

to move the field up

3. When finished, click OK.
To change the field’s properties, complete the following steps:
1. Display the Organize Spreadsheet Columns dialog box by taking one of the following actions:


Right-click the spreadsheet, and click Organize Columns… on the context menu.



On the View tab, click Table Layout.

2. Select a field in the Display these fields list and click the Properties button.
The <Field> Properties dialog box opens:

This dialog box has the same fields as the Add Column, Insert Column, and Edit
Column dialog boxes. For more information on these dialog boxes, see “Customizing
Spreadsheet Column”.
Only the Title field and options applicable to formatting are available. The Advanced…
option is also not available when the dialog is invoked in this context.

3. When finished, click OK, and then OK in the Organize Spreadsheet Columns dialog box.
To add fields to the Available Fields or Display these fields panes, complete the following
steps:
1. Display the Organize Spreadsheet Columns dialog box by taking one of the following actions:


Right-click the spreadsheet, and click Organize Columns… on the context menu.



On the View tab, click Table Layout.
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2. Click the Add button located at the right side of the dialog box.
The Add Column dialog box displays.

3. Define the column settings that you want to add.
The Add Column dialog box has the same fields as the Insert Column dialog box. For more
information on these fields, refer to the first part of this section. On-the-fly calculated field
expressions will not appear in the Available Fields pane when they are removed from the
Display these fields list since such fields exist only in the context of a given view.

Using the Fill Column Down Command
The Fill Column Down command allows you to fill a spreadsheet column (or a selected range of
cells in a column) with a single operation. To use this command, enter the value you want to apply to
other cells in a spreadsheet column. Select a range of cells that includes the target cell as the
topmost cell. Select Fill Column Down and Open Plan responds by filling all the selected cells with
the value contained in the top cell of the range.
This command is available in both spreadsheet views and in the spreadsheet pane of a barchart
view.

To use the Fill Column Down Command, complete the following steps:
1. In a spreadsheet view, select a range of cells within a single column.
2. Take one of the following actions:


Press Ctrl+D.



On the Edit tab, click Fill Column Down.

3. When Open Plan asks for confirmation, click OK.

Chapter 20 Spreadsheet Views
Deltek Open Plan 8.0 User Guide

466

Customizing Spreadsheet Columns

Open Plan responds by filling all the selected cells with the value contained in the topmost
cell.
If you want to fill an entire column with the information in its first cell, right-click the column
heading, and click Fill Column Down on the context menu.

Splitting the Spreadsheet View
Open Plan allows you to split the view into two panes in order to “freeze” the columns displayed in the
left pane. No matter how far you scroll the right-hand pane horizontally, the information in the lefthand pane remains the same.

Splitter bar

You can still horizontally scroll the left-hand pane if you wish to change the information that is
displayed.

At the left edge of the horizontal scrollbar is the splitter control that you can use to drag the splitter bar
to the desired position. The splitter bar marks the boundary between the two panes.

Splitter control

To split the view, complete the following step:
1. Use one of the following procedures:
Split view cursor



On the View tab, click Split View.
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Double-click the splitter control located at the left edge of the horizontal scrollbar.



Point to the splitter control, and use the split view cursor that is displayed to drag the
splitter bar to the desired location.

Chapter 20 Spreadsheet Views
Deltek Open Plan 8.0 User Guide

468

Spreadsheet Display Options

Spreadsheet Display Options
You can set the various display options for a spreadsheet view with the Options tab of the
Spreadsheet Preferences dialog box:

This tab controls how a spreadsheet is displayed by using the following settings:


Table Name — Allows you to change the table upon which the spreadsheet is based.
For information on changing the spreadsheet table, refer to the “Support for All Tables”
section later in this chapter.





Grid Lines — Controls the display of grid lines on the spreadsheet. You can select on of the
following settings from the list:


Full — Displays both horizontal and vertical grid lines



Horizontal — Displays horizontal grid lines only



Vertical — Displays vertical grid lines only



None — Suppresses the display of grid lines

Grid Color — Controls the color of the grid lines that Open Plan displays on the spreadsheet.
Clicking the Grid Color drop-down arrow displays a Color dialog box that you can use to select a
color for the grid. The Color dialog box offers a choice of 70 standard.
You can define custom colors using an enhanced version of the Color dialog box accessed from
the General tab of the Options dialog box.
For more information on defining custom colors, refer to Chapter 25, “System Defaults.”
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Enable Subsections — Subsections allow you to group related data for presentation in a singletable spreadsheet view based on the contents of an activity field.
For more information on subsections, refer to the “Subsections” section later in this
chapter.



Enable Outlining — With outlining, you can use the hierarchical information implicit in the activity
ID to expand or collapse the display of detail information.
For more information on outlining, refer to the “Outlining” sections later in this chapter.



Disable Subsections and Outlining — Turns off both subsections and outlining.



Show Skills as Resources — Displays skills as resources on a resource spreadsheet.



Heading — Allows you to define the text color, background color, and font of the heading section
of a spreadsheet. This setting also controls the buttons on the left of the spreadsheet, matching
the heading color.



Table — Allows you to define the text color, background color, and font of the table section of a
spreadsheet.

To customize display options, complete the following steps:
1. On the View tab, click Preferences.
If you are in a barchart view, click Spreadsheet Preferences on the View tab.
You can also invoke this command by right-clicking an area of the spreadsheet and clicking
Preferences on the context menu.
2. On the Options tab, enter the information for the display options.
3. To return to the view, click OK.
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Support for All Tables
You can display any data table in a single-table spreadsheet view by using the Table Name option on
the Options tab of the Spreadsheet Preferences dialog box:

Select a data table to
display.

The Table Name option is available only for single-table spreadsheet views.

This field contains a list from which you can select a data table that the spreadsheet should use. If
you select a different table (for example, change from the Activity table to the Resource table), Open
Plan replaces the selection of fields displayed in the spreadsheet with the default set of the new table.
When you change the data table, double-clicking the selection box for an activity on the spreadsheet
displays the relevant Details dialog box.
Because all code tables have the same structure, changing between code tables does not affect
the columns that are displayed in the spreadsheet.

To change the spreadsheet table, complete the following steps:
1. Display a single-table spreadsheet view.
2. Take one of the following actions:


On the View tab, click Preferences.



Right-click an empty area of the spreadsheet, and click Preferences on the context
menu.
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3. From the Table list on the Options tab, select the data table to display.
4. Click OK.
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Subsections
Subsections allow you to group related data for presentation in a single-table spreadsheet view based
on the contents of an activity field:

Subsection header

You can display summaries for subsections at either the top or the bottom of the group. The type of
summarization Open Plan performs for a column depends on the data displayed in the column. For
example, if the column displays a numeric value, then the summary represents the total of all the
values for that subsection. On the other hand, a column displaying finish dates will summarize as the
latest date in that group. Some columns (for example, activity IDs or descriptions) do not summarize
at all.
You can control how calculated fields are summarized by Open Plan in subsections.
For more information on calculated fields, refer to Chapter 23, “Project Utilities.”

You can also display a row showing grand totals for the entire project at the bottom of the view.
Open Plan allows you to specify the font, text color, and background color for subsection headings
and summary lines. In addition, you can indicate a field to display for each heading. This allows you,
for example, to base your subsections on a particular activity code and then display the description
field for that code in the subsection heading. You also have the option of forcing a page break each
time a new subsection appears in the view.
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You can define subsections for the spreadsheet portion of a barchart view as well as for stand-alone
spreadsheet views:

If you use subsections for a view that has a sort order in effect, Open Plan sorts the rows within
the defined subsections.

To enable subsections, use the Options tab of the Spreadsheet Preferences dialog box:

Click to enable subsections.

To enable subsections, complete the following steps:
1. Open the appropriate spreadsheet or barchart view.
2. Take one of the following actions:
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On the View tab, click Preferences. (In a barchart view, click Spreadsheet
Preferences.)



Right-click the spreadsheet, and click Preferences on the context menu.

3. On the Options tab of the Spreadsheet Preferences dialog box, click Enable Subsections.

Defining Subsections
You can control the subsections for a spreadsheet view. To set up subsections, you must first enable
subsections on the Options tab of the Spreadsheet Preferences dialog box. You can then define the
settings for the subsections by displaying the Subsections tab:

Select to enable grand totals.

Scroll to see additional
settings.

Subsections are defined using the Break On column on the Spreadsheet Preferences Subsections
tab. Each additional row entered in the Break On column of the subsections grid indicates a further
sublevel grouping.
Wherever you add a “break,” you can insert a heading row in the spreadsheet view to indicate a
subsection. You can then choose a heading label for the row or just leave it blank.
The Subsections tab contains the following:


Grid — Each line on the grid uses the following settings to control how Open Plan displays the
information within a subsection. The grid on this tab contains the following fields:


Break On — This field defines the criteria by which members of the subsection are grouped.
When this field is selected, Open Plan displays a list containing fields from the current table.
If a hierarchical field is selected from the list, you can further define the level in the hierarchy
that determines the grouping. This field can be a user-defined calculated field.
You may subsection on data items from different tables with multi-table spreadsheet
views. In this case, when you select the subsection data item, it appears in the form
[TABLE]FIELD. In this case, FIELD refers to the actual field name that Open Plan uses
internally (e.g., "ACT_ID" instead of "Activity ID").
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Break Level — The hierarchical level that triggers a subsection. This setting applies only if
you selected a hierarchical field for the Break On setting. For example, a code field
representing a work breakdown structure is a hierarchical field.



Page Break — Set to Yes if you want Open Plan to begin a new printed page each time
there is a different value at this row's subsection level.



Font — The font used to display the subsection heading.



Text — The text color used to display the subsection heading.



Background — The background color used to display the subsection heading.



Heading — This field controls the display of a heading line at the beginning of a subsection.
If you select Yes, Open Plan enables the Heading Field column.
You must display headings for each subsection level if you want to be able to expand
and collapse subsections in a view.



Summary — This field controls the display of a summary line. The options for this field are:


Bottom – Displays the summary at the bottom of the subsection.



Heading – Displays the summary on the same row as the heading.



Top – Displays the summary at the top of the subsection.



<None> – Inhibits the display of a summary line.
If you are customizing the spreadsheet pane of a barchart view, you must display a
subsection summary line to display a summarized bar in the barchart pane or you may
enable the "Show Summary Bars when there are no Subsection Summary Rows" check
box.

Summary information appears only for the following field types:


Numeric – Display the total in a given section.



Date – Displays the earliest date in the subsection.
If any of the start dates in a subsection are blank, the summary date will be blank as
well.




Finish Date – Displays the latest date in the subsection.

Heading Field — Specify the field to appear in the subsection header for descriptive
purposes. Open Plan offers a default heading field, usually the same field on which
subsections break. For hierarchical fields, however, the default heading is a combination of
the ID and description fields appropriate to the level on which the subsectioning is based.
To set up a subsection heading that includes a descriptive label (for example, “Total
Float =”), create a calculated field that contains the text string and assign it as the
heading field. For information on calculated fields, refer to Chapter 23, “Project
Utilities,” in this guide and “Chapter 2, “Defining Calculated Fields,” in the Deltek Open
Plan Developer’s Guide.

The bottom half of the Subsections tab contains the following settings:
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Grand Total Options — To generate a grand total summary row at the end of the report,
select Enable Grand Total. You can also define a text color, background color, and font for
the grand total.
The grand total of the view includes totals for all activities that are displayed in the
current view. Activities that do not appear in the view due to a filter are not included in
the grand total calculations.



Show Summary Bars when there are no Subsection Summary Rows — Selecting this
options will display summary bars in a barchart view when the Summary setting is not
enabled.



Sort Blank Values Last — Selecting this option causes a subsection containing blank values
that would normally be sorted above non-blank values to be displayed below the non-blank
values.



Initial Drill Down Level — Controls the lowest level that is expanded on the spreadsheet
when it is first opened. The default for this field is 0, which results in the top level being
expanded.



Number of Characters to Indent per Level — Controls the number of characters Open Plan
should use when indenting a spreadsheet view that has heading rows defined. You can enter
any value between 0 and 20.

To define subsections, complete the following steps:
1. Open the appropriate spreadsheet or barchart view.
2. Display the Subsections tab of the Spreadsheet Preferences dialog box.
3. Enter the information for the subsections, and click OK to return to the view.
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Outlining
Outlining is a feature available in spreadsheet views, including the spreadsheet portion of the
barchart view. With outlining, you can use the hierarchical information implicit in the activity ID to
expand or collapse the display of detail information:

Click to collapse or expand this row

For information about using outlining to expand and collapse subprojects, refer to Chapter 6,
“Activity Information.”

With the outlining feature, you can display higher-level elements using a different font and
background color to distinguish them from detail rows. You can also indicate the default level for
collapsing information.
If you use outlining for a view with a filter in effect, the display of child items is determined by the
status of the parent. If you use outlining for a view that has a sort order in effect, Open Plan
sorts the rows within the defined outlining structure.
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To enable outlining for a spreadsheet view, use the Options tab of the Spreadsheet Preferences
dialog box:

Click to enable outlining.

To enable outlining, complete the following steps:
1. Open the appropriate spreadsheet or barchart view.
2. Take one of the following actions:


On the View tab, click Preferences. (In a barchart view, click Spreadsheet
Preferences.)



Right-click a row or a column heading in the spreadsheet, and click Preferences on the
context menu.

3. On the Options tab of the Spreadsheet Preferences dialog box, click Enable Outlining.
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Defining Outlining
You can control the outlining feature for a spreadsheet view. To define outlining, you must first enable
the feature by clicking Enable Outlining on the Options tab of the Spreadsheet Preferences dialog
box. You can then define the settings for outlining by displaying the Outlining tab:

Use the following settings to define outlining for a view:


Initial Drill Down Level — Controls the lowest level that is expanded on the spreadsheet. You
can enter any value for this field between 0 and 20. The default is 0. This means that the entire
structure is collapsed.



Number of Characters to Indent per Level — Controls the number of characters Open Plan
should use when indenting a spreadsheet view that has the outlining option enabled. You can
enter any value between 0 and 20.



Filter from the Top Down — When using outlining in a spreadsheet or barchart, this option
controls how Open Plan applies a filter:





If this option is selected, Open Plan applies the filter to a parent activity before applying it to
its children. When the filter is applied top down, an activity is displayed only if it and all of its
descendants match the filter. This may cause some activities not to be displayed even though
they match the filter. For example, assume that Activity A matches the filter, but that its child
Activity A.1 does not. With this setting, neither Activity A nor Activity A.1 will be displayed.



If this option is cleared, Open Plan applies the filter bottom up. This means that Open Plan
applies the filter to a child activity before applying it to its parent. This is the default setting.
When the filter is applied bottom up, an activity is displayed if it or any of its descendants
match the filter. This may cause some activities to be displayed even though they,
themselves, do not match the filter. For example, assume that Activity A does not match the
filter, but that its child Activity A.1 does. With this setting, both Activity A.1 and its parent,
Activity A will be displayed.

Background Color — Controls the background color Open Plan displays for the outline rows.
Clicking the down arrow for this field displays a Color dialog box that you can use to select a color
for that feature. The Color dialog box offers a choice of 70 standard colors.
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You can define custom colors using an enhanced version of the Color dialog box
accessed from the General tab of the Options dialog box.



Font — Click the Font button to display a dialog box where you can change all the font attributes
for the text Open Plan displays for the outline rows.
Open Plan always sorts within the outline and calculates summary information for
outlining from the entire project, regardless of any filters in effect.

To define outlining, complete the following steps:
1. Open the appropriate spreadsheet or barchart view.
2. Display the Outlining tab of the Spreadsheet Preferences dialog box.
3. Enter the information for the outlining feature, and click OK to return to the view.
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Although it is possible to display individual fields from different data tables using calculated fields,
Open Plan offers a more general linking capability in multi-table spreadsheet views. In multi-table
spreadsheet views, you can display any field from linked tables just as though the field resided on the
primary data table for the view. This allows you to produce sophisticated reports showing information
from a number of different data tables.
Open Plan provides a number of standard multi-table spreadsheet views, including a resource/activity
spreadsheet that displays information from the resource description table (the primary data table for
the view), the assignment table, and the activity table:

In the example illustrated above, notice that there are many assignments for each resource — in
other words, there is a one-to-many relationship between each resource (the primary record) and its
assignments (the secondary records). Just as you can expand and collapse records in a spreadsheet
view using outlining, multi-table spreadsheet views allow you to expand and collapse the display of
information based on one-to-many relationships. To expand or collapse the display of secondary
records in a multi-table spreadsheet view, use the outlining button (displayed to the left of the row) or
the Collapse, Expand, and Expand All commands.
Multi-table spreadsheet views can combine outlining on an activity or resource ID with the
display of one-to-many secondary records from linked data tables.
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Defining Links
You can define the links for many multi-table spreadsheet views. By customizing the linking in a multitable spreadsheet view, you can display fields from any linked data table. To define links in a multitable spreadsheet view, display the Define Links tab in the Spreadsheet Preferences dialog box:

Use this dialog box to define the tables and fields comprising the link. For example, to link to the
Assignment table from the Resource Description table, you might use the Res. ID field, which
appears on both tables. This type of one-to-many link would allow you to display the activity IDs for
each assignment stored for a resource. To display more information about these activities (for
example, their descriptions), you could then link from the Assignment table to the Activity table
using the activity ID field.
For a complete listing of data tables and fields in Open Plan, refer to Chapter 18, “Open Plan
Table Migration” in the Deltek Open Plan Developer’s Guide.

Notice that Open Plan does not allow recursive linking — that is, linking a file back to itself. Thus, for
example, you cannot create a view that shows both predecessors and successors for activities by
linking the Activity table to the Relationship table and then linking the Relationship table back to
the Activity table. Instead, you must define two links between the Activity table and the
Relationship table as follows:
Activity

Activity ID

Relationship

Activity

Activity

Activity ID

Relationship

Succ ID

Open Plan limits the list choices for linking tables and fields to only those that are based on the From
Table.
For example, if the resource description table is linked to both the assignment and usage tables, data
from the assignment and usage records will be displayed on the same line. This is true even if no
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relationship exists between the data from these two tables except through the single resource
description record.
You can also use this Define Links tab to indicate if the primary record should appear on a row by
itself in cases of one-to-many links. If you do not select the Put Primary Record on Its Own Row
option, Open Plan displays the first linked record on the same row as the primary record.
Clicking Baselines Colors displays a dialog box that allows you to assign a different color for up to
three baselines.
For more information on multiple baselines, refer to Chapter 16, “Status Information.”

To define links, complete the following steps:
1. On the View tab, click Preferences.
If you are in a barchart view, click Spreadsheet Preferences on the View tab.
You can also invoke this command by right-clicking a column heading and clicking
Preferences on the context menu.
2. On the Define Links tab, enter the tables and fields that define the links, and click OK to
return to the view.
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Modifying Hierarchal IDs Using Indent and Outdent
Open Plan allows you to quickly modify hierarchical IDs for activity, resource assignment, and code
assignment spreadsheets by using the Indent and Outdent commands.
After displaying the appropriate spreadsheet, you simply select the target ID and issue either the
Indent or Outdent command. Depending on the command, Open Plan responds with one of the
following actions:


Indent — The target ID is made into a child of the previous ID and that previous ID is made into a
subproject if it is not already one.
For example, assume you have a project with the following activities:
10
20
30
40
50
Indenting ID 20 instructs Open Plan to make it a child of ID 10 and to make ID 10 a subproject.
Therefore, the following hierarchy results:
10
10.20
30
40
50



Outdent — The target ID is promoted to the level of its parent and assigned the first available ID
in the hierarchy.
For example, assume you have a project with the following hierarchy:
10
10.1
30
40
50
If ID 10.1 were to be outdented, Open Plan would promote it to the same level as ID 10 and
assign it the first available ID according to the rules of automatic numbering.
For more information on automatic numbering, refer to the next section, “Automatic Numbering
within a Spreadsheet.”
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Automatic Numbering within a Spreadsheet
Activity IDs and resource IDs can be generated automatically from within a spreadsheet view. If you
leave the ID field blank on the appropriate Details dialog box when creating a new activity or
resource, Open Plan generates an ID for the new item automatically according to the following rules:


If the previous ID at a given level is all alphabetic, the program increments alphabetically.



If the previous ID at a given level is a mixture of alphabetic and numeric characters, the numeric
part is incremented numerically.



If there is no previous ID, the program uses a numeric ID. Therefore, the first ID in the file is
numbered "1."

Open Plan attempts to find a pattern in the ID numbering scheme for IDs that are incremented
numerically by looking at the last two IDs in the hierarchy. If a pattern can be established, Open Plan
uses the pattern when automatically creating a new ID.
For example, assume that your project has the following hierarchy:
A11
A12
A13
A14
A15
A20
Open Plan looks at the last two IDs in the hierarchy and determines that there is an difference of 5
between the two. Therefore, if you use automatically numbering to create the next ID, Open Plan
creates ID A25.
On the other hand, if there is only one ID in the hierarchy and you have Open Plan create the other
IDs , it uses the ID’s value as the incremental pattern.
For example, if you enter 12 for the first ID in the hierarchy and then have Open Plan create the
remaining IDs, it increments the IDs by 12 resulting in the following hierarchy:
12
24
36
48
60
For information on using automatic numbering when creating new resources in a resource view,
refer to Chapter 7, “Resource Definitions.” For information on using automatic numbering when
creating new codes in a code view, refer to Chapter 11, “Project Codes.”
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Overview

Overview
Open Plan offers two types of histogram views: resource histograms and risk histograms. Both types
of views allow you to display time-scaled data using a graphical format, a tabular format, or a
combination of the two.
Resource histograms are familiar reporting tools in most project management systems since they can
display resource and cost data in an easy-to-understand graphical form. Resource histogram views
are especially useful for modeling project resources since they allow you to compare resource
assignments to availabilities as well as allow you to view the overall usage of a resource (or a group
of resources) over the time span of the project.
Risk histograms, on the other hand, display the results of risk analysis for designated key activity in a
project. Risk histograms allow project planners to see at a glance how Open Plan scheduled an
activity over the course of many trial simulations.
In Open Plan, you can display a resource histogram as a stand-alone view or as part of a barchart
view. In either case, the features of the resource histogram are identical, and you can perform any
operation in a similar manner in either view. By contrast, risk histograms are available only as standalone views.
This chapter starts with a general discussion of resource histogram views in Open Plan, followed by a
description of the types of resource and earned value information that can appear in a histogram
view. Next is a description of how to customize a resource histogram.
The chapter concludes with a discussion of risk histograms, followed by information on how to select
an activity to view in a risk histogram and how to customize the view.
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Working with Resource Histograms
To display a resource histogram in Open Plan, the following conditions must be met:


You have assigned a resource file to a project.



The project has at least one activity with a resource assignment.



You have selected a resource to display. (Use the Select Resource command from the View tab
to indicate your selection.)
If you are only interested in showing resource or cost information based on early or late dates,
you do not have to perform resource scheduling to display a resource histogram.

Each bar in the histogram represents a value corresponding to the smallest time unit displayed on the
date scale. For example, if you define a date scale with the most detailed axis showing months, you
can display bars that show how many units of the selected resource are required on a monthly basis:

If you are displaying a resource histogram as part of a barchart view, the date scale for the barchart
pane controls the display of the histogram. If you are displaying the resource histogram as a standalone view, the date scale typically starts at the earliest instance of relevant project data. For
example, if you are not displaying actual cost information, the histogram starts at Time Now since this
is the earliest date that time analysis or resource scheduling can schedule an activity.
When you view a resource histogram that shows bars or S-curves, notice the legend to the left of the
date scale. This legend tells you the type of information represented by the bars and S-curves.
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If you prefer to see the precise values being represented in the view, you can configure a resource
histogram to display information in a tabular format below the bars:

It is also possible to display just the tabular portion of the view.
As in the case of histogram bars, the aggregation of tabular data corresponds to the smallest unit
displayed on the date scale.
In addition to displaying information aggregated on a period-by-period basis, you can display
cumulative S-curves in a resource histogram view:

Chapter 21 Histogram Views
Deltek Open Plan 8.0 User Guide

490

Working with Resource Histograms

This feature can be combined with the display of histogram bars:

Views that combine both histogram bars and S-curves, the vertical axis for the histogram bars
appears on the left, while the vertical axis for the S-curve appears on the right.
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Displaying Resource Information
Resource histogram views allow you to display the following types of resource information in a
graphical format:


Resource availabilities



Resource assignments based on the early dates calculated by time analysis



Resource assignments based on the late dates calculated by time analysis



Resource assignments based on the scheduled dates calculated by resource scheduling (these
assignments can show the effects of splitting, stretching, and reprofiling activities)



Baseline resource assignments using the dates (early, late, or scheduled) selected at the time
you created the baseline currently attached to the project



Actual resource usage based on resource progress information

You can use a resource histogram view to display any of these items individually, or you can display
more than one at the same time.
The options that define how resource information appears in a view are found on the Resources tab
of the Histogram Preferences dialog box:

Select to show
item in view.

Use the following settings to control the appearance of resource information:


Show — You can indicate one or more sets of resource data to appear in the view as either
histogram bars or S-curves. You can also indicate the color of the bar by clicking the drop-down
arrow to display a Color dialog box from which you can choose a color. For S-curves, clicking the
ellipsis button displays the S-Curve Line Selection dialog box that you can use to indicate the
line style and color to use for the line.
For early dates, late dates, scheduled dates, baseline dates, and actuals, the defined
color indicates the color of the first selected resource when stacked. Subsequent
stacked resources are assigned a color automatically by Open Plan.
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Availability —You can select from the following options to choose the type of availability data
that Open Plan should show in both a histogram bar and an S-curve:


Total Availability — Displays the total availability of the resource. The histogram does not
identify quantities that are reserved for another project or used by a project with a higher
priority.



Unreserved Availability — Displays the availability that is not reserved for another project.



Unused Availability — Displays the availability that is not used by a project with a higher
priority or reserved for another project.



Total & Reserved — Displays both the total availability and the availability that is reserved
for another project.



Total & Reserved or Used — Displays both the total availability and the availability that is
either reserved for another project or used by a project with a higher priority.



Total, Reserved and Used — Displays the total availability, the availability that is reserved
for another project, and the availability that is used by a project with a higher priority.



Unreserved and Used — Displays both the availability that is not reserved for another
project and the availability that is used by a project with a higher priority.

If the option selected includes the total, this is shown with a solid line. Otherwise, the solid line will
represent the net availability of reserved availability, or the net availability of reserved and used
availability.
If the option selected includes more than one of the three possibilities, these will be shown as
progressively lighter filled areas below the solid line.
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The following histogram has the option Total, Reserved and Used selected and shows the gradation
of the availability line:

By comparing resource assignments and usage with the availability information, you can easily see
where each resource is over- or under-utilized.


Calculate — You can have Open Plan display resource information in terms of either resource
units, base unit costs, or escalated costs. You can also specify the label displayed on the vertical
axis for the selected value.
The option to show escalated costs does not affect the display of actuals.



Values for — You can control which values appear in the view with one of the following options:


Average Histogram — Resource values appear as bars representing an average value per
the default duration unit used by the project. Open Plan calculates this average over the
smallest time unit displayed on the date scale and uses the default project calendar to
determine valid working periods. (If you have not assigned a calendar to the project, Open
Plan assumes a 5-day, 40-hour work week with no holidays.) This option does not apply to Scurves.



Totals — In Open Plan, histogram bars can display total values. When this option is selected,
each bar represents a total value for the period defined by the date unit. S-curves represent
cumulative total values.
Text boxes allow you to enter labels for both histogram bars and S-curves.
To create a view that shows the equivalent headcounts for resource availabilities and
assignments based on person-days, display average resource values.

To define the display of resource information, complete the following steps:
1. Display the Histogram Preferences dialog box by taking one of the following actions:


On the View tab, click Preferences (in a barchart view) or Preferences (in a histogram
view).
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Right-click anywhere in the view, and click Preferences on the context menu.

2. On the Options tab, click the Resources setting for the Display option.
3. Click the Resources tab.
4. Enter the information, and click OK to return to the view.
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Displaying Earned Value Information
As an alternative to resource information, you can display the following types of earned value
information in a resource histogram view:


Forecast — Open Plan determines the forecast cost (Estimate At Complete or EAC) of a
resource by adding any actual costs prior to Time Now to any planned costs subsequent to Time
Now. If you choose to display forecast costs, you can base planned costs on early, late, or
scheduled dates.



Budgeted Cost of Work Scheduled (BCWS) — BCWS is derived from the planned resource
budget stored in the current baseline for the project. This budget may be based on early, late, or
scheduled dates depending on the dates used to create the baseline.



Actual Cost of Work Performed (ACWP) — ACWP is based on the actual costs recorded for
the resource.



Budgeted Cost of Work Performed (BCWP) — To calculate BCWP, Open Plan applies the
value from the physical completion of the resource assignment to the corresponding portion of the
planned resource budget (as defined in the current project baseline). For example, if you indicate
that resource assignment has a physical complete value of 50%, Open Plan calculates BCWP for
an assigned resource by determining how much of its planned budget (BCWS) corresponds to
the first half of the activity duration.
Note that earned value information can be displayed in terms of either resource units or
resource costs.

You can use a resource histogram view to display any of these items individually, or you can display
more than one at the same time.
The options that define how earned value information appears in a histogram view are found on the
Earned Value tab of the Histogram Preferences dialog box:

Click to show item
in view.

Use the following settings to control the appearance of earned value information:
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Show — You can indicate one or more sets of earned value data to appear in the view. You can
also indicate the color of the bar or line for each item. If you are displaying forecast costs, you can
indicate which set of forecast dates to use as the basis of the forecast.
The defined color indicates the color of the first selected resource. Subsequent
resources are assigned a color automatically by Open Plan.



Calculate — You can have Open Plan display earned value information in terms of either
resource units, base unit costs, or escalated costs. You can also specify the label displayed on
the vertical axis for the selected value.
The option to show escalated costs does not affect the actuals portion of forecast costs
or the display of ACWP.



Values for — You can also specify identification labels for both histograms and S-curves.

To define the display of earned value information, complete the following steps:
1. Display the Histogram Preferences dialog box by taking one of the following actions:


On the View tab, click Preferences (in a barchart view) or Preferences (in a histogram
view).



Right-click anywhere in the view, and click Preferences on the context menu.

2. On the Options tab of the Histogram Preferences dialog box, click the Earned Value setting
for the Display option.
3. Click the Earned Value tab.
4. Enter the information, and click OK to return to the view.
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Customizing Resource Histogram Views
Three operations allow you to customize resource histogram views in Open Plan:


Selecting resources



Defining histogram display options



Customizing the date scale

Selecting Resources
Before you can display data in a resource histogram, you must select the resource(s) to include in the
view. When you click Select Resource on the View tab, Open Plan displays the Resource Selection
dialog box:
Select the type of resources to display in the list.

Select the resources to view.

Show only resources that have been assigned to activities.

The list field at the top of the dialog box allows you can to filter the display of resources by category:


All Resource Categories



Labor



Material



Other Direct Costs



Subcontract
A resource’s category is defined on the General tab of the Resource Details dialog box.

The Expand All button will expand the entire hierarchy for viewing.
To display a resource from the list, simply select the checkbox next to the resource name. To select
all the resources, click the Select All button.
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You can also choose to display resource pools in the histogram. Keep in mind, however, that all
availabilities, requirements, and usage displayed for a pool include both the pool and a roll-up of the
child resources belonging to the pool. Clearing the Hide Unreferenced Resources setting displays
the entire resource use file hierarchy, which makes the resource pools available for selection.
When selecting resources to display, be sure that all selected resources use the same time unit.
For example, you should not mix resources measured in person-hours and resources measured
in person-days or person-weeks in the same bar.

The Show options determine how Open Plan displays bars or curves representing more than one
resource. There are three choices:


Total — This option displays the resource bars or curves for multiple resources as a total
quantity. You cannot discern the amount of resource requirement or usage within a time frame for
any specific resource.



Stacked — This option displays the resources bars for multiple resources in a stacked format.
Each selected resource is displayed in a separate color. In the case of cumulative values, Open
Plan displays separate S-curves for each resource.



Category — This option displays the resource bars for each resource category. In the case of
cumulative values, Open Plan displays separate S-curves for each resource category.
If you select both a pool and any other pool or individual resource, the histogram displays each
pool as a total histogram bar or S-curve.

To select resources, complete the following steps:
1. Take one of the following actions:


On the View tab, click Select Resource.



Right-click anywhere in the view, and click Select Resource on the context menu.

2. Select one or more resources from the list displayed in the dialog box.
To select all the resources, click Select All.
3. Indicate if the bars and curves should be total, stacked, or category.
4. When the information is complete, click OK to return to the view.
If you have applied a filter to the view, a resource histogram represents only those activities that
satisfy the filter.
For information about filters, refer to Chapter 17, “Views and Reports.”
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Resource Histogram Display Options
To define the appearance of bars in a resource histogram view, click Preferences on the View tab or
right-click within the histogram view and click Preferences on the context menu to display the
Options tab of the Histogram Preferences dialog box:

With this dialog box, you can indicate whether you want to display resource information or earned
value information and if you want to display a graph only, a table only, or a combination of the two. If
you display a table, you can indicate how many decimal places should be displayed.
You also have the option of specifying the bar style (3-dimensional or flat). If multiple bars are
displayed, you can specify their display as either side-by-side or front-to-back. If you choose to
display flat bars front-to-back, Open Plan varies the width of the bars to distinguish between the
different types of information being displayed, for example:
Early dates
Late dates
Schedule dates

You can also set the following options:


Scale Factor — This setting determines how Open Plan scales the values appearing in the
histogram bar or S-curves. For no scaling, set the scale factor to 1.



Max Y Value — This setting determines the highest value displayed on the vertical axis of the
histogram bars or S-curves. To allow Open Plan to set a maximum value based on the data,
leave this setting at 0.



Number of Decimal Places — This field controls the number of decimal places that Open Plan
should display on the histogram. You can specify any value between 0 and 5.



Time Now — You can select from the following three options:


None — If you select this option, Open Plan does not display the Time Now line on the
histogram.
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Line — If you select this option, Open Plan identifies Time Now using a vertical line. There is
no identifying text beside the Time Now line.



Line with Text — If you select this option, Open Plan identifies Time Now using a vertical
line. In addition, the words "Time Now" are displayed next to the Time Now line.

If the histogram is displayed as a pane in the barchart view, Open Plan also features the following
additional options:


Conditional Line — If you select this option, Open Plan identifies Time Now using a vertical
line only if the barchart identifies Time Now with a vertical line.



If the barchart does not identify Time Now in this way, the histogram does not identify Time
Now.



Conditional Text — If you select this option, Open Plan identifies Time Now using both a
vertical line and the text specified as the label in the Barchart Preferences dialog box only if
the barchart identifies Time Now with a vertical line and a label.
If the barchart does not identify Time Now in this way, the histogram displays Time Now with
only a vertical line.



Resource Description — You can select from the following options:


Show Full ID — If you select this option, Open Plan identifies each resource by the full
resource ID. For example, the resource may be identified as:
TEAM.LAB.JOAN



Show Local ID — If you select this option, Open Plan identifies each resource by the local
portion of the resource ID. For example, the resource may be identified as:
JOAN
Where:
JOAN is the local portion of the TEAM.LAB.JOAN resource ID.



Show Description — If you select this option, Open Plan identifies each resource only by its
description. For example, the resource may be identified as:
JOAN SHERWOOD
Where:
JOAN SHERWOOD is the resource description.



Show Full ID and Description — If you select this option, Open Plan identifies each
resource by both the full resource ID and the description. For example, the resource may be
identified as:
TEAM.LAB.JOAN JOAN SHERWOOD
Where:
TEAM.LAB.JOAN is the full resource ID.
JOAN SHERWOOD is the resource description.



Show Local ID and Description — If you select this option, Open Plan identifies each
resource by both the local portion of the resource ID and the description. For example, the
resource may be identified as:
JOAN JOAN SHERWOOD
Where:
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JOAN is the local portion of the resource ID.
JOAN SHERWOOD is the resource description.


Font — Clicking this button displays the Font dialog box that you can use to customize the font
used in the histogram view.

To define histogram display options
1. Take one of the following actions:
On the View tab, click Preferences (in a barchart view) or Preferences (in a histogram view).
Right-click anywhere in the view, and click Preferences on the context menu.
2. On the Options tab of the Histogram Preferences dialog box, enter the information for the
display options.
3. When the information is complete, click OK to return to the view.

Customizing the Date Scale
You can customize the date scale appearing in a stand-alone resource histogram view using the
same procedures that you use to customize the date scale in a barchart view. (In fact, when a
resource histogram appears in a barchart view, the barchart date scale controls the histogram portion
of the view as well.)
For information about customizing the date scale, refer to Chapter 18, “Barchart Views.”
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Working with Risk Histograms
To display a risk histogram in Open Plan, the following conditions must be met:


You must have performed risk analysis for the project.



The project must have at least one activity designated as a key activity.



You have selected an activity to display. (Click Select Activity from the View tab or right-click the
workspace and click Select Activity from the context menu.)

As in the case of resource histograms, each bar in a risk histogram represents a value corresponding
to the smallest time unit displayed on the date scale. For example, if you define a date scale with the
most detailed axis showing months, you can display bars that show how many times a key activity
finished in a given month:

When you view a risk histogram, notice the legend to the left of the date scale. The legend includes
information related to risk calculations — the mean values and standard deviations for the dates
being displayed as well the equivalent date calculated by time analysis or resource scheduling. The
legend also tells you the type of information appearing in the histogram, and how that information is
displayed.
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If you prefer to see the precise values being represented in the view, you can configure a risk
histogram to display information in a tabular format below the bars:

It is also possible to display just the tabular portion of the view.
As in the case of the histogram bars, the aggregation of tabular data corresponds to the smallest unit
displayed on the date scale.
In addition to displaying information aggregated on a period-by-period basis, you can display Scurves representing the cumulative results of multiple trials:

This feature is especially useful for estimating how much confidence is associated with a particular
start or finish date.
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Customizing Risk Histogram Views
Three operations allow you to customize risk histogram views in Open Plan:


Selecting a key activity



Defining histogram display options



Customizing the date scale

Selecting a Key Activity
Open Plan allows you to select the activity that appears in the view using the following dialog box:

To select a key activity, complete the following steps:
1. Click Select Activity from the View tab or right-click anywhere in the view, and click Select
Activity on the context menu.
2. Select an activity from the list displayed in the dialog box, and click OK to return to the view.

Chapter 21 Histogram Views
Deltek Open Plan 8.0 User Guide

505

Customizing Risk Histogram Views

Risk Histogram Display Options
To define the appearance of a risk histogram view, display the Risk Analysis Preferences dialog box:

With this dialog box, you can indicate which dates (Early Start, Early Finish, Late Start, or Late
Finish) to display in the view and whether you want to display histogram bars or cumulative S-curves.
You can also indicate whether you want to display a graph only, a table only, or a combination of the
two. If you display a table, you can indicate how many decimal places should be displayed.
If you are displaying histogram bars, you have the option of specifying the bar style (3-dimensional or
flat). If multiple bars are displayed, you can specify their display as either side-by-side or front-toback. If you choose to display flat bars front-to-back, Open Plan varies the width of the bars to
distinguish between the different types of information being displayed.
To define risk histogram display options, complete the following steps:
1. Take one of the following actions:


On the View tab, click Preferences.



Right-click anywhere in the view, and click Preferences on the context menu.

2. Enter the information for the display options.
3. Click OK to return to the view.

Customizing the Date Scale
As in the case of a resource histogram, you can customize the date scale appearing in a risk
histogram view using the same procedures that you use to customize the date scale in a barchart
view.
For information about customizing a histogram date scale, refer to Chapter 18, “Barchart Views.”
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Overview

Overview
Open Plan includes three facilities for importing and exporting project data:


An import/export facility for Microsoft Project .mpp files



An import facility for projects created with Primavera Project Planner®.



A customizable import/export facility based on user-defined scripts that can be used to transfer
project data to and from a wide range of external applications
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Microsoft Project
Open Plan features a seamless integration with the data formats used by Microsoft Project, allowing
Open Plan to share project data with it. This interface accepts data in Microsoft Project’s .mpp format.

Importing Microsoft Project Data
You can display the Microsoft Project Import Wizard – Project Page by clicking the MS project
button from the Import group of the Integration tab.

Microsoft Project Import Wizard – Project Page
This page allows you to select the Microsoft Project (.mpp) files to be imported.

This page contains the following fields:


Load File Info for Project — Selecting this option retrieves the settings information used last for
the project selected, if any. When selected, any files in the Project File(s) list box are cleared
and replaced with the last MSP Project imported into the selected Open Plan project.



Project Files(s) — Click

to locate and select the .mpp files that you want to import:

Selecting one or more .mpp files and clicking Open on the Open dialog box instructs Open Plan
to populate the Project Files(s) list with the location and file name of the project files.


Update an Existing Project — Selecting this option opens the Select Open Plan Project to Update
dialog box.
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You will not be allowed to update an existing project when you select multiple projects to
import in the Project File(s) list.

Microsoft Project Import Wizard – Options Page
The Microsoft Project Import Wizard – Options page will display different options, depending on
whether you choose to import into a new Open Plan project from Microsoft Project or update an
existing Open Plan file.


When you choose to create a new project while importing a project from Microsoft Project, the
available options are the following:

This page contains the following options:


Store WBS to Code 1 — If WBS values have been assigned to the Microsoft Project
activities, this option creates an Open Plan code file and stores the WBS values in the Code
1 field.
If the Open Plan project you are updating has code fields assigned at indexes other than 1,
you can change the code file to which WBS values are assigned by using the Field
Mapping dialog box.

Selecting this option enables the Share WBS file option.


Include Resources — This option allows the addition or update of resources. Selecting this
option enables the Insert Group before Resource Name option.
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Insert Group before Resource Name — With this option selected, Open Plan imports the
resource name along with the group ID. The group ID becomes a pool (parent) resource in
Open Plan, and the resource becomes its child.



Assignment Granularity — The following options are available:



Daily — Use this option for Open Plan to examine time-scaled records in Microsoft Project,
both when creating/updating assignments and baseline usage records, to model the original
records accurately. One assignment in MSP may generate multiple assignments in OP
different offsets and periods.



Single Period — Use this option for cases where assignments in Open Plan span multiple
months, and the generation of OP assignments and baseline usage records from time-scaled
records may cause unacceptable import times for a large project. With this option, OP
generates one OP assignment for each MSP assignment, using the total level for the
assignment and spreading it linearly over the owner’s activity duration.



Logging Level — This field allows the logging of errors, errors and warnings, or all
messages.



Share Calendar File — Use this option when you want the imported project(s) to share an
existing or new calendar file.
Selecting this option opens the Select Ancillary File dialog box. Click OK after you select a
calendar file.



Share Resource File — Use this option when you want the imported project(s) to share an
existing or new resource file.
Selecting this option opens the Select Ancillary File dialog box. Click OK after you select a
resource file.



Share WBS File — Use this option when you want the imported project(s) to share an
existing or new WBS code file.
Selecting this option opens the Select Ancillary File dialog box. Click OK after you select a
WBS file.
With this option selected, the existing WBS file is shared instead of creating or replacing the
ancillary file.
During import, Open Plan sets the MSPUNIQUEID field on activities and resources. These unique
IDs link an activity or resource in Open Plan to its corresponding activity or resource in Microsoft
Project.
If the baseline is set in the Microsoft Project being imported, Open Plan creates a PMB Baseline.
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Field Mapping — Click this button to open the MS Project to Open Plan Field Mapping
dialog box.

The dialog contains the following fields:


Table — You can make separate mappings for the following tables: Activity, Resource
Assignment, or Resource Data.



MSP Fields — Select the available source fields listed.



OP Fields — Select the available destination fields listed.

To use the MS Project to Open Plan Field Mapping Dialog Box, complete the following steps:
1. From the Table field dropdown menu, select the table for which you want to add, modify, or
delete field mappings.
2. To add a field mapping, select the destination field under the OP Fields list and the source
field under the MSP Fields list. Click Add.
3. To modify a field mapping, select an existing mapping and change the MSP field and/or OP
field. Click Update.
4. To delete one or more field mappings, select one or multiple mapping(s) and click Delete.
5. Tick the checkbox to make the mapping applicable to both Import and Export.
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When you choose to update an existing project from the imported Microsoft Project data, the
available options are the following:



Store WBS to Code 1 — If WBS values have been assigned to the Microsoft Project
activities, this option creates an Open Plan code file and stores the WBS values in the Code
1 field.



Include Resources — This option allows the addition or update of resources. Selecting this
option enables the Insert Group before Resource Name option.



Insert Group before Resource name — With this option selected, Open Plan imports the
resource name along with the group ID. The group ID becomes a pool (parent) resource in
Open Plan, and the resource becomes its child.



Assignment Granularity — The following options are available:



Daily — Use this option for Open Plan to examine time-scaled records in Microsoft Project,
both when creating/updating assignments and baseline usage records, to model the original
records accurately. One assignment in MSP may generate multiple assignments in OP
different offsets and periods.



Single Period — Use this option for cases where assignments in Open Plan span multiple
months, and the generation of OP assignments and baseline usage records from time-scaled
records may cause unacceptable import times for a large project. With this option, OP
generates one OP assignment for each MSP assignment, using the total level for the
assignment and spreading it linearly over the owner’s activity duration.



Update Project Status Only — When selected, only new activities, calendars and resources
are created. Existing activities are updated.
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For activities that are updated, relationships and resource assignments are deleted and
replaced as part of the update (i.e., for activities where the MSPUNIQUEID field is > 0).
The activity fields updated are: ASDATE, AFDATE, PROGTYPE, PROGVALUE, ORIG_DUR,
TARGSTYPE, TSDATE, TARGFTYPE, TFDATE, ACT_TYPE, CRITICAL, EVT, and
PRIORITY.
Additionally the STATDATE on the project is updated.


Update PMB Baseline — When importing to an existing Open Plan project, select this option
to update the PMB baseline.
In order for the Import to recognize the baseline in MSP, the default project
baseline must be set. BASELINE1 through BASELINE10 are not imported.
If a baseline is set in the project to be imported, Open Plan creates the PMB
Baseline for the Open Plan project when you are in Create/Replace mode. When
you are in Status Update mode, Open Plan will create or update the PMB
Baseline only if the Update PMB Baseline option was selected.
For more information, see Export Type in the Microsoft Project Export —
Options Page section.



Logging Level — This field allows the logging of errors, errors and warnings, or all
messages.



Time Now — This option is enabled when you select the Update Project Status Only
option. When enabled, select the
date and time from this dialog box.

button to open the Select Date dialog box. Select the

You can also specify the Time Now date on the Processes tab from the Schedule
group.



Field mapping — Click this button to open the MS Project to Open Plan Field Mapping
dialog box.
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Use this dialog to add, modify, or delete field mappings. You can also use the dialog box to
validate and make sure that a field mapping already exists in the list.
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Microsoft Project Import Wizard – Project Selection Page
This page allows you to select the project(s) you want to import. This page displays only if


you are importing multiple MSP projects, or



you are importing one or more MSP projects that contain external subprojects.
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Microsoft Project Import Wizard – Master Project Name Page
This page allows you to create the master project that will contain the projects you selected and interproject relationships associated with those projects. This page only displays if one or more of the
projects you selected on the Project Selection page contain inter-project relationships.

Microsoft Project Import Wizard – Validate Files Page

This page allows you to validate Open Plan files and fix any warnings or errors that may occur.
Additionally, if desired, you may change the default names given for the project(s) and ancillary files.
You will not be able to continue with the import process until all problems have been resolved.
If there are problems, Open Plan displays the following icons next to the file in question:


— warning



— error
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To see a description of the warning or error message, you may hover the cursor over the icon.
For information on warning and error messages, please see the Deltek Open Plan Online Help.

Microsoft Project Import Wizard – Import Complete Page
This page displays at the end of the import process.
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Exporting Microsoft Project Data
To export a project to Microsoft Project, complete the following steps:
When performing this procedure, Microsoft Project must be present on your computer.

1. On the Integration tab, click the MS Project button from the Export group.
The Save As dialog box opens.
2. Enter a file name and select a location for the project to be exported.
Click Save.
The Microsoft Project Export – Project page opens.
Open Plan saves the file with a default extension of .mpp. If you select an existing filename
for the project, Open Plan prompts you for confirmation before overwriting the file.

3. On the Microsoft Project Export – Project page, click Next.
The Microsoft Project Export – Options page opens.
4. On the Microsoft Project Export – Options page, select the appropriate options.
Click Next.
The Microsoft Project Export – Export Complete page opens.
5. Click View Log to display the Open Plan Log Viewer or Close the Microsoft Project
Export – Export Complete page.
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You can export data from an Open Plan project to a Microsoft Project file. On the Integration tab, click
the MS Project button from the Export group. The Save As dialog box opens:

Before you can export a project to Microsoft Project, it must first be saved as an Open Plan project.

You can update an existing Microsoft Project data when exporting. You do this by selecting the
existing file and clicking Yes in the following message box. You will have the choice to Replace or
Update on the options dialog box.

The Microsoft Project Export – Project page opens.
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Microsoft Project Export – Project Page
This page allows you to save the project you are exporting in Microsoft Project format. Clicking the
ellipsis button launches the Save As dialog box where you can provide a file name and location for
the project to be exported.
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Microsoft Project Export – Options Page
This page allows you to set the options that Open Plan will use when exporting a project to MSP.

This page contains the following options:


Export Type — This option allows you to select the type of export you want to apply:
Create/replace, Update status only, or Update status on existing MSP data only.
When you choose a file name that does not exist in the Microsoft Project Export – Project
Page, the only option available is Create/replace.



Update status only — When you select this option, the following actions occur:


Activities that have been added in Open Plan will be added to MSP. Relationships for new
activities are added in MSP provided that both ends of the relationship are included in the
exported activities (See Activity Filters below). Relationships in MSP are not updated for
existing activities being updated.



If an Open Plan activity has been deleted in MSP, the MSP Unique ID field in Open Plan will
be set to zero (indicating a disconnected activity). On a subsequent update, the Open Plan
activity will be added back to MSP as a new activity if it has not been removed beforehand.
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If an activity has been deleted in Open Plan, no changes occur to the MSP task that was
previously matched to that activity.



Assignments are replaced in MSP for exported activities.



Note on Activity Filters: If you choose an activity filter, only activities included in the filter will be
exported. The statements above assume that the activities described are included in the filter.



Update status on existing MSP data only – when you choose this option the following actions
occur:


Resource definitions that exist in OP but are not in MSP will not be added to MSP. The
following will be written in the log file: “Ignoring OP resource <resource definition> as it does
not exist in MSP.”



Activities that exist in OP but not in MSP will not be added to MSP. The following will be
written in the log file: “Ignoring OP activity <activity name> as it does not exist in MSP.”



Relationships in MSP will not be modified.



Assignments in MSP will be progressed from matching assignments in Open Plan, if a
resource progress method was specified. Levels and time-phased values in MSP will not be
modified.



MSPRIF Compatibility — This option allows you to maintain compatibility with Open Plan 3.3.2
and 3.4.1 during export.



Save changes to OP source project — Selecting this option automatically saves Open Plan
data modified during export, in particular, the Unique IDs associated with the MSP tasks and/or
resources created during the export along with their corresponding Open Plan activities and/or
resources. This option is enabled by default since these important associations would be lost if
you inadvertently do not save the project following export.



Update MS Project WBS column — This option updates the WBS field of the MSP Project to be
exported with either of the following:


with Open Plan Activity ID



with Open Plan Code 1
If you intend to map your own field to WBS, do not select this option.



Export Resources — This option exports resources with either of the following:


Use OP resource ID as Microsoft Project resource Name
This option exports the Open Plan resource ID to the Microsoft Project resource name field



Use OP resource Description as MSP Name
This option exports the Open Plan resource description to the MSP resource name field.



Resource Progress — When not exporting in MSPRIF-compatible mode, you can choose to
export resource assignment remaining quantity or resource assignment physical percent
complete to MSP.
The options available are the following:


Do not export



Use Assgn. PPC (export resource assignment physical percent complete)
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Use Assgn. Remaining (export resource assignment remaining quantity).

OP levels represent — Select the resource export unit for the exporting process. This will be the
unit that is specified when the Open Plan resource unit cost field is exported to the MSP standard
rate field. If Default Units is selected, the unit will be based on the Open Plan project’s default
duration unit (provided that it is either days or hours). For example, a unit cost of 50.00 will be
interpreted as $50.00/day if the levels represent days for OP labor resources (work resources in
MSP).
This setting does not affect material resources.



Update OP USER_NUM01 with MSP ID — This option updates the Open Plan USER_NUM01
field with an MSP Task unique ID.
This option is intended for backwards compatibility. Open Plan now uses the
MSPUNIQUEID field on the activity.



Use Constraint to adjust 5pm to 8am/8am to 5pm — This option allows the use of constraints
to adjust 5pm to 8am/8am to 5pm.
Open Plan will add a Start No Earlier Than constraint in MSP to move the start date to the next
day when the MSP Start Date is on the end of one day and the Open Plan Start Date falls on the
start of the following day. A Must Start On constraint is added in MSP to move the MSP Start
Date to the previous day, when the Open Plan Start Date is at the end of one day and the MSP
Start Date falls on the start of the following day.
This option is only enabled when the MSPRIF Compatibility is selected.



Update MSP Notes field with comments — This option updates the MSP notes field with errors
and warnings pertaining to an exported task.



Use OP Milestone Dates/Times — This option is not selected by default. It applies to completed
milestone activities.
When disabled, Open Plan compares the Actual Dates on milestone activities. If they are on the
same date with different times, the export sets the Actual Start and Finish Dates in Microsoft
Project, so that both values have the same date and time and the MSP duration will be zero.


For Start Milestones, they are set to the Open Plan Actual Start date (if the Open Plan Actual
Start date is missing, then the OP Early Start date is used).



For Finish Milestones, they are set to the Actual Finish (if the OP Actual Finish date is
missing, then the OP Early Finish date is used).

For activities that occur on different dates, the OP actual dates will be honored (with the OP Early
Start/Early Finish date substituted, if an OP actual date is missing), unless either or both actual
dates exceed Time Now. In the latter case, the corresponding early date(s) will be substituted.
When the option is selected, the dates are set to the Open Plan Actual dates on milestone
activities (if either date is missing, then the Open Plan Early Start or Early Finish date replaces
the missing date), and MSP may calculate a duration that fits the dates.


Activity Filter — This field allows you to apply an activity filter to the export, so that not all
activities will be exported. Only activities that meet the filter along with associated resource
assignments will be exported. Clicking the ellipsis at the right edge of the field displays the Filters
dialog box that you can use to select a filter. You can also use this dialog box to create, edit, or
modify filters.
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Logging Level — This field allows the logging of errors, errors and warnings, or all messages.



Use Options from Group Set — This field allows you to load options from a group set (selecting
a blank current group set will load the default group options). If any of the options is changed,
you will be prompted when clicking Finish to replace the group set (if you already have a named
group set) or save the group set to a new or different name.
If the existing settings are to be used, you should select this option before filling out the
page.



Field Mapping — Click this button to open the Open Plan to MS Project Field Mapping dialog
box.
Use this dialog to add, modify, or delete field mappings.
You can also use the dialog box to inspect the current field mappings.

The dialog contains the following fields:


Table — You can make separate mappings for the following tables: Activity, Resource
Assignments, or Resource Data.



OP Fields — Select the available source fields listed.



MSP Fields — Select the available destination fields listed.

To use the Open Plan to MS Project Fields Mapping Dialog box, complete the following steps:
1. From the Table field dropdown menu, select the table for which you want to add, modify, or
delete field mappings.
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2. To add a field mapping, select the destination field under the MSP Fields list and the source
field under the OP Fields list.
3. To modify a field mapping, select an existing mapping and change the OP field and/or MSP
field. Click Update.
4. To delete one or more field mappings, select the mapping(s) and click Delete.
5. Tick the checkbox to make the mapping applicable to both import and export. Note that
some fields may not be applicable to both import and export, due to certain destination fields
being read-only in either OP or MSP.

Microsoft Project Export Wizard – Export Complete Page
This page displays at the end of the export process.
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Primavera Project Planner
Open Plan allows you to import and export both Primavera P3 and XER files.

Importing Primavera Files
The Import Primavera File utility allows you to import P3 and XER projects from the Primavera
Project Planner® system.
To import a P3 Btrieve file
1. On the Integration tab, click Primavera P3 from the Import group.
2. From the Select P3 Project dialog box, select a Primavera P3 project, and click OK.
3. If a converted ancillary file already exists in Open Plan, a New File dialog box is displayed for
that file.
4. Enter a name for the converted ancillary file, and click Finish.
5. When the data has transferred successfully, click OK.
For more information on importing P3 Btrieve files, refer to Chapter 3, “Import and Export
Facilities in Open Plan,” in the Deltek Open Plan Developer’s Guide.

To import a XER file, complete the following steps:
1. On the Integration tab, click Primavera XER from the Import group.
2. From the Open dialog box, select the Primavera XER project, and click OK.
3. If a converted ancillary file already exists in Open Plan, a New File dialog box is displayed for
that file.
4. Enter a name for the converted ancillary file, and click Finish.
5. When the data has transferred successfully, click OK.

Exporting Primavera Files
Open Plan allows you to export project data to either a batch file or XER file that can then be
imported into Primavera.
To export XER data, complete the following steps:
1. Open the project you wish to export.
2. On the Integration tab, click General from the Export group.
3. Select the Primavera XER Format, and click OK.
4. On the Export File dialog box, enter a name and location for the XER file.
5. Click Save.
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Custom Import/Export Operations
In addition to the utilities for importing Microsoft Project and Primavera P3 and XER files and the
utility for exporting Microsoft Project files, Open Plan also offers a more general capability based on
user-defined import/export specifications. Each specification consists of a series of commands and
parameters that allow Open Plan to import and export project, resource, code, and calendar
information to a wide range of data formats.
Open Plan provides a number of standard import/export specifications that allow you, for example, to
export a simple comma-delimited text file containing activity IDs and descriptions that can be read by
many types of applications. It is also possible to create your own scripts for special-purpose
operations.
For a complete description of creating custom import/export specifications, refer to Chapter 3,
“Import and Export Facilities in Open Plan,” in the Deltek Open Plan Developer’s Guide.

Import General
To import project information, issue the Import General command to display the following dialog box:

You can use this dialog box to select an import specification. When you click OK, Open Plan allows
you to open a source data file and create an untitled project containing the imported information. If the
project includes references to ancillary data files such as resource or code files, Open Plan creates
untitled versions of these files as well.
If you have a project open when you issue the Import General command, Open Plan allows you to
indicate if the imported data should be used to update the current project. Note, however, that
whether or not the imported data overwrites existing records is determined by a parameter set in the
import specification.
To import project data, complete the following steps:
1. On the Integration tab, click General from the Import group.
2. Select the specification for the operation.
You can also indicate if Open Plan should update the current project with the imported data.
3. When the information in the dialog box is correct, click OK to continue.
Open Plan allows you to open the source data file and then displays an untitled project for the
imported project.
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4. To save the project as an Open Plan project, click Save or Save As.
If the project includes references to ancillary data files, you must save the ancillary data files
as well.

Export General
To export project information, issue the Export General command to display the following dialog box:

Use this dialog box to select an export specification.
To export project data, complete the following steps:
1. Open the project you want to export.
2. On the Integration tab, click General from the Export tab.
3. Select the export specification for the operation.
4. When the information in the dialog box is correct, click OK.
Open Plan allows you to specify the destination file for the operation.

Crosstable Exports
To export crosstable data, click Crosstable Data from the Export group on the Integration tab to open
the Crosstable Exports dialog box.

The export specifications listed on this dialog box include those that you have created as well as
those that other users have created and chosen to share. When you select an export specification
and click Run, you are given the opportunity to save the export file in either .xml or .csv format. You
may also click on View to see those export files that have been utilized in the past.
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Elements that have a value of zero are exported as a blank value instead of a zero (0).

The buttons along the bottom of the dialog box allow you to create, copy, edit, and delete export
specifications. When you create, copy, or edit an export specification, a tabbed dialog box allows you
to select the elements to include in the export file. The default view is the General tab.

General Tab

The General tab of the Crosstable Export Definition dialog box features the following choices that
determine the type of data to export and enables or disables the appropriate tabs.
For Data Type, you can choose between the following:




Resource — Select this option to export resource data and to enable the Resources tab.
Resource data is demand based on the following:


Early, late, or scheduled dates



Availability



Actuals



Baseline

Earned Value — Select this option to export earned value data and to enable the Earned Value
tab. Earned value data includes the following:


Budget



Actual



Forecast



Earned Value

Once you have decided what type of data to export, you can choose to export the data rolled up by:


Resource — Select this option to export the data rolled up by resource and to enable the
Resource Data tab.
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Resource Assignments — Select this option to export the data rolled up by resource
assignment and to enable the Activity Data tab.



Roll up similar Assignments — When the Resource Assignments option is chosen, this
option becomes available. Selecting this option instructs Open Plan to roll up similar
assignments.

Resources Tab
The Resources tab is enabled when you select Resource as the Data Type on the General tab.

You can export the resource Availability as well as any of the following types of resource data:


Early — Selecting this option exports the resource values (quantity, cost, and/or escalated cost)
by early dates.
Early dates are calculated in time analysis as the earliest dates on which activities can
start and finish.



Late — Selecting this option exports the resource values (quantity, cost, and/or escalated cost)
by late dates.
Late dates are calculated in time analysis as the latest dates on which activities can start
and finish without delaying the project.



Schedule — Selecting this option exports the resource values (quantity, cost, and/or escalated
cost) by schedule dates, also know as resource usage.
Schedule dates are the activity start and finish dates calculated by resource scheduling.



Actual — Selecting this option exports the resource values (actual quantity, actual cost, and/or
actual escalated cost) by actual dates.
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Baseline — Selecting this option allows you to choose up to 3 baselines attached to the project.
Open Plan exports the baseline resource values (quantity, cost, and/or escalated cost) for each
selected baseline.

For the resource data you select, you can export any of the following values:


Quantity — For each of the Usage options you select, the Quantity option instructs Open Plan
to export the resource quantity values when calculating usage.



Cost — For each of the Usage options you select, the Cost option instructs Open Plan to export
the unescalated resource cost values.



Escalated Cost — For each of the Usage options you select, the Escalated Cost option
instructs Open Plan to export the escalated resource cost values.

You can also select one of the following methods for calculating the values to export:


Period — Selecting this option instructs Open Plan to calculate the resource usage by period.
The periods used are determined by the selection you make on the Date Scale tab.



Cumulative — Selecting this option instructs Open Plan to calculate the resource usage as
cumulative to date for each period exported.



Average — Selecting this option instructs Open Plan to calculate the average resource usage.
The average value is expressed in terms of the default duration defined for the project. For
example, if the default duration is weeks, an average of 4 would mean 4 resource units per week.
When calculating the average value, Open Plan uses the calendar assigned to the first availability
record for each selected resource.

Earned Value Tab
The Earned Value tab is available when you select Earned Value as the Data Type on the General
tab.

You can export the following earned value data:
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Forecast —Selecting this option allows you to export forecast data (quantity, cost, and/or
escalated cost) based on early, late, or schedule dates.



BCWS — Selecting this option allows you to export budgeted cost of the work scheduled data
(quantity, cost, and/or escalated cost) according to the baseline dates.



ACWP — Selecting this option allows you to export actual cost of the work performed (quantity,
cost, and/or escalated cost) that has been calculated, entered, or imported.



BCWP —Selecting this option allows you to export the budgeted cost of work performed data
(quantity, cost, and/or escalated cost).

For the earned value data you select, you can export any combination of the following values:


Quantity — Selecting this option instructs Open Plan to calculate and export the resource
quantity values.



Cost — Selecting this option instructs Open Plan to calculate and export the unescalated
resource cost values.



Escalated Cost — Selecting this option instructs Open Plan to calculate and export the
escalated resource cost values.

You can also select one of the following methods for calculating the values to export:


Period — Selecting this option instructs Open Plan to calculate the earned value by period.
The periods used are determined by the selection you make on the Date Scale tab.



Cumulative — Selecting this option instructs Open Plan to calculate earned value cumulative to
date.

Date Scale Tab
The Date Scale tab allows you to specify the time periods Open Plan uses to calculate and export the
data. The time periods are then used to display the calculations in the .csv or .xml export file. You can
also set the range of dates that Open Plan uses for the operation.
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You can select one of the following options to specify the time periods:


Reporting Calendar — Selecting this option allows you to use the time periods in an existing
reporting calendar when calculating and exporting the data. Reporting calendars allow you to
view the exported time-based data against a non-linear date scale with varying degrees of
granularity.
The fiscal calendar is a reporting calendar assigned to the project on the Cost tab of the Project
Properties dialog box. This is useful if your company uses a fiscal calendar that contains periods
that do not end on the last day of the month.
By exporting data using different reporting calendars, you can create reports that provide
different views of the same data.



Linear — Selecting this option allows you to set the Granularity and Frequency of the time
periods Open Plan uses when calculating and exporting the data.



Granularity — This field controls the time period to use to calculate and export the data. You can
select from years, quarters, months, weeks, days, and hours.



Frequency — This field allows you to set the frequency of the time periods Open Plan uses. For
example, if you set a Granularity of months with a Frequency of 3, the data would be calculated
and exported using time periods similar to the following:


01/01/2003



04/01/2003



07/01/2003



10/01/2003



01/01/2004
The options in the Date Range portion of the dialog box allow you to control the time span
for the data that Open Plan exports.

The Date Range section allows you to set the dates in the From and To fields that Open Plan uses
when calculating and exporting the data. You can select from the following options:


Custom — Selecting this option allows you to set the From and To dates manually.



Entire Project — Selecting this option instructs Open Plan to use the project’s Start Date and
Schedule Finish Date.



Time Now — Selecting this option instructs Open Plan to use Time Now for the From date but
allows you to enter the To date manually.



Project Start — Selecting this option instructs Open Plan to use the project’s Start Date for the
From date but allows you to enter the To date manually.
You can enter a date directly into the From and To fields or click the ellipsis button next to
a field to display a pop-op calendar which you can use to select a date.
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Activity Data
The Activity Data tab is enabled when you select the option to export the data rolled up by Resource
Assignment (on the General tab).

This tab allows you to do two things:


Apply a filter to the activities that are exported



Export additional activity fields that are available to the project

Selecting the Filter option enables a list that you can use to select an existing filter to apply to the
project activities. The activities that are returned by the filter are used in the export specification.
The Available Fields list contains all of the activity-related fields included in the project. To include a
field in the export specification, simple select it, and click the right arrow button. It is moved to the
Selected Fields list where you can use the up and down arrows to arrange the fields in the order in
which you want to export them. To remove a field from the export specification, select it in the righthand list, and click the left arrow button.
You can move multiple fields from one list to the other at one time by Ctrl+clicking or Shift+clicking
the desired fields and clicking the appropriate arrow button.
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Resource Data
The Resource Data tab is enabled when you select the option to export the data rolled up by
Resource (on the General tab).

This tab allows you to do two things:


Apply a filter to the resources that are exported



Export additional resource fields that are available to the project

Selecting the Filter option enables a list that you can use to select an existing filter to apply to the
project resources. The resources that are returned by the filter are used in the export specification.
The Available Fields list contains all of the resource-related fields included in the resource file. To
include a field in the export specification, select it and click the right arrow button. It is moved to the
Selected Fields list where you can use the up and down arrows to arrange the fields in the order in
which you want to export them. To remove a field from the export specification, select it in the righthand list, and click the left arrow button.
You can move multiple fields from one list to the other at one time by Ctrl+clicking or Shift+clicking
the desired fields and clicking the appropriate arrow button.
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Access Control
The Access Control tab allows you to define the access rights that users or groups have and what
role they play in the project.

If you are the owner of the project or a member of the System Administrator group and you have the
project open in Exclusive mode, you can use the following fields to define access rights to the
project:


Owner —You can change the owner of the project by selecting a new owner from the list.
If you provide access rights to a group for a project, members of that group automatically
inherit read rights to all resource files, calendar files, code files, and external subprojects
assigned to that project. Note, however, that it is possible that after you change the
ownership of a project to another user, you may not have rights to save the project. If this
occurs, simply close the project without saving.



Group — By selecting a field in this column and selecting a group from the list, you can specify
the group(s) that can have access to the project.



Role — When you select a group or user ID, its default role is automatically entered in this field.
You can then change default role to any role that has been defined in the data source.



User ID — By selecting a field in this column and selecting a user ID from the list, you can specify
the users that can have access to the project.



Read Only — By selecting Yes for this field, you limit the group or user to opening the project in
Read Only mode. By selecting No for this field, Other users may open the file in any mode they
choose. Read Only mode has the following limitations:


In order to make changes to the project, you must first save the project under a different
name.



You cannot see changes made by other users.
In order to see changes made by other users who may have the project open in Exclusive
or Shared mode, you have to close and reopen the project.
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Overview

Overview
Open Plan includes a number of project-level utilities that facilitate the manipulation of project data.
These include:


Filters



Sorts



Calculated fields



Global edits



User-defined fields



Spread curves

This chapter discusses each of these features in turn.

Chapter 23 Project Utilities
Deltek Open Plan 8.0 User Guide

541

Filters

Filters
Filters limit the display of items in a view based on a specific criterion. For example, you may wish to
display a view that shows only activities requiring a particular resource. Open Plan provides a number
of predefined filters common to many project management reports. In addition to these predefined
filters, you can define custom filters of your own.
When applying a filter to a view, keep the following points in mind:


When selecting filtered activities, the status of the parent item determines the status of the child.
For example, assume that you apply a filter to a view and then select a parent activity or resource
pool. This selects all children of the item, even if they do not meet the original filter criteria.



If you apply a filter to a spreadsheet or barchart view with outlining turned on, the status of child
items is determined by the status of the parent when you select the Filter from the Top Down
option. For example, if a parent activity fails to meet the criteria of a filter, none of that parent’s
children will appear in the view, even in cases where the individual child activities satisfy the filter.



If you apply a filter to a linked spreadsheet view, the filter applies only to information from the
primary data table for the view.
For information about outlining and linking in spreadsheets, refer to Chapter 20, “Spreadsheet
Views.”

Using Filters
To display a list of available filters, click the Filters command on the Tools tab or the Edit tab. Open
Plan responds by displaying the following dialog box:

Select the data table.

Select the filter for the view.

Definition of the filter is shown as a
tooltip

Create a new filter.

If you hover your mouse cursor over a filter, Open Plan displays the definition of that filter as a tool
tip.
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Each view for a project can have a different filter in effect. The name of the filter currently in effect
appears in the status bar at the bottom of the Open Plan window:

Current filter in effect.

To reapply the filter (or the sort) without exiting the view, click the Reapply Filter And Sort button on
the Edit tab.
Once a filter is in effect for a view, you can continue to add items to the view. Open Plan displays the
items as you add them, even if the new items do not satisfy the current filter condition. However, if
you refresh the view or close the view and return to it later, the items you added may not be displayed
if the filter expression excludes them.
To apply a filter in a network view, you must use the Placements command.
For more information on applying a filter in a network view, refer to Chapter 19, “Network Views.”

To apply a filter, complete the following steps:
1. Take one of the following actions:
Filters button



On the Edit tab, click Filters from the Filters group.



Right-click within the view, and click Filters on the context menu.



Double click the status bar filter name or < No Filter > text

2. From the Filters dialog box, select the filter you want to apply.
3. Click OK.
To refresh a filter, complete the following step:
Reapply Filter
And Sort button

1. On the Edit tab, click Reapply Filter And Sort from the Filters group.
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To cancel a filter, complete the following steps:
1. Take one of the following actions:
Clear Filter
button



On the Edit tab, click Clear Filter from the Filters group.



Right-click within the view, and click Filters on the context menu.



Double click the status bar filter name or < No Filter > text

2. From the Filters dialog box, select <Cancel filter>, and click OK.

Defining Filter Expressions
Open Plan allows you to define custom filter expressions that can be applied to views of project
information. These custom expressions can be based on any field from the activity- or resourcerelated data tables and can feature complex expressions using logical operators and parentheses.
Once you create a filter, you can make that filter available to other users in the network.
In addition to their use as view filters, filter expressions can appear as criteria for bar attributes in a
barchart view or for box attributes in a network view or in the Conditional Formatting dialog.
When you create a new filter, Open Plan displays a dialog box in which you can enter a filter name
and indicate the source of the fields to appear in the filter.

Select a data table for the filter.

Once you have entered a name and a data table for the filter, Open Plan allows you to enter the
expression for the filter criterion using the following dialog box:

Click to insert a parenthesis
in the filter expression.

With this dialog box, you can build a filter using the following components:




Logic — You can build complex filter expressions using the following logical operators:


AND



AND NOT



OR

Field Name — Filter expressions can include any field from the selected data table, including
calculated fields and any filters already defined for that table. Previously defined filters specified
as fields can have one of two values: true or false.
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For information about calculated fields, refer to the “Defining Calculated Fields” section
in this chapter.



Operator — Filter expressions can contain any of the following operators:


Between



Contains



Equals



Greater or Equals



Greater Than



Is Empty (available for text fields only)



Less or Equals



Less Than



Not Between



Not Contains



Not Empty (available for text fields only)



Not Equals
The Contains operator is case-sensitive. Criteria entered using this expression must
be typed in the same case as the original value. If the same case is not used, no
results will be displayed.



Value 1 — The values available for a filter expression depend on the type of field used in the
expression. For example:


If you select a text, numeric, or date field, Open Plan allows you to select another field from
the table (including calculated fields and previously defined filters), or you can enter a text,
numeric, or date constant.
If you are defining a filter that includes an activity or resource ID, make sure that you
enter the value using upper-case characters.



If you select an enumerated field for the expression, Open Plan displays a list of valid choices
from which you must select. For example, the Activity Type field is an enumerated field with
valid values such as ASAP, ALAP, or Start Milestone.



If you select a logical field for the expression, Open Plan allows you to select either true or
false as a value.



Value 2 — If the expression uses either the Between or Not Between operators, you can enter a
second value for the filter.



Insert Parentheses — You can insert a left and right parenthesis in any expression. Left
parentheses can be inserted at the beginning of the Field column; right parentheses can be
inserted at the end of a row in the Value 2 setting. Parentheses allow you to develop complex
expressions such as the following examples:


C1 Equals “1.1” AND (C2 Equals “QA” OR C2 Equals “Pubs”)



(C1 Equals “1.1” AND C2 Equals “QA”) OR C2 Equals “Pubs”
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When you click More, the Filter Expression dialog box extends to display additional controls:



Expression — This field reflects the actual expression that is displayed in the grid. If you prefer,
you can enter the filter expression directly in the text box.



Fields — Clicking this button displays the Fields dialog box. You can use this dialog box to select
fields to include in the filter expression.



Functions — Clicking this button displays the Functions dialog box. You can use this dialog box
to select functions to use in the filter expression.



Validate — When you have created a filter expression, you can click this button to have Open
Plan validate the expression. If the filter expression is valid, Open Plan populates the grid with the
appropriate values.



Access Control — Select this option to grant rights to other users in the data source to use the
filter expression.



References — Clicking this button displays the References dialog box, which has a list of items
that use the sort. This list of items includes the file type, name of the project or file, description,
and owner.



Less — Clicking this button hides the dialog box extension.

To add a filter expression, complete the following steps:
1. On the Edit tab, click Filters

from the Filters group.

2. When Open Plan displays a list of existing filters, click New.
3. In the New Filter dialog box, enter a name, and select a source data table for the new filter.
4. Click OK.
5. In the Filter Expression dialog box, define the filter expression.
6. When the information for the filter expression is complete, click OK to return to the Filters
dialog box.
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To edit a filter expression, complete the following steps:
1. Take one of the following actions:


On the Edit tab, click Filters
change, and click Edit.



On the Edit Tab, also click Edit Filter

from the Filters group. Select the filter you want to
from the Filters group.

2. In the Filter Expression dialog box, update the filter expression.
3. When the information for the filter expression is complete, click OK to return to the Filters
dialog box.
To copy a filter expression, complete the following steps:
1. On the Edit tab, click Filters

from the Filters group.

2. Select the filter you want to copy, and click Copy.
3. In the Filter Expression dialog box, enter a new name for the filter.
4. When the information for the new filter expression is complete, click OK to return to the
Filters dialog box.
To delete a filter expression, complete the following steps:
1. On the Edit tab, click Filters

from the Filters group.

2. Select the filter you want to delete, and click Delete.
3. When Open Plan asks you to confirm the deletion, click Yes.
When an error is generated by Open Plan, the portion of the failed expression in the
Expression field is highlighted.

Additional Filtering Options
The following options are also available for filtering:




Add To Filter
— This option takes a selection range and adds the selection values to the
currently selected filter based on the following rules:


Multiple selections within a column are added to the filter with an OR EQUALS condition



Multiple selections across columns are added to the filter with an AND EQUALS condition

Remove From Filter
— This option takes a selection range and adds the selection values to
the currently selected filter based on the following rules:


Multiple selections within a column are added to the filter with an OR NOT EQUALS condition



Multiple selections across columns are added to the filter with an AND NOT EQUALS
condition



Clear Filter
— This option removes the currently selected filter. It is equivalent to displaying
the Manage Filters dialog box and choosing Cancel Filter.



Toggle Filter
remembering it.

— Once a filter has been applied, this option turns the filter on or off while still
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Edit Expression
— This option displays the Filter Expression dialog box while bypassing the
Manage Filters dialog box.



Reapply Filter And Sort

— Select this option to apply the last filter and sort again.

To apply one of these options, complete the following steps:
1. Click the Edit tab.
2. Select the appropriate command from the Filters group of the Edit tab.

Temporary Filters
In addition to creating permanent filters, you can also create temporary filters. Temporary filters are
available only in the view in which they are defined and valid until superseded by another filter. You
cannot make these temporary filters available to other projects, nor can you make them available to
other users with the Share this Item with Others option.
Temporary filters can be created in two ways:


By selecting <Temporary Filter> on the Filters dialog box.
Creating a temporary filter in this manner uses the same Filter Expression dialog box used for
creating a new filter but with two exceptions: the name of the filter is <temporary> and the Share
this Item with Others option is disabled.



By typing the temporary filter expression directly in the field where it will be used.
For example, you can type the temporary filter expression directly into the Criterion field on the
Bar Attributes tab of:


The Bar Set Preferences dialog box



The Network View Preferences dialog box

The manner in which the Filter Expression dialog box for a temporary filter is displayed depends on
the view from which it is accessed:


In network views, you can display the Filter Expression dialog box for a temporary filter by clicking
Filters on the Placements dialog box and then selecting <Temporary Filter> from the Filters
dialog box.



In spreadsheet and barchart views, you can display the Filter Expression dialog box for a
temporary filter by clicking Filters on the Tools tab and then selecting <Temporary Filter> from
the Filters dialog box.
The temporary filter created in this manner can be applied only to a primary table. In multi-table
views, you can apply a filter to a secondary table using the Define Link tab of the Spreadsheet
Preferences dialog box.

To define a temporary filter using the Filter Expression dialog box. Complete the following
steps:
1. Display the view in which you want to apply the temporary filter.
2. On the Tools tab, click Filters.
Open Plan displays the Filters dialog box.
3. Take one of the following actions:
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Select <Temporary Filter>, and click Edit.



Double-click <Temporary Filter>.

4. In the Filter Expression dialog box, define the temporary filter in the grid.
Click More to expand the Filter Expression dialog box if you want to use the Fields and
Functions buttons as an aid in building your filter expressions.

5. Click OK.
To define a temporary filter in a Network view, complete the following steps:
1. On the View tab, click Placements.
2. On the Placements dialog box, click the Filters button to display the Filters dialog box.
3. Take one of the following actions:


Select <Temporary Filter>, and click Edit.



Double-click <Temporary Filter>.

4. In the Filter Expression dialog box, define the temporary filter in the grid.
Click More to expand the Filter Expression dialog box if you want to use the Fields and
Functions buttons as an aid in building your filter expressions.

5. Click OK.
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Temporary Filters on a Secondary Table
You can apply a temporary filter to a secondary table in a multi-table view by using the Define Link
tab of the Spreadsheet Preferences dialog box:

The filter for data from all subsidiary tables is controlled independently, so a new filter on a subsidiary
table is in addition to a filter on a higher level.
If you inadvertently enter the filter expression on the wrong row, Open Plan attempts to automatically
move the filter expression to the correct row. This will be visible the next time that you display the
Define Link tab.
To define a temporary filter on a secondary table in a multi-table view, complete the following
steps:
1. Open the multi-table view to which you want to apply a temporary filter.
2. Take one of the following actions:


On the View tab, click Preferences from the Table group.



Right-click within the view, and click Preferences on the context menu.

Open Plan displays the Spreadsheet Preferences dialog box.
3. Click the Define Link tab.
4. In the Filter column, enter the temporary filter you want to apply, and click OK.
Open Plan applies the filter to the secondary table identified in the table column.
These temporary filters are not displayed in the Filters dialog box. They are not saved as part of
the project. If you save a view while a temporary filter is in effect, Open Plan saves the view with
the filter applied.
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In addition to using temporary filters in Open Plan views, you can create and use temporary filters in
the following circumstances:


Export scripts



OLE automation

Favorite Filters

Favorite Filters
button

After applying a predefined or a custom filter to a view, you can use the Favorite Filters button to
designate the filter as one of your favorites. You can also use the Manage Favorites dialog to
designate favorite filters.
The feature allows you to easily access a favorite filter. Open Plan displays a maximum of 10 favorite
filters. If you have more than 10 favorite filters, you can click More Favorites to display the rest of the
filters.
The filters that appear on the favorites list depend on the view you are in. A resource-based view will
show favorite filters that apply to the resource table, whereas an activity based view will show favorite
filters that apply to activities.
You can also use the Organize Favorites dialog box to manage your favorite filters. For more
information, see Chapter 03, “Getting Started”.

To designate a filter as a favorite, complete the following steps:
1. Apply a predefined or a custom filter.
2. Click the Favorite Filters button from the Filters group of the Spreadsheet or Barchart Edit
tab.
3. Click the Add To Favorites button.
The favorite filters list will display as follows:

You can also use the Organize Favorites dialog box to manage your favorites list.
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By default, Open Plan displays activities and resources in barchart and spreadsheet views in order of
ID. However, you can assign a different sorting sequence to a view so that, for example, activities
appear in order of early start dates.
Open Plan provides a number of predefined sorts that are commonly used in project management
reports. In addition to these predefined sorts, you can define custom sorts of your own.
If a view is displayed using outlining or subsections, Open Plan sorts the items within the outline
or subsection hierarchy.

Default Sort Order Rules
The following rules apply to the default sort order, which is in effect when there is no sort specified.
Explicitly sorting on Activity ID will still sort alphabetically.

Reapply Filter
And Sort button



The default sort order for all hierarchical fields (activity IDs, resource IDs, and codes) is
interpreted numerically, if possible. Therefore, “1.2” is sorted before “1.10.” Character data is
sorted alphabetically.



Mixed character and numeric data is also sorted alphabetically, except that any trailing numeric
digits are sorted numerically. For example, “A2” comes before “A10.” Since each component of
the name is sorted independently, some data can be numeric and some not.



IDs with leading zeros are sorted first. For example, “A01” comes before “A1.”

Also, when you have a table based upon a hierarchy, the Reapply Filter And Sort button on the Edit
tab is enabled even when no sort or filter is specified.
The rules for the sort order are fundamental to the workings of the automatic numbering and
indent/outdent features.
For information on automatic numbering and the indent/outdent features, refer to Chapter 20,
“Spreadsheet Views.”
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Using Sorts
Issuing the Sorts command displays a list of available sorts in the Sorts dialog box:
Select the data table.

Select the sort for the view.

Definition of the sort is shown as a tooltip

Click to create a new sort.

You can use this dialog box to apply an existing sort to the view as well as to cancel the sort currently
in effect.
If you hover your mouse cursor over a sort criteria, Open Plan displays the definition of the sort as a
tool tip.
Each view for a project can have a different sort in effect. The name of the sort currently in effect
appears in the status bar at the bottom of the Open Plan window:

Current sort in effect.

To reapply the sort (or the filter) without exiting the view, click the Reapply Filter And Sort button on
the Edit view.
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Sorts do not affect the display of activities in a network view.

To apply a sort, complete the following steps:
1. Take one of the following actions:
Manage button



On the Edit tab, click Manage from the Sorts group.



Right-click within the view, and click Sorts on the context menu.



Double click the sort name in the status bar

2. From the Sorts dialog box, select the sort you want to apply, and click Close.
To refresh a sort, complete the following step:
Reapply Filter
and Sort
button

1. On the Edit tab, click Reapply Filter And Sort from the Sorts group.
To cancel a sort, complete the following steps:
1. Take one of the following actions:


On the Edit tab, click Manage from the Sorts group.



Right-click within the view, and click Sorts on the context menu.



Click Clear Sort

in the Sorts group.

2. From the Sorts dialog box, select <Cancel sort>, and click Close.

Defining Custom Sorts
You can define custom sort sequences based on data from any activity- or resource-related data
table. Custom sorts can also include any calculated fields for those tables.
When you create a new sort, Open Plan displays a dialog box in which you can enter a sort name
and indicate the source of the sort fields.

Select a data table for the sort.
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Once you have entered a name and selected a data table, Open Plan allows you to define the sort
expression using the following dialog box.

With this dialog box, you can build a sort expression by indicating each sorting field and whether
Open Plan should use an ascending or a descending order when sorting activities using that field.
You can choose to share this item with other users.
You can define sort expressions based on substrings of a text field (for example, the activity
description) by creating a calculated field containing the substring and then including the calculated
field in the sort expression.
You may use the Access Control option to grant rights to other users in the data source to use the
expression.
You may use the References option to see a list of items that use the sort. This list of items includes
the file type, name of the project or file, description, and owner.
For information about creating calculated fields, refer to the “Defining Calculated Fields” section
in this chapter.

To add a sort, complete the following steps:
1. On the Edit tab, click Manage from the Sorts group.
2. On the Sorts dialog box, click New.
3. In the New Sort dialog box, enter a name, and select a source data table for the new sort
expression.
4. Click OK.
5. In the Sort Expression dialog box, define the sort expression.
6. When the information for the expression is complete, click OK to return to the Sorts dialog
box.
To edit a sort, complete the following steps:
1. On the Edit tab, click Manage from the Sorts group.
2. From the Sorts dialog box, select the sort you want to change, and click Edit.
3. In the Sort Expression dialog box, update the sort expression.
4. When the information for the expression is complete, click OK to return to the Sorts dialog
box.
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To copy a sort, complete the following steps:
1. On the Edit tab, click Manage from the Sorts group.
2. From the Sorts dialog box, select the sort you want to copy, and click Copy.
3. In the Sort Expression dialog box, enter a new name for the sort.
4. When the information for the new expression is complete, click OK to return to the Sorts
dialog box.
To delete a sort, complete the following steps:
1. On the Edit tab, click Manage from the Sorts group.
2. From the Sorts dialog box, select the sort you want to delete, and click Delete.
3. When Open Plan asks you to confirm the deletion, click Yes.

Temporary Sorts
In addition to creating permanent sorts, you can also create temporary sorts. Temporary sorts are
available only in the view in which they are defined and valid until they are superceded by another
sort. You cannot make these temporary filters available to other projects or users.
You can create temporary sorts in the following ways:


By clicking the column headings in a spreadsheet view if the Click to Sort option is enabled.
Using this method you can sort the data in the spreadsheet based on either a single column or on
multiple columns.
For more information on the Click to Sort option, refer to the “Click to Sort” section
later in this chapter.



By selecting <Temporary Sort> from the Sorts dialog box to display the Temporary Sort
Expression dialog box.

The temporary sort created in the two manners described above can be applied to a primary table. In
a multi-table spreadsheet view, you have the option of applying a sort to a secondary table using the
Define Link tab of the Spreadsheet Preferences dialog box or by clicking the column headings as
described above.
In a multi-table view, the primary table is the main table upon which the view is based. The
secondary table is the linked table.
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While you can simply type the sort expression in the text box of the Temporary Sort Expression dialog
box, you can also use the Fields button to display a dialog box that you can use as an aid in building
the sort expression.

Open Plan temporary sorts are formed using the following syntax:
<sort_field1>,<sort order>|<sort_field2>,<sort order>|…
where:


Each of the <sort_fieldx> values is either the name of an existing field on the appropriate table
or the definition of a calculated field for that table.



The <sort order> indicates an ascending (0) or a descending (1) sort.



The piping symbol (|) separates the sorts you create.

The following is an example:
ORIG_DUR,0|ACT_ID,1
Would first sort ascending the original duration field and then within that would sort descending the
activity ID field.
In addition to using temporary sorts in Open Plan views, you can also use temporary sorts in the
following circumstances:


Export scripts



OLE automation

To define a temporary sort using the Temporary Sort Expression dialog box, complete the
following steps:
1. Display the view to which you want to apply the temporary sort.
2. On the Edit tab, click Manage from the Sorts group.
Open Plan displays the Sorts dialog box.
3. Display the Temporary Sort Expression dialog box by taking one of the following actions:


Double-click <Temporary Sort>.



Select <Temporary Sort>, and click Edit.

4. Enter the temporary sort in the text box.
You can use the Fields and Functions buttons as an aid in building your sort
expressions.

5. Click OK.
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Temporary Sort on a Secondary Table
You can apply a temporary sort to a secondary table in the multi-table spreadsheet view by using the
Define Link tab of the Spreadsheet Preferences dialog box:

The sort order for data from all subsidiary tables is controlled independently, so a new sort on a
subsidiary table is in addition to a sort on a higher level.
You can also create a temporary sort for a secondary table by applying the Click to Sort feature
to column headings of the secondary table. The Click to Sort feature is discussed later in this
chapter.

If you inadvertently enter the sort expression on the wrong row, Open Plan attempts to automatically
move the sort expression to the correct row. This will be visible the next time that you display the
Define Link tab.
To define a temporary sort on a secondary table in a multi-table view, complete the following
steps:
When you sort columns based on a secondary table, using the Click to Sort option
records the temporary sort in the Sort column of the Define Link tab of the
Spreadsheet Preferences dialog box.
1. Open the multi-table spreadsheet view to which you want to apply a temporary sort.
2. Take one of the following actions:


On the View tab, click Preferences from the Table group.



Right-click an empty area of the view, and click Preferences on the context menu.

3. On the Spreadsheet Preferences dialog box, click the Define Link tab.
4. In the Sorts field, enter the temporary sort you want to apply, and click OK.
Open Plan applies the sort to the secondary table identified in the To Table column.
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These temporary sorts are not displayed in the Sorts dialog box. They are not saved as
part of the project. If you save the view while a temporary sort is in effect, Open Plan
saves the view with the sort applied.

Click to Sort
In addition to the temporary sort, the spreadsheet and barchart views allow column sorting by clicking
the column headings.
With the Click to Sort option enabled, you can click the column heading on which you want to base
the sort. Clicking the same column heading again will toggle the sort operation between ascending
and descending order.
To sort the data based on multiple columns, click the first column heading on which you want to sort.
For non-adjacent columns, Ctrl-click additional columns until you have defined the entire sort
expression. For adjacent columns, Shift-click additional columns until you have defined the entire
sort expression.
When you sort columns based on a primary table in multi-table views, using the Click to Sort
option records the temporary sort on the Temporary Sort Expression dialog box. If you sort the
spreadsheet based on a secondary table, the sort expression is reflected in the Sort column on
the Define Link tab of the Spreadsheet Preferences dialog box.

When Click to Sort is enabled, a small arrow ( or ) is displayed when you click the column
heading of a view. This shows the direction of the sort.
To enable the Click to Sort option, complete the following step:
1. Take one of the following actions:


Right-click a column heading, and click Click to Sort on the context menu.



On the View tab, point to Spreadsheet, and click Click to Sort on the submenu.

To disable the Click to Sort option, complete the following step:
1. Take one of the following actions:
Click to Sort
button



Right-click a column heading, and click the Click to Sort option on the context menu to
clear it.



On the View tab, click the Click to Sort button to clear it.

Favorite Sorts
After you assigned a predefined or custom sorting sequence to a view, you can use the Favorite
Sorts button to designate the sorts as your favorites.
Favorite Sorts
button

The feature allows you to easily access a favorite sort sequence. Open Plan displays a maximum of
10 favorite sorts. If you have more than 10 favorite sorts, you can click More Favorites to display the
rest of the sorts.
The sorts that appear on the favorites list depend on the view you are in. A resource-based view will
show favorite sorts that apply to the resource table, whereas an activity based view will show favorite
sorts that apply to activities.
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You can also use the Organize Favorites dialog box to manage your favorite sorts. For more
information, see Chapter 03, “Getting Started”.

To designate a sort as a favorite, complete the following steps:
1. Apply a predefined or a custom sort.
2. Click the Favorite Sorts button from the Sorts group of the Spreadsheet or Barchart Edit tab.
3. Click the Add To Favorites button.
The favorite sorts list will display as follows:

You can also use the Organize Favorites dialog box to manage your favorites list.
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Calculated Fields
In Open Plan, the data fields displayed in a view are typically one of three types:


Normal data entry fields — for example, an activity ID or description that can be updated by the
user at any time



Fields generated by Open Plan processes — for example, the early start and finish dates
calculated by time analysis.



Calculated fields defined by the user.

User-defined calculated fields allow you to calculate and display data not stored in the standard
versions of the project database tables. With calculated fields, you can extend the flexibility of any
view by displaying data that is the result of a custom calculation. Once defined, a calculated field can
be treated as any other type of field. For example, you can display that field as a column in a
spreadsheet view or in an activity box, just as you can any standard field. You can also include
calculated fields in custom filter and sort expressions.
Open Plan does not store the results of calculated fields in the project database. Only the
definition of the calculation is saved — the results are recalculated each time the field is required
for display. Third-party applications that query the database cannot, therefore, access the results
of calculated fields. You can, however, use the global edit feature (described later in this
chapter) to place the contents of a calculated field into a user-defined field.

Using Calculated Fields
To display a list of available calculated fields, click the Calculated Fields command on the Tools tab.
Open Plan responds by displaying the following dialog box:
Select the data table.

Select the calculated field for the view.

Definition of the calculated field is shown
as a tooltip

Click to create a new sort.

If you hover your mouse cursor over a calculated field, Open Plan displays the definition of that
calculated field as a tool tip.
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Defining Calculated Fields
You can use the Calculated Fields command from the Tools tab to define a new calculated field at
any time. When you define a new calculated field, Open Plan displays a dialog box in which you can
enter a name for the field, the data table to which you want to associate the field, and the type of
result produced by the field.

You can define a new calculated field to produce one of the following types of results:


Character — Returns a character string to the calculated field



Date — Returns a date to the calculated field



Decimal — Returns a decimal number (for example, 7.89) to the calculated field



Duration — Returns a duration to the calculated field



Finish Date — Returns an activity finish date to the calculated field



Integer — Returns a whole number to the calculated field



Logical — Returns True or False to the calculated field

Once you provide a name, data table association, and result type for the calculated field, Open Plan
allows you to enter the expression for the field.

Click to display list of available fields.

Click to display list of available functions.

The Calculated Field Expression dialog box is resizable. You can resize this by dragging any
corner or side of the dialog box.

Use the Fields and Functions commands to display lists of items that you can insert into the
expression you are editing.
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The Calculate Summary Rows Horizontally option applies to calculated fields appearing in
summary rows of spreadsheets using subsectioning. If you select this option, Open Plan calculates
the value of the field based on the values of the summarized row, effectively disabling the rolling up of
the field. If you leave the option unselected, Open Plan simply rolls up the values appearing in the
column. For example, assume that you have defined a calculated field that compares two activity
dates. When this calculated field appears in a summary row, it is likely that you want to display a
value based on summarized dates rather than one that is the simple aggregation of the calculated
values appearing in the column.
You can also change the table and data type assignment for the expression. For expressions that
result in decimal data types, you can specify the number of decimal places in the result.
For a complete description of the operators and functions available for calculated fields, refer to
Chapter 2, “Defining Calculated Fields,” in the Deltek Open Plan Developer’s Guide.

You can define calculated fields for both project and resource files. By default, Open Plan stores the
calculated field with the project or resource file that is open when you define the field. (Open Plan
may also store the field with the current view if the field is used by the view.)
Select the Access Control option to grant rights to other users in the data source to use the
expression.
Select the References option to display the References dialog box, which has a list of items that use
the calculated field. This list of items includes the file type, name of the project or file, description, and
owner.
To add a calculated field, complete the following steps:
1. On the Tools tab, click Calculated Fields.
2. On the Calculated Fields dialog box, click New.
3. Enter the following information:


Field name



The data table to which you want to associate the field



The data type of the field
The data type of the field must match the result produced by the calculated field
expression.

4. When the information for the field is complete, click OK.
5. In the Calculated Field Expression dialog box, enter the expression for the calculation.
To see a list of fields for the expression, click Fields.
To see a list of functions for the expression, click Functions.
6. When the expression is complete, click OK to return to the Calculated Fields dialog box.
To edit a calculated field, complete the following steps:
1. On the Tools tab, click Calculated Fields.
2. Select the calculated field you want to change, and click Edit.
If you do not see the appropriate calculated field listed in the dialog box, use the Display For
list to select another data table.
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3. In the Calculated Field Expression dialog box, update the expression for the field.
4. When the information for the expression is complete, click OK to return to the Calculated
Fields dialog box.
To copy a calculated field, complete the following steps:
1. On the Tools tab, click Calculated Fields.
2. Select the calculated field you want to copy, and click Copy.
If you do not see the appropriate calculated field listed in the dialog box, use the Display For
list to select another data table.
3. In the Calculated Field Expression dialog box, enter a new name for the field.
4. When the information for the new expression is complete, click OK to return to the Calculated
Fields dialog box.
To delete a calculated field, complete the following steps:
1. On the Tools tab, click Calculated Fields.
2. Select the calculated field you want to delete, and click Delete.
If you do not see the appropriate calculated field listed in the dialog box, use the Display For
list to select another data table.
3. When Open Plan asks you to confirm the deletion, click Yes.
When an error is generated by Open Plan, the portion of the failed expression in the
Expression field is highlighted.

Temporary Calculated Fields
In addition to allowing you to name and save calculated fields for future use, Open Plan allows you to
create and use temporary calculated fields in the following circumstances:


Export scripts



Spreadsheet Add, Insert, and Edit Column dialog boxes



Multi-table define links



When defining the box layouts for the network and hierarchy views



When defining box attributes for the network view



OLE automation
These temporary calculated fields are not displayed in the Calculated Fields dialog box. They
are not saved as part of the project. If you save the view while a temporary calculated field is in
effect, Open Plan saves the view with the definition applied.

To define a temporary calculated field in a network view, complete the following steps:
1. Display the network view to which you want to apply the temporary calculated field.
2. Take one of the following actions:


On the View tab, click Preferences.
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Right-click an empty area of the view, and click Preferences on the context menu.

3. On the Preferences dialog box, click the Box Attribute or the Box Layout tab.
4. Enter the temporary calculated field in the Criterion or Field column, and click OK.
Open Plan displays the results of the calculated field in the network view.
To define a temporary calculated field in a spreadsheet view, complete the following steps:
1. Display the spreadsheet view to which you want to apply the temporary calculated field.
2. Right-click the column heading, and click Add, Insert, or Edit column.
Open Plan displays the appropriate Column dialog box.
3. Enter the calculated field in the Field Name field and a column title in the Title field, and click
OK.
Open Plan displays the results of the calculated field in the selected column.
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Rollups
The Rollup utility provides the ability to perform a roll-up of date and numeric fields selected by the
user. Rollups may be defined for Activities, Resources, and Codes.
Selecting Rollups from the Tools tab displays the following dialog box:

This dialog box allows you to perform a rollup of selected numeric and date fields for Activities,
Resources, and Codes. For numeric fields, the parent object is the sum of its children. For date fields,
the Start date of the parent object is the earliest date of its children, and the Finish date is the latest
date of its children.
If any of the children have a blank finish date, a blank finish date is rolled up to the parent.

The Display for field allows you to select the table that contains the rollup definition you want to use.
When a table is selected, the dialog box is populated with all of the rollup definitions that have been
created for that table. Selecting a rollup definition and clicking Apply performs the rollup for the
current file.
For numeric fields, the parent object is the sum of its children. For date fields, the Start date of the
parent object is the earliest date of its children, and the Finish date is the latest date of its children.
If any of the children have a blank finish date, a blank finish date is rolled up to the parent.
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When you click New or select a rollup definition and click Copy or Edit, the Rollup Definition dialog
box is displayed:

The Rollup Definition dialog box displays the following controls:


Name — If you are creating a new definition, this field will display blank, allowing you to add a
name. If you are copying an existing definition, this field will be populated with the name,
preceded by copy_ name. You can either accept the new name or replace it with a different
name. If you are editing a definition, the name will display dimmed, and cannot be changed.



Applies to Table — This field is populated with the table name that was previously selected, and
cannot be changed on this dialog box.



Available Fields — This lists all date and numeric fields created for the selected table. To apply
a field to the rollup you are defining, double-click the edit name or click the > button to move the
listed edit to the Assigned Fields window.
To move the entire list, select the list by clicking the first name, then depress the Shift
key and click the last name in the list, then click the > button. To select a random group
from the list to move, press and hold the CTRL key and click the mouse pointer on the
items to be moved to highlight, then click the > button.



Assigned Fields— This lists the fields the rollup definition will use. You can also remove any or
all of the items in the Assigned Fields list by either double-clicking the item name, or clicking it to
highlight and then clicking the < button. This will move the selected item or items to the Available
Fields list.



Access Control — Select this option to grant rights to other users in the data source to use the
definition.

After you have created or edited rollup definitions, the display returns to the Rollups dialog box.
To execute a rollup for the current file, complete the following steps:
1. From the Tools tab, select Rollups from the Manage group.
1. Select a rollup definition from the Rollups dialog box.
2. Click Apply.
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Group Process Rollups
You can also perform a rollup in Batch Mode. This allows you to use a rollup definition for multiple
projects at one time. To use a rollup definition in Batch Mode, select more than one project from the
Details pane of the Open Plan Explorer, and click Rollups on the Tools tab. The Rollups [Batch
Mode] dialog box will be displayed. Select the rollup definition to use, and click Apply.
If a project is closed, Open Plan will open it in Exclusive mode, perform the process, save the
changes, and then close the project. If a project cannot be opened in Exclusive mode (because
another user has it open in Exclusive or Shared mode), it will be skipped.
If you have a project open when the batch process is run, rollup will be performed on the project, but
the changes will not be saved and the project will remain open. You must manually save the changes
yourself.
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Global Edits
With the Global Edits utility, you can modify multiple activity, resource description, or resource
assignment records with a single operation. Using the global edit utility you can, for example,
increase all the durations in a project by 25% or change all the assignments for a specific resource.
Global edit operations can modify all the records in a file or selected records based on a filter
expression.
Note: You may be able to perform basic global edits using Find/Replace functionality if there is no
math or other expressions required.
When you click Global Edits on the Tools tab, Open Plan responds with the following dialog box:

This dialog box displays a list of currently available global edits. Since they change all instances of
the data, global edits may be applied regardless of whether or not any specific view is open.
The Display For field contains a list that segregates the global edits by type of data. For example, if
you select Project from the list, the global edits that are displayed are project related.
To apply a global edit, complete the following steps:
1. Open the project or resource file to which you want to apply the global edit.
2. On the Tools tab, click Global Edits from the Manage group.
3. Select the global edit you want to apply.
To display the expression for the edit, click Edit.
4. Click Apply.

Defining Global Edits
You can define a new global edit at any time.
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You can define global edits for both project and resource files. By default, Open Plan stores the edit
expression with the project or resource file that is open when you define the field. When you define a
new global edit, Open Plan displays the following dialog box:

You can use the following controls to define the global edit:


Name — If you have a project or resource file open, the default value in this field is <temporary>.
By leaving this default value, you can create global edits without saving them.
In order to save a global edit, you must change the default <temporary> value to a different
name. When you then save the global edit, the name you entered is displayed on the Global
Edits dialog box.

If you have accessed this dialog box without first opening a project or resource file, the Name
field is blank since there is no target for a temporary sort.


Applies to Table — Controls the data table to which the new global edit applies. The choices
from which you can select depend on whether you are creating a global edit for a project or for a
resource file:
Project

Resource

Activity

Resource Availability

Relationship

Resource Description

Resource Assignment

Resource Escalation

Resource Cost

Summary Usage

Resource Usage
Risk Detail
Subproject


Replace Values in — Controls the field of the data table to which the global edit applies.
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Of Type —Displays which of the following types of data is stored in the selected field of the data
table:


Date



Decimal



Duration



Finish Date



Integer



Character



Logical



Enumerated values
For more information on enumerated field values, refer to the Help for this topic.



With Expression — Controls the expression that will replace the data in the selected data table
field. The expression must create data of the same type as the data it will replace. For example, if
the global edit replaces a date, the global expression must also create a date.
An expression defining a global edit can include the following elements:


Character operators



Constants



Duration operators



Field names



Functions



Logical operators



Mathematical operators



Calculated fields



Relational operators
For more information on the above elements, refer to the online Help for this topic.



Matching Filter — The ellipsis button at the right edge of this field displays the Filters dialog box
that you can use to apply a filter to the global edit. In this way, you can limit the records that will
be affected by the global edit.



Access Control — Select this option to grant rights to other users in the data source to use the
definition.



References — Displays the References dialog box, which has a list of items that use the global
edit. This list of items includes the file type, name of the project or file, description, and owner.



Fields — Displays a dialog box where you can select a field to include in the expression.



Functions — Displays a list of available functions.
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Values — Displays the Select a Value dialog box that you can use to select a value to include in
the global edit.

The expression for a global edit can use the same set of functions, operators, and field names that
you use when creating calculated fields.
For more information, refer to Chapter 2, “Defining Calculated Fields,” in the Deltek Open Plan
Developer’s Guide.

The following table shows some simple examples of operations you can perform on the original
durations of activities in a project:
Expression

Result

ORIG_DUR-|1d|

Subtract one day from each duration

ORIG_DUR*1.25

Increase durations by 25%

SCHED_DUR

Set original durations to scheduled durations

You can also specify a filter to limit the effect of the operation to a selected group of records.
To add a global edit, complete the following steps:
1. On the Tools tab, click Global Edits from the Manage group.
2. On the Global Edits dialog box, click New.
3. Enter the following information for the operation:


The name of the edit



The data table and field to modify



The expression for the operation



An optional filter for the operation

To see a list of fields for the expression, click Fields.
To see a list of functions for the expression, click Functions.
4. When the definition is complete, click OK to return to the Global Edits dialog box.
To create a new filter for the edit from the Global Edit Definition dialog box, click the
ellipsis button displayed next to the filter text box. For information about creating a
filter, refer to the “Defining Filter Expressions” section in this chapter.

To apply a global edit without saving the expression, complete the following steps:
1. Open the project or resource file for which you want to apply the temporary global edit.
2. On the Tools tab, click Global Edits from the Manage group.
3. On the Global Edits dialog box, click New.
4. Enter the information for the expression, but leave the name as <temporary>.
5. When the expression is complete, click Apply.
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To update a global edit definition, complete the following steps:
1. On the Tools tab, click Global Edits from the Manage group.
2. Select the global edit you want to change, and click Edit.
3. In the Global Edit Definition dialog box, update the definition.
4. When the information for the new edit is complete, click OK to return to the Global Edits
dialog box.
To copy a global edit, complete the following steps:
1. On the Tools tab, click Global Edits from the Manage group.
2. Select the global edit you want to copy, and click Copy.
3. In the Global Edit Definition dialog box, enter a new name for the definition.
4. When the information for the new edit is complete, click OK to return to the Global Edits
dialog box.
To delete a global edit, complete the following steps:
1. On the Tools tab, click Global Edits from the Manage group.
2. Select the global edit you want to delete, and click Delete.
3. When Open Plan asks you to confirm the deletion, click Yes.

Batch Global Edits
A global edit allows you to modify multiple activities or resources with a single operation. The Batch
Global Edits dialog box allows you to create groups of global edits (batches) that can be applied to a
file in a single operation. When you click Batch Global Edits on the Tools tab, Open Plan responds
with the following dialog box:

The Batch Global Edits dialog box displays a list of currently available definitions. The Display For
field contains a list that segregates the batches by type of data. For example, if you select Activity
from the list, the batches that are displayed are activity related.
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When you click New or select a batch and click Copy or Edit, the Batch Global Edit Definition
dialog box is displayed.

You can use this dialog box to select the global edits that the batch will use as well as the order in
which the global edits are executed.
The Batch Global Edit Definition dialog box displays the following controls:


Name —If you are creating a new definition, this field will display blank, allowing you to add a
name. If you are copying an existing definition, this field will be populated with the name,
preceded by copy_ name of edit. You can either accept the new name or replace it with a
different name. If you are editing a definition, the name will display dimmed, and cannot be
changed.



Applies to Table —This field is populated with the table name that was previously selected, and
cannot be changed on this dialog box.



Available Global Edits —This field initially lists all global edits created for the selected table. To
apply a global edit to the batch global edit you are defining, double-click the edit name or click the
> button to move the listed edit to the Assigned Global Edits field.
To move the entire list, select the list by clicking the first name, then depress the Shift
key and click the last name in the list, then click the > button. To select a random group
from the list to move, press and hold the CTRL key and click the mouse pointer on the
items to be moved to highlight, then click the > button.



Assigned Global Edits — This field lists the global edits the batch definition will be used, and
the order in which the global edits will be executed. To change the order of the list, select the item
to be moved and click the up or down arrows adjacent to the list.
You can also remove any or all of the items in the Assigned Global Edits list by either doubleclicking the item name, or clicking it to highlight and then clicking the < button. This will move the
selected item or items to the Available Global Edits list.



Global Edits — Clicking this button opens the Global Edits dialog box. You would use this option
if the global edit you want to include in the batch definition does not exist or if you need to modify
an existing global edit before including it in the batch.
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Access Control — Select this option to grant rights to other users in the data source to use the
definition.

To create a batch global edit definition, complete the following steps:
1. On the Tools tab, click Batch Global Edits from the Manage group.
Batch Global
Edits button

2. From the Display for list on Batch Global Edits dialog box, select the table to which the batch
global edit applies.
3. Click New.
4. From the Available Global Edits lists, select the global edits to include in the batch
definition, and click the right arrow button.
5. You can select multiple global edits to include at once by clicking Ctrl+ or Shift + and
selecting the global edits you want to include.
6. If the global edit you want to include is not listed, click the Global Edits button to display the
Global Edits dialog box that you can use to create the appropriate global edit.
7. In the Assigned Global Edits list, use the up and down arrow buttons to determine the order
in which the global edits are to be executed.
8. If you wish to share the batch definition with other users, select the Share this Item with
Others option.
9. When you are finished defining the batch, click OK.
When a batch is applied, it is first reconciled to verify all referenced global edits exist. If missing
global edits are detected, a message is displayed to let you decide if you want to continue to
apply the batch or not. If you choose to continue, the batch is applied and the missing global
edits are removed from the definition.
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User Defined Fields
Open Plan allows you to create and use data fields that are not included in the product as delivered
by Deltek. Because these fields can be used by most tables and are available in any view where you
can select fields for display, they provide a great deal of flexibility and customizability.
At the same time, it is important to note that while user defined fields can be created very quickly,
they are not the only way in which data fields can be added to the Open Plan database. It is also
possible to add fields to the Open Plan tables. The question of which is the better avenue to take
depends on how often the additional fields will be used:


If the fields to be added will be used infrequently, user defined fields provide a quick and easy
solution. However, because user defined fields may be used by many projects, they require
identifying information in addition to their data. This means that there is much more information
that must be processed each time the field is required. If the field is used frequently, performance
may be adversely affected.



If the additional field will be used frequently, the best answer may be to modify the structure of the
affected Open Plan table. While this will take more effort than creating a user defined field, the
improved performance may be significant. You may want to consult with your database
administrator if you want to modify the structure of an Open Plan table.
For more information about the Open Plan data structures, refer to Chapter 17, “Standard File
Structures,” in the Deltek Open Plan Developer’s Guide.

Clicking User Fields on the Tools tab displays the following dialog box:

This dialog box displays a list of user defined fields that are available for the selected data table.
The Table field at the top of the dialog box allows you to select the data table to which the user
defined field applies.
Data is not saved by Open Plan when the data is entered on inter-project links for user defined
fields created on the Relationship table.
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Creating a User Defined Field
To create a user defined field, click New on the User Defined Fields dialog box to display the
following:

This dialog box contains the following controls:

Name
The name of the new user defined field. This is the internal name that Open Plan associates with the
user defined field.

Data Type
You can select from the following data types:


Character



Date



Finish Date



Decimal



Duration

In addition to specifying the type of data that you will be able to enter in the new user defined field,
the data type also specifies the length of the field. For example, if you select Character, Open Plan
creates the user defined field with a length of 60.

Description
You can use this field to assign a longer, more meaningful description to the user defined field.

Also Create Field for Baseline
This option is enabled only if you are creating a user defined field for the Activity table. If you select
this option, Open Plan adds the new user defined field to the Baseline table.

Link Field to Lookup Table
Selecting this option will link the field to a Lookup Table by selecting from the following list of options:


Lookup Table Type — Select the type of Lookup Table from the list.



Lookup Field Name — Once the type is selected, you can select the specific field.
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Lookup Table Name — This option is available if you previously selected a Resource or Code
Table type.

To create a user defined field, complete the following steps:
1. On the Tools tab, click User Fields.
User Fields
button

2. On the User Defined Fields dialog box, click New.
3. Enter the information for the new field, and click OK.
Open Plan adds the user defined field to the appropriate data table and includes it in the list
displayed on the User Defined Fields dialog box.

Copying a User Defined Field
You can copy any existing user defined field by selecting a field and clicking Copy on the User
Defined Field dialog box to display the following:

Using this dialog, you can change the Name, Data Type, and Description for the copy of the user
defined field. You can also select or clear the Also Create Field for Baseline option.
To copy a user defined field, complete the following steps:
1. On the Tools tab, click User Fields.
2. From the list on the User Defined Fields dialog box, select the field to copy.
3. Enter the information for the copy, and click OK.
Open Plan adds the user defined field copy to the appropriate data table and includes it in the
list displayed on the User Defined Fields dialog box.
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Editing a User Defined Field
You can edit the description of an existing user defined field using the following dialog box:

To edit an existing user defined field, complete the following steps:
1. On the Tools tab, click User Fields.
2. From the list on the User Defined Fields dialog box, select the field to edit.
3. Enter a new description, and click OK.
Open Plan adds the user defined field copy to the appropriate data table and includes it in the
list displayed on the User Defined Fields dialog box.

Deleting a User Defined Field
Provided you have the appropriate rights to it, you can delete a user defined field from the User
Defined Fields dialog box.
To delete a user defined field, complete the following steps:
1. On the Tools tab, click User Fields.
2. From the list on the User Defined Fields dialog box, select the field to delete.
3. Click Delete.
4. When Open Plan asks for confirmation of the delete, click Yes.
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User Defined Validations
Open Plan implements User Defined Validation, allowing you to define and apply your own rules and
business logic. This allows customers to ensure that data entered into schedules meets corporate
and industry best practice guidelines, and reduces re-work when subsequent schedule quality audits
are performed.
This set of rules or validations is applied on a per project basis, which means different organizations
or customers can have different rules or standards. Open Plan applies these rules each time you
save information.
For more information about User Defined Validations (UDVs), examples, and best practices, see
Knowledge Base Article #75068.

Clicking User Validations on the Tools tab displays the following dialog box:

This dialog box allows you to add, copy, edit, and delete rules for projects. It contains the following
fields and buttons:

Display for
This drop-down list allows you to select one of the following areas to which you want to apply the
validation rule:


Activity



Relationship



Resource Assignment

New
Click this button to add a rule. Clicking it displays the Edit User Defined Validation dialog box.

Copy
Click this button to copy a selected rule. Clicking it displays the Edit User Defined Validation dialog
box with values from the copied rule.
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Edit
Click this button to edit a selected rule. Clicking it displays the Edit User Defined Validation dialog
box.

Delete
Click this button to remove a selected rule from the list.

Close
Click this button to exit the dialog box.

Assign
Click this button to assign a selected rule to specific projects, projects with specific group access, or
projects with a specific owner.

References
Click this button to view the projects to which the rule is assigned. Clicking it displays the References
dialog box.

Edit User Defined Validation Dialog Box
Clicking New, Copy, or Edit on the User Defined Validations dialog box displays the Edit User
Defined Validation dialog box.
For more information on how to set up expressions and messages, see Knowledge Base
Article #75068.

It contains the following fields and buttons:

Name
This field allows you to enter or update a validation name.
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Applies to Table
This drop-down list allows you to select an area to which you assign the validation:


Activity



Relationship



Resource Assignment

If you click Edit on the User Defined Validation dialog box, this field is read-only.

Expression
Enter the syntax or condition of the validation rule. It can be any filter, a calculated field, or a
temporary filter expression. Alternatively, you can click Fields or Functions to select an existing field
and/or function when creating or editing expressions.

Validation Type
This drop-down list allows you to select the validation that you want Open Plan to generate:


Warning



Error

Message
Enter or modify the message that you want to display when users fail the validation.

Fields
Click this button to display the Fields dialog box, allowing you to select a field from an Open Plan data
table that you can include in the expression.
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Functions
Click this button to display the Functions dialog box, allowing you to select a function that you can use
when building the expression.

Validate
Click this button to validate the expression that you entered.
When an error is generated by Open Plan, the portion of the failed expression in the
Expression field is highlighted.

Creating a Validation Rule
When building or editing a condition (sort, filter, calculated field, or global edit expression) for the
validation rule, you can click Fields or Functions to view and select valid options.
For more information on how to set up expressions and messages, see Knowledge Base
Article #75068.

To create a validation rule, complete the following steps:
User Validations
button

1. On the Tools tab, click User Validations.
2. On the User Defined Validations dialog box, click New.
3. On the Edit User Defined Validations dialog box, enter or select the necessary information.
4. When you are done, click OK.
5. Click Close.

Copying a Validation Rule
You can copy an existing validation rule by selecting it from the list and clicking Copy on the User
Defined Validations dialog box. .
To copy a validation rule, complete the following steps:
1. On the Tools tab, click User Validations.
2. From the list of rules on the User Defined Validation dialog box, select the rule that you want
to copy.
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3. Click Copy.
4. On the Edit User Defined Validations dialog box, enter or select the necessary information.
5. When you are done, click OK.
6. Click Close.

Editing a Validation Rule
When you are editing a rule, the Applies to Table field is read-only.
For more information on how to set up expressions and messages, see Knowledge Base
Article #75068.

To edit a validation rule, complete the following steps:
1. On the Tools tab, click User Validations.
2. From the list of rules on the User Defined Validation dialog box, select the rule that you want
to update.
3. Click Edit.
4. On the Edit User Defined Validations dialog box, enter or select the necessary information.
5. When you are done, click OK.
6. Click Close.

Assigning a Rule to a Project using the Assign User Defined
Validation Box
Before you perform this procedure, make sure that you have already defined the rule or the rule that
you need already exists. One of the ways that you can assign a rule to a project is through the Assign
User Defined Validations dialog box. This is more useful when assigning the rule to multiple projects.
The other way of assigning the rule is through the Validations Tab on the Project Properties
dialog box.

To assign the validation rule, complete the following steps:
1. On the Tools tab, click User Validations.
2. From the list of rules on the User Defined Validation dialog box, select the rule that you need.
3. Click Assign.
4. On the Assign User Defined Validations dialog box select one of the following options:


Assign to Specific Project



Assign to Projects with this Access Group



Assign to Projects with this Owner

5. From the drop-down list of the selected option, select a project, group, or owner.
6. Click OK.
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7. Click Close.

Removing an Assigned Validation Rule from a Project
Before you can delete a validation rule, you need to remove it from any project to which it is assigned.
To check the list of affected projects or files, click the References button on the User Defined
Validation dialog box.
To remove the assigned rule from the project, complete the following steps:
1. Open a project.
2. On the Processes tab, click Properties.
3. On the Project Properties dialog box, click the Validations tab.
4. From the Assigned User Defined Validations list, select the assigned rule that you want to
remove and then click . The selected rule displays in the Available User Defined
Validations list.
5. Click OK.

Deleting a Validation Rule
You cannot delete a rule that has been assigned to a project. To check the list of projects or files to
which the rule is assigned, click the References button on the User Defined Validation dialog box.
If the validation rule that you want to delete is assigned to a project, you need to remove it from that
project before you can proceed with the deletion.
To delete a validation rule, complete the following steps:
1. On the Tools tab, click User Validations.
2. From the list of rules on the User Defined Validation dialog box, select the rule that you want
to delete.
3. Click Delete.
4. On the confirmation dialog box, click Yes.
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Spread Curves
Spread curves allow you to define the manner in which a resource assignment is distributed over the
duration of an activity. When assigning a resource to an activity, you can use the Curve field on the
Resources tab of the Activity Details dialog box to select a predefined spread curve.
When you click Spread Curves on the Tools tab, Open Plan displays the following dialog box:

This dialog box lists the spread curves defined for Open Plan. Using this dialog box, you can create a
new spread curve, edit a spread curve, or delete a spread curve.
Clicking New on the Spread Curves dialog box displays the New Spread Curve dialog box:

This dialog box features the following controls:


Name — Open Plan uses the (single) character entered in this field to identify the spread curve.
If you enter a character that is already in use for another spread curve, Open Plan issues a
warning when you click OK.



Description — This field allows you to specify a more descriptive name for the spread curve.
Once defined, the spread curve is identified by both its Name and its Description.
You cannot leave this field blank. You must enter a description for the spread curve.



Cumulative — As you enter values in the grid, Open Plan recalculates the values and displays
the current total in column 10 of the Cumulative row.



Incremental — The values in the Incremental row allow you to define the percentage to be
applied to each specific period.



Reconcile — If you click this button, Open Plan ensures that the value in column 10 of the
Cumulative row equals 100%. If necessary, Open Plan redistributes the values in the remaining
cells in such a manner as to honor your inputs to the extent that it is possible.
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When you select an existing spread curve from the Spread Curves dialog box and click Edit, Open
Plan displays the Edit Spread Curve dialog box:

This dialog box is similar to the New Spread Curve dialog box except that the Name field is disabled.
You can edit only the description and percentage values in the Cumulative and Incremental rows.
Select the Access Control option to grant rights to other users in the data source to use the curve.
Modifying or deleting a spread curve that is in use by another project will affect the project the
next time resource scheduling is performed or a baseline is updated.

To create a new spread curve, complete the following steps:
Spread Curves
button

1. On the Tools tab, click Spread Curves.
2. On the Spread Curves dialog box, click New.
3. In the Name field of the New Spread Curve dialog box, enter a single character to serve as
the name.
4. In the Description field, enter a longer description for the spread curve.
5. In the grid at the bottom of the dialog box, enter the appropriate values in any combination of
cells in the Cumulative and Incremental rows.
The total in the Cumulative row is displayed in column 10. This value must equal 100%.
6. Click Reconcile to ensure that the values in each column of the Cumulative row are correct.
7. Click OK.
To edit a spread curve, complete the following steps:
1. On the Tools tab, click Spread Curves.
2. From the Spread Curves dialog box, select the spread curve to edit.
3. Click Edit.
4. In the Edit Spread Curve dialog box, enter a new description and percentage values as
desired.
The total in the Cumulative row is displayed in column 10. This value must equal 100%.
5. Click Reconcile to ensure that the values in each column of the Cumulative row are correct.
6. Click OK.
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To delete a spread curve, complete the following steps:
1. On the Tools tab, click Spread Curves.
2. From the Spread Curves dialog box, select the spread curve to delete.
3. Click Delete.
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Overview

Overview
Open Plan ships with standard system options defined. You can change these default settings at any
time by using the Options dialog box.
This chapter discusses the different tabs of the Options dialog box.
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System Options
You can set system-wide options in Open Plan by clicking Application on the File menu »
Preferences submenu to display the Options dialog box. You can then navigate among the various
tabs to set the system options for Open Plan.
To change system options, complete the following step:
1. On the File menu, click Preferences » Application.
2. Navigate the tabs and change the desired settings, and click OK.
The following sections describe each tab of the Options dialog box.

General Tab
On the File menu, click Preferences » Application, and then click the General tab to display the
following:

Use this tab to change the following system options:


StartUp Clip Notes — You can control the automatic display of help information when opening
an empty view.



Opening Splash Screen — You can control the display of the opening splash screen when you
start Open Plan.



Startup Tips — You can control the display of the Tip of the Day window when you start Open
Plan.



Status Bar — You can control the display of the status bar along the bottom of the screen.



Default Times — These fields control the standard work day that Open Plan uses when you
create a project using default settings. You can override this setting in the New File Wizard.
For more information on using the New File Wizard, refer to Chapter 4, “Creating a New File.”
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Week Starts On — The selection you make from this list controls the day of the week that Open
Plan uses as the starting day of each work week.



Language — You can specify the language used by Open Plan for dialog boxes, commands, and
system messages.



Default Open Mode — The selection you make here controls the default access mode Open
Plan uses for a project when you create a project using default settings. You can override this
setting in the New File Wizard.
For more information on using the New File Wizard, refer to Chapter 4, “Creating a New File.”



Open Last File on Startup — You can have Open Plan automatically start with the last project or
data file you opened in the previous session.



Symbols — Clicking this button displays the Symbols dialog box.
For more information on using the Symbols dialog box, refer to Chapter 17, “Views and
Reports.”



Edit Briefcase — Clicking this button displays the Edit Data Source dialog box for the Briefcase
data source. You can use this dialog box to make changes to your Briefcase data source.
For more information on using the Edit Data Source dialog box, refer to Chapter 24, “System
Utilities.”

Edit Tab
On the File menu, click Preferences » Application, and then click the Edit tab to display the
following:

Use this tab to change the following system options:
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Do Not Clear Contents of the Dialog Box When Creating a New Activity —This option
controls whether the contents of a dialog box are cleared when you create a new activity:


If this option is selected, Open Plan does not remove the existing contents of an Activity
Details dialog box when you create a new activity. This effectively copies the data to the new
activity.



If this option is cleared, the dialog box that is displayed when you create a new activity is
empty. This is the default.

Request Confirmation of Save When Navigating to Another Record — This option controls
whether Open Plan should generate a message asking you to confirm that you want your
changes saved when you navigate to another record:


If this option is selected, Open Plan issues a message when you navigate to another record
that asks you whether you want your changes saved.



If this option is cleared, Open Plan saves your changes without asking you to confirm the
action. This is the default.

You can also control how Open Plan should synchronize modeless dialog boxes with views using the
following options:


Do Not Navigate Views When Navigating in Dialog Box — Selecting this option instructs Open
Plan not to navigate the open views when clicking the navigation buttons in a dialog box.



Navigate Current View When Navigating in Dialog Box — Selecting this option instructs Open
Plan to navigate the open view that has focus when clicking the navigation buttons in a dialog
box. For example, assume you have a barchart view and a spreadsheet view open. Also assume
that you display the Activity Details dialog box for an activity from the spreadsheet view. Since the
spreadsheet view has focus, when you use the navigation buttons in the dialog box to display
another activity, the new activity will automatically be highlighted in the spreadsheet view but not
the barchart view.



Navigate All Views When Navigating in Dialog Box — Selecting this option instructs Open
Plan to navigate all open views when clicking the navigation buttons in a dialog box. For example,
assume that you have a barchart view and a spreadsheet view open and you display the Activity
Details dialog box for an activity. Using the navigation buttons in the dialog box to display another
activity will automatically highlight the new activity in the two open views.
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Project Tab
On the File menu, click Preferences » Application, and then click the Project tab to display the
following:

Use this tab to change the following system options:




Show Process Log Message Only if Errors Occur During Processing — This option controls
whether you are always prompted to view a log produced by operations such as time analysis
and resource scheduling.


If this option is selected, Open Plan prompts you to view the operation log only if errors occur
during processing. This is the default setting.



If this option is cleared, Open Plan always prompts you to view the operation log regardless
of whether errors occurred during the process.

Create New Project Using Default Project — This option controls whether new projects are
created as copies of a default project.


If this option is selected, Open Plan opens the default project when you create a new project.
After you have entered information for the new project, you can save your changes using the
Save As command on the File menu.
Selecting this option enables two fields:


File Type — Select Project or Project Template



File Name — Select the file name from the list

If the Create New Project Using Default Project option is cleared, Open Plan does not
open a default project when you create a new project.
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Views Tab
On the File menu, click Preferences » Application, and then click the Views tab to display the
following:

The top half of the Views tab is a grid that lists the views that will automatically be assigned when a
new project is created. These views are selected using the Views button.
This tab also includes the following controls:


Default Startup View — This field contains a list of the currently defined standard views that are
displayed in the grid. You can select a view from this list to instruct Open Plan to display that view
by default whenever the project is opened.



Views — If you click this button, Open Plan displays the Select Standard Views dialog box that
you can use to specify which view(s) Open Plan should automatically assign to a newly created
project:

To add a view to the Standard Views list, complete the following step:
1. On the File menu, click Preferences » Application.
2. On the Views tab of the Options dialog box, click Views
3. Open Plan displays the Select Standard Views dialog box.
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4. From the Available Views list, select a view, and click Add.
You can select more than one view at a time and click Add to move all of them to the
Standard Views list at once.

If you are adding all the views from the list, you can click Add All without having to first select
the views.
5. When finished, click OK.
To remove a view from the Standard Views list, complete the following step:
1. On the File menu, click Preferences » Application.
2. On the Views tab of the Options dialog box, click Views
3. From the Standard Views list, select a view, and click Remove.
You can select more than one view at a time and click Remove to move all of them to
the Available Views list at once.

If you are removing all the views from the list, you can click Remove All without having to
first select the views.
4. When finished, click OK.

Codes Tab
On the File menu, click Preferences » Application, and then click the Codes tab to display the
following:

The Codes tab of the Options dialog box allows you to specify project-level code files that Open Plan
should automatically assign to all projects.
Project-level code files might represent entities such as geographic region, client, business objective,
division or other project-level reporting values.
Once codes have been specified on this tab of the Options dialog box, you can use the Codes tab on
the Project Properties dialog box to assign values to the code fields.
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The Project Codes text box displays the following information about each currently assigned code
file:


The code field to which the code file is assigned



The prompt associated with the code file



The code file name

The ellipsis button provides access to the Assign Code dialog box that you can use to assign code
files to code fields and to specify a prompt for each code file.

Color Tab
On the File menu, click Preferences » Application, and then click the Color tab to display the
following:

You can select the Use Windows Color Scheme option to let Open Plan use the Windows color
scheme.
Use this tab to change the following system options:


Theme Colors — You can set the color for each field by clicking its
following:

button to display the

You can use this to select a new color for the field.
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Set Custom Colors — This button displays the Select Custom Colors dialog box:

Clicking the

button gives you the following options:



Selecting <Not Set> allows Open Plan to use the default color.



Clicking the Select Color… option opens the Colors dialog box:

You can add custom colors with this dialog box. To do this, click the
click any of the available colors from the color swatch.



button and

Clicking the 3rd option allows Open Plan to use the current color.

Reset Theme Colors — This button resets the colors of the fields to the Open Plan default
colors.
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Email Tab
On the File menu, click Preferences » Application, and then click the Email tab to display the
following dialog box:

The Email tab of the Options dialog box allows the system administrator to configure email alerts to
use either MAPI or SMTP to transmit email. The Email tab contains two sections: Email and SMTP
Server Information.

Email
There are two email options available:


MAPI



SMTP
By default, the MAPI option is selected. When MAPI is selected, the controls in the SMTP Server
Information group box are disabled. When the SMTP option is selected, the controls in the
SMTP Server Information group box are enabled.

Test
When the Test button is selected and the MAPI option is selected, the message page provided
by the default system MAPI provider is invoked:


The Subject text defaults to the string Test.



The Body text defaults to the string This is a test message.



If the test message is sent, a message box indicating success or failure is displayed after the
message is sent.

When the Test button is selected and the SMTP option is selected, Open Plan attempts to
connect to the SMTP server using the settings specified in the SMTP Server Information group
box.


If the connection to the SMTP server is successful, the SMTP Message dialog is displayed.



If the connection to the SMTP server is not successful, an error message is displayed.

The Test button is always enabled.
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SMTP Server Information
The following options are available for SMTP Server Information configuration:


SMTP Server Address — SMTP Server Address stores the address of the SMTP Server.



Email Address — Email Address stores a default sender email address.
The Email Address supports the use of the replaceable parameters %WINUSERNAME% and
%OPPUSERNAME% to allow for simplified deployment scenarios (for example,
%WINUSERNAME%@deltek.com).
If the Email Address is left blank, Open Plan will attempt to obtain the email address associated
with the Open Plan User ID.
The maximum length of the user name portion of the email address cannot exceed 64 characters
and the domain name portion of the email address should not exceed 255 characters.



Server requires authentication — By default, the Server requires authentication checkbox is not
selected.
The Account Name and Password controls are disabled when the Server requires authentication
option is not selected.



Account Name — Account Name allows the user to enter an SMTP server account name if
required by the SMTP server.
There are no limits on the length of the server account name.



Password — Password allows the user to enter a SMTP server password if required by the
SMTP server.
There are no limits on the length of the server password.

Advanced Tab
On the File menu, click Preferences » Application, and then click the Advanced tab to display the
following dialog box:

This tab allows you to specify the predefined options you want enabled. The options that you enable
are stored in the User Preferences table.
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For example, selecting the BarchartToolTipsField from the Category list and defining a single field
as the Value allows you to define text to be displayed as a Tool Tip for the barchart. This category
requires that you enter a single field as the Value. However, in addition to allowing you to enter a
standard field, Open Plan also allows you to specify a calculated field that contains exactly the
information that you want displayed.
For more information on calculated fields, refer to Chapter 23, “Project Utilities.”

A Defaults button displays the System Preferences Defaults dialog box that a system administrator
can use to define system-wide preferences from which a user can select.

The entries that the system administrator makes in this dialog box are stored in the System
Preferences Default table.
In previous versions of Open Plan, the settings on this tab of the Options dialog box were set by
entries in the .ini file.

The following is a list of standard Open Plan options:


_ALLOW_EDIT_READONLY



_ApplicationTimeOut



_AUDIT_LOG_LEVEL



_BLANKDIALOGCONTENTSONNEW



_CONFIRMCHANGESONDIALOGNAVIGATION



_COPY_ACL_ON_SAVEAS



_COST_COLOR



_COST_COLOR_DK



_DEFAULTFINISHTIME



_DEFAULTOPENMODE



_DEFAULTSTARTTIME



_ENABLE_AUDIT_LOG



_LABEL_COLOR



_LOCK_COLOR
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_LOGVIEWTHRESHOLD



_NOTIFICATIONPOLLINGINTERVAL



_OPENLASTFILE



_QTY_COLOR



_QTY_COLOR_DK



_SharedModeBaselines



_SPLASHSCREENENABLE



_STATUSBAR



_SUPPRESSEMPTYCLIPNOTE



_SUPPRESSLOOPDETECTION



_SYNCDIALOGNAVIGATION



_SYNC_TREE_STATUS



_TIPSTARTUP



_TOOLBAR



_USEDEFAULTPROJECT



_UseOldRemainingQtyRules



ALLOWACTIVEXINBROWSERVIEW



ALLOWSCRIPTINBROWSERVIEW



ALLOWZEROBASELINEUSAGE



BARCHARTTOOLTIPSFIELD



BARPRINTMODE



CALCOMPFIX



HISTOGRAMARRAYLIMIT



LOGLEVEL



RISKPERCENTILEARRAYSIZE



SHOWSQLLOG



SUPPRESSCOMBINEVERTICALS
Option settings displayed on the Advanced tab of the Options dialog are specific to the user who
defines them.
Option settings displayed in the System Preferences Defaults dialog apply to all users and can
be set only by someone with system administrator rights.

_Allow_Edit_ReadOnly
When you open read-only files within Open Plan, this option allows you to make changes to these
files and save them using a new name, preserving the original read-only file. There are two settings:
0 = Do not allow modifications to read-only files.
1 = Enable users to modify read-only files, saving under a different name.
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Because the process of applying this option differs from the way the predefined options are applied,
the process is listed below:
To Set Edits to Read-only Files, complete the following step:
1. On the File menu, click Preferences » Application.
2. On the Options dialog, select the Advanced tab.
3. Choose the Defaults button.
4. Scroll to the end of the grid.
5. Enter the value _ALLOW_EDIT_READONLY in the Category column.
6. Enter the desired numeric value in the Default Value column.
7. Click OK to dismiss the System Preferences Defaults dialog box.
8. Click OK to dismiss the Options dialog box.

_ApplicationTimeOut
This option is used to set the amount of notice given to users (in seconds) whose sessions are about
to be terminated. The default period of time for notification is 10 seconds.

_AUDIT_LOG_LEVEL
This option determines the level of information captured in the Audit Log. The Audit Log must exist in
the database and have been enabled (see _ENABLE_AUDIT_LOG).


A setting of 3 captures basic login or logout events.



A setting of 4 captures additional information about the authentication method used.

_BLANKDIALOGCONTENTSONNEW
This option controls the display of the contents of a dialog. There are two settings:
0 = Blanks out the contents of the dialog when the user presses the New button.
1 = Leaves the existing contents of the dialog when the user presses New, effectively copying the
data to the new activity.
The default setting is 1.

_COLUMNCLICKTOSORT
This option is no longer used. The setting is stored in each individual view.

_CONFIRMCHANGESONDIALOGNAVIGATION
This option makes Open Plan display a confirmation message to save changes when the user
presses a navigation button or closes a modeless dialog through the Windows Close button (X).
There are two settings:
0 = Does not display a confirmation message.
1 = Displays a confirmation message.
The default setting is 0.
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_Copy_ACL_On_SaveAs
This option allows access control information to be copied when Save As is used to save a file. There
are two settings:
0 = Do not copy access control lists when performing a Save As.
1 = Copy access control lists when performing a Save As.
The default setting is 1.
Because the process of applying this option differs from the way the predefined options are applied,
the process is listed below:
To Enable the Option to Copy Access Control Lists When Performing a Save As
1. On the File menu, click Preferences » Application.
2. On the Options dialog box, select the Advanced tab.
3. Choose the Defaults button.
4. Scroll to the end of the grid.
5. Enter the value _COPY_ACL_ON_SAVEAS in the Category column.
6. Enter the value 1 in the Default Value column.
7. Click OK to dismiss the System Preferences Defaults dialog box.
8. Click OK to dismiss the Options dialog box.

_COST_COLOR
This holds the RGB value of the Cost Color setting.

_COST_COLOR_DK
This holds the RGB value of the Locked setting.

_DEFAULTFINISHTIME
Allows the user to specify a default time to be added to finish dates that are entered without a
specified time. The format of the time is HH:MM. The default setting is 16:00.

_DEFAULTOPENMODE
This option controls the default mode for File » Open. This option also sets the default access mode
for new projects. There are three modes:
1 = Exclusive.
2 = Shared.
3 = Read Only.
The values are E, S, and R. The default setting is E.

_DEFAULTSTARTTIME
This option allows the user to specify a default time to be added to start dates that are entered
without a specified time. The format of the time is HH:MM. The default setting is 08:00.
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_DISPLAYSTATUSVIEWER
This setting is no longer used.

_ENABLE_AUDIT_LOG
This option enables logging certain login or logout events to an Audit Log. The Audit Log must exist
in the database (table WST_AUDIT_LOG).

_LABEL_COLOR
This holds the RGB value of the Label Color setting.

_LOCK_COLOR
This holds the RGB value of the Lock Color setting.

_LOGVIEWTHRESHOLD
This option controls when the user is prompted to view messages produced by operations such as
time analysis and resource scheduling. There are two settings:
0 = Always prompt to view messages – regardless of severity.
1 = Only prompt to view messages when error messages have been generated.
The default setting is 1.

_NOTIFICATIONPOLLINGINTERVAL
This option controls how often (in seconds) Open Plan checks to see if the session has been
terminated or if there are any new messages. Note that this is an application-wide setting that will
affect all users. The default setting is 10 seconds.

_OPENLASTFILE
This option controls whether the last file used is opened on start-up. There are two settings:
0 = Does not open the last file used on start up.
1 = Opens the last file used on start up.
The default setting is 0.

_QTY_COLOR
This holds the RGB value of the Quantity Color setting.

_QTY_COLOR_DK
This holds the RGB value of the Quantity Color – Locked setting.

_SHARED_LOCK_DEFAULT_DURATION
This option controls how often (in seconds) Open Plan checks to see how long the temporary lock
has been in effect. The default setting is 30 minutes.
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_SharedModeBaselines
Enabling this option allows Baselines to be created or updated when a project is open in Shared
mode. If the option is not enabled, baselines can only be created or updated when the project is open
in Exclusive mode.

_SPLASHSCREENENABLE
This option controls the display of the Open Plan splash screen at start-up.
0 = Disables the splash screen.
1 = Enables the splash screen.
The default setting is 1.
Because the process of applying this option differs from the way the predefined options are applied,
the process is listed below:
To Set the Splash Screen, complete the following step:
1. On the File menu, click Preferences » Application.
2. On the Options dialog box, select the Advanced tab.
3. Choose the Defaults button.
4. Scroll to the end of the grid.
5. Enter the value _SPLASHSCREENENABLE in the Category column.
6. Enter the desired numeric value in the Default Value column.
7. Click OK to dismiss the System Preferences Defaults dialog box.
8. Click OK to dismiss the Options dialog box.

_STATUSBAR
This option controls the display of the Open Plan status bar.
0 = Hide Open Plan status bar.
1 = Show Open Plan status bar.
The default setting is 1.

_SUPPRESSEMPTYCLIPNOTE
A clip note is a help item that comes up when you create a new project, pool, calendar, code, or view
within Open Plan. This option allows the display of these help items to be suppressed.
0 = Open Plan displays the clip notes.
1 = Open Plan does not display the clip notes.
The default setting is 1.

_SUPPRESSLOOPDETECTION
This option allows full automatic loop detection in Open Plan to be turned off (by setting a value of 0)
or restricted (by setting a value less than the total number of activities) for large networks or networks
with large numbers of complex relationships. Full loop detection will still be performed during Time
Analysis.
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The default value for _SUPPRESSLOOPDETECTION is 1000. The number is a threshold value that
determines at what point loop detection will be turned off. Thus, for the default value of 1000, loop
detection is enabled as long as the total number of activities does not EXCEED 1000.

_SYNCDIALOGNAVIGATION
This option controls whether the modeless dialogs are synchronized when the user displays another
record by pressing a navigation button on the dialog. The Open Plan setup program automatically
enables this option.
0 = Does not synchronize the dialogs.
1 = Synchronizes the navigation of the dialogs.
The default setting is 1.

_SYNC_TREE_STATUS
This option is used to control how the Open Plan Explorer Tree is synchronized with operations
performed by the user. The default behavior (_SYNC_TREE_STATUS=1) is that the Tree View (left
pane of Explorer) changes focus when projects are opened. This action causes the List View (right
pane of the Explorer) to display the contents of the project folder for any opened project.
If _SYNC_TREE_STATUS is set to 0, the Tree View (left pane) does not change focus to any newly
opened project, leaving the list view (right pane) as previously selected by the user. This can facilitate
navigation when the user has access to many projects.

_TIPSTARTUP
This option controls whether the Tips dialog is displayed on startup.
0 = Does not display tips on startup.
1 = Displays tips on startup.
The default setting is 1.
Because the process of applying this option differs from the way the predefined options are applied,
the process is listed below:
To Set the Tips Dialog, complete the following step:
1. On the File menu, click Preferences » Application.
2. On the Options dialog box, select the Advanced tab.
3. Choose the Defaults button.
4. Scroll to the end of the grid.
5. Enter the value _TIPSTARTUP in the Category column.
6. Enter the desired numeric value in the Default Value column.
7. When finished, click OK to close the System Preferences Defaults dialog box.
8. Click OK to close the Options dialog box.

_TOOLBAR
This option controls the display of the Open Plan toolbar.
0 = Hide Open Plan Toolbar.
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1 = Show Open Plan Toolbar.
The default setting is 1.

_USEDEFAULTPROJECT
This option specifies whether the template project specified in DefaultProjectName should be used
when creating new projects.
0 = Do not use template project to create new projects.
1 = Use template project when creating new projects.
The default setting is 0.

_UseOldRemainingQtyRules
This option prevents changes to Original Duration triggering an update to Remaining Quantity for
Total Resources. Setting _USeOldRemaining QtyRules = 1 makes Open Plan use the original rules.

AllowActiveXInBrowserView
When you view a Web page locally from within Open Plan, this option allows the local page to access
OLE objects and ActiveX controls without issuing a warning.
0 = A warning is issued if the local page contains OLE objects and/or ActiveX controls. You are also
prompted as to whether or not you want to allow the interaction for this Web page.
1 = OLE objects and ActiveX controls are allowed without issuing a warning.
If you link to a page outside the local zone, this setting no longer applies, and your browser’s
default security takes over.

AllowScriptInBrowserView
When you view a Web page locally from within Open Plan, this option allows the local page to run
scripts without issuing a warning.
0 = A warning is issued if the page contains scripts.
It is possible that your browser is already configured to run scripts without first issuing a warning.
If this is the case, setting this option to 0 does not override the browser setting.

1 = No warning is issued if the page contains scripts.
If you link to a page outside the local zone, this setting no longer applies, and your browser’s
default security takes over.

AllowZeroBaselineUsage
This option helps with Cobra integration by allowing Open Plan to save a zero to the Baseline Usage
table for a resource. To enable this option, select AllowZeroBaselineUsage from System
Preferences Defaults table and set the default value to 1.
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BarchartToolTipsField
This option allows you to define text to be displayed as a Tool Tip for the barchart. It requires that you
enter a single field as the Value. However, in addition to allowing you to enter a standard field, Open
Plan also allows you to specify a calculated field that contains exactly the information that you want
displayed.
The default value is Description.
For more information on calculated fields, refer to Chapter 23, “Project Utilities.”

BarPrintMode
This option is used to correct problems on certain devices when drawing barchart views that contain
bars that use hatch patterns.
0 = Use normal bar drawing method. This is the default setting.
1 = Use alternate bar drawing method.

CalCompFix
This option prevents Open Plan from printing segmented bars which are known to cause problems
with certain Calcomp plotter drivers due to a problem with the driver support of the GDI Polygon
function. This eventually results in a general protection fault in Open Plan.
0 = Print segmented bars. This is the default setting.
1 = Do not print segmented bars.

HistogramArrayLimit
This option defines the maximum number of array elements in the histogram. Each array element
represents a time unit as defined by the date scale of the view.
Valid values are 1000 – 15000. The default value is 3000.

LOGLEVEL
This option can be used to capture additional diagnostic information during an Open Plan session.
Valid values are 0 through 4, where 0 means no additional logging and 4 captures the most detail.

RiskPercentileArraySize
This option is used to specify the size of the array used to store percentile values for key activities
during risk analysis.
Valid values are 5 – 1000. The default value is 21.

ShowSQLLog
This option allows you to view the SQL Log in the Open Plan Log Viewer. The log is created when
you start your Open Plan session and is automatically updated whenever the database is accessed.
0 = The log is not displayed in the Open Plan Log Viewer. This is the default setting.
1 = The log is displayed in the Open Plan Log Viewer on the SQL Log tab.
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If you wish to view the SQL Log outside the context of Open Plan, you can use any text editor
(such as Windows Notepad) to open the sql.log file located in the \User directory of your Open
Plan installation.

SuppressCombineVerticals
By default, when performing automatic placements, Open Plan combines vertical relationship lines
when showing relationships using the Routed line style as in the following example:

Activity A has a Finishto-Start relationship with
each of the other
activities.

The SuppressCombineVerticals option instructs Open Plan to display each relationship line
separately:

0 = Open Plan combines vertical relationship lines. This is the default setting.
1 = Open Plan suppresses the combining of vertical relationship lines.
The following options are no longer used by Open Plan:
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Overview

Overview
Open Plan includes a number of special system-level utilities to provide features related to file
management and security. Other utilities allow you to communicate project information using the
Internet or email.
This chapter discusses each of the system utilities provided by Open Plan and concludes with a brief
discussion of working with project data in a multi-user environment.
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Email Advisor
The Email Advisor sends automatically generated email messages from within Open Plan. While the
Email Advisor can contain any information and can be sent to any person within your organization
as well as to anyone with a valid email address, it is typically used to facilitate communication
between planners and others involved in the project.
When a project is open, you can access the Email Advisor by clicking Email Advisor on the Tools
tab. Doing so displays the following Advisory Definitions dialog box:

An advisory definition is the name assigned to a set of values that collect project information that
can then be sent to recipients in an email.

The Advisory Definitions dialog box displays a list of previously defined advisory definitions that you
can test and send.
You can also use this dialog box to perform the following two functions:


Delete a previously created advisory definition.



Display the Edit Advisor Emails dialog box that you can use to create or edit an advisory
definition.
You can display the Edit Advisor Emails dialog box from the Advisory Definitions dialog box in
any of the following ways:



By clicking New. This displays a blank Edit Advisor Emails dialog box that you can use to create
a new advisory definition.



By selecting an advisory definition and clicking Copy. This displays the selected advisory
definition in the Edit Advisor Emails dialog box. The name of the selected advisory definition is
preceded by the word “Copy_” in the Name field. You can then either accept this default name
for the definition or change it before you save it.
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By selecting an advisory definition and clicking Edit. This displays the selected advisory definition
in the Edit Advisor Emails dialog box and allows you to make changes to the advisory definition.

You can use this dialog box to create or edit an advisory definition using the following fields:


Name — Enter any descriptive name for your advisory definition. When saved, the name is listed
in the Advisory Definitions dialog box.



Subject — Enter the subject of the message. In addition to being able to enter text, you can
include any field or calculated field from the activity table. You can also enter a title block variable
in this field.
For example you might enter <Project Short Name> to display the short name of the project in
the subject of the email.
Fields, calculated fields, and title block variables must all be enclosed within angle
brackets (<>).



Header — Enter a header for the message. You may enter constants, standard field names,
symbolic field names, or leave the header empty. The header is displayed only once in an email.



Message — You can select any field from the list. When the email advisory is generated, Open
Plan will address the advisory to any valid entries in the field that you select.
For example, assume that you have assigned CLEANOBS in the C1 field for your project and that
you have entered the following email addresses in a user character field (e.g., C1.USER_CHR01)
for the E&D code in CLEANOBS:
johndoe@company.com;marydoe@company.com
Open Plan would generate an email advisory to both johndoe and marydoe for all the activities
that have a code of E&D (and that have not been excluded by a filter).
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Create a code file to hold addresses and assign this file to a project. Note: Code fields
are not selectable from the address field.

You can also specify an addressee by selecting the following fields:


<Project Manager Email> — Selecting this field sends the email advisory to the address
specified in the Project Manager Email Address field on the Summary tab of the Project
Properties dialog box for the project.



<Resource Managers Email> — Selecting this field sends the email advisory to all resource
managers identified in the resource file associated with the project



<Subproject Manager Email> — If the project contains external subprojects, selecting this field
sends the email advisory to the Project Manager Email Address defined in the specific external
subproject containing the triggering event.
If you select <Subproject Manager Email> for a project containing no subprojects, Open Plan
sends the advisory to the address specified by the <Project Manager Email> field.
The syntax for field names and symbolic field names has been extended. Now the user may
optionally specify a column width in characters for a particular field that he has included in the
message box. The new syntax is the following:
<field or symbolic field name [, OPTIONAL]column width (1..256)>
Note that column alignment is assured only if all columns in the message specify a column width,
AND the font used in the email message is a standard monospaced font (i.e., characters are all of
equal width). A standard text message in Outlook falls into this category. Also, if any column in
the message box specifies the optional width parameter, the divider that normally appears
between different activity items (“++++++++++++++++++”) will be suppressed.



Footer — Enter a footer for the message. You may enter constants, standard field names,
symbolic field names, or leave the footer empty. The footer is displayed only once in an email.



Address format — Describes the format of the Address field, and allows you to select from the
following two options:


Embedded in the field — If you use this option, the address referenced in the Address field
must be contained within square brackets as in the following format:
[mailto:jdoe@company.com]. Multiple addresses may be used, but each address must be
contained within its own set of square brackets as in the following example:
[mailto:jdoe@company.com][mailto:mdoe@company.com]
Use addresses embedded in the field when combining address and non-address text in
the same field.



Listed in the field — If you use this option, the addresses referenced in the Address field must
be separated by semicolons (;) such as ;jdoe@company.com;mdoe@company.com
When using lists, do not include any non-address text in the field.



Send one email per address combining all activities — Select this option to send a single
email that includes all of the activities referenced in the email to each addressee. A separator
divides each message included in this email.
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For activities matching filter — Select a filter from the drop-down list to specify the activities
that can generate an email advisory. An ellipsis has been added to the right of the Filter dropdown list. As in other dialogs, it allows the user to invoke the Filter Expression Dialog.
Clicking the buttons located along the right-hand side of the Edit Advisor Emails dialog box has
the following actions:


Save — Saves the advisory definition, lists its name on the Advisory Definitions dialog box,
and closes the dialog box



Cancel — Cancels any changes you may have made to the advisory definition and closes
the dialog box



Send — Generates the email advisory and sends it to the addresses specified in the
definition using your default email application
Open Plan allows a maximum of 50 addresses for each email generated by the Send
command.



Test — Displays the Test Advisory Definition dialog box for verification of the subject,
message, and results before you send the emails



Fields — Displays the Fields dialog box that you can use to select data fields that you can
embed in both the subject and the text of the Advisor Email. Using the Fields dialog box,
you can, for example, embed the product manager’s name and email address in the text of
the advisory email.



abc — Runs the spell-checking feature and checks the subject and message fields of the
advisory definition.
For more information on the spell-checking feature in Open Plan, refer to the “Spell
Checker” section later in this chapter.



Access Control — Select this option to grant rights to other users in the data source to use
the advisory definition.



Help — Displays additional information about this dialog box.

To set up an email advisory address list, complete the following steps:
1. Open the project for which you want to set up an email advisory address list.
2. Display the appropriate view to display the field you want to use for the address. For
example, if you want to use the Code Description field of a particular code, open the code
file that contains that code.
For a list of fields you can use to contain addresses, display the list in the Address field
of the Edit Advisor Emails dialog box.

3. Open the element that will contain the address list, and assign addresses to the field of your
choice using any of the following methods:


Embedded addresses enclosed in brackets: [mailto:marydoe@company.com]



Multiple addresses entered as a list and separated by semicolons:
[johndoe@company.com;marydoe@company.com



Email addresses and nicknames referenced from your email address book
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The following display shows email addresses added to the description field of a code file:

To use Email Advisor in a project, complete the following step:
1. Open the project to which you want to create an email advisory.
2. Configure the Email Advisory address list.
3. On the Tools tab, click Email Advisor.
4. From the Advisory Definition dialog box, take one of the following actions:


Click New to create a new advisory definition.



Select an advisory definition, and click Edit.

5. In the Edit Advisor Emails dialog box, enter the definition for the advisory.
6. Optional. To review the advisory that will be sent, click Test.
7. If you run the test, click OK to return to the Edit Advisor Emails dialog box.
8. Click Save.
Open Plan saves the advisory definition and returns you to the Advisory Definitions dialog
box.
9. Select the advisory definition, and click Send.
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To help you handle project-related data files, Open Plan provides five functions related to file
management:


Deleting data files



Backing up projects and associated data files



Restoring projects and associated data files



Checking files in and out (Briefcasing)



Changing a file’s access mode

All of these functions are available from the Manage Files submenu of the File menu.

Deleting a File
With the Delete File command, you can delete any project or project-related data file from the data
source. On the File menu, point to Manage Files, and click Delete File on the submenu to display the
following dialog box:

This dialog box displays a list of files based on the type of file you select in the File Type field. Also,
depending on the file type, Open Plan performs one of the following actions when you delete a file:


If the file is a project, all the project data is deleted from the data source. The links created in the
Project folder to any ancillary files are removed, but the ancillary file data itself is not deleted. Any
links to the project in your My Folder are also removed.



If the file is a calendar file, resource file, code file, or view template, the actual data is deleted
from the data source.
A file cannot be deleted if it is referred to by another file. For example, you cannot delete a
resource file if a project still uses it.

To delete a data file, complete the following steps:
1. On the File menu, point to Manage Files.
2. On the Manage Files submenu, click Delete.
3. Select the file you want to delete, and click OK.
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4. When Open Plan asks you to confirm the deletion, click Yes.

Backing Up a File
The Backup File command allows you to create a backup copy of a project and any of the following
associated with that project:


Calendars



Codes



Resources



System Library



Views

If the project includes references to external subprojects that are open, these subprojects are
included with the master project as well.
By default, all the information about a project and its ancillary data files is stored by Open Plan in a
single file with the extension .bk3. You can also use the Backup Data command to back up calendar,
code, project, resource, system library, and view files outside of the context of a project.
In order to back up a project, you must have write access to it.

On the File menu, point to Manage Files, and click Backup Data to display the Backup dialog box:

Select the file(s) to backup.

The Backup dialog box displays a hierarchical list of all the files in the data source. You can use this
dialog box to select the file(s) to back up. After selecting the file(s) for backup and clicking OK, Open
Plan displays a Save As dialog box where you can enter a name and location for the backup file set.
The buttons along the right hand side of the dialog box have the following functions:


OK — Creates the backup.



Cancel — Closes the dialog box without creating the backup.



Select All — Selects all the files in the list.
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Clear All — Clears the check mark from all selected files.



Expand All — Expands all the levels of the hierarchical list for view.



Help — Displays the help system.

To back up a file, complete the following steps:
1. On the File menu, point to Manage Files.
2. On the Manage Files submenu, click Backup Data.
3. Select the file(s) you want to back up, and click OK.
4. In the Save As dialog box, enter a name and location for the backup to be stored.
5. Click Save.

Restoring Data
You can use the Restore Data command to restore the information stored in a backup file set. When
you restore a file, Open Plan allows you to provide a new name for the file. This feature is handy in
cases where you do not want to overwrite existing versions of the files.
After selecting the backup file set to restore, Open Plan displays the first page of the Restore wizard:

The top list box displays the names of the files in the backup file set. While you can select the items
that you want to restore individually, the settings in the Include section of this dialog box can be used
to simplify this task.
The following options control the categories of items in the hierarchy that Open Plan should select for
the restore operation:


Views —This option instructs Open Plan to select all the views associated with any item that will
be restored.



Ancillary data —This option instructs Open Plan to select the Calendar, Resource, and Code
items associated with the items to be restored.



External Subprojects — This option instructs Open Plan to select all external subprojects
associated with the project that will be restored.
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System Library Data — This option instructs Open Plan to select the system library data (such
as global edits, filters, sorts, calculated fields, and email advisory definitions) associated with the
project to be restored. By default, this option is not selected. Open Plan handles the restoring of
system library data as follows:


If the system library data does not exist in the target data source (for example, it has been
deleted), the data will automatically be restored.



If the data already exists in the target data source, it will be listed on the Details page of the
Restore Wizard. This gives you the option to overwrite the existing data on a one-to-one
basis. For example, if you have modified filters in the target data source, you may not want to
overwrite them during the restore process.

You can clear any specific items that you do not want to restore.
If you are trying to restore a file to which you do not have access control rights, that file
will appear in the Files that cannot be restored due to your Access Rights section
of the dialog box.

If you click Next, Open Plan displays the Details page of the wizard:

This page of the wizard provides more detailed information about the individual items that can be
restored. (Files that cannot be restored due to your access rights do not appear on this page.)
You can select or clear as many items as you want from this list.
If you know that you have not made any changes to some of these items, you can save time by
not restoring them.

When you click Finish on this page or the previous one, Open Plan checks for any differences
between the backup set and the files that will be modified by the restore operation:


If no differences are found, Open Plan restores the data.



If any differences are found, Open Plan displays additional dialog boxes where you can
instruct Open Plan how to proceed.
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Open Plan displays the Restore Target Exists dialog box when differences are found between the
backup set and the files in the data source:

Differences between the backup set and files in the data source are expected to occur. This
dialog then gives you overwrite options you can use to rectify the problem.

You can use this dialog box to instruct Open Plan to do the following:


Skip restore of item — Clicking this option and then clicking Yes instructs Open Plan to not
restore the identified item. Open Plan redisplays the Restore Target Exists dialog box for the next
item that will be modified by the restore operation.
If this is a dependent file, Open Plan will retain the link to the existing file of the same name.
Clicking Yes to All instructs Open Plan to not restore any of the remaining files in the backup set
and closes the Restore Target Exists dialog box.



Overwrite existing item — Clicking this option and then clicking Yes instructs Open Plan to
overwrite the existing item with information from the backup file.
Clicking Yes to All instructs Open Plan to overwrite all remaining affected files with information
from the backup file.



Rename and restore — When you click this option and click Yes, Open Plan enables a text box
that you can use to provide a new name for the restored file.
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Also, if you choose not to include Ancillary Data and External Subprojects when you restore a
project and then click Finish, Open Plan checks to see if these files already exist in the target
data source. If the files do exist, then the restore process proceeds normally. But, if the ancillary
files and external subprojects do not exist, Open Plan displays the following dialog box:

In order for the restore process to proceed, the files in the list on the Restore Required dialog box
must be restored. Clicking Restore instructs Open Plan to automatically restore the files in the list
and then proceed with the rest of the restoration process.
If the backup file being restored contains data fields that do not exist in the target data source, Open
Plan displays the following dialog box that allows you to create the missing fields in the target data
source:

This dialog box features the following controls:


Do Not Restore – Skip Item — Clicking this button instructs Open Plan to interrupt the
restoration process and display the Restore Process dialog box that you can use to take one of
the following further actions:


Cancel Restore Process



Re-select Restore Files



Add Missing Data to Target Data Source — Clicking this button instructs Open Plan to add the
missing data fields to the file that will be modified by the restore operation.



Ignore Missing Data – Continue to Restore — Clicking this button instructs Open Plan to
ignore the data that is missing and to continue with the restore operation.
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The grid on this dialog box displays the following information for each data field that will be created if
you choose to add the missing data to the target data source:


Collection — Displays the name of the table for the missing data field



Name — Displays the name of the data field that will be created



Type — Displays the type of data field that will be created



Precision — Displays the maximum character width of the data field that will be created



Scale — Displays the number of decimal places to use if the missing data field to be created is a
numeric field

If Open Plan determines that there are fields present in the backup that it cannot restore into the
target data source, it will display the Structure Differences dialog box. Normally, if a user has added
non-standard fields to Open Plan, their values are backed up during the backup process. Under most
circumstances, these will usually be user-defined fields. It is possible, however, for a user to modify
the structure of our tables and put non-standard fields in a table that does not support user-defined
fields. In this event, Open Plan will not be able to add the missing fields as user-defined fields and
displays the new dialog. This dialog will appear in very rare circumstances.

To restore a file, complete the following steps:
1. On the File menu, point to Manage Files.
2. On the Manage Files submenu, click Restore Data.
3. From the Open dialog box, select the backup file to restore, and click Open.
4. Select the files from the backup set to restore using the Restore wizard, and click Finish.

Briefcasing a File
The Briefcasing feature of Open Plan allows you to check out a project, work on it, and then check it
back in. Checking out a project is similar to opening a project in Exclusive mode in that while you
have the project checked out, you are the only person who can save changes to it. There is, however,
a difference:


A project that is open in Exclusive mode is automatically closed when you exit Open Plan. At
that time, other users with the appropriate rights can open the project in Exclusive or Shared
mode, make changes, and save their changes.
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A project you check out cannot be modified by other users until you check it back in. Therefore,
checking out a project is especially useful when you need to maintain exclusive rights to the
project over a longer period of time.

In order to check out a project, you must be able to open it in Exclusive mode. This means that in
addition to having the appropriate rights to the project, no other user can have it open in either
Exclusive or Shared mode at the time you want to check it out.

Checking Out a File
On the File menu, when you point to Manage Files and click Check Out, Open Plan displays the
following dialog box:

Open Plan allows you to check out a project in two ways:


In the Main Data Source — When a project is checked out in the main data source, it is locked
so that it cannot be modified by other users. When you later check in the project, Open Plan
removes the lock.



To the Briefcase Data Source — When a project is checked out to the briefcase data source,
Open Plan copies the project and all its ancillary files to your Briefcase data source, which must
be running at that time. You also have the option of copying the views used by the project.
Checking out a project in this manner allows you to work on your project on another computer.
Your briefcase data source must be called BRIEFCASING.

When you check out a project to the Briefcase data source, the copy of the project that remains in the
Main data source is locked so that it cannot be modified by other users. When you later check in the
project, Open Plan copies the project back to the Main data source and removes the lock. Open Plan
also deletes the copy in the Briefcase data source.
When ancillary files and views are copied to the Briefcase data source with the project, they are not
locked in the Main data source since other users may need access to them. Therefore, the ancillary
files and views can be opened only in Read Only mode in the Briefcase data source.
You cannot modify or delete any external subprojects, foreign subprojects, or foreign activities a
briefcased project may contain, nor can you create these items in the Briefcase data source.

If the project was previously checked out to your Briefcase data source, checking it out again
overwrites the data in the Briefcase data source. (You can prevent this from occurring by clicking No
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or No to All to the alert that asks whether you want to overwrite the data. This cancels the check out
procedure for the duplicated data.)
To check out a project, complete the following steps:
If the project you want to check out has been opened in Exclusive or Shared mode by another
user, you will not be able to check out the project.

1. On the File menu, point to Manage Files, and click Check Out on the submenu.
2. On the Check Out dialog box, select the project you want to check out from the list.
3. Click one of the following options:


Check Out in Main Data Source



Check Out to Briefcase Data Source

4. If you are checking out to your Briefcase Data Source and want to include the project views,
select Check Out Views with Project.
5. Click Check Out.

Checking In a File
On the File menu, when you point to Manage Files and click Check In, Open Plan displays the
following dialog box:

The Check In dialog box has the following options:


Include Projects in Briefcase Data Source — Selecting this options will display projects
checked out in the Main data source and projects checked out in the Briefcase data source as
well as projects created in the Briefcase data source



Details — Clicking this button displays the Checked Out Projects dialog box that provides the
following information about the projects that are currently checked out:


Project



User ID



Machine ID



Checkout Date



Data Source
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Undo Check Out — If the project was checked out in the Briefcase data source, this option
removes the lock from the project in the main data source. Any changes made to the project while
briefcased are not copied to the main data source. This option is not available for projects
briefcased to the main data source

To check in a project, complete the following steps:
1. On File menu, point to Manage Files, and click Check In on the submenu.
2. From the list on the Check In dialog box, select the project to check in.
If the project was checked out to the Briefcase Data Source, select Include Projects in
Briefcase Data Source to display the project in the list.
3. Click Check In.

Changing the Access Mode
The Change Mode command allows you to change the access mode in which you have a file open.
On the File menu, point to Manage Files, and click Mode on the submenu to display the following
dialog box:

The list box at the top of the dialog box allows you to select the type of file to be displayed in the text
box:


Project



Calendar



Resource



Code

When you select a file from the list, Open Plan displays the following information in a grid located at
the bottom of the dialog box:


User ID — This column displays the ID of all the users who currently have the file open.



Machine ID — This column displays the ID of all the computers on which the file is currently
open.



Open Mode — This column displays the access mode in which each file is open.



Opened On — This column displays the date on which each file was opened.
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The Access Mode list displays the modes to which you can change the file. If the file is currently
open by another user, the mode in which that user has the file open may impact the changes that you
can make. For example, both you and another user have a file open in shared mode, you can only
change the mode to Read-Only. The Exclusive mode is disabled.
Once you have selected a new access mode for the file, you must click Change in order to put the
new access mode into effect.
To change the access mode of an open file, complete the following steps:
1. On the File menu, point to Manage Files, and click Mode on the submenu.
2. From the Change Access Mode dialog box, select the file for which to change the access
mode.
3. From the Access Mode list, select the new mode for the file.
4. Click Change.

Change Ownership and Access Rights
The Change Ownership and Access Rights dialog box allows you to change the ownership and/or
access control information for one or more project, resource, code, calendar, or view objects. This
option is available only to the object's owner or users with System Administrator rights.
This feature is accessed by pointing to Manage Files on the File menu and then clicking Owner and
Access Rights:

Using the appropriate option, you can filter the display of objects in the dialog box by owner and
object type. You can also sort the displayed objects by column in either ascending or descending
alphabetical order by clicking the column heading.
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Change Owner
Clicking the Change Owner button on the Change Ownership and Access Rights screen displays the
Change Owner dialog box:
Click here to display a list of available
owners.

To change the owner of an object
1. On the File menu, point to Manage Files, and click Owner and Access Rights.
Open Plan displays the Change Owner and Access Rights dialog box,
2. Select the object or objects for which you want to change the owner.
To select more than one object, use Ctrl+click or Shift+click. To select all the objects
displayed, click Select All. Reverse the process to clear selected items, or click Clear
All.

3. Click Change Owner.
4. From the New Owner list on the Change Owner dialog box, select a new owner.
5. Click OK to save the change.
6. Click Close twice.

Change Access Rights
Selecting one or more objects and then clicking the Change Access Rights button displays the
following dialog box that you can use to change the access control information for the object(s):

To change the access rights of an object, complete the following steps:
1. On the File menu, point to Manage Files, and click Owner and Access Rights.
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Open Plan displays the Change Owner and Access Rights dialog box,
2. Select the object or objects for which you want to change the access rights.
To select more than one object, use Ctrl+click or Shift+click. To select all the objects
displayed, click Select All. Reverse the process to clear selected items, or click Clear
All.

3. Click Change Access Rights.
4. In the grid on the Change Access Rights dialog box, add or delete groups and users.
5. Select one of the following options:


Add to Access Lists



Replace Access Lists

6. Click Update Access Controls.
7. Click Close twice.
When changing access control information, individual access control entries can be added and
deleted or all existing access control entries can be replaced with a new set of access control entries.
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Group Delete
The Group Delete command allows you to delete a group of data records in an open project that
share a common characteristic.
Clicking Group Delete on the Tools tab displays the Group Deletion dialog box.

This dialog box contains the following fields that allow you to apply a filter to a table in the open
project and then delete the data records that are identified by the filter criteria.
The dialog box contains the following two fields:


Applies to Table — Contains a list of all the tables in the open project.



Matching Filter — Contains a list of all the filters defined for the open project.

Clicking the ellipsis button to the right of the Matching Filter field displays the Filters dialog box that
you can use to create a new filter.
To delete a group of data records in an open project, complete the following steps:
1. Open a project in Shared or Exclusive mode.
2. From the Tools tab, click Group Delete.
3. Select the table from which to delete the data records.
4. Select the filter to use, or click the ellipsis (…) button to create a new filter using the Filters
dialog box.
5. Click OK. Open Plan informs you how many records match the filter criteria and asks you to
confirm the deletion.
6. Click Yes.
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Open Plan Log Viewer
The Open Plan Log Viewer is a stand-alone application that can be accessed in two ways:


Within the context of Open Plan — Allows you to display the log files that have been created
during the current session of Open Plan as well as previously saved log files.



Outside the context of Open Plan — Allows you to display only saved log files.
While you can navigate to the User folder and open any of the log files using a text editor such
as Windows Notepad, the Log Viewer provides a more convenient way to review this
information.

To open the Open Plan Log Viewer from within Open Plan, click Log Viewer on the Tools tab:
Name of the log file

Vertical & horizontal
navigation

Open Plan creates a log file each time you run a procedure such as Time Analysis or Resource
Scheduling. These log files provide information about the functions that have been performed.
If more logs are created than can be displayed at once in the Open Plan Log Viewer, Open Plan
provides two navigation arrows you can use to scroll horizontally through the tabs.

Open Plan Log Viewer File Menu
From the File menu, you can:


Save a log file



Open a previously saved log file



Close a log file



Print a log file

When run from within Open Plan, the Open Plan Log Viewer features the following tabs:
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System Log — Unless you have performed a process such as Time Analysis or Resource
Scheduling, the System Log is the only tab that is displayed. This tab allows you to view the
opwin.log that provides information such as the time the Open Plan executable file was opened
and the location of the opwin.log.
All the log files are stored in the same directory.



Time Analysis — This tab is displayed when you run time analysis on a project. It allows you to
view the opp_ta.log that provides information that was generated during the procedure. If you
run time analysis on more than one project during your Open Plan session, the Time Analysis tab
displays information about the last project on which you ran the procedure.



Resource Scheduling — This tab is displayed when you run resource scheduling on a project. It
allows you to view the opp_rs.log that provides information that was generated during the
procedure. If you run resource scheduling on more than one project during your Open Plan
session, the Resource Scheduling tab displays information about the last project on which you
ran the procedure.



Risk Analysis — This tab is displayed when you run risk analysis on a project. It allows you to
view the opp_risk.log that provides information that was generated during the procedure. If you
run risk analysis on more than one project during your Open Plan session, the Risk Analysis tab
displays information about the last project on which you ran the procedure.



Cost Calculations — This tab is displayed when you run cost calculations on a project. It allows
you to view the opp_cost.log that provides information that was generated during the procedure.
If you run cost calculations on more than one project during your Open Plan session, the Cost
Calculations tab displays information about the last project on which you ran the procedure.



Progress Calculations — This tab is displayed when you run progress calculations on a project.
It allows you to view the opp_prog.log that provides information that was generated during the
procedure. If you run progress calculations on more than one project during your Open Plan
session, the Progress Calculations tab displays information about the last project on which you
ran the procedure.



Backup/Restore — This tab is displayed when you backup or restore Open Plan files. It allows
you to view the opp_bkp.log that provides information that was generated during the backup or
restore procedure. If you perform more than one backup or restore during your Open Plan
session, the Backup/Restore tab displays information about the last operation.



Import/Export — This tab is displayed when you transfer data between Open Plan and another
application. It allows you to view the opp_xfer.log that provides information that was generated
during the transfer operation. If you perform more than one import or export procedure during
your Open Plan session, the Import/Export tab displays information about the last transfer
operation.

With the exception of the System Log, each of these tabs is displayed only when you perform the
relevant operation. If more logs are created than the Log Viewer can display at one time, Open Plan
provides navigation arrows that you can use to scroll through the tabs, or you can maximize the
window to view all the tabs at once.
If you have the Open Plan Log Viewer running when you run an Open Plan procedure that creates a
log, the log viewer, by default, will automatically refresh its display at a user-defined time interval. You
can manually refresh the display by clicking Refresh on the View menu or by pressing F5.
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If you run the Open Plan Log Viewer outside the context of Open Plan, refreshing the display
will have no effect.

When you open a previously saved log file, the tab created for the opened log file displays the log
file’s name.
While you cannot edit the information in any of the log files using the Open Plan Log Viewer, you
can copy text from a log and paste it into another Windows application.

Find In Log Dialog Box
Clicking the View menu and selecting Find displays the Find in Log dialog box:

You can use this dialog box to find a specific text string in the log displayed in the viewer. You can
press F3 or click the Find button to find the next occurrence of the specified text string in the log.
The Find in Log dialog box is not case sensitive.

Log Viewer Options
Clicking Options on the View menu displays the Options dialog box.

The Options dialog box allows you to set the following options for the Open Plan Log Viewer:


Enable automatic refresh — While in Open Plan, if you have the Open Plan Log Viewer
running when you execute one of the Open Plan processes which creates a log, the log viewer
becomes out of sync with the new log information. For example, assume you just performed Time
Analysis and have viewed the log file. Also assume that while the Open Plan Log Viewer is still
running, you perform Time Analysis again. The new time analysis log generated by the process
does not overwrite the currently displayed (old) time analysis log. To view the new log, you have
to refresh the Open Plan Log Viewer display.
The Enable automatic refresh option will refresh the display automatically according to a userdefined time interval. This option is selected by default. If you deselect this option, you can still
manually refresh the display using one of the following methods:


From the View menu, click Refresh.
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Press F5.



Close the Log Viewer, and reopen it.
If you are running the Open Plan Log Viewer outside the context of Open Plan,
refreshing the display will not have any effect.



Enable autoscroll — If you have a log file that is longer than the display screen, this option will
automatically scroll to the end of the log file when you first view it.



Refresh files every X seconds — If you are using the Enable automatic refresh option, you
can set the time interval in seconds that the Open Plan Log Viewer uses when automatically
refreshing the display. For example, if you wanted the display to refresh every 2 minutes, you
would enter 120 seconds. By default, this option is set to 10 seconds.



Default log file path — The log file path you enter in this field is the starting location the Open
Plan Log Viewer uses when you execute the Open command.
While you can change the path in this field as many times as you want, clearing this
field does not automatically revert the path back to the default path. The last path name
entered is remembered regardless if you clear it from this field.

You can either type the full path name directly in this field, or you can click the ellipsis button to
display a dialog box that you can use to select the desired location.
Closing Open Plan removes all the tabs from the Open Plan Log Viewer.
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Managing the Data Source
Open Plan allows you to manage your data source using the Data Sources dialog box. Clicking Data
Sources from the File Menu » Preferences displays the following:

This dialog box features the following:


Data Sources — Displays a list of data sources to which you can connect.



Add — Clicking this button displays the Windows Data Link Properties dialog box that you can
use to configure a data source and add it to the list displayed in the Data Sources dialog box.



Edit — Selecting a data source from the list and clicking this button displays the Edit Data Source
dialog box that you can use to modify settings for the selected data source.



Delete — Selecting a data source from the list and clicking this button deletes the data source.

You can easily change to a different data source by selecting it from the list.
To change to a new data source, complete the following steps:
1. From the File menu, click Preferences » Data Sources.
Open Plan displays a list of available data sources.
2. Select the data source to which you want to connect, and click OK.
Open Plan informs you to restart the program to use the new data source.
You will have to complete the normal log-on sequence upon restarting Open Plan to
successfully complete the connection.
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Editing a Data Source
When you select a data source from the Data Sources dialog box and click Edit, Open Plan displays
the following dialog box:

The Edit Data Source dialog box has the following controls:


Name — The name of the currently selected data source is displayed in this field. You cannot edit
this field.



Database Name (Schema) — Use of this field is optional. If you wish, you can enter the schema
name of the selected database in this field.
If you do not enter a schema name in this field, the Datasources.dat file must identify
an Initial Catalog for the database.



Database is Unicode — This option is selected by default. MS Access databases are always in
Unicode. Additionally, this option is used for double-byte languages such as Chinese, Russian,
and Hebrew.



Data Link Properties — Clicking this button displays the Windows Data Link Properties dialog
box that you can use to specify how to link to the server where the database is stored.

If you are currently connected to the data source you are modifying, your changes will not take effect
until the next time you start Open Plan.
To edit a data source, complete the following steps:
1. From the File menu, click Preferences » Data Sources.
2. On the Data Sources dialog box, select the data source that you want to edit.
3. Click Edit.
4. In the Edit Data Source dialog box, make any needed modifications.
5. Click Data Link Properties.
6. In the Windows Data Link Properties dialog box, enter the appropriate settings for the data
source.
7. Click OK to return to the Edit Data Source dialog box.
8. Click OK again to return to the Data Sources dialog box.
For more information on editing the Data Source, see the Deltek EPM Security Administrator
Help System.
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You can perform the following security-related operations from within Open Plan:


Define access rights for project data



Change your user password

These operations are described in the following sections.

Defining Access Rights
You can define the access rights to any project, resource file, calendar file, code file, view template,
and baseline file for which you are the “owner.” By default, the owner of a file is the user who creates
the file. By creating the file, the owner is automatically given full read/write access rights to the data
and can grant rights to other users.
Both the current owner and any user in the SYSADMIN group can transfer ownership of the file
to another user.

Security access rights are granted the same way for all files except a baseline. The following example
shows the Access Control tab (in this case for a project) that you can use to grant access rights to
other users:

For information on defining access rights to a baseline, refer to Chapter 16, “Status Information.”

As the owner, you can use the following fields to grant access rights to other users:


Owner — If you are the owner or have SYSADMIN privileges, you can select a new owner for the
file from this list.



Group — This field allows you to grant access rights to an entire user group. User groups are
created within Security Administrator.



Role — You can use this field to assign a role to either a group or individual user. By assigning a
role, you can control how the group or user manipulates your file. Roles are created within
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Security Administrator, and groups are assigned default roles. With this setting, you can override
the default role of a group.


User ID — This field allows you to grant access rights to individual users. User IDs are created
within Security Administrator.



Read Only — Selecting Yes for this field limits the group or individual to read-only status for the
file regardless of the role assigned.

If you provide access rights to a group for a project, members of that group automatically inherit read
rights to all resource files, calendar files, code files, and external subprojects assigned to that project.
Note, however, it is possible that after you change the ownership of a project to another user, you
may not have rights to save the project. If this occurs, simply close the project without saving.
Provided that you are the owner or have SYSADMIN rights, you do not have to open a project or
file in order to grant access rights to it on this tab.

To define access rights to a project, complete the following steps:
You must be the owner of the project or have SYSADMIN rights in order to define access rights
to it.

1. Select the project for which you want to define access rights.
2. Take one of the following actions:


On the Processes tab, click Properties.



Right-click the project folder, and click Properties on the context menu.

3. Click the Access Control tab.
4. Assign access rights to the project.
5. When finished, click OK.
To define access rights to a resource file, calendar file, code file, or view template, complete
the following steps:
You must be the owner of the file or view template in order to define access rights to it.

1. In the Open Plan Explorer, right-click the appropriate file or view template, and click
Properties on the context menu.
2. Click the Access Control tab.
3. Assign access rights to the file.
4. When finished, click OK.
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Changing Your User Password
To change your user password (that is, the password you enter when you start Open Plan), use the
Change Password command to display the following dialog box:

To change your user password, complete the following steps:
1. On the File menu, click Change Password.
2. In the Old Password field, enter your old password.
3. In the New Password field, enter your new password.
4. In the Re-enter New Password field, re-enter your new password for verification.
5. Click OK.

Security Administrator
The Deltek family of products provides a comprehensive set of security-related features that allow a
system administrator to control access to both an application and its data. These features are accessed
through the Security Administrator, a common security utility designed to work with Deltek’s software
applications. Security features that might affect an Open Plan user are described in this section.

Login Lockout
Using the Security Administrator, a user with system administrator access can prevent users from
logging into Open Plan. When users try to log into Open Plan, they receive a message stating that the
system administrator has disabled logins to the data source. Clearing the message returns the users
to the Open Plan Login dialog box, where they can cancel the login attempt completely or use
Ctrl+Login to select another data source.
This function would be useful, for example, if maintenance needed to be performed on the database.
If even one user was logged in, the maintenance could not be performed.

Login Message
Using the Security Administrator, a user with system administrator access can specify a message
that is displayed to all users when they log into Open Plan. This function would be useful, for
example, to warn users of scheduled downtime for upcoming database maintenance.

Session Termination Function
Using the Security Administrator, a user with system administrator access can remotely terminate
the Open Plan session for any user logged into the program. When a user’s session is terminated,
the user receives a warning that Open Plan has been terminated by the system administrator and will
automatically close in 10 seconds.
Please note that any unsaved changes to Open Plan are lost when the program is remotely
terminated by the system administrator. Once the termination message is displayed, users cannot
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perform any actions in Open Plan. Hopefully, the system administrator sent a message to the users
informing them to save their information before issuing the session termination.

User Notification Function in Security Administrator
Using the Security Administrator, a user with system administrator access can send a message to
any user logged into Open Plan. Messages can be sent to individual users or several users at once.
This function is similar to the Send Message command on the Open Plan File menu.
This function would be useful, for example, if the system administrator needed to inform all users to
log out so that database maintenance could be performed.
For more information on the Security Administrator, see the Security Administrator Guide.
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User Notification in Open Plan
An Open Plan user can send a message to another user who is logged in to Open Plan. To send a
message, click Share » Send Message from the File menu to display the Send Message dialog box:

When the message is sent, a message box pops up on the recipient’s screen. The message box
displays your user name and date/time the message was sent along with the message.
To send a message to a user, complete the following steps:
1. From the File menu, click Share » Send Message.
2. From the Users pane on the Send Message dialog box, select the recipient(s) of your
message. Select All Users to send a message to all logged in users.
3. Type your message in the Message pane (maximum 250 characters).
4. Click Send.
You cannot send a blank message or a message without a recipient.
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Sending Project Information Via Email
If your installation of Windows specifies a MAPI-compliant application (such as Microsoft Outlook) as
your default email system, you can use the Open Plan email feature to send project, resource, or
code information using electronic mail.
When you click Send on the File menu, Open Plan creates a backup file of the current data, invokes
your email application, and creates a blank email message with the backup file as an attachment. If
you have a view open at the time you click the Send command, Open Plan attaches the view as well.
To email a project, complete the following steps:
1. Open the project, resource file, or code file that you want to attach to an email.
2. On the File menu, click Share » Send Project.
This command is not available if you do not have a MAPI-compliant email application
designated as your default email system.

3. On the Backup Items To Send dialog box, verify the file you are sending, and click OK.
You can change which files are sent by selecting or clearing the appropriate files.
For information on backing up a file, refer to “Backing Up a File” earlier in this chapter.

4. On the Save As dialog box, enter a name and location for the backup, and click Save.
Choosing the default name and location Open Plan uses will save the file in the
Windows\Temp folder.

Open Plan invokes your email application, creates a blank message, and attaches the
appropriate files.
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Shortcut Properties
You can change the properties of a shortcut by displaying its Properties dialog box. There are two
different dialog boxes that are displayed depending on the type of shortcut it is.
If the shortcut is to a Windows application or file, a dialog box similar to the following is displayed:

This dialog box has the following controls:


Target — Specifies the name of the item to which this shortcut points



Arguments — Specifies optional parameters that are passed on to the target



Start in — Specifies the folder that contains the original item or some related files



Run — Specifies how you want the window to display this item when you open the shortcut:


In a standard window (Normal)



In a full screen (Maximized)



As a button on the taskbar (Minimized)
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If the shortcut is to a URL, the following dialog box is displayed:

You can use this dialog box to change the target URL for the shortcut.
To edit the shortcut properties, complete the following steps:
1. In the Open Plan Explorer, locate the shortcut.
2. Right-click the shortcut, and click Properties on the context menu.
3. On the Properties dialog box, make the desired changes.
4. Click OK.
To change the name of a shortcut, complete the following steps:
1. In the Open Plan Explorer, locate the shortcut.
2. Right-click the shortcut, and click Rename on the context menu.
3. Type a new name for the shortcut.
4. Press Enter.
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Spell Checker
The full-featured spell checker allows you to specify the dictionaries that you want to use. You can
use up to 32 dictionaries. If you have defined special terms in a dictionary, you can simply assign that
dictionary to the Open Plan spell checker. Open Plan also allows you to assign many different
language dictionaries so that you can check the spelling of words in other languages.
In addition to using the dictionary files shipped with Open Plan, you can create your own custom
project dictionary. This dictionary can be any of the following types.


.tlx – The default dictionary type for the Open Plan spell checking feature



.dic – The default dictionary type of Microsoft Word and other word processing programs



.txt – The default dictionary of custom dictionaries and dictionaries containing acronyms
You can add acronyms as shortcuts for other words. The spell checking feature finds the
acronym and offers you suggested replacement words. For example, you can define ‘sw’ as a
shortcut for software. If you have existing acronym dictionaries, you can import these
dictionaries and use them in Open Plan.

The following spell check button has been added to the Email Advisor and all Notes tabs:

When using the spell checking feature, the following dialog box is displayed whenever a word is
encountered that cannot be found in the current dictionaries.

In addition to highlighting unrecognized words, this dialog box also suggests words that you might
want to use as replacements.
Two buttons located at the bottom of the dialog box provide access to customizable spell checker
features: Options and Dictionaries
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Clicking the Options button displays the following dialog box that you can use to specify the options
you want to use:

Clicking the Dictionaries button displays the following dialog box that you can use to add new
dictionaries and to add or delete words from the current dictionary:

For more information on enhancing the spell checking feature, click Help on the Check Spelling
dialog box.
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Web Publisher
The Open Plan Web Publisher allows you to publish any Open Plan view or report as a document
that can be viewed by most common World Wide Web browsers. By producing reports using the
industry-standard Hyper Text Markup Language (HTML) and Adobe Acrobat’s Portable Document
Format (.pdf) , you can provide electronic versions of the most up-to-date project information to any
project member.
For more information on enhancing the spell checking feature, click Help on the Check Spelling
dialog box.

For example, assume that one of your responsibilities as a project manager is to gather information
each month about the current status of one or more projects, update a set of standardized reports to
reflect the revised schedule, and make these reports available to the appropriate managers in your
organization.
With the Open Plan Web Publisher, you can assign a group of project views to a report batch and
then have Open Plan output each report as a .pdf file. These files can be displayed by any user who
has the Adobe Acrobat Reader software, which is available for a number of different hardware
platforms. In addition to the reports in the batch, Open Plan produces an HTML document that lists
each report in the batch:

Each icon in the HTML document serves as a Uniform Resource Locator (URL) link to a .pdf file
generated from a view. This HTML document can then be placed on any Web server, making the
views available to all users with access to that server. To display a view listed in the HTML file, simply
click the appropriate icon.
To produce reports for publication on the Web, you must have the Adobe Acrobat PDFWriter
(included in packages such as Adobe Acrobat Exchange) installed as an output device for your
Windows system.
To view a report produced in the .pdf format, you must have an installed copy of Adobe Acrobat
Reader. This software is available at no charge from Adobe (http://www.adobe.com). The Windows
version of Acrobat Reader is included with your copy of Open Plan.
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To view a report produced in the .pdf format on the Web, your Web browser must support the use of
Acrobat Reader as a helper application.
In addition to producing reports for the Web, the Open Plan Web Publisher can also be used as a
facility for defining and running report batches that can be produced to any output device defined for
your Windows system.
For information about customizing the operations of the Open Plan Web Publisher, refer to
Chapter 15, “Customizing the Open Plan Web Publisher,” in the Deltek Open Plan Developer’s
Guide.

Creating a Report Batch
To use the Open Plan Web Publisher to create a report batch, open the project you want to process,
and click Web Publisher on the Tools tab.
If you do not have a project open at the time you click the command, the Open Plan Web Publisher
prompts for a project to open before proceeding.
Once you have selected a project, the Open Plan Web Publisher displays the following dialog box:

Use this dialog box to display a list of the views currently included in a report batch.
To see the file name for the views, scroll the list horizontally.
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To create a new batch, click New, and provide a name for the batch. When you return to the Open
Plan Web Publisher dialog box, click Views to define the views to include in the batch. The Open
Plan Web Publisher responds by displaying the following dialog box:

Use the controls in the dialog box to create a list of views to be published with this batch as follows:


To include all of the project views in the report batch, click All>> .



To remove all the views from the report batch, click <<All.



To include specific views in the report batch, select the items from the list of available views, and
click Include >>.



To remove specific views from the report batch, select the items from the list of views to publish,
and click << Remove.
You can also include or remove views from a list by either double-clicking the name of the view
or selecting the view and pressing the space bar.

When you have finished defining the views for the batch, click OK to return to the Open Plan Web
Publisher dialog box.
In addition to creating new report batches, you can use the Open Plan Web Publisher dialog box to
update, delete, preview, and run existing batches.
To create a report batch, complete the following step:
1. Open the project for which you want to create a report batch.
2. On the Tools tab, click Web Publisher.
3. On the Open Plan Web Publisher dialog box, click New.
If there are no report batches for this project, Open Plan automatically invokes this
procedure.

4. Enter a name for the new report batch, and click OK.
5. On the Open Plan Web Publisher dialog box, click Views.
6. In the Add or Remove Views dialog box, select the views to add to the report batch, and click
«Include.
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7. When the information for the batch is correct, click OK to return to the Open Plan Web
Publisher dialog box.
To update a report batch, complete the following step:
1. Open the project containing the report batch you want to update.
2. On the Tools tab, click Web Publisher.
3. From the Open Plan Web Publisher dialog box, select the report batch to update.
4. Click Views.
5. In the Add or Remove Views dialog box, update the list of views contained in the batch.
6. When the information for the batch is correct, click OK to return to the Open Plan Web
Publisher dialog box.
To delete a report batch, complete the following step:
1. Open the project containing the report batch you want to delete.
2. On the Tools tab, click Web Publisher.
3. From the Open Plan Web Publisher dialog box, select the report batch to delete.
4. Click Delete.
5. When Open Plan asks you to confirm the operation, click OK.
To preview a report, complete the following step:
1. Open the project containing the views you want to preview.
2. On the Tools tab, click Web Publisher.
3. From the Open Plan Web Publisher dialog box, select the report batch containing the views
you want to preview.
4. From the list of views, select the view to preview, and click Preview.
5. Open Plan responds by displaying the print preview window.
6. To return to the Open Plan Web Publisher dialog box, press Alt+Tab.
To run a report batch, complete the following step:
1. Open the project containing the report batch you want to run.
2. On the Tools tab, click Web Publisher.
3. From the Open Plan Web Publisher dialog box, select the report batch, and click Run.
Open Plan produces the reports in the batch, using the output device specified in the Open
Plan Web Publisher dialog box.

Defining Output Options
In addition to defining the views contained in a report batch, you can use the Open Plan Web
Publisher dialog box to control the publication of the batch with the following settings:


Current Device — The output device for the batch. If you specify an output device other than the
Acrobat PDFWriter, you cannot enter information for the Destination Directory, Generate HTML
File, and Web Site Address settings.
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When producing a batch using an output device other than the Acrobat PDFWriter, the definition
for that device in Windows determines if user intervention is required to produce each report in
the batch.



Destination Directory — The location of the directory for storing the .pdf files generated by the
batch. Open Plan will also use this location for storing the HTML file (if created) as well as the .gif
files for the various icons included in an HTML file. Clicking the ellipsis at the right edge of this
field displays the Destination Directory dialog box that you can use to quickly select the target
directory.



Generate HTML File — Select this option if you want Open Plan to create an HTML file (file
extension .htm) containing an inventory and links to the .pdf files created by the batch. If you
choose to create this file, Open Plan stores it in the destination directory.



Web Site Address — If you are generating an HTML file for the batch and want the URL links to
include the address of a specific Web site, you can specify the address of the Web site with this
setting. (If you do not specify the Web site address with this setting, you can still manually update
the URL addresses contained in the HTML file produced by the batch.)
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Working in a Multi-User Environment
Open Plan allows multiple users simultaneous access to project data. You can open project data in
Exclusive, Read Only, and Shared mode as well.
The following sections discuss the three access modes used in Open Plan.

Opening Files
Each time you open a file in Open Plan using the Open File dialog box, you can select the access
mode for the operation.

You use this dialog box to define the following settings:


File Name — The name of the file to open. Select the file to open from the list displayed in the
pane.



List Files of Type — The type of files (project, calendar, resource, or code) displayed in the list.



Exclusive — Opening a file in this mode puts a lock on the data preventing other users from
being able to change the data. Other users can only open the file in Read Only mode.



Shared — Opening a file in this mode allows multiple users to access and change the data of the
file.



Read Only — Opening a file in this mode allows you to only view the data and not make any
changes.
The following sections provide more information on the three access modes.

When you select a file from the list, Open Plan indicates which modes are available for that file by
enabling/disabling the appropriate selections. For instance:


If you select a program that another user has opened in Exclusive mode, the Exclusive and
Shared options are disabled (dimmed), and the Read Only option is active.



If you select a file that another user has opened in Shared mode, the Exclusive mode is
disabled, and the Shared and Read Only modes are active.



If you select a file that another user has opened in Read Only mode, all three modes are active.
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In some cases, however, it may be impossible for Open Plan to fulfill your request. This can happen if
another user has opened the same file that you want between the time it takes you to you display the
File Open dialog box and make your selection. Open Plan issues a warning when it cannot fulfill your
request. For example, assume you display the File Open dialog box and select a project to open in
Exclusive mode. Before you click OK, another user selects the same file to open in Exclusive mode
and hits OK. Since the other user beat you to the punch, the project opens for him or her, and you
receive a warning indicating that you cannot open the file.
When you open a project (regardless of the access mode you select), the ancillary files associated
with the project are opened in the default access mode established on the Preferences tab of the
Project Properties dialog box. If you open an ancillary file outside the context of a project, rightclicking the file and clicking Default on the Open submenu opens the ancillary file in the default
access mode established on the Properties dialog box for that file.

Working in the Exclusive Mode
If you open a file using the Exclusive mode, the file cannot be opened by other users except in the
Read Only mode. In the Exclusive mode, changes are not saved to a file until you use either the
Save or the Save As command. This means that you can abandon your changes at any time by
simply closing the file without saving the information.
You cannot perform Save As on a file if there is another file open which refers to it. For
example, if you open project CLEAN and then try to perform a Save As on the calendar file
CLEANCAL, you are given the following warning: "Cannot perform Save As on Calendar File
CLEANCAL because there are open objects referring to it." Since CLEAN refers to CLEANCAL,
you need to close the project before you can perform Save As on CLEANCAL.

Working in the Shared Mode
You can work with project data in the Shared mode. In this mode, it is possible for two or more users
to access the data concurrently. To handle this situation, Open Plan uses an optimistic concurrency
control approach that is based on the assumption that the probability of two users updating the same
data item at the same time is relatively small.
If multiple users are updating the same set of records, it is possible that the information for a record
has already been updated by another user. For example, assume you are updating project data using
a dialog box. If you attempt to edit data that has already been changed by another user, Open Plan
displays a message to that effect and asks if you want to view the updated information for the item
before continuing. If you click Yes, Open Plan displays the new information for the record and allows
you to reenter your edit; if you click No, Open Plan returns you to the current view without saving any
changes.
Because changes are saved to the file as you make them, the Save command is not available in the
Shared mode. However, you can always use the Save As command to save the file under a different
name.
In the Shared mode, user-entered data (for example, activity information or costs) is stored, but data
calculated by Open Plan (for example, dates generated by time analysis or resource scheduling) is
not stored. As a result, you must open the project in the Exclusive mode in order to save the results
of a calculation.
In addition to calculated information, Open Plan does not allow you to save changes to information
stored at the project level in the Shared mode. Thus, you cannot change the ancillary files assigned
to a project information
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Shared Mode Locking
While in Shared Mode, you can apply a temporary exclusive lock on a project to perform processes
like Time Analysis, Resource Scheduling, Risk Analysis, Cost Calculations, and Progress
Calculations.
When you apply a lock on a project, other shared mode users will not be able to make changes while
you have the lock in effect. To apply a temporary exclusive lock, complete the following steps:
Shared Mode
Locking button

1. Select a project to which you want to apply the temporary exclusive lock.
2. Click the Lock Project command on the Processes tab.
You can also apply the lock by right-clicking the project you selected, and click Shared
Mode Lock from the context menu.

After a user releases the temporary exclusive lock on a project, a dialog box is displayed to other
shared mode users, confirming the refresh of the project data. Clicking Yes ensures that the project
data is current and updated. Note that the refresh retrieves data changed by other users but not
globally calculated data such as the results of Time Analysis. To update calculated data, run the
process on your machine.
A new security option has been added to control which groups of users can acquire temporary
shared mode locks. See chapter 25 for more information on setting up security.

Working in the Read Only Mode
If you have opened a file in the Read Only mode, it is possible for other users to have access to the
same file in any mode. If another user who has the file open in Exclusive or Shared mode makes
changes to the information, you cannot see the effect of those changes unless you close the file and
reopen it. Also, you cannot make any changes to the file while in this mode.

Setting the Default Access Mode
Although you can always select an access mode when opening a file from the Open File dialog box, it
is also possible to open files from a context menu without displaying this dialog box. Right-clicking on
a project folder or ancillary file in the hierarchical view and pointing to Open on the context menu
displays the following submenu:

If the file has been opened by another user, the appropriate modes will be enabled or disabled on this
submenu. You can open the file in its default access mode by clicking Default.
You can use the Project Properties dialog box to set the default access mode for a project and its
ancillary files when the project is opened in default mode. You can also use an ancillary files
Properties dialog box to set its default access mode when the file is opened outside the context of a
project.
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For a project, display the Preferences tab of the Project Properties dialog box:

Select the default access mode for the
project and ancillary files.

You can use the lists for the Project and Ancillary Files fields to select the Default Access Mode.
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For a calendar, resource, and code file, display the General tab of the Properties dialog box:

You can use the Default Access Mode list to select the new mode for the file.
To set the default access mode for a project, complete the following step:
1. In the Open Plan Explorer, select the project folder to which you want to change the default
access mode.
2. Take one of the following actions:


On the Processes tab, click Properties.



Right-click the project folder, and click Properties on the context menu.

3. On the Project Properties dialog box, click the Preferences tab.
4. Set the default access mode for Project and Ancillary Files, and click OK.
To set the default access mode for a calendar, resource, or code file, complete the following
step:
1. In the Open Plan Explorer, right-click the file to which you want to change the default access
mode, and click Properties on the context menu.
Open Plan displays the Properties dialog box for that file.
2. On the General tab of the Properties dialog box, select a new mode from the Default Access
Mode list.
3. Click OK.
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Activity

The smallest self-contained unit of work used to define the
logic of a project.
In general, activities share the following characteristics:


They have a definite start and finish date.



They may have logical relationships to other activities
in a project.



They use resources such as people, materials, or
facilities.



They have an associated cost.

Activity File

The data tables corresponding to the ACT file in other
versions of Open Plan.

Activity ID

A unique code identifying each activity in a project.

Activity Status

The state of completion of an activity:


Planned — The activity has not yet started.



In Progress — The activity is in progress.



Complete — The activity is complete.

Actual Cost of Work Performed
(ACWP)

The actual cost expended on an activity, a part of a
project, or an entire project.

Actual Finish

The date on which an activity was completed.

Actual Start

The date on which an activity was started.

Alternate Resource

A resource that Open Plan may substitute for an activity
requirement during resource scheduling, if the requested
resource is not available. An alternate resource may be an
individual, a pool, or a skill.

As-Late-As-Possible (ALAP)

An activity for which Open Plan sets the early dates as
late as possible without delaying the early dates of any
successor.

As-Soon-As-Possible (ASAP)

An activity for which Open Plan sets the early dates to be
as soon as possible. This is the default activity type.

Assignment Profile Curve

A profile that describes how a resource assignment is
spread through the duration of an activity. Open Plan
provides seven standard assignment profile curves: back
load, double peak, early peak, front load, late peak, linear,
and normal (bell).

Asymmetrical Distribution

A probability distribution not symmetrical about its central
tendency. Same as skewed distribution.
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Average

A measure of central tendency of a sample or a probability
distribution, obtained by adding the individual values in a
sample and dividing by the sample size. Same as mean or
expected value.

Backward Pass

A procedure within time analysis to calculate the late start
and late finish dates of all activities in a project.

Barchart View

A view that uses horizontal bars on a time scale to depict
activity information. In Open Plan, a barchart view is a
composite view that displays an activity barchart, a
spreadsheet, and, if resources are assigned to the project,
a histogram.
A barchart is frequently called a Gantt chart.

Baseline

A copy of the project data for baseline comparison use.

Beta Distribution

A family of continuous probability distributions in which the
random variable varies in the range of 0 to 1 and with a
skew and kurtosis (“peakedness”) that depends on a pair
of parameters. In the context of Open Plan, the definition
of the beta distribution has been expanded to allow
random variables distributed between any pair of userspecified values, instead of always between 0 and 1.

Breakdown Structure

A hierarchical, validated structure for codes that allows
you to summarize project data for reporting requirements.

Budget

The planned cost for an activity or project.

Budget at Completion (BAC)

The sum total of the time-phased budget.

Budgeted Cost of Work Performed
(BCWP)

A measure used in cost control that allows you to quantify
the overall progress of the project in monetary terms.
BCWP is calculated by multiplying the physical percent
complete by the planned cost. Another term for BCWP is
“earned value.”

Budgeted Cost of Work Scheduled
(BCWS)

Planned cost multiplied by the percentage of completion
that should have been achieved according to the project
baseline dates.

Calendar

A definition of valid working periods for a group of project
activities.

Calendar File

A file containing calendar information for one or more
calendars.

Central Tendency

The central area of a probability distribution, usually
corresponding to the mode (“most likely”) or mean
(“average”) value of the random variable. Most of the
results of Open Plan processing use the mean to measure
central tendency.

Child

A lower-level element in a hierarchical structure.
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Code File

A file used in reporting that contains information
associated with codes entered on an activity record or a
resource record.

Confidence

The likelihood of a statistical deduction from empirical
data. Confidence is usually expressed as a percentage
and applied to a range of possibilities. See also
Confidence Interval.

Confidence Interval

A pair of values bracketing an estimate (usually derived
from sampled data), indicating that there is some stated
percentage probability that the true value falls within that
range. For example, a 99% confidence interval would be a
pair of values such that there was a 0.5% chance of the
true value being less than the lower value, and a 0.5%
chance that the true value is above the higher value.

Consumable Resource

A type of resource that remains available until consumed
(for example, a material).

Controlling Relationship

A relationship that controls the early date of the successor
activity. In Open Plan, a controlling relationship can be
detected by its free float being zero.

Cost Variance (CV)

The difference between the budgeted and actual cost of
work performed.

Critical Activity

An activity is termed critical when it has zero or negative
float.

Critical Path

Series of consecutive activities that represent the longest
path through the project.

Criticality Index

In Open Plan, a measure of the probability that a particular
activity is on the critical path of a project. Expressed as a
percentage.

Cumulative Distribution

The representation of a probability distribution as a
cumulative curve. Each point on the curve represents the
probability that the random variable will be no greater than
the value represented by that point. By definition, the
height of such a curve must be non-decreasing, starting at
zero and increasing to one.

Default Calendar

If no user-created calendar file is associated with the
project, the default calendar is used for date calculations.
The default calendar is defined as Monday through Friday,
8 A.M. to 4 P.M., and no holidays.

Delaying Resource

In resource scheduling, inadequate availability of one or
more resources may require that the completion of an
activity be delayed beyond the date on which it could
otherwise be completed.
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The delaying resource is the first resource on an activity
that causes the activity to be delayed.
Discontinuous Activity

An activity in which the interval between the start and
finish dates is allowed to exceed its duration in order to
satisfy start-to-start and finish-to-finish relationships with
other activities.

Distribution

See Probability Distribution.

Duration

The number of working periods required to perform the
work represented by an activity. In risk analysis, this
corresponds to “most likely” duration.

Earliest Feasible Date

The earliest date on which the activity could be scheduled to
start based on the scheduled dates of all its predecessors,
but in the absence of any resource constraints on the
activity itself. This date is calculated by resource scheduling.

Early Dates

Calculated in the forward pass of time analysis, early
dates are the earliest dates on which an activity can start
and finish.

Early Finish

The earliest date on which an activity can finish. This date
is calculated by time analysis.

Early Start

The earliest date on which an activity can start. This date
is calculated by time analysis.

Earned Value Cost Control

An approach to project cost control that quantifies the
overall progress of the project in monetary terms. Earned
value is calculated by multiplying the physical percent
complete by the planned cost. Another term for earned
value is budgeted cost of work performed (BCWP).

End Activity

An activity with no logical successors. Also known as a
finish activity.

Escalation

A feature that allows you to specify different resource unit
costs and the date on which each new cost takes effect.

External Subproject

A complete project represented as a single activity in a
higher-level project.

Extra Work Day

An exception to the standard non-working day. For
example, assume that a calendar defines Monday through
Friday as days on which work is normally performed. In
this case, a specific Saturday might be identified as an
extra work day if work is to be performed on that day.

Finish Activity

An activity that has no successor. Also known as an end
activity.

Finish Float

The number of work periods between the early finish date
and the late finish date.

Finish Milestone

A milestone activity signifying the end of a project phase.
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Finish-to-Finish Relationship

The relationship between activities that specifies that the
finish of the successor activity depends on the completion
of the predecessor activity.
In most cases, this means that the successor activity
cannot be completed before the predecessor activity is
completed.

Finish-to-Start Relationship

The relationship between activities that specifies that the
start of the successor activity depends on the completion
of the predecessor activity.
In most cases, this means that the successor activity
cannot start until the predecessor activity is completed.
This is the default relationship.

Fixed Format Significant Coding
Structure

A coding structure that relies on the length of the code to
represent the hierarchical level.

Float

The number of time periods by which an activity can be
delayed without affecting other activities in a project.

Foreign Activity

A placeholder activity used to represent relationships with
projects that are not currently open.

Forward Pass

A procedure within time analysis to determine the early
start and early finish dates of activities.

Free Float

The maximum amount by which an activity can be delayed
beyond its early dates without delaying any successor
activity beyond its early dates. In the absence of finish
targets, free float is always less than or equal to total float.

Hammock

An activity that plays no part in time analysis, but which
provides the means to report on the start and finish of a
group of activities.

Hard Zeros

In resource scheduling, there is a distinction made
between resource availabilities specified as zero but which
can be exceeded under certain circumstances, and hard
zeros, which can never be exceeded.

Hierarchical Coding Structure

A coding system that can be represented as a multi-level
tree structure in which every code except those at the top
of the tree has a parent code.

Hierarchical Project

A project that allows you to break down project information
into multiple levels using the activity ID. With hierarchical
projects, you enter project data at the lowest level of the
project hierarchy, then summarize it to appropriate levels
for reporting purposes.

Hierarchical Resource Structure

Resource definitions organized in a hierarchical structure
in which every resource except those at the top of the tree
has a parent.
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Histogram View

A view in which resource or risk information are shown
against a time scale. In Open Plan, a resource histogram
can be displayed both alone and in combination with a
barchart view.

Holiday

An exception to the standard working day. For example,
assume that a calendar defines Monday through Friday as
days on which work is normally performed. In this case, a
specific Monday (such as September 1, 1997) might be
identified as a holiday if the office would be closed on that
day.

Immediate Activity

An activity that can be forced to start on its earliest
feasible date by resource scheduling, even if that means
overloading a resource.

In Progress

An activity partially completed.

Internal Subproject

A group of activities represented as a single activity in a
higher level of the same project.

Iteration

In Open Plan, one complete trial of Monte Carlo simulation
of a project (that is, sampling a value for each activity
duration, performing a time analysis with this sampled
data, and storing the results). The Monte Carlo technique
accumulates the results from a large number of these
iterations.

Key Activity

In Open Plan, an activity specified by a user about which
the program is to store detailed information generated by
risk analysis.

Kurtosis

A technical term used to define a characteristic of the
shape of a probability distribution, identified with the
thickness of the tails of the distribution.

Labor Resources

Open Plan permits certain resources to be flagged as
representing labor. The significance of this is that only
resources so flagged will be included in the labor percent
complete calculations.

Ladder

A style for displaying children in a breakdown structure.

Lag

A time delay associated with a relationship in a project.
Lag can be either positive or negative. Negative lag is
sometimes called “lead.”

Late Dates

Calculated in the backward pass of time analysis, late
dates are the latest dates on which an activity can start
and finish.

Late Finish

The latest date on which an activity must be completed if
the project completion date and any finish targets are to
be met. This date is calculated by time analysis.
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Late Start

The latest date on which an activity must start if the project
completion date and finish targets are to be met. This date
is calculated by time analysis.

Loop

In networks, a consecutive set of activities that are
mutually dependent.

Mean

The most common and useful measure of central
tendency for a probability distribution. The mean value is
the same as the “average” or “expected” value.

Median

A measure of the central tendency of a probability
distribution such that there is a 50% chance of a value
sampled from the distribution is less than the median.

Milestone

An activity with zero duration — must be designated as
either a start milestone or a finish milestone.

Military Time

A means of representing time by use of a 24-hour clock.

Mode

A measure of central tendency for a probability
distribution, being the most likely single value for a
variable sampled from that distribution. For a theoretical
distribution, the mode is represented by the peak of the
curve. The mode is the same as the “most likely” value.

Monte Carlo Simulation

The technique used in Open Plan to estimate the likely
range of outcomes from a complex random process by
simulating the process a large number of times.

Most Likely Value

See Mode.

Multiple Ends Processing Option

The multiple ends processing option causes time analysis
to treat each end activity as if it was the end of an
independent project, so that the float would normally be
zero.

Negative Float

The amount of time by which the early date of an activity
exceeds its late date.

Network View

A project drawing in which the project logic is the sole
determinant of the placements of the activities in the
drawing. Frequently called a flowchart, PERT chart, logic
drawing, or logic diagram.

Non-Working Day

The standard non-working day on the calendar. For
example, assume that a calendar defines Monday through
Friday as days on which work is normally performed. In
this case, a Saturday that has not been identified as an
extra work day would be a non-working day.

Appendix A Glossary
Deltek Open Plan 8.0 User Guide

665

Appendix A - Glossary

Normal Distribution

A family of symmetrical continuous probability distributions
defined by two parameters representing the mean and
standard deviation of the distribution. In Open Plan, the
sampling method for normal distributions is an approximation
that curtails the curve at three standard deviations either side
of the mean. (In theory there would be approximately a 1%
chance of values falling outside of this range.)

Open Plan Ancillary File

A resource, code, or calendar file associated with an Open
Plan project.

Organizational Breakdown
Structure (OBS)

A hierarchical structure designed to pinpoint the area of
an organization responsible for each cost element in a
project.

Out-of-Sequence Progress

Progress that has been reported even though activities
that have been deemed predecessors in project logic have
not been completed.

Pad Character

A character that is used to fill out a code in a fixed-format
significant breakdown structure so that all codes are the
same length.

Parent

A higher-level element in a hierarchical structure that
summarizes lower-level elements.

Percent Complete

One measure of completion used in Open Plan to
determine the remaining duration of a partially completed
activity.

Performance Measurement
Baseline (PMB)

A baseline that is used for cost calculations. If a PMB
exists, it is used even if it is not one of the selected
baselines. By always using the PMB when it is available,
Open Plan provides consistency and reliability.

Perishable Resource

A consumable resource with an expiration date.

Physical Percent Complete

The percentage of the work content of an activity that has
been achieved. See also Budgeted Cost of Work
Performed.

Placements

The automatic calculation of coordinates for activities in a
network view.

Planned Activity

An activity not yet started.

Precedence Diagram Method
(PDM)

One of the two popular methods of representing projects
as networks, in which the activities are represented by
nodes and the relationships between them by arcs.

Predecessor

An activity that logically precedes another activity.
Normally, this term refers to an immediate predecessor,
that is, one directly implied by the project data.
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Priority Rule

A rule used to determine the order of processing in
resource scheduling algorithms.

Probability

The measure of the chance of a particular outcome
resulting from a random process. If the process can be
performed a number of times, then the proportion of times
that a particular outcome results should converge on a
value, called the probability, as the number of trials
increases.

Probability Distribution

The representation of the range and relative probabilities
of the possible outcomes from a random process. A
probability distribution may be in the form of a table, a
curve, or a histogram.

Progress

The partial completion of a project, or a measure of same.
Also, the act of entering progress information for a project.

Project

A set of activities directed to an overall goal. Also, the
collection of data relating to the achievement of that goal.
More specifically, a network of activities, or the file(s)
containing such a network.

Project Logic

The relationships between the various activities in a
project.

Punctuated Significant Coding
Structure

A coding structure in which a specific character (usually a
period) is used to separate the part of the code that
corresponds to the different levels in the breakdown
structure.

Reprofiling

In resource scheduling, it is possible to indicate that the
specified resource requirement profile may be modified to
fit the availability, without changing the total amount
required.

Relationship

A logical connection between two activities.

Relationship Float

Open Plan permits the calculation of both free and total
float on relationships, which are analogous to the float
fields on the activities.

Remaining Duration

The remaining portion of an in-progress activity’s duration.

Requested Resource

The preferred resource requirement for an activity.

Resource

An item required by an activity. Resources can be people,
equipment, facilities, funding — anything needed to
perform the work of a project.
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Resource Allocation

A feature, used in conjunction with alternate resources,
pools, and skills, that allows you to selectively replace a
requested resource with one suggested by Open Plan.
During resource allocation, you can also selectively lock
the allocation of either the requested, or the suggested
resource.

Resource Assignment

The requirement for a particular resource by a particular
activity, or part of an activity. Sometimes called a resource
requirement.

Resource Availability

The level of availability of a resource, which may vary over
time.

Resource Breakdown Structure
(RBS)

A feature of hierarchical resources.

Resource Level

A specified level of resource units required by an activity
per time unit.

Resource Leveling

The resource scheduling process of determining scheduled
dates such that neither the project completion date nor any
target finishes are jeopardized while minimizing the
maximum extent to which any resource availability is
exceeded.

Resource-Limited Resource
Scheduling

The production of scheduled dates in which the resource
constraints are considered as absolute and project
completions are delayed as necessary to avoid exceeding
resource requirements.

Resource Offset

The number of work periods between the start of the
activity and when the resource is first required.

Resource Period

The number of work periods for which a resource is
required.

Resource Pool

A higher-level resource in a resource breakdown structure.

Resource Scheduling

The process of calculating a set of scheduled dates that
takes into account the resource requirements of each
activity and the availability of these resources.

Resource Thresholds

In resource-limited scheduling, it is possible to specify that
a particular resource may be exceeded, if necessary, by
an amount not to exceed the specified threshold for that
resource.

Resource Total

A specified total of resource units required by an activity
over a period of time.

Risk Analysis

Any technique designed to quantify the impact of
uncertainty. Usually, but not necessarily, associated with
the Monte Carlo simulation technique used in Open Plan.
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Schedule Dates

The start and finish dates calculated by the resource
scheduling program, having regard to resource constraints
as well as project logic.

Schedule Variance (SV)

A summary measure of lateness for a project or part of a
project.

Scheduled Duration

The scheduled duration of an activity is calculated by
resource scheduling, and takes into account such
advanced activity management techniques as activity
splitting, stretching, or reprofiling.

Scheduled Finish

The date calculated by the resource scheduling program
as the earliest date on which an activity can finish, having
regard to resource constraints as well as project logic.

Scheduled Float

Calculated during resource scheduling, the scheduled float
of an activity is the difference between the late finish date
and the scheduled finish date of the activity. In some
circumstances, scheduled float may be shared with other
activities in the logical flow of the project.

Scheduled Start

The date calculated by the resource scheduling program
as the earliest date on which an activity can start, having
regard to resource constraints as well as project logic.

Skew

A measure of the degree of asymmetry in a probability
distribution. For symmetrical distributions, the skew is
zero.

Smoothing

A resource-scheduling option that modifies the way timelimited scheduling (and resource-limited scheduling with
thresholds) works.

Splitting

In resource scheduling, it is possible to indicate that the
specified duration may be divided into two or more pieces,
while retaining the specified profile for resource
requirements relative to this split duration.

Spreadsheet View

A view in which data is shown in a tabular format. There
are single-table spreadsheets and multi-table
spreadsheets. An activity spreadsheet is always shown as
one of the windows in a barchart view.

Standard Calendar

The default calendar in a calendar file.

Standard Deviation

A measure of the amount of random variation in a random
variable, calculated as the square root of the variance.
Same as root mean square deviation.

Standard Work Week

The working hours and days defining the basic work
pattern for a calendar.

Start Activity

An activity that is not logically dependent on any
predecessor activity.
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Start Milestone

A milestone activity signifying the start of a project phase.

Start-to-Finish Relationship

The relationship between activities that specifies that the
finish of the successor activity depends on the start of the
predecessor activity.
In most cases, this means that the successor activity
cannot be completed before the start of the predecessor
activity.

Start-to-Start Relationship

The relationship between activities that specifies that the
start of the successor activity depends on the start of the
predecessor activity.
In most cases, this means that the successor activity
cannot be started before the start of the predecessor
activity.

Stochastic

Random variation that cannot be predicted other than in
statistical terms.

Stretching

In resource scheduling, it is possible to indicate that the
specified duration may be increased, while the specified
profile is reduced proportionately.

Subsection

A block of data in a spreadsheet that typically begins with
a subheading, and ends with a subtotal.

Successor

An activity that logically follows another activity. Normally,
this term refers to an immediate successor, that is, one
directly implied by the project data.

Symmetrical Distribution

A probability distribution in which variations from the
central tendency by a given amount in either direction is
equally likely.

Target Date

A date imposed on an activity or project by the user. There
are two types of target dates: target start dates and target
finish dates.

Target Finish

A finish date imposed on an activity or project by the user.

Target Start

A start date imposed on an activity or project by the user.

Target Type

Open Plan allows you to specify four types of target dates
for activity start and finish dates:

Appendix A Glossary
Deltek Open Plan 8.0 User Guide



Not Earlier Than — The earliest date on which the
activity can start or finish. This constraint affects the
early dates calculated by time analysis.



Not Later Than — The latest date on which the
activity can start or finish. This constraint affects the
late dates calculated by time analysis.



On Target — Combines the effects of both Not Earlier
Than and Not Later Than target dates, and affects
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both the early and late dates calculated by time
analysis.


Fixed Target — Requires that the activity take place
on the given date even if the logic of the project says
that it cannot happen.

Threshold

The level to which Open Plan may exceed the availability
of a resource during resource-limited resource scheduling.

Time Analysis

The process of calculating the early and late dates for
each activity on a project, based on the Time Now date,
the duration of the activities, and the logical relationships
between them.

Time Now

The status date of a project. All progress information
entered for a project should be correct as of this status
date. No work will be scheduled by the time analysis or
resource scheduling functions prior to this date.

Total Float

The maximum number of work periods by which an activity
can be delayed without delaying project completion or
violating a target finish date.

Triangular Distribution

A family of probability distributions that is triangular in
shape when represented as a frequency distribution.

Uncertainty

The lack of precision in estimating or predicting the
outcome of some process.

Uniform Distribution

A family of probability distributions characterized by two
parameters, representing the minimum and maximum
possible values. Any allowable outcome between the two
extreme values is equally likely. For example, the
distribution of the outcome from the throwing of a single
die is uniform in the range 1 to 6.

Variance

A discrepancy between the actual and planned
performance on a project, either in terms of schedule or
cost.

Whole Relationship

A relationship in which both the predecessor and the
successor activities are visible in the displayed view.

Work Breakdown Structure (WBS)

The breakdown of a project from the client's point of view
in terms of deliverables.

Working Day

The standard working day on the calendar. For example,
assume that a calendar defines Monday through Friday as
days on which work is normally performed. In this case, a
Monday that has not been identified as a holiday would be
a working day.

Zoning

A feature of Open Plan that causes activities on a network
view to be grouped into horizontal bands based on one or
more criteria that you specify.
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Appendix B - Keyboard Shortcuts
Command

Keyboard Shortcut

New

Ctrl+N

Open
Save
Print
Cut
Copy
Paste
Find
Find Next
Display Next Window
Help
Add Activity (Activity views)
Add Resource (Resource file)
Delete Item
Display Activity Information (Activity views)
Time Analysis (Activity views)
Resource Scheduling (Activity views)
Risk Analysis (Activity views)
Display Time Analysis dialog box (Activity
views)
Placements (Network view)
Properties (Explorer)
Define Work Hours (Calendar file)
Previous Year (Calendar file)
Next Year (Calendar file)

Ctrl+O
Ctrl+S
Ctrl+P
Ctrl+X
Ctrl+C
Ctrl+V
Ctrl+F
Shift+F4
Ctrl+Tab
F1
Ctrl+A
Ctrl+A
Delete
F5
Ctrl+T
Ctrl+R
Ctrl+K
Shift+F9

Go to first record in the file (Modeless dialog
box)

Ctrl+Home

Go to last record in the file (Modeless dialog
box)

Ctrl+End

Go to previous record in the file (Modeless
dialog box)

Page Up

Go to next record in the file (Modeless dialog
box)

Page Down
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Shift+P
Alt+Enter
Ctrl+Spacebar
Page Up
Page Down
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Index

Index
A
About Open Plan message box, 18
Access modes
changing modes, 627
default, 81, 91, 655
exclusive, 58, 82, 92, 654
read only, 58, 82, 92, 655
shared, 58, 82, 92, 654
Accomplished Duration field, 355
Activities
actual finish dates, 353
actual start dates, 353
adding in network views, 154
adding in spreadsheet views, 153
as-late-as-possible, 134
as-soon-as-possible, 134
automatic progressing, 362
baseline information, 350
calculated dates, 161
calculating actual costs, 249, 251
calculating budget costs, 246
calendars, 134, 225
changing durations in barchart views, 149
changing target start dates in barchart views,
149
characteristics, 131
child, 131, 280, 286, 288
complete, 298
computed remaining duration, 298
computed status, 298
controlling critical, 161
copying between subprojects, 287
costs, 162
critical, 161, 298
default duration unit, 115
default type, 113
descriptions, 133
discontinuous, 134
displaying actual costs, 162
displaying budget costs, 162, 252
durations, 133
effort-driven, 134, 179, 221
entering code assignments, 276, 277
external subproject, 134
finding, 159
finish, 298
finish milestone, 134
float, 161
foreign, 293
free float, 298
guidelines for planning, 131
hammock, 134, 294
ID, 133
identifiers, 131, 133
immediate, 313
indenting, 289
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information, 161
in-progress, 298
internal subproject, 134
key, 333
maximum duration, 313
maximum number of splits, 313
minimum duration, 313
most critical, 161, 298
moving to subprojects, 286
not critical, 161, 298
notes, 400
outdenting, 290
pasting in network views, 46
physical % complete, 358
planned, 298
relationships, 138
reprofiling, 312
resource scheduling attributes, 311
splitting, 311
start, 298
start milestone, 134
start/finish, 298
stretching, 311
subproject, 131, 280
target dates, 135
time analysis calculations, 298
total float, 297
types, 134
utilities, 159
Activity calendars, 114, 228
Activity Details dialog box
Advanced tab, 323
Codes tab, 276
described, 132
General tab, 133
Relationships tab, 139
Resources tab, 203
Risk tab, 331
User Fields tab, 137
Activity Information command (Edit tab), 162, 167
Activity Information dialog box, 161
Activity Progress dialog box
Activity tab, 353
Resources tab, 358
Activity Resource Allocation dialog box, 216
Activity spreadsheet views
adding activities, 153
described, 156
entering code assignments, 278
Activity/resource spreadsheet views, 213
Actual cost of work performed, 119, 162, 241,
254, 496
Actual costs
based on resource progress, 180
calculating, 249, 251
role in earned value calculations, 241
Actual date option, 302
Actual start and finish dates, 352, 357
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ACWP. See Actual cost of work performed
Add Activity command (Edit tab), 147, 153, 433
Add Annotation command (View tab), 425, 426
Add Baseline dialog box, 343
Add Child command, 188, 268, 286
Add Code command (Edit tab), 268
Add Relationship command (Edit tab), 154, 158
Add Relationship cursor, 150, 154, 456
Add Resource command (Edit tab), 188
Add Skill dialog box, 193
Adding
activities in network views, 154
activities in spreadsheet views, 153
calculated fields, 563
child activities in network views, 286
child activities in spreadsheet views, 288
child codes, 268
code assignments, 278
codes, 268
codes to code file, 268
global edits, 572
network annotations, 426
project-level codes, 596
relationships in barchart views, 149
relationships in network views, 154
relationships in spreadsheet views, 158
resource assignments, 212
resources, 188
sort expressions, 555
spreadsheet columns, 461
standard views, 595
symbols, 381
Advisory Definitions dialog box, 613
ALAP. See As-late-as-possible activities
All Resource Categories, 210
Allocation. See Resources, allocation
Allocation command (Edit tab), 217
Alternate resources, 205, 216
Annotations, 425
Application shortcuts, 66
ASAP. See As-soon-as-possible activities
As-late-as-possible activities, 134
Assign Code dialog box, 87, 275
Assign Multiple Resources to Multiple Activities
dialog box, 208
Assignment profile curves, 222
As-soon-as-possible activities, 134
Automatic activity progressing
discussion, 362
session log, 365
Automatic numbering
defined, 135
examples, 135
in activity views, 135
in resource views, 190
in spreadsheet views, 486
indenting, 289
rules, 135
Automatic placements
defined, 433
saving, 436
Automatic resource progressing
Index
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description, 366, 369
session log, 367
Automatic Scaling dialog box, 412
Automatic time analysis, 304
Autoscaling, 411
Availabilities. See Resources, availabilities
Availability dates, 182
Availability options
Total & Reserved, 493
Total & Reserved or Used, 493
Total Availability, 493
Total, Reserved and Used, 493
Unreserved and Used, 493
Unreserved Availability, 493
Unused Availability, 493

B
BAC. See Budget at completion
Backup, 619
Backup dialog box, 619
Backup File command (File→Manage Files
submenu), 620
Backward pass, 297
Bar Data Mode button, 148
Bar Set field, 109
Bar Set Preferences dialog box, 417
Bar Sets command (View tab), 417
Barchart Preferences dialog box, 415
Barchart views
adding relationships, 149
changing activity durations, 149
changing target start dates, 149
clicking to sort, 559
custom date scales, 407
date range, 388
defined, 147, 372, 406
display of Time Now marker, 415
display options, 415
displaying controlling relationships, 415
displaying relationships, 147, 415
displaying temporary filters, 548
histogram pane in reports, 388
legend, 388
multi-table, 417
printing, 386
relationship mode, 149
spreadsheet pane in reports, 388
title blocks, 391
Baselines
creating, 342
defined, 342
defining access rights, 347
deleting, 350
displaying baseline information, 350
fields, 350
filters, 344, 345
including complete activities, 344, 345
including in-progress activities, 344, 345
managing, 348
performance measurement baseline, 119, 349
security, 347
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selecting, 112
updating, 347
user defined fields, 577
Baselines command (Processes tab), 342, 348,
350
Baselines dialog box, 342
BCWP. See Budgeted cost of work performed
BCWS. See Budgeted cost of work scheduled
Beta distribution shape, 332
bk3 files, 619
Breakdown structures, 258
Briefcase system folder, 49
Briefcasing
auxiliary files, 625
checking in a file, 626
checking out in main data source, 625
checking out to briefcase data source, 625
described, 49, 624
undoing check out, 627
views, 625
Budget at completion, 119, 162, 254
Budgeted cost of work performed, 119, 162, 241,
254, 496
Budgeted cost of work scheduled, 119, 162, 241,
496
Budgets
baseline dates, 241
calculating for activities, 246
displaying activity costs, 162, 252
displaying project costs, 253
Buttons
described, 27
dimmed, 35
displaying a description, 35
navigation, 41
outlining, 288

C
Calculated fields
access control, 563
adding, 563
calculating across summary rows, 563
copying, 564
defining, 562
deleting, 564
described, 561
editing, 563
references, 563
results, 562
temporary calculated fields, 564
use in cost reporting, 254
Calculated Fields command (Tools tab), 563
Calendar files
assigning to projects, 64, 116, 225, 226
assigning to resource files, 229
assigning to resources, 226
copying, 226
creating, 225
default calendar, 227
defined, 225
deleting, 226
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icons, 225
opening, 226
Calendar Preferences dialog box
Color tab, 237
described, 237
Layout tab, 237
Calendars
adding, 230
adding a child, 235
assigning to activities, 134
assigning to relationship lags, 140
controlling the display, 236
copying, 235
default, 227
default activity calendar, 114, 228
default relationship calendar, 114, 228
defined, 225, 227
defining standard work week, 231
deleting, 236
extra days, 227
fonts, 237
holidays, 227
keyboard shortcuts, 232
non-working days, 227
printing, 385
renaming, 236
reporting calendars, 119
resource calendars, 182
Start Day of Week setting, 237
Start Month of Year setting, 237
working days, 227
Change Access Mode dialog box, 627
Change Mode command (File→Manage Files
submenu), 628
Change Password command (File menu), 640
Changing
access modes, 626
activities to internal subprojects, 282, 283
activity durations in barchart views, 149
activity target start dates in barchart views, 149
data sources, 636
default calendar, 227
work status of a day, 233
Check boxes, 39
Check In command (File→Manage Files
submenu, 627
Check In dialog box, 626
Check Out command (File→Manage Files
submenu), 626
Check Out dialog box, 625
Check Spelling dialog box, 646
Child activities, 131
Choose a Project dialog box, 373
Click to Sort option, 559
Clip Notes, 591
Clipboard function, 44
Close command
using the Close button, 62
using the context menu, 62
using the File menu, 62
Code Details dialog box
Code tab, 265
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described, 265
Notes tab, 266
User Fields tab, 266
Code Display Preferences dialog box
Box Layout tab, 272
Options tab, 271
Code File Prompt dialog box, 87
Code files
assigning to projects, 116, 264
assigning to resource files, 264
copying, 263
creating, 261
defined, 262
deleting, 264
icons, 262
notes, 400
opening, 262
removing from projects, 263
removing from resource files, 263
Code views, 372
Codes
adding, 268
adding a child, 268
adding project-level codes, 596
adding to code file, 268
assigning codes in spreadsheet views, 278
assigning codes to projects, 64, 127
assigning to resource files, 87
assigning to resources, 180
assignments, 275
breakdown structures, 258
child codes, 259
collapsing parent codes, 270
deleting, 67, 269
described, 258
descriptions, 265
displaying code information, 271
editing, 269
entering assignments, 276, 277
expanding all parent codes, 270
finding, 269
fixed format significant, 92, 260
fixed level length, 260
hierarchies, 258
identifiers, 265
moving in hierarchy, 269
notes, 400
pad characters, 260
parent codes, 259
punctuated significant, 92, 258, 260
self-defining structures, 258
summarizing, 259
Collapse All command (Edit tab), 285, 289, 430
Collapse button, 270
Collapse command (Edit tab), 190, 270, 288
Color dialog box, 469, 492
Command buttons, 39
Commands
context menus, 37
dimmed, 27
keyboard shortcuts, 38
submenus, 27
Index
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toolbar, 27
Complete activities, 298
Computed remaining duration, 298
Computed status, 298
Constraints. See Target dates
Consumable resources, 177, 183
Context menus, 37
Context-sensitive help. See Help system
Controlling critical activities, 161
Controlling relationships, 415
Copy Baseline dialog box, 344
Copy button, 46
Copy command (Edit tab), 44, 287
Copy User Defined Field dialog box, 578
Copying
activities between subprojects, 287
calculated fields, 564
calendar files, 226
calendars, 235
code files, 263
effect of filters, 542
filter expressions, 547
global edits, 573
reporting calendars, 398
resource files, 174
sort expressions, 556
text, 46
title blocks, 392
user defined fields, 578
Cost Calculations
Use Version 2 Cost Calculation Method, 119
Cost Calculations command (Processes tab), 251
Cost performance index, 254
Cost variances, 254
Costs
activity-level, 358
actual cost of work performed, 162, 241, 254,
496
budget at completion, 162, 254
budgeted cost of work performed, 162, 241,
254, 496
budgeted cost of work scheduled, 162, 241,
496
calculating actual costs, 249, 251
calculating budget costs, 246
cost performance index, 254
cost variances, 242, 254
displaying budget costs, 252
displaying earned value, 496
earned value cost control, 241
escalations, 184
estimate at complete, 162, 254, 496
estimate to complete, 254
forecasting, 496
planned baseline progress, 254
planning, 244
progress information, 358
reporting, 254
resource cost based on progress, 180
schedule performance index, 254
schedule variances, 243, 254
target total, 118
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variance at complete, 254
CPF. See Cost performance factor
CPI. See Cost performance index
Creating
application shortcuts, 66
auxiliary files, 59, 77
baselines, 342
calendar files, 225
code files, 261
custom folders, 48
Email Advisor address list, 616
hammocks, 294
new templates, 374
projects, 59, 77, 594
report batches, 649
reporting calendars, 398
resource files, 173
temporary filters, 548
temporary sorts, 556
title blocks, 392
user defined fields, 578
using the New File dialog box, 59, 77
using the New File Wizard, 59, 81
Critical activities, 161, 298
Criticality index, 334, 338
Crosstable Export Definition dialog box
Access Control tab, 538
Resource Data tab, 537
Crosstable exports, 530
Crosstable Exports
Group field, 538
Read Only field, 538
Role field, 538
User ID field, 538
Crosstable Exports
access control, 538
owner field, 538
resource data, 537
Crosstable exports dialog box, 530
Cursors
Add Relationship, 150, 154, 456
Duration, 149
Move, 154, 424, 426
Paste, 287
Progress, 356
Resize, 424
Split view, 455, 468
Target Start, 149
Update Relationship, 155
Zoom, 395
Curves. See Assignment profile curves
Custom folders, 48
Customizing the Details format display, 52
best fit, 56
customizing columns, 53
filtering, 69
removing columns, 54
renaming columns, 55
sort ascending, 55
sort descending, 55
Cut button, 46
Cut command (Edit tab), 44, 286
Index
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Cutoff files. See Reporting Calendars
Cutting
effect of filters, 542
text, 45
CV. See Cost variance

D
Data sources
changing, 636
Data Sources command (View tab), 636
Data Sources dialog box, 636
Data type, 577
Date Range Options dialog box, 389
Date Scale Preferences dialog box
Manual tab, 408, 412
Options tab, 407
Reporting Calendar tab, 413
Date scales
adjusting, 414
autoscaling, 411
axis height, 411
customizing, 407
defining, 411, 412, 414
font, 411
format, 408
full scale, 410
histogram views, 502
in histogram views, 506
line width, 411
manual definition, 408, 412
non-linear, 397
position, 410
relative dates, 410
reporting calendars, 397, 413
Dates
actual finish, 352
actual start, 352
calculation by time analysis, 297
default format, 113
display of relative dates, 410
earliest feasible, 309
early, 297
early finish, 117, 297, 299
early start, 297
finding in calendar, 233
late, 297
late finish, 117, 297
late start, 297
project start, 117
scheduled, 309
scheduled finish, 117, 309
scheduled start, 309
target, 117, 135
target finish, 117, 135
target types, 117, 135
Default access mode, 81, 91, 105, 111, 115, 125,
655
Default calendars, 227
Default duration unit, 115, 205
Default projects, 594
Define Work Hours command (Edit tab), 233
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Define Work Hours dialog box, 233
Define Work Week command (Edit tab), 231
Define Work Week dialog box, 231
Defining
access rights to calendar files, 639
access rights to code files, 639
access rights to projects, 639
access rights to resource files, 639
access rights to view templates, 639
bars in histogram views, 500, 506
calculated fields, 562
cost resources, 245
custom zoning in network views, 436
date scales, 411, 412, 414
filters, 544
global edits, 569
links in spreadsheet views, 483
outlining in spreadsheet views, 480
skills, 193
sorts, 554
subsections in spreadsheet views, 475
temporary calculated fields, 564
temporary filters, 548
temporary sorts, 557
time scaling in network views, 438
Delete Code command (Edit tab), 269
Delete File command (File→Manage Files
submenu), 618
Delete Relationship command, 155
Delete Resource command (Edit tab), 174, 189
Deleting
calculated fields, 564
calendar files, 226
calendars, 236
code files, 264
codes, 67, 269
email advisory definitions, 613
files, 67, 618
filter expressions, 547, 548
from My Folder, 48, 67
from Open Plan Library, 49, 67
from Projects, 49, 67
from Startup, 51
global edits, 573
notes, 401
relationships in network views, 155
report batches, 651
reporting calendars, 398
resource files, 174
skills, 194
sort expressions, 556
spreadsheet columns, 462
symbols, 381
user defined fields, 579
views, 375
Dialog boxes
check boxes, 39
command buttons, 39
Confirm Paste, 44
default commands, 39
described, 39
getting help, 16
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list boxes, 39
modeless, 40
navigation buttons, 41
radio buttons, 39
tabbed, 40
text boxes, 39
Dictionaries dialog box, 647
Discontinuous activities, 134
Distribution shapes
beta, 332
normal, 332
triangular, 332
uniform, 332
Drag and drop, 48, 63, 65, 226
Duration cursor, 149
Durations
activity, 133
changing in barchart views, 149
computed, 309
conversions, 114
default unit, 115, 205
discontinuous activities, 134
hammocks, 294
maximum, 313
minimum calculated, 115, 313
mode, 332
optimistic, 331
original, 309
pessimistic, 331
probability distribution, 331
scheduled, 309

E
EAC. See Estimate at complete
Earliest feasible dates, 309
Early dates, 297
Early finish dates
activities, 297
projects, 117, 299
Early start dates, 297
Earned value cost control, 241
Edit Advisor Emails dialog box, 613
Edit box, 43
Edit Code command (Edit tab), 269
Edit Date Scale command (View tab), 411
Edit Reporting Calendar dialog box, 397
Edit Resource command (Edit tab), 189
Edit User Defined Field dialog box, 579
Editing
calculated fields, 563
codes, 269
filter expressions, 547
global edits, 573
network annotations, 427
relationships in network views, 155
report batches, 651
reporting calendars, 398
sort expressions, 555
time-scaled headers, 439
title blocks, 392
user defined fields, 579
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zone headers, 438
Effort factor, 179
Effort-driven activities, 179, 221
Elapsed duration, 353
Email Advisor command (Tools tab), 613
Email Advisor utility
address format, 615
creating address lists, 616
deleting advisory definitions, 613
described, 613
filtering, 616
temporary filtering, 616
testing advisory definitions, 616
Emailing project information, 643
Error logs. See Session logs
Escalations, 184
Estimate at complete, 119, 162, 254
Estimate to complete, 254
ETC. See Estimate to complete
Exclusive access mode, 58, 82, 92, 654
Exiting Open Plan, 19
Expand All button, 270
Expand All command (Edit tab), 190, 270, 285,
289
Expand button, 190
Expand command (Edit tab), 285, 429, 430
Expanded subprojects, 284
Expected finish dates, 353
Export XER utility, 528
Exporting
general, 508, 530
Microsoft Project 98/2000, 508
Primavera Project Planner, 528
External Subproject Open dialog box, 291
External subprojects. See Subprojects
Extra work days, 227

F
Fields dialog box, 393
File Open dialog box
described, 58
exclusive mode, 653
listing files by type, 653
read only mode, 653
shared mode, 653
Files
access mode, 653
access rights, 638
assigning, 63
backing up, 619
bk3 file format, 619
briefcasing, 624
closing, 62
default access mode, 655
deleting, 67, 618
exclusive access mode, 58, 654
finding, 70
management, 618
multi-user, 653
opening, 57
owners, 347, 638
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read only access mode, 58, 655
restoring, 620
saving, 61
security, 638
shared access mode, 58, 654
Fill Column Down command (Edit tab), 466
Filter Expression dialog box, 544
Filter Settings dialog box, 69
Filters
access control, 546
copying, 547
defining, 69, 544
deleting, 547, 548
described, 542
editing, 547
email advisories, 616
expressions, 544, 546
field names in, 544
Fields button, 546
Functions button, 546
in baselines, 344, 345
logical operators, 544
operators, 545
references, 546
refreshing, 543
temporary filters, 548
use of parentheses, 545
using, 542
validating the expression, 546
values in, 545
Filters command (Tools tab), 69
Filters dialog box, 542
Find command (Edit tab), 70, 160, 189, 269
Find dialog box, 70
Find In Log dialog box, 634
Find Record dialog box, 159
Finding
activities, 159
codes, 269
files, 70
in logs, 634
Finish activities, 298
Finish milestone activities, 134
Finish-to-finish relationships, 149
Finish-to-start relationships, 149
Fixed format significant coding systems, 92, 260
Fixed seed points, 335
Fixed Target target dates, 135
Float
calculation by time analysis, 297
controlling critical activities, 161
critical activities, 161
free, 298
minimum total, 117
most critical activities, 161
negative, 297
not critical activities, 161
remaining, 324
total, 297
types, 161
Font command (Edit tab), 237
Fonts
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in calendars, 237
in date scales, 411
in histogram views, 502
in outlining, 481
in subsection headings, 476
in zone headers, 437
Forecasting, 496
Foreign activities, 293
Forward pass, 297
Free float, 298

G
Gantt chart. See Barchart views
Global Edit Definition dialog box, 570
access control, 571
applies to table, 570
fields, 571
functions, 571
matching filter, 571
name, 570
of type, 571
references, 571
replace values in, 570
values, 572
with expression, 571
Global edits
adding, 572
applying, 569
copying, 573
defining, 569
deleting, 573
described, 569
editing, 573
Global Edits command (Tools tab), 572
Global Edits dialog box, 569
Go To Date command (Edit tab), 233
Go To Date command (View tab), 163
Go to Date dialog box, 163
Go To Parent command (View tab), 285, 286
Go To Predecessor command, 155
Go To Subproject button, 285
Go To Subproject command (View tab), 284, 430
Go To Successor command, 155
Go To Top Level command (View tab), 285, 432
Grand totals, 473
Grid lines, 469

H
Hammocks
activity type, 134
creating, 294
defined, 294
durations, 294
restrictions, 294
Hard zeros processing option, 183, 321
Help Contents, 16
Help system
Clip Notes, 591
described, 16
displaying help, 17
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using, 16
Hierarchical priority field, 324
Hierarchical projects. See Subprojects
Histogram Preferences command (View tab),
494, 497, 502
Histogram Preferences dialog box
Earned Value tab, 496
Options tab, 500
Resources tab, 492
Histogram views
availability, 493
cumulative curves, 490, 504
customizing the date scale, 502, 506
date range, 388
defined, 372, 488
defining bars, 500, 506
displaying earned value, 496
legends, 489, 503
printing, 386
resource, 488
risk, 339, 488, 503
selecting key activities, 505
selecting resources, 498
tabular format, 490, 504
title blocks, 391
Holidays
defined, 227
setting up, 234
HTML. See Hyper Text Markup Language
Hyper Text Markup Language, 648

I
Icons
calendar files, 225
code files, 262
resource files, 173
Immediate activities, 313
Import dialog box, 529
Import P3 File utility, 528
Import XER utility, 528
Importing
general, 508, 529
Primavera Project Planner, 508, 528
Indent command (Edit tab), 290
Indenting
activities, 289
defined, 289
examples, 289
spreadsheets, 485
In-progress activities, 298
In-progress priority processing option, 320
Intermediate display mode, 440
Internal subprojects. See Subprojects

K
Key activities, 333
Key Activity Selection dialog box, 505
Keyboard shortcuts, 38, 151, 232
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L
Labor resources, 210
Ladder format, 195, 271
Lags
calendars, 140
default calendar, 140
described, 140
duration-driven, 140
percentage, 140
Late dates, 297
Late finish dates
activities, 297
projects, 117
Late start dates, 297
Lead time. See Lags
Legends
customizing, 423
in histogram views, 489, 503
in network views, 423
positioning manually, 424
viewing, 423
Leveling. See Resource scheduling
Linking in spreadsheet views, 482
List boxes, 39
Lists, 43
Locking. See Resources, locking
Log Viewer. See Open Plan Log Viewer
Log Viewer command (Processes tab), 632
Logged-in User dialog box, 50
Logic diagrams. See Network views
Logic drawings. See Network views
Logical loops, 144
Loop detection, 144, 289

M
Make Straight command, 155
Manage Calendars dialog box, 235
Manage Holidays command (Edit tab), 234
Manage Skills command (Edit tab), 193
Manage Summary File dialog box, 122
Manage Symbols dialog box, 381, 592
Managing baselines, 348
Margins, 386
Material resources, 210
Maximum duration, 313
Maximum number of splits, 313
Microsoft Project 98/2000 Export
defined, 519
Milestones
finish milestone activities, 134
start milestone activities, 134
Minimum calculated duration, 115
Minimum duration, 313
Minimum total float, 117
Mode durations, 332
Modeless dialog boxes, 40
Most critical activities, 161, 298
Mouse techniques
right-clicking, 37
Move cursor, 154, 424, 426
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Multiple ends processing option, 302
Multi-project processing. See Subprojects
Multi-table spreadsheet views, 458
Multi-user features
described, 653
file access, 653
shared mode, 654
My Folder system folder, 48

N
Navigation buttons, 41
Network preferences
draft mode, 443
showing page breaks, 443
snapping to grid, 443
Network view
defined, 372
Network View Preferences dialog box
Legend tab, 423
Options tab, 443
Network views
adding activities, 154
adding child activities, 286
adding relationships, 154
annotations, 425
automatic placements, 433
defining temporary calculated fields, 564
defining temporary filters, 549
deleting relationships, 155
described, 154, 420
display options, 443
displaying multiple subprojects, 430
displaying subprojects, 284, 428
displaying temporary filters, 548
editing relationships, 155
intermediate display mode, 440
legends, 423
normal display mode, 440
pasting activities, 46
printing, 386
reduced display mode, 440
splitting, 455
time-scaling, 438
title blocks, 391
zoning, 436
zoom commands, 440
New button, 217
New Calculated Field dialog box, 562
New Code Structure dialog box, 260
New command (File menu), 261
New File dialog box, 59, 77
New File Wizard
Code Structure page, 78, 92
Create page, 78, 81
described, 59, 63
External Subprojects page, 78, 89
Files page, 78, 85
Notes page, 78, 94
Preferences page, 78, 90
Security page, 78, 95
Status Information page, 78, 84
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Summary page, 78, 83
using the New File Wizard, 81
New Filter dialog box, 544
New Sort dialog box, 554
New User Defined Field dialog box, 577
Next Year command (Edit tab), 234
Non-linear date scales, 397
Non-working days, 227
Non-working times, 225
Normal display mode, 440
Normal distribution shape, 332
Not critical activities, 161, 298
Not Earlier Than target dates, 117, 135
Not Later Than target dates, 117, 135
Note Categories command (Tools tab), 402
Notes
adding, 120
categories, 401
deleting, 401
description, 400
including in reports, 387, 403
printing, 387
spell checking, 646

O
Offsets, 205
On Target target dates, 118, 135
Online help. See Help system
Open button, 262
Open command (File menu), 174, 226, 262
Open Plan
file management, 618
help system, 16
multi-user features, 653
Professional edition, 11
security features, 638
starting, 14
system options, 591
working with windows, 38
Open Plan Developer’s Guide, 13
Open Plan Explorer
contents pane, 52
deleting files, 67
described, 47
hierarchical pane, 48
system folders, 47
Open Plan Library system folder, 49
Open Plan Log Viewer
described, 632
Find button, 634
resource scheduling, 318
risk analysis, 336
time analysis, 303
Open Plan Release Notes, 13
Open Plan User Guide, 13
Open Plan Web Publisher
creating report batches, 649
deleting report batches, 651
described, 648
output options, 651
previewing report batches, 651
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running report batches, 651
updating report batches, 651
URL links, 652
use of .pdf files, 648
use of HTML files, 648
Open Plan Web Publisher dialog box, 649
Open Status tab
machine ID, 105, 125
open mode, 105, 125
opened on, 105, 125
user ID, 105, 125
Opening
calendar files, 226
code files, 262
external subprojects, 291
resource files, 174
views, 374
Opp_prog.log, 365, 367
Opp_risk.log, 334
Opp_rs.log, 317
Opp_ta.log, 300
Options command (File menu), 591
Options dialog box
Advanced tab, 600
Codes tab, 596
Color tab, 597
Edit tab, 592
Email options, 599
Email tab, 599
General tab, 591
MAPI, 599
Project tab, 594
SMTP, 599
SMTP Server Information, 600
Views tab, 595
Other Direct Costs resources, 210
Outdent command (Edit menu), 290
Outdenting
activities, 290
defined, 290
examples, 290
spreadsheets, 485
Outlining
described, 478
effect of filters, 542
effect of sort order, 478
enabling, 479
Outlining button, 288
Out-of-sequence progressing, 302, 357
Owners, 347, 638

P
P3Export Add-Ins tool, 528
Pad characters, 260
Passwords, 640
Paste button, 46
Paste command (Edit tab), 44, 286, 287
Paste cursor, 287
Paste Special, 44
Pasting
activities in network views, 46
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effect of filters, 542
text, 46
PDF. See Portable Document Format
PDM. See Precedence diagramming method
Percent complete, 353
Performance Measurement Baseline, 119
Perishable resources, 178, 183
PERT charts. See Network views
Physical percent complete, 241
Placements, 433
automatic, 434
avoiding page breaks, 434
filtering projects, 435
Filters button, 435
manual, 434
saving as manual, 434
showing all levels, 434
Time Scale button, 434
time scaling projects, 434
Zoning button, 435
zoning projects, 435
Placements command (View tab), 435
Placements dialog box, 434
Planned activities, 298
Planned baseline progress, 254
PMB. See Performance measurement baseline
Pools. See Resources, pools
Portable Document Format, 648
Predecessor/successor spreadsheet views, 157
Preferences command (View tab), 196, 272, 506
Previous Year command (Edit tab), 234
Primavera Project Planner, 528
Print command (File menu), 384
Print dialog box, 384
Print Options command (File menu), 386
Print Options dialog box
General tab, 386
View tab, 388
Print Preview button, 394, 395
Print Preview command (File menu), 395
Print Setup dialog box, 385
Printing
barchart views, 386
calendars, 385
collating, 385
copies, 385
current display, 389
described, 384
histogram views, 386
margins, 386
network views, 386
note categories, 387
notes, 387
on a network, 386
paper, 385
paper orientation, 386, 387
print preview, 395
print range, 384
print setup, 385
printer, 384, 385
project start, 389
range of data, 389
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spreadsheet views, 386
Time Now, 389
title blocks, 391
Priority fields, 322
Profile curves. See Assignment profile curves
Progress calculations
updating activity status and actual dates, 363
Progress Calculations command (Processes tab),
363, 367
Progress Calculations dialog box, 363
Progress cursor, 356
Progress information
Accomplished Duration field, 355
actual finish date, 353
actual start date, 353, 357
as planned, 353
automatic activity progress, 362
automatic resource progress, 180, 366, 369
baselines, 342
calculations, 357
complete, 353
costs, 358
costs based on progress, 180
effect on time analysis, 357
elapsed duration, 353
entering in barchart views, 355
entering in spreadsheet views, 355
expected finish date, 353
out of sequence, 357
percent complete, 353
Progress Type field, 355
Progress Value field, 355
remaining duration, 353
Remaining Duration field, 355
resources, 358
subprojects, 357
Time Now, 352
turnaround reports, 352
use of actual dates, 352
viewing, 356
Progress Type field, 355
Progress Value field, 355
Project
startup view, 114
Project priority, 121
Project Properties command (Processes tab),
356
Project Properties dialog box
Access Control tab, 124
Codes tab, 110, 127, 275
Cost tab, 110, 118, 253
Files tab, 63, 110, 116
Notes tab, 110, 120, 186
Open Status tab, 105, 110, 125
Preferences tab, 110, 113, 228, 655
References tab, 126
Scheduling tab, 110, 120
Security tab, 110
Status tab, 110, 117, 356
Summary tab, 110, 111, 349
User Fields tab, 107, 110, 123
Project-level codes, 596
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Projects
access control, 124
baselines, 342
briefcasing, 624
code files, 264
computed status, 299
creating, 594
default, 594
default activity type, 113
default duration unit, 115, 205
displaying budget costs, 253
early finish date, 117
emailing, 643
exporting MSP files, 519
exporting P3 files, 528
exporting XER files, 528
foreign activities, 293
hierarchies, 280
importing and exporting general, 529
importing MSP files, 509
importing P3 files, 528
importing XER files, 528
late finish date, 117
latest early finish date, 299
latest late finish date, 299
loop detection, 144
minimum calculated duration, 115
minimum total float, 117, 299
notes, 400
open status, 105, 125
percent complete, 299
project priority, 121
project-level codes, 596
scheduled finish date, 117
standard views, 595
start date, 117
status, 117
target finish dates, 117
target start dates, 117
target total cost, 118
target types, 117
time analysis calculations, 299
Time Now, 117
Projects system folder, 49
Punctuated significant coding systems, 92, 258,
260

R
Radio buttons, 39
RBS. See Resource breakdown structure
Read Only access mode, 58, 82, 92, 655
Reduced display mode, 440
References
assigning references to projects, 126
Refresh button, 543
Relationship calendars, 114, 228
Relationship mode, 149
Relationship Mode button, 149, 150
Relationship spreadsheet views, 157
Relationships
adding in barchart views, 149
Index
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adding in network views, 154
adding in spreadsheet views, 158
calendars, 225
controlling, 415
default type, 149
deleting in network views, 155
described, 138
displaying in barchart views, 147, 415
duration-driven lags, 140
editing in network views, 155
finish-to-finish, 149
finish-to-start, 149
lag calendars, 140
lags, 140
mode in barchart views, 149
percentage lags, 140
start-to-finish, 149
start-to-start, 149
types, 140
Relationships Mode command (View tab), 150
Relative dates, 410
Remaining duration, 353
Remaining Duration field, 355
Remaining float, 324
Renaming calendars, 236
Reporting Calendar field, 399
Reporting calendars
copying, 398
creating, 398
deleting, 398
described, 397
editing, 398
in date scales, 413
selecting, 119
Reporting Calendars command (Tools tab), 397
Reporting hammocks. See Hammock activities
Reports. See Views
Reprofiling activities, 312
Resize cursor, 424
Resource assignment spreadsheet views, 212
Resource breakdown structures, 172
Resource curve, 114
Resource Details dialog box
Availability tab, 182
Code tab, 181, 277
described, 176
displaying, 176
Escalations tab, 184
General tab, 177
User Fields tab, 184
Resource Display Preferences dialog box
Box Layout tab, 196
Options tab, 195
Resource files
assigning to projects, 64, 116, 175
code files, 264
copying, 174
creating, 173
deleting, 174
described, 173
icons, 173
notes, 400
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opening, 174
Resource level, 91, 114
Resource reservations
described, 187
effect on Select Resource dialog box, 187
Resource scheduling
activity reprofiling, 312
activity splitting, 311
activity stretching, 311
calculation of dates, 309
described, 308
effect of thresholds, 178
hard zeros processing option, 183, 321
hierarchical priority field, 324
in-progress priority processing option, 320
performing, 316
priority fields, 322
remaining float, 324
reporting, 328
reservations, 308
resource-limited, 308, 310, 316, 327
roll-up, 179
scheduling interval, 324
session logs, 317
smoothing processing option, 321
summary resource usage file, 120
Time Now, 117, 309
time-limited, 308, 310, 316, 327
Resource Scheduling button, 318
Resource Scheduling command (Processes tab),
316
Resource Scheduling dialog box
Advanced tab, 320
Options tab, 316
Resource Selection dialog box, 498
Resource views, 372
Resource/activity spreadsheet views, 214
Resource-limited resource scheduling, 308, 310,
316, 327
Resources
actual cost based on progress, 180
actual quantity, 359
adding, 188
all resource categories, 210
allocation, 216
alternate, 205, 216
assigning resources in spreadsheet views, 212
assignment levels, 205
assignment offsets, 205
assignment periods, 205
assignment profile curves, 204
assignments, 202
automatic progressing, 180, 366, 369
availabilities, 181
availability dates, 182
availability of consumable resources, 183
availability of perishable resources, 183
breakdown structures, 172
budgeted, 358
calculating actual costs, 249, 251
calculating budget costs, 246
calendars, 225
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categories, 178, 210, 498
consider in cost calculations, 180
consumable, 177
cost escalations, 184
custom box text, 196
default resource curve, 114
default resource level, 91, 114
defining assignment profile curves, 222
described, 172
displaying in histogram views, 492
displaying resource information, 195
effort factor, 179
expanding pools, 190
hard zeros processing option, 183, 321
hierarchies, 172
ID, 177
interpreting zero availabilities, 183
labor, 210
level assignments, 204
leveling, 308
locking, 216, 218, 219
material, 210
moving in hierarchy, 189
normal, 177
notes, 400
other direct costs, 210
perishable, 178
pools, 172, 178, 216
progressing, 358
project, 178
Properties dialog box, 229
remaining quantity, 360
requested, 216
reserving a portion of a resource, 187
reserving a resource completely, 187
reserving for projects, 187, 308
roll up for scheduling, 179
selecting, 209, 325
selecting for histogram views, 498
skill filter, 209
skills, 192, 193, 216
soft zeros, 183
subcontract, 210
suggested, 216
suppress for scheduling, 179
suppress in lists, 179
thresholds, 178
total assignments, 204
types, 177
unbudgeted, 358
unit costs, 178
unit descriptions, 178
Restore command, 620
Restore File command (File→Manage Files
submenu), 624
Restore Target Exists dialog box, 622
Restore Wizard
Details page, 621
Restore page, 620
Restoring files, 620
Risk analysis
compared to time analysis, 334
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criticality index, 334, 338
described, 330
distribution shapes, 331
fixed seed point, 335
histogram views, 339
key activities, 333
mode durations, 332
options, 334
session log, 334
simulations, 334
spreadsheet views, 337
standard deviations, 337
Risk Analysis button, 334, 336
Risk Analysis command (Processes tab), 335
Risk Analysis dialog box, 334
Options tab, 334
Risk Analysis Preferences dialog box, 506

S
Save As command (File menu), 61, 174, 226,
263, 283
Save As dialog box, 61
Save button, 61
Save command (File menu), 61
Save View command (File menu), 374, 428
Saving
automatic placements, 436
files, 61
views, 374, 375
Scaling Specification dialog box, 438
Schedule performance index, 254
Schedule variances, 243, 254
Scheduled dates, 309
Scheduled durations, 309
Scheduled finish dates
activities, 309
projects, 117
Scheduled start dates, 309
Scheduling interval, 324
S-curves. See Histogram views
Searching. See Finding
Security Administrator, 13
Security features
access rights, 347, 638
baselines, 347
described, 638
Group field, 104, 124, 638
Owner field, 104, 124, 638
owners, 347, 638
Read Only field, 104, 124, 639
Role field, 104, 124, 638
Security Administrator, 13
User ID field, 104, 124, 639
user passwords, 640
Select Code dialog box, 127, 276
Select dialog box, 64, 86, 283
Select File to Delete dialog box, 68, 174, 618
Select Note Categories dialog box, 387, 404
Select P3 Project dialog box, 528
Select Project or Project Database dialog box,
509
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Select Resource command (View tab), 499
Select Resource dialog box, 209
Select Standard Views dialog box, 595
Selecting
files, 64, 86
resources, 209
resources for resource scheduling, 325
Send command (File menu), 643
Session logs
automatic activity progressing, 365
automatic resource progressing, 367
resource scheduling, 317
risk analysis, 334
time analysis, 300
Shared access mode, 58, 82, 92, 654
Sheets. See Spreadsheet views
Shifts. See Calendars
Skills
assigning to resources, 194
defining, 193
deleting, 194
described, 192
managing, 193
skill ID, 193
unit cost, 193
Smoothing processing option, 321
Soft zeros, 183
Sort Expression dialog box, 555
access control, 555
references, 555
Sorts
adding, 555
clicking to sort a column, 559
copying, 556
default sort order rules, 552
defining, 554
deleting, 556
described, 552
editing, 555
effect on outlining, 478
expressions, 554
temporary sorts, 556
using, 553
Sorts command (Tools tab), 553
Sorts dialog box, 553
Spell checking
custom dictionaries, 646
described, 646
dictionaries, 647
email advisories, 616, 646
notes, 646
options, 647
SPI. See Schedule performance index
Split view cursor, 455, 468
Splitting
network views, 455
splitter control, 455
spreadsheet views, 467
Splitting activities, 311
Spread curves. See Assignment profile curves
Spreadsheet Preferences dialog box
Define Links tab, 483
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Options tab, 469, 471, 475
Outlining tab, 480
Subsections tab, 475
Spreadsheet views
activity spreadsheets, 156, 278
activity/resource spreadsheets, 213
adding child activities, 288
adding columns, 461
changing column headings, 462
changing data tables, 471
changing grid line color, 469
clicking to sort, 559
customizing, 459
defined, 372
defining links, 483
defining subsections, 475
defining temporary calculated fields, 565
deleting columns, 462
described, 458
disabling subsections and outlining, 470
display options, 469
displaying grid lines, 469
displaying subprojects, 288
displaying temporary filters, 548
enabling outlining, 470
enabling subsections, 470, 474
filling columns down, 466
formatting, 461
grand totals, 473
icons, 458
including line numbers, 387
indenting, 485
inserting columns, 462
keyboard shortcuts, 151
linking, 482
multi-table, 458, 482
outdenting, 485
outlining, 478
predecessor/successor spreadsheets, 157
printing, 386
resource assignment spreadsheets, 212
resource/activity spreadsheets, 214, 482
risk, 337
showing skills as resources, 470
splitting, 467
subsection headings, 473
subsections, 473
summary lines, 473
supporting all tables, 471
table name, 460, 469
Table Name option, 471
text format, 460
title blocks, 391
wrapping text, 460
Stacked histograms, 499
Standard deviation, 337
Standard work week, 231
Start activities, 298
Start Day of Week setting, 237
Start milestone activities, 134
Start Month of Year setting, 237
Start/finish activities, 298
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Start-to-finish relationships, 149
Start-to-start relationships, 149
Start-up Clip Notes, 591
Startup folder, 66
Startup system folder, 50
Startup view, 114
Status date. See Time Now
Status information. See Progress information
Stretching activities, 311
Subcontract resources, 210
Subheadings. See Subsections
Submenus, 27
Subprojects
activity type, 134
adding child activities in network views, 286
adding child activities in spreadsheet views,
288
auxiliary data files, 293
closed external, 292
converting external to internal, 293
described, 280
displaying in network views, 284, 428
displaying in spreadsheet views, 288
drawing relationships in network views, 429
drilling down in network views, 284
effect on activity information, 281
effect on time analysis calculations, 292
expanding in network views, 284
external, 291
foreign activities, 293
internal, 282
navigation in network views, 284
progress information, 357
relationships, 281
target dates, 281
time analysis calculations, 298
Subsections
defining, 475
described, 473
enabling, 474
grand totals, 473
headings, 473
summary lines, 473
Subtotals. See Subsections
Summary resource usage file
creating, 121
deleting, 122
described, 120
Support for all tables
changing data tables, 471
Table Name option, 471
Suppressed resources, 179
SV. See Schedule variance
Symbols, 381, 592
System Folders
Briefcase, 49
custom folders, 48
My Folder, 48
Open Plan Library, 49
Projects, 49
Startup, 50
Users, 49
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System options
custom colors, 598
default open mode, 592
default start up view, 595
default work day, 591
displaying the Status Bar, 591
language, 592
opening last file on startup, 592
selecting standard views, 595
showing process logs, 594
start up tips, 591
starting day of the week, 592
System Preferences Defaults dialog box, 601
theme colors, 597, 598
user-defined options, 599, 600
System utilities, 612

T
Tabbed dialog boxes, 40
Tabular reports. See Spreadsheet views
Target dates
assigning to activities, 135
effect of, 118
Fixed Target, 135
Not Earlier Than, 117, 135
Not Later Than, 117, 135
On Target, 118, 135
project finish dates, 117
project start dates, 117
setting in barchart views, 148
types, 117, 135
Target finish dates, 117, 301
Target Start cursor, 149
Target types, 117, 135, 301
Tasks. See Activities
Temporary calculated fields, 564
Temporary fields, 564
Temporary filters
defining, 548
described, 548
displaying in barchart views, 548
displaying in network views, 548
displaying in spreadsheet views, 548
in email advisories, 616
in export scripts, 551
on secondary tables, 550
Temporary Sort Expression dialog box, 557
Temporary sorts
defining, 557
described, 556
on secondary tables, 558
Text boxes, 39
Thresholds, 178
Time analysis
actual date option, 302
automatic time analysis, 304
backward pass, 297
calculation of dates, 297
described, 297
effect of progress information, 357
float calculations, 297
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forward pass, 297
free float, 298
minimum calculated duration, 115
multiple ends processing option, 302
operations, 300
options, 301
out-of-sequence options, 302
session log, 300
target date types, 301
target finish dates, 301
Time Now, 117, 297, 301
total float, 297
Time Analysis Button, 300
Time Analysis command (Processes tab), 303
Time Analysis dialog box, 300
Time Now, 117, 301, 309, 352, 389, 415
Time-limited resource scheduling, 308, 310, 316,
327
Time-scaling, 438
Tip of the Day, 591
Title Block Definition dialog box, 392
access control, 393
references, 393
Title blocks
copying, 392
creating, 392
editing, 392
in email advisories, 614
Title Blocks command (Tools tab), 394
Title Blocks dialog box, 391
Toolbar, 27
Total float, 297
Triangular distribution shape, 332
Turnaround reports, 352

U
Uniform distribution shape, 332
Uniform Resource Locator, 648
Update Baseline dialog box, 347
Update Relationship cursor, 155
URL. See Uniform Resource Locator
User defined fields
copying, 578
creating, 578
creating for baselines, 577
data types, 577
deleting, 579
described, 576
editing, 579
User Defined Fields command (Tools tab), 576,
580
User Defined Fields dialog box, 576
User passwords, 640
Users system folder, 49

V
VAC. See Variance at complete
Variance at complete, 254
Variances
cost, 242
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schedule, 243
Views
adding standard views, 595
assigning to projects, 65, 374
bar sets, 109
barchart, 372
calculated fields, 561
code, 372
creating report batches, 649
creating templates, 374
deleting report batches, 651
displaying baseline information, 350
emailing, 643
filters, 109, 542
for new projects, 595
histogram, 372
modifying templates, 374
network, 372
opening, 374
previewing report batches, 651
printing reports, 384
publishing on the Web, 648
removing from projects, 375
removing standard views, 596
resource, 372
running report batches, 651
saving, 374, 375
sorts, 109, 552
spreadsheet, 372
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title blocks, 109
updating report batches, 651
user defined fields, 576

W
WBS. See Work breakdown structure
Web Publisher. See Open Plan Web Publisher
Web Publisher command (Tools tab), 649
Windows
in Open Plan, 38
Work breakdown structure, 131
Work shifts. See Calendars
Working days, 227
Working times, 225

Z
Zero availabilities, 183
Zone Attributes dialog box, 437
Zoning, 436
Zoning headers, 437
Zoom cursor, 395
Zoom In button, 442
Zoom In command (View tab), 198, 274, 440
Zoom Out button, 442
Zoom Out command (View tab), 198, 273, 440
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Deltek is the leading global provider of enterprise software and information solutions for professional
services firms, government contractors, and government agencies. For decades, we have delivered
actionable insight that empowers our customers to unlock their business potential. Over 14,000
organizations and 1.8 million users in approximately 80 countries around the world rely on Deltek to
research and identify opportunities, win new business, optimize resource, streamline operations, and deliver
more profitable projects. Deltek – Know more. Do more.®
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